Student software

Guidebook

This guidebook applies to TI-Nspire™ software version 3.0. To obtain the
latest version of the documentation, go to education.ti.com/guides.

Important Information
Except as otherwise expressly stated in the License that accompanies a
program, Texas Instruments makes no warranty, either express or
implied, including but not limited to any implied warranties of
merchantability and fitness for a particular purpose, regarding any
programs or book materials and makes such materials available solely on
an "as-is" basis. In no event shall Texas Instruments be liable to anyone
for special, collateral, incidental, or consequential damages in connection
with or arising out of the purchase or use of these materials, and the sole
and exclusive liability of Texas Instruments, regardless of the form of
action, shall not exceed the amount set forth in the license for the
program. Moreover, Texas Instruments shall not be liable for any claim of
any kind whatsoever against the use of these materials by any other
party.

FCC Statement
Note: This equipment has been tested and found to comply with the
limits for a Class B digital device, pursuant to Part 15 of the FCC Rules.
These limits are designed to provide reasonable protection against
harmful interference in a residential installation. This equipment
generates, uses and can radiate radio frequency energy and, if not
installed and used in accordance with the instructions, may cause
harmful interference to radio communications. However, there is no
guarantee that interference will not occur in a particular installation.
If this equipment does cause harmful interference to radio or television
reception, which can be determined by turning the equipment off and
on, the user is encouraged to try to correct the interference by one or
more of the following measures:
•

Reorient or relocate the receiving antenna.

•

Increase the separation between the equipment and receiver.

•

Connect the equipment into an outlet on a circuit different from
that to which the receiver is connected.

•

Consult the dealer or an experienced radio/TV technician for help.

© 2006 - 2011 Texas Instruments Incorporated
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Go!Temp®, DataQuest™, and Blackboard™ are trademarks of their
respective owners.
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Getting started with TI-Nspire™ Software
TI-Nspire™ software enables students and teachers to use PC and MAC®
computers to perform the same functions as on a handheld. This
document covers the following TI-Nspire™ software:
•

TI-Nspire™ Teacher Software

•

TI-Nspire™ Student Software

•

TI-Nspire™ CAS Teacher Software

•

TI-Nspire™ CAS Student Software

Note: When there are differences between the software, those
differences are described.

Using the Welcome screen
By default, the Welcome Screen opens the first time you start the
software after installation is complete. To begin working with
documents, click an icon or link, or close this screen manually. Any normal
action that takes place automatically, such as upgrade prompts or the
ability to begin using connected handhelds, appears after you close the
Welcome Screen.

À
Á
Â
Ã

Ä

Å
À

Title bar. Shows the screen name. The close button is also located
here.
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Name. Shows software name.
TI-Nspire™ applications. Click one of these icons to create a new
document with the selected application active. The icon applications
are Calculator, Graphs, Geometry, Lists & Spreadsheet, Data &
Statistics, Notes, and the Vernier DataQuest™ application. The icon
for the Question application also appears in this space in the
TI-Nspire™ Teacher Software. When you click an icon, the Welcome
Screen closes and the selected application opens.

Quick Start links. Click one of these options to:
•

Create a new document with the application you select as the first
page.

•

Create a new, blank document.

•

Find and open an existing document.

•

In the TI-Nspire™ Teacher Software, teachers can use the
following links to:
–

View content. Find content on your computer, the web, or
connected handhelds.

–

Manage handhelds. Use the Content Workspace to see every
handheld connected to your computer as well as the status of
each handheld.

–

Transfer documents. Use the Content Workspace to send
documents, folders, or new handheld OS files to connected
handhelds.

Ä

Preview area. When you move your mouse pointer over the icons, a
definition and example of the selected application is displayed.

Å

Always show this at startup. Deselect this checkbox to skip this

screen when you open your software.

Closing the Welcome screen
To access the default workspace and begin working with documents,
click
to close the Welcome Screen. To open the Welcome screen
again, click Help > Welcome Screen.
•

In the TI-Nspire™ Teacher Software, the Content workspace is
displayed when you open the software for the first time.

•

In the TI-Nspire™ Student Software, the Documents workspace is the
default workspace.

Note: The next time you open the software, the last workspace used is
displayed.
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Exploring the Content workspace
In the TI-Nspire™ Teacher Software, the Content workspace provides
access to the files on your computer, to files on connected handhelds,
and links to web resources. Teachers can also use this workspace to create
and manage lesson bundles.
Note: Those using the TI-Nspire™ Student software will not see the
Content workspace.

À
Á
Â
Ã
Ä

Å

Æ

Ç

À

Title bar. Shows the name of the software. The minimize, maximize,
and close buttons are located in the right corner.

Á

Menu bar. Contains options used to work with files and to modify

system settings. In the Content workspace these are File, Edit, View,
Tools, Window, and Help.

Â

Content/Documents tabs. In the TI-Nspire™ Teacher Software, use

these tabs to switch between the Content workspace to the
Documents workspace. These tabs are not shown in the student
software.

Ã

Tool bar. Contains shortcuts to tools used to create folders, save files,

create lesson bundles, send files to handhelds, and copy/paste.
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Ä

Resources pane. Enables you to locate and view files on your

computer, access web links, and access files on connected handhelds.
When you select a resource, the details for that resource are displayed
in the content pane.

Å

Navigation bar. Contains tools needed to search for and navigate to
folders and files on your computer, on a web site, or on a connected
handheld. When you select a resource, the options available are
specific to that resource.

Æ

Content pane. Shows the content based on the resource selected.

Use the content pane as you would a file manager to locate and view
folders, lesson bundles, TI-Nspire™ documents, and PublishView™
documents on your computer or on connected handhelds. Click
to
access options applicable to the selected folder or TI-Nspire™
document.

Ç

Preview pane. Details about the selected file or folder are displayed
in the bottom half of the space.

Working with lesson bundles
Teachers can use lesson bundles to collect and package multiple files
needed for a lesson. Use lesson bundles to easily collect and distribute
lessons to connected handhelds or to share with other educators. For
detailed information about lesson bundles, refer to Using the Content
Workspace or Using the Documents Workspace.

Exploring the Documents workspace
Use the Documents workspace to create or edit TI-Nspire™ and
PublishView™ documents and work with applications and problems. The
tools in the workspace are specific to working with open documents.

4
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Title bar. Shows the name of the current document and the name of
the software. The minimize, maximize, and close buttons are located
in the right corner.

Á

Menu bar. Contains tools for working with documents. In the

Documents Workspace, these are File, Edit, View, Insert, Tools,
Window, and Help. In the student software, the Submit Response
option is active when a teacher sends a question to your computer.

Â

Workspace tabs. The name of the active workspace. In the

TI-Nspire™ Teacher Software, use the tabs to switch between the
Documents workspace and the Content workspace. In the TI-Nspire™
Student Software, the Document workspace is the only available
workspace; these tabs are not shown

Ã

Workspace toolbar. Contains shortcuts to frequently performed tasks
such as creating new documents, opening existing documents, saving
documents, inserting applications, inserting variables, and taking
screen captures. The cut, copy, and paste icons are also located in the
toolbar.
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Ä

Documents Toolbox. Contains tools needed to work with
TI-Nspire™ and PublishView™ documents. Use these tools to insert
applications, use the page sorter to view TI-Nspire™ documents, open
the TI-SmartView™ emulator, open Content Explorer, insert utilities
such as math templates and the symbols from the catalog, and insert
text and images into PublishView™ documents. Click each icon to
access the available tools.

Å

Toolbox pane. Options for the selected tool are displayed in this area.

For example, click the Document Tools icon to access tools needed to
work with the active application.
Note: In the TI-Nspire™ Teacher Software, the tool for configuring
questions opens in this space when you insert a question. For more
information, see Using Question in the TI-Nspire™ Teacher Software
Guidebook.

Æ

Workspace. Shows the current document and enables you to
perform calculations, add applications, and add problems and pages.
Only one document at a time is active (selected). Multiple documents
appear as tabs.

Ç

Status bar. Provides information about the document.

Understanding the status bar
The status bar provides information about the current document,
enables you to toggle between Handheld and Computer mode, and
adjust how the document appears in the workspace.

À

Á

Â

Ã

À

Problem and page number. References current document. This is not
displayed in PublishView™ documents.

Á

Settings. Current settings for Angle, Auto or Approximate, and Real
or Complex. Click here to change General or Graphs & Geometry
settings.

Â

Document View. Choose between Handheld and Computer modes.

•

Handheld: Enables you to see documents as they appear on a
handheld screen. The screen size is limited as it would be on the
handheld.

•

Computer: This is the default view in the software.

Note: These icons are disabled in a PublishView™ document.
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Scale. When working with a document in computer mode, use the
Boldness slider to increase or decrease the boldness of the lines in a

document. Go to the left to decrease the boldness. Go to the right to
increase the boldness.
When working with a document in handheld mode, use the Scale
slider to control the size of the document in the workspace. Go left to
make the document smaller. Go right to make the document larger.
Teachers will find the boldness and scale sliders useful when giving
presentations. The ability to adjust the contrast or size of the
displayed document will improve visibility when the image is
projected on a screen.

Using the Documents Toolbox
The Documents Toolbox, located on the left side of the workspace,
contains tools needed for working with both TI-Nspire™ documents and
PublishView™ documents.

When you click a documents tool icon, the associated tools are displayed
in the toolbox panel. Refer to the following table for information about
each tool.
Icon

What you can do
Opens the Application Menu.

Document
Tools

In a TI-Nspire™ document, you can select tools
available for working with an application. By default,
the tools listed are specific to the application in the
active problem or page.
In a PublishView™ document, Document Tools
contains tools needed to insert TI-Nspire™
applications and TI-Nspire™ documents.
Note: For more information about PublishView™
documents, see Working with PublishView™
documents.
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Icon

What you can do
Provides a view of the pages in the active document,
which enables you to:
•

See the number of problems in your document
and where you are.

•

Move from one page to the other by clicking on
the page you want.

•

Add, cut, copy, and paste pages within the same
problem or between problems and documents.

•

Add, cut, copy, and paste problems within the
same document or between documents.

Page Sorter

Note: The Page Sorter icon is not available in a
PublishView™ document.

TI-SmartView™

Teachers can use the TI-Smartview™ emulator to
demonstrate concepts on the handheld. The
TI-Smartview™ emulator works the same as the
handheld.
Note: Content is displayed on the TI-Smartview™
small screen only when the document is in Handheld
mode.
Students can use TI-Smartview™ feature to emulate a
keypad and use the software as if using a handheld.
The TI-Nspire™ SmartView™ emulator is not available
when working in a PublishView™ document.
Provides access to the following utilities:

Utilities

8

•

Math Templates

•

Symbols

•

Catalog

•

Math Operators

•

Unit Conversions

•

Libraries

Getting started with TI-Nspire™ Software
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Content
Explorer

What you can do
•

See a list of files on your computer

•

See a list of files on any connected handheld

•

Create and manage lesson bundles

•

Update the OS on connected handhelds

Use the Content Explorer tool to send or collect
documents between a computer and connected
handhelds. More information about using Content
Explorer is available in Using the Documents
Workspace.

Changing language
Use this option to select a preferred language. You must restart the
software for the language to take effect.
1. Select File > Settings > Change Language.
The Choose a Language dialog box opens.

2. Click ¤ to open the drop-down menu.
3. Select a language from the list.
4. Click Quit Now to close the software immediately. You will be
prompted to save any open documents. When you restart the
software, the language change is effective.
-ORClick Quit Later to continue your work. The language change is not
applied until you close and restart the software at a later time.

Getting help
From the Help menu, you can perform tasks and get useful information
to help you use the software more productively. You can:
Getting started with TI-Nspire™ Software
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•

Open the help file (Press F1 or select Help > TI-Nspire™ Software
Help)

•

Activate the software license

•

Register your TI product

•

Download the latest guidebooks.

•

–

Find information easily and quickly.

–

Learn how to perform new tasks more easily and efficiently.

Visit knowledge sites on the Internet to improve your proficiency with
the product. On these sites, you can find information about how to
use TI products as well as lessons, quizzes, and other instructive
activities shared by educators.
Note: Activities may vary depending on your geographical language.

•

Explore online troubleshooting

•

Run TI-Nspire™ diagnostics

•

Check for updates to the software and handheld operating systems.

•

Find information about the current software version.

•

Open the Welcome Screen

Activating your software license
1. Ensure you are connected to the Internet.
2. Click Help > Activate to open the Texas Instruments Activation
Wizard.
3. Select Activate your License, then click Next. The Complete Software
Activation dialog box opens.

10
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4. Complete the name and e-mail fields, then select the region where
you live if different from the default entry. If you want to receive
e-mails from TI about updates, support, and promotions, ensure the
check box is selected.
5. Click Next to open the Activate your software dialog box.

6. Type the license number or upload your web portal file, then click
Next. The Licence Agreement dialog is displayed.

7. In the Country field, select your country from the drop-down menu if
it is different from the default entry.
8. Review the license agreement, then select to accept the agreement.
9. Click Activate. The license number is validated against the TI
database to ensure it is valid.
If the license number is valid, the Successful Activation dialog opens.
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10. Click Next or Finish to launch the software.
11. When prompted, click OK to accept the default location for your
TI-Nspire™ folder. If needed, navigate to the location on your
computer where you want to store your TI-Nspire™ documents and
files.
12. Select whether or not to replace any documents that have the same
name.
The software launches and the Welcome Screen is displayed.
Note: If the license number is not valid, check to make sure the numbers
are entered correctly. If the problem persists, contact TI Support.

Registering your product
1. Ensure you are connected to the Internet.
2. Click Help > Register to access the TI Registration Product site.
3. Follow the instructions on the web site to complete the product
registration process.

Downloading the latest guidebook
1. Ensure you are connected to the Internet.
2. Click Help > Download latest Guidebook.
3. When the Download Central web site opens, click Download to
download the corresponding guidebook.

Exploring TI resources
The Help menu also provides links to TI resources and web sites.
f Click Help > Visit education.ti.com to access the Texas Instruments
Education Technology web site.
12
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f Click Help > Visit Activities Exchange to access the Texas Instruments
Activities Exchange site. This site contains over 500 TI-Nspire™
activities.
f Click Explore Online Troubleshooting to access TI’s Knowledge Base
where you can get troubleshooting help.

Running TI-Nspire™ diagnostics
In the event you have trouble with your software, this option enables
you to run a short diagnostics program that will help TI support
personnel troubleshoot the problem. You do not need Internet access to
run diagnostics; however, Internet access is required to send the log file
to TI Support. To run diagnostics:
1. Click Help > Run TI-Nspire™ Diagnostics.
The Software Diagnostics dialog box opens.
2. Click Start to run the program.
The log file is created and the Save as dialog box opens.
3. Navigate to the folder where you want to save the file, then click
Save As.
4. When the Software Diagnostics dialog box appears:
•

Click Send to TI to send the file to TI Support.

•

Click Restart to run the program again.

•

Click Cancel to quit, then click OK to confirm and close the dialog
box.

Updating your software
Here are some important notes to remember about updating your
software:
•

•

If you are connected to the Internet and you have automatic
notification enabled, your system will notify you of any TI-Nspire™
software updates when you open the desktop software.
–

The automatic check occurs once each time you open the
software.

–

If your system is up-to-date, you will receive no notification.

–

You can turn off this feature if you don’t want to receive
notifications automatically.

You can also check for updates manually.
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Manually checking for software updates
1. Click Help > Check for Software Updates.
If your software is current, the Check for Software Update dialog is
displayed indicating that you have the latest version of the software.

2. To turn off automatic notifications, deselect “Automatically check for
updates.” By default, this option is turned on.
3. Click OK to close the window.

Installing updated software
After the system checks for an update, the Check for Software update
dialog box is displayed with a message informing you that a newer
version of the software is available.
To install the software update and manage your update notifications:
1. Check to make sure you’re connected to the Internet.
2. To turn off automatic notifications, deselect “Automatically check for
updates.“
3. Click Update to save the settings and begin the download.
A progress message box opens to show the download progress.
Note: If you receive a connection error, check your Internet connection

and try again.

Upgrading a handheld operating system
This option is active only if a handheld is connected. To check for OS
updates for a connected, selected handheld, complete the following
steps.
1. Open the Content Explorer, then select a connected handheld.
2. Click Help > Check for Handheld OS Update.

14

Getting started with TI-Nspire™ Software

If the operating system is current, the Check for Handheld OS Update
dialog is displayed indicating that the operating system on the
handheld is current.

3. To turn off automatic notifications, deselect updates.” for updates.”
By default, this option is turned on.
4. Click OK to close the window.

Installing an updated operating system
If the operating system is not current, the Check for Handheld OS Update
dialog box is displayed.

1. Click Browse if you want to change the location where the operating
system file is saved.
2. Click Continue to download the OS and update the handheld.
3. Accept the license agreement and click Continue.
4. When the message warning you that any unsaved data will be lost is
displayed, click Yes. The Installing OS dialog opens indicating the
progress of the download.

Getting started with TI-Nspire™ Software
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When the download is complete, the Information dialog box opens
informing you that the OS has been downloaded and that you can
disconnect the handheld from the computer.
5. Click OK. The updated operating system is installed on the handheld.
When the update is complete, the handheld reboots.
6. On the handheld, follow the prompts to:
•

Choose your preferred language

•

Select a preferred font size

7. When the Welcome Screen opens, click OK. The Home screen is
displayed.

About the software
Complete the following steps to open the About window, which provides
legal information about the software and indicates which version you
have.
1. Click Help > About “Student” TI-Nspire™ Software.
Note: You do not need an Internet connection to open this window.
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2. Click OK to close the window.
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Using the Documents Workspace
Use the tools in the Documents workspace to work with both TI-Nspire™
and PublishView™ documents. This chapter provides an overview for the
Documents Workspace in the following TI-Nspire™ software:
•

TI-Nspire™ Teacher Software

•

TI-Nspire™ Student Software

•

TI-Nspire™ CAS Teacher Software

•

TI-Nspire™ CAS Student Software

When there are differences between the software, those differences will
be described.

Exploring the Documents workspace
À
Á
Â

Ã

Ä
Å

Æ

Ç
À

Title bar. Shows the name of the current document and the name of
the software. The minimize, maximize, and close buttons are located
in the right corner.

Á

Menu bar. Contains tools for working with documents.

Using the Documents Workspace
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Â

Content/Documents tabs. In the TI-Nspire™ Teacher software, use

these tabs to switch between the Documents workspace and the
Content workspace. (These tabs do not appear in the Student
Software.)

Ã
Ä

Workspace tool bar. Shows frequently performed tasks.
Documents Toolbox. Contains tools such as the Document Tools

menu, Page Sorter, Content Explorer, Utilities, and TI-SmartView™
emulator. Click each icon to access the available tools. When you are
working in a TI-Nspire™ document, the tools available are specific to
that document. When you are working in a PublishView™ document,
the tools are specific to that document type.

Å

Toolbox pane. Options for the selected tool are displayed in this area.

For example, click the Document Tools icon to access tools needed to
work with the active application.
Note: In the TI-Nspire™ Teacher Software, the tool for configuring
questions opens in this space when you insert a question. For more
information, see the Using Question in the TI-Nspire™ Teacher
Software chapter.

Æ

Workspace. Shows the current document and enables you to
perform calculations, add applications, and add pages and problems.
Only one document at a time is active (selected). Multiple documents
appear as tabs.

Ç

Status bar. Shows the current problem number, enables you to access

document settings, toggle between computer mode and handheld
mode, and adjust the boldness or scaling of documents in the
workspace.

Exploring the menu bar and the tool bar
Using the menu bar
The menu bar contains all available options for working with documents.
The menu bar also provides access to options for managing your view
and accessing Help.

Click an option on the menu bar to open the drop-down menu that lists
options needed to perform tasks. If applicable, shortcut keys are also
listed on the drop-down menu.
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Using the tool bar
The tool bar provides quick access to options frequently used to work
with documents. These tasks are also accessible from the menu bar.

Note: Icons are grayed out when they are not available.

Using the File menu
Options available on the File menu are listed in the following table along
with their corresponding tool bar icon and shortcut key if applicable..
File Menu
Option

Options

Tool bar Shortcut
Icon
Key

New
Document

Create a new TI-Nspire™
document.

Windows®:
Ctrl+N
Macintosh®:
“+N

New
PublishView™
Document

Create a new PublishView™
document.

Open
Document

Open an existing document

Windows®:
Ctrl+Shift+N
Macintosh®:
“+Shift+N

Windows®:
Ctrl+O
Macintosh®:
“+O

Close

Close a document

Windows®:
Ctrl+W
Macintosh®:
“+W

Save
Document

Save a document

Windows®:
Ctrl+S
Macintosh®:
“+S

Save as...

Save a document with a new
name

Save to
Handheld

Save the document to a
connected handheld

Using the Documents Workspace
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File Menu
Option

Options

Convert to

•

Convert a TI-Nspire™
(.tns) document to a
PublishView™ (.tnsp)
document

•

Convert a PublishView™
document to a
TI-Nspire™ document

•

Export to web page

•

Copy HTML to clipboard

Export
Print

Print a document

Tool bar Shortcut
Icon
Key

Windows®:
Ctrl+P

Macintosh®:
“+P
Settings

Access settings for changing
the language, document
settings, and TI-SmartView™
emulator options.

Document
Properties

View and set document
properties such as copyright
and protection settings.

View copyright If document has a copyright,
Information
that information is displayed.
Recent
documents

Access recently opened
documents.

Exit

Exit or close the software,
with a prompt to save any
unsaved work.
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Windows®:
Alt+F4

Macintosh®:
“+Q

Using the Edit menu
Options available on the Edit menu are listed in the following table
along with their corresponding tool bar icon and shortcut key if
applicable.
Edit Menu
Option

Available Tasks

Tool bar
Icon

Undo

Undo last action performed

Shortcut Key
Windows®:
Ctrl+Z

Macintosh®:
“+Z
Redo

Click Redo to reverse the
Undo

Windows®:
Ctrl+Y

Macintosh®:
“+Y
Cut

Cut text from a document
and copy it to the clipboard

Windows®:
Ctrl+X

Macintosh®:
“+X
Copy

Copy text from a document
to the clipboard

Windows®:
Ctrl+C

Macintosh®:
“+C
Paste

Paste text in the clipboard
into a document

Windows®:
Ctrl+V

Macintosh®:
ì“ + V
Rename

Give a file a new name

Windows®:
F2

Delete

Permanently delete a file

Delete key

Page layout

Select a page layout for the
current TI-Nspire™ or
PublishView™ document.

Using the Documents Workspace
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Edit Menu
Option

Available Tasks

Color

Apply color to text and
highlight text background
with color.
•

Fill color

•

Line color

•

Text color

Tool bar
Icon

Shortcut Key

Using the View menu
Options available on the View menu are listed in the following table
along with their corresponding tool bar icon and shortcut key if
applicable.
View Menu
Options

Available Tasks

Computer

View document in
computer mode

Tool bar Short-cut Key
Icon
Windows®:
Alt+Shift+C

Macintosh®:
option + Shift +
C
Handheld

View document in
handheld mode

Scaling

Change the size of a
document view in
handheld mode

Previous page

Return to a previous
page in document with
multiple pages

Windows®:
Ctrl+left

Go to the next page in a
document with multiple
pages

Windows®:
Ctrl+right

Next page

PublishView™
Layout Options
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When a PublishView™
document is active, you
can select to show or
hide problem breaks and
object borders.
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Windows®
Alt+Shift+H

Macintosh®:
option + !

Macintosh®:
option + "

Using the Insert menu
Options available on the Insert menu are listed in the following table
along with their corresponding shortcut key if applicable.
Insert Menu
Options

Available Tasks

Shortcut Key

Add a problem
Add pages to a document with one of
the following applications:

Windows®:
Ctrl + I
Macintosh®:
ì“ + I

•
•
•
•
•
•
•
•

(Teacher software only)

Insert an image into a document (not
active if application does not support
images)
Insert a new program editor, open or
view an existing program editor, or
import a program editor
Opens the sensor console on the bottom Windows®:
of the active application to accept data Ctrl + D
collection input.
Macintosh®:
ì“ + D

Using the Documents Workspace
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Using the Tools menu
Options available on the Tools menu are listed in the following table
along with their corresponding tool bar icon and shortcut key if
applicable.
Tools Menu
Options

Available Tasks

Tool
bar
Icon

Shortcut Key

Screen
Capture

•

Capture Page

Windows®: Ctrl + J

•

Capture Selected
Handheld

Macintosh®: ì“ + J

Copies the active page
or handheld screen to
the clipboard and to the
TI-Nspire™ Screen
Capture window.
Transfer Tool

Variables

Opens the Transfer Tool,
which is used to transfer
files and folders to
connected handhelds

Windows®: Ctrl + T

Create and store
variables in a problem

Windows®: Ctrl + L

Refresh
Libraries

Refreshes the list of
stored libraries.

Install
Handheld OS

Update the operating
system on a connected
handheld

Macintosh®: ì“ + T

Macintosh®: ì“ + L

Using the Window menu
Options available on the Window menu are listed in the following table
along with their corresponding shortcut key if applicable.
Window Menu
Options

Available Tasks

Reset
workspace
layout

Reset the workspace layout
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Shortcut Key

Window Menu
Options

Available Tasks

Shortcut Key

Content
Workspace

Teacher software only: open the
Content Workspace

Windows®:
Ctrl + Alt + 1
Macintosh®:
ì“ + Alt + 1

Documents
Workspace

Teacher software only: Open the
Documents Workspace

Windows®:
Ctrl + Alt + 3
Macintosh®:
ì“ + Alt + 3

Document Tools Opens the application menu for the
active application.

Windows®:
Ctrl + Alt + M
Macintosh®:
ì“ + Alt + M

Page Sorter

Show pages of multiple page
Windows®:
document in the Documents Toolbox Ctrl + Alt + P
Macintosh®:
ì“ + Alt + P

TI-Smartview™
Emulator

Opens the TI-Smartview™ emulator
in the Documents Toolbox. In the
teacher software, the emulator
works the same as the handheld.

Windows®:
Ctrl + Alt + E
Macintosh®:
ì“ + Alt + E

Students can use TI-SmartView™
feature to emulate a keypad and use
the software as if using a handheld.
Utilities

Opens Utilities in the Documents
Toolbox

Windows®:
Ctrl + Alt + U
Macintosh®:
ì“ + Alt + U

Content
Explorer

Opens the Content Explorer in the
Documents Toolbox

Windows®:
Ctrl + Alt + O
Macintosh®:
ì“ + Alt + O

Autohide
Documents
Toolbox

Select this option to hide the
Documents Toolbox and make the
workspace area larger. When you
hide the Documents Toolbox, a tab is
placed vertically on the left side of
the window for accessing the tools.
Using the Documents Workspace
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Window Menu
Options

Available Tasks

Shortcut Key

Show Document Toggle view to tiled view to show
in Tiles/Tabs
thumbnails of open documents. If in
tiled view, toggle to show one
document in window with tabs
showing names of other documents
Screen Capture
Window

Opens the TI-Nspire™ Screen Capture
window

Document.tns

Shows the name of open documents

Using the Help menu
Options available on the Help menu are listed in the following table
along with their shortcut key if applicable. See Getting Started with the
TI-Nspire™ Software for additional information about Help menu
options.
Help Menu Option

What you can do

TI-Nspire™ Software Help Access help online help
Activate

Activate the software

Register

Register the software

Download latest
Guidebook

Download the latest
guidebook from the
Education Technology web
site

Visit education.ti.com

Access the Education
Technology web site

Visit Activities Exchange

Go to the Activities Exchange
web site

Explore Online
Troubleshooting

Go to the Knowledge Base
where you can submit
questions

Run TI-Nspire™
Diagnostics

Run diagnostics and send a
report to TI support
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Shortcut
Key
F1

Help Menu Option

What you can do

Check for Software
Updates

Check for software updates
and download updated
software if needed

Check for Handheld OS
Update

Check for handheld OS
updates and download
updated operating system
files if needed

About TI-Nspire™
Software

Open the About window

Welcome Screen

Open the Welcome screen

Shortcut
Key

Using the Documents Toolbox
The Documents Toolbox, located on the left side of the workspace,
contains tools needed for working with both TI-Nspire™ documents and
PublishView™ documents.

When you click a toolbox icon, the associated tools appear in the
workspace. Refer to the following table for information about each tool.
Icon

What you can do
Opens the application menu.
In TI-Nspire™ documents, the Document Tools menu

Document Tools contains tools available for working with an

application. The tools are specific to the active
application.
In PublishView™ documents, the Document Tools
menu contains tools needed to insert TI-Nspire™
applications and TI-Nspire™ documents, as well as
multimedia objects such as text boxes, images, and
links to web sites and files. See Working with
PublishView™ documents for more information
about these tools.

Using the Documents Workspace
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Icon

Page Sorter

What you can do
•

See the number of problems in your document
and where you are.

•

Move from one page to the other by clicking on
the page you want.

•

Add, cut, copy, and paste pages and problems
within the same document or between
documents.

Note: When working in a PublishView™ document,
the Page Sorter is not available in the Documents
Toolbox.
Teachers can use TI-Smartview™ emulator to
demonstrate concepts on the handheld.
TI-SmartView™ TI-Smartview™ emulator works the same as the
handheld. Students can use the TI-Smartview™
feature to emulate a keypad to use the software as if
using a handheld.
Note: Content is displayed on the TI-Smartview™
small screen only when the document is in Handheld
view.
When working in a PublishView™ document,
TI-SmartView™ emulator is not available.
Provides access to the following utilities:
Utilities
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•

Math Templates

•

Symbols

•

Catalog

•

Math Operators

•

Unit Conversions

•

Libraries

Using the Documents Workspace

Icon

Content
Explorer

What you can do
•

See a list of files on your computer

•

See a list of files on any connected handheld

•

Create and manage lesson bundles

•

Update the OS on connected handhelds

Those using the TI-Nspire™ Teacher Software to work
with documents can use the Content Explorer tool to
send or collect documents between their computer
and connected handhelds without changing
workspaces.

Exploring Document Tools
In the following example, the Document Tools menu is open showing the
options for the Calculator application.

À
Á

Â

À

The Documents Toolbox menu.

Á

Tools available for the Calculator application. Click ¢ to open
the sub-menu for each option.

Â

Click

to close and click

open Document Tools.
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Exploring the Page Sorter Pane
The following example shows the Documents Toolbox with the Page
Sorter open.

À
Á

Â

À

The Documents Toolbox menu.

Á

Click the minus sign to collapse the view. Click the + sign to
open the view and show pages in the document.

Â

Scroll bar. The scroll bar is only active when there are too many
pages to show in the pane.

Exploring the TI-SmartView™ pane or keypad pane
The TI-Smartview™ feature emulates how a handheld works. In the
teacher software, the emulated handheld facilitates classroom
presentations. In the student software, the emulated keypad gives
students the ability to drive the software as if using a handheld.
Note: The following illustration shows the TI-SmartView™ pane in the
teacher software. In the Student Software, only the keypad is shown. See
Using the TI-SmartView™ emulator chapter for more information.
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À
Ã

Á
Â

À

The Documents Toolbox menu.

Á

Handheld Selector. Click the ¤ to select which handheld to
show in the pane:
•

TI-Nspire™ CX

•

TI-Nspire™ Touchpad

•

TI-Nspire™ Clickpad

Then, select how to show the handheld:
•

Normal

•

High contrast

•

Outline

Using the Documents Workspace
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Â

View selector. In the teacher software, click ¤ to select the
handheld view:
•

Handheld only

•

Keypad plus sidescreen

•

Handheld plus sidescreen

Note: You can also change these options in the
TI-SmartView™ Options window. Click File> Settings >
TI-Smartview™ Options to open the window.
Note: The view selector is not available in the student
software.

Ã

When the Handheld Only display is selected, check Always in
Front to keep the display in front of all other open
applications. (Teacher software only.)

Exploring the Content Explorer pane
Use the Content Explorer pane to:
•

See a list of files on your computer

•

See a list of files on any connected handheld

•

Create and manage lesson bundles

•

Update the OS on connected handhelds

•

Transfer files between a computer and connected handhelds

Note: Teachers using TI-Nspire™ Teacher Software can use the Content
Explorer tool to transfer and copy documents between their computer
and connected handhelds without changing workspaces.
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À
Á

Ã

Â

Ä

Å
Æ

À

The Documents Toolbox menu.

Á

Shows files on your computer and the name of the folder where
the files are located. Click ¤ to navigate to another folder on the
computer.

Â

The list of folders and files within the folder named in the Look
In: field. Right-click on a highlighted file or folder to open the
context menu listing available actions for that file or folder.

Ã

Click

to close the list of files. Click

to open the list of files.
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Ä

Options menu. Click ¤ to open the drop-down menu of
actions you can perform on a selected file:
•

Open an existing file or folder

•

Move (navigate) up one level in the folder hierarchy

•

Create a new folder

•

Create a new lesson bundle

•

Rename a file or folder

•

Copy selected file or folder

•

Paste file or folder copied to clipboard

•

Delete selected file or folder

•

Select all files in a folder

•

Package lesson bundles

•

Refresh the view

•

Install OS

Å

Connected handhelds. Lists the connected handhelds. Multiple
handhelds are listed if more than one handheld is connected to
the computer or when using the TI-Nspire™ Docking Stations.

Æ

The name of the connected handheld. To display the folders and
files on a handheld, double-click the name.
Click ¤ to navigate to another folder on the handheld.

Exploring the Utilities pane
The Utilities pane provides access to the math templates and operators,
special symbols, catalog items, and libraries that you need when working
with documents. In the following example, the Math templates tab is
open.
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À

Á

Â

Ã

À

The Documents Toolbox menu.

Á

Math Templates are open. Double-click a template to add it to
a document. Click the Math Template tab to close the
template view.
To open the Symbols, Catalog, Math Operators, and Libraries,
click the tab.

Â

Wizards On check box. Turn this option on to use a wizard to
enter function arguments.

Ã

Tabs for opening views where you can select and add symbols,
catalog items, math operators, and library items to a
document. Click the tab to open the view.
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Using the workspace
The space on the right side of the window provides an area for creating
and working with TI-Nspire™ and PublishView™ documents. This space
provides a view of the document so that you can add pages, add
applications, and perform all work. Only one document at a time is
active.
You can view documents in one of two views: Computer mode or
Handheld mode. Either view will remember the last size and file location
you used.
•

Handheld mode. View documents as they appear on the handheld
screen. The screen size is limited as it would be on the handheld.

•

Computer mode. This is the default view in the software as shown in

the following example.

Understanding the status bar
The status bar provides information about the current document,
enables you to toggle between Handheld and Computer modes, and
adjust the view of the document.
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Ä
Á Â
Ã
À
À If in tabbed view, the name of the document is displayed. If unsaved,
the default name is "Document1." If in tiled view, open documents
are displayed as thumbnails in the workspace.

Á
Â

Problem and page number. References the current document.
Settings. Current settings for Angle, Auto or Approximate, and Real
or Complex. Click here to view or change General or Graphs &
Geometry settings.

Ã

Document View. Toggle between Handheld and Computer modes.
Click the appropriate icon to change views.

Ä

Scale. When working with a document in computer mode, use the
Boldness scale to increase or decrease the boldness of the lines in a

document. Go to the left to decrease the boldness. Go to the right to
increase the boldness.
When working with a document in handheld mode, use the Scale
slider to control the size of the document in the workspace. Go left to
make the document smaller. Go right to make the document larger.

Viewing and changing document settings
Settings control how information is displayed in TI-Nspire™ and
PublishView™ documents.
•

General settings control how all numbers, including elements or
matrices and lists, are displayed. You can change the default settings
at anytime and you can specify settings for a specific document.

•

Graphs & Geometry settings control how information is displayed
in open problems and in subsequent new problems. When you
change the Graphs & Geometry settings, the selections become the
default settings for all work in these applications.

Changing General settings
Complete the following steps to customize the general settings that are
applied to your document.
1. Create a new document or open an existing document.
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2. From the status bar, double-click Settings or select
File > Settings > Document Settings to open the Document Settings
window.
When you open Document Settings the first time, the default General
Settings are displayed.

3. Press Tab or use your mouse to move through the list of settings. Click
¤ to open the drop-down list to view the available values for each
setting.
Field

Value

Display Digits

•

Float

•

Float1 - Float12

•

Fix0 - Fix12

•

Radian

•

Degree

•

Gradian

•

Normal

•

Scientific

•

Engineering

Angle

Exponential Format

Real or Complex Format •
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Real

•

Rectangular

•

Polar
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Field

Value

Calculation Mode

•

Auto

•

CAS: Exact

•

Approximate

Note: Auto mode displays an answer
that is not a whole number as a fraction
except when a decimal is used in the
problem. Exact mode (CAS) displays an
answer that is not a whole number as a
fraction or in symbolic form, except
when a decimal is used in the problem.
Vector Format

Base

Unit System (CAS)

•

Rectangular

•

Cylindrical

•

Spherical

•

Decimal

•

Hex

•

Binary

•

SI

•

Eng/US

4. Use the mouse to click and select the desired setting.
5. Choose one of the following options:
•

To apply the customized settings to ALL documents, click Make
Default.

•

To apply the settings to the open document only, click OK.

•

To restore default settings, click Restore.

•

Click Cancel to close the window without making changes.

Changing Graphs & Geometry settings
Complete the following steps to customize the application settings for
graphs and geometry.
1. Create a new document or open an existing document.
2. From the status bar, double-click Settings or select File > Settings >
Document Settings to open the Document Settings window.
3. Click Graphs & Geometry to view the current settings.
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4. Press Tab or use your mouse to move through the list of settings. Click
¤ to open the drop-down list to view the available values for each
setting.
Field

Values

Display Digits

•

Auto

•

Float

•

Float1 - Float12

•

Fix0 - Fix12

Graphing Angle

Geometry Angle

•

Auto

•

Radian

•

Degree

•

Gradian

•

Auto

•

Radian

•

Degree

•

Gradian

5. Use the mouse to select the desired setting.
6. Click a check box to enable or disable an option.
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Check box

Operation when selected

Automatically hide plot
labels

Plot labels are displayed only when
selected, grabbed, or hovered.

Show axis end values

A numeric label is displayed at the
least and greatest values visible on
an axis

Show tool tips for function
manipulation

Shows helpful information as you
manipulate function graphs

Automatically find a point
of interest

Shows zeros, minima, and maxima
for graphed functions and objects
while tracing function graphs.

7. Choose one of the following options:
•

To apply the customized settings to ALL documents, click Make
Default.

•

To apply the settings to the open document only, click OK.

•

To restore default settings, click Restore.

•

Click Cancel to close the window without making changes.

Sending files to a handheld
From the Documents workspace, complete the following steps to send a
TI-Nspire™ document (.tns file) to connected handhelds.
1. Open the Content Explorer, then navigate to the file on your
computer that you want to send to the handheld.
2. "Drag and drop" the file to the handheld. Click the file to select it,
then without releasing the mouse button, drag the file to the
handheld. Release the mouse button to copy the file to the selected
handheld.
Note: You can also select File > Save to Handheld to send a file from
your computer to a connected handheld.

Working with Lesson Bundles
Many lessons or activities contain multiple files. For example, teachers
usually have a teacher version of a file, a student version, assessments,
and sometimes supporting files. A lesson bundle is a container that
enables teachers to group all files needed for a lesson together. In the
Documents workspace, you can view, edit, demonstrate, and save
updates to .tns files in a lesson bundle. You can use lesson bundles to:
Using the Documents Workspace
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•

Add any type of file (.tns, .tnsp, .doc, .pdf, .ppt) to a lesson bundle.

•

Send lesson bundles to connected handhelds; however, only the .tns
files are sent to the handheld.

•

View all the files in a lesson bundle using the TI-Nspire™ Software

•

Group all files associated with one lesson in one place

•

E-mail one lesson bundle file to teachers or students instead of
looking for and attaching multiple files.

In the Documents workspace, options for working with lesson bundles
are in the Content Explorer.

Creating a new lesson bundle
Complete the following steps to create a new lesson bundle.
1. From the Documents workspace, click
pane to open the Content Explorer.

in the Documents Toolbox

2. Navigate to the folder where you want to save the lesson bundle file.
3. Click

to open the drop-down menu, then select New Lesson

Bundle.

The new lesson bundle file is created with a default name and placed
in your list of files.
4. Type a name for your lesson bundle and press Enter to save the file.

Adding files to a lesson bundle
By default, lesson bundles are empty when created. Use any of the
following methods to add files to a lesson bundle:
•

"Drag and drop" any file into a selected lesson bundle. This method
moves the file to the lesson bundle. If you delete the lesson bundle,
the file is deleted from your computer. You can recover the file from
the Recycle Bin.

•

Copy and paste any file into a selected lesson bundle.

•

Use the "Add files to lesson bundle" option. This method copies the
selected files into the lesson bundle. The file is not moved from its
original location.

Using the Add files to lesson bundle option
To add files to the bundle using the Add files to lesson bundle option:
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1. From the Content Explorer, double-click the lesson bundle file to
open the lesson bundle window. The window name reflects that
name of the lesson bundle.

2. Click Add Files to Lesson Bundle to open the Add window.

3. Use the file manager to navigate to and select the file you want to
add to the lesson bundle.
•

You can select multiple files at one time if they are located in the
same folder.

•

If files are located in different folders, you can add them one at a
time.

•

You cannot create a folder within a lesson bundle or add a folder
to a lesson bundle.

4. Click Add to add the file to the bundle.
The file is added to the bundle and is now listed in the lesson bundle
window.
5. Repeat this process until all needed files are added to the lesson
bundle.
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Opening a lesson bundle
To view and work with files within a lesson bundle, complete one of the
following steps to open the lesson bundle file.
f Double-click the lesson bundle name.
f Select the lesson bundle, then right-click and select Open from the
context menu.
f Select the lesson bundle, click

, then select Open.

f Select the lesson bundle, then press Ctrl + O. (Macintosh®: “ + O).
When you open a lesson bundle, the files in the bundle are displayed in a
separate window.

Note: You cannot open a lesson bundle outside of the TI-Nspire™
software. For example, if you open the folder using the file manager on
your computer and double-click the lesson bundle name, it does not
automatically launch the software.

Opening files within a lesson bundle
You can open any file within a lesson bundle on your computer if you
have the program associated with the file type.
•

When you open a .tns or .tnsp file, the file opens in the Documents
workspace in the TI-Nspire™ software.

•

When you open another file type, it launches the application or
program associated with that file. For example, if you open a .doc
file, it opens in Microsoft® Word.

Use one of the following options to open a file within a lesson bundle:
f Double-click the lesson bundle, then double-click a file within the
lesson bundle.
f Within a lesson bundle, select the file, then click ¢ or right-click the
file name and select Open from the context menu.
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Managing files in a lesson bundle
You can open, copy/paste, delete, and rename files in an existing lesson
bundle. To locate and work with files in an existing lesson bundle:
1. In the Documents Toolbox pane, open the Content Explorer.
2. Navigate to the folder where the lesson bundle is saved.
3. Click ¢ or double-click the lesson bundle name to open the Lesson
Bundle window.
4. Select the file you want to work with and click ¢ to open the context
menu.

5. Select the action you want to perform:
•

Click Open to open the file. TI-Nspire™ and PublishView™
documents open in the Documents workspace. When you open
another file type, it launches the application or program
associated with that file.

•

Click Copy to place the file in the clipboard.

•

Navigate to a folder on your computer or select a handheld, then
right-click and select Paste to place the copied file in a new
location.

•

Click Delete to delete a file from the lesson bundle. Use caution
when deleting a file from a lesson bundle. You should ensure files
contained in the bundle are backed up if you need the files for
future use.

•

Click Rename to give the file a new name. To cancel this action,
press the Esc key.

•

Click Add Files to Lesson Bundle to select and add additional files
to the bundle.
Using the Documents Workspace
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•

Click Refresh to update the list of files in the bundle.

•

Click Package Lesson Bundle to create a .tilb file

•

Click Send to Connected Handhelds to open the Transfer Tool
and send the selected file to connected handhelds. You can only
send .tns files to handhelds.

6. When finished, click Close to close the window.

Packaging lesson bundles
Packaging lesson bundles creates a "package" folder with a .tilb file. This
file contains all contents of the lesson bundle. You must package the
lesson before you can e-mail the lesson bundle (.tilb file) to colleagues or
students. By default, the lesson bundle is saved in the following folder:
...\TI-Nspire\New Lesson Bundle1.tilb\package\...

To package a lesson from the Documents workspace:
1. Open the Content Explorer.
2. Navigate to the folder where the lesson bundle is saved.
3. Select the lesson bundle you want to package.
4. Right-click to open the context menu, then select Package Lesson.
A dialog box is displayed confirming that the .tilb file was created
and the lesson bundle was successfully packaged.

5. Click Yes to open the folder where the lesson package is stored. Click
No to close the dialog box.

E-mailing a lesson bundle
After a lesson bundle is packaged, you can e-mail the .tilb file to other
teachers or students. To attach the lesson bundle to an e-mail:
1. In your e-mail client, select the option needed to attach a file, then
navigate to the .tilb folder.
2. Make sure you open the folder and select the .tilb file to attach to the
email. You cannot email the .tilb folder.
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Managing lesson bundles
Use the options menu or the context menu to copy, delete, rename, or
send a lesson bundle to connected handhelds. You cannot add a folder to
a lesson bundle.
1. In the Content Explorer, right-click the lesson bundle name or click
to open the context menu.

2. Select the action you want to perform. If an action is not available, it
is grayed out.
•

Click Open to open the lesson bundle.

•

Click Up One Level to navigate up one level in the folder
hierarchy.

•

You cannot add a folder to a lesson bundle. If you select Open
Folder, a new folder is added to the folder where the lesson
bundle is stored.

•

Select New Lesson Bundle to create a new lesson bundle. The
new lesson bundle is not added to the existing lesson bundle—it is
created in the same folder as the existing lesson bundle.

•

Click Rename to change the name of the lesson bundle. Press the
Esc key to cancel this action.

•

Click Copy to copy the lesson bundle to the clipboard.

•

Navigate to another folder, then click Paste to copy the lesson
bundle in another location.

•

Click Delete to delete the lesson bundle. Use caution when
deleting a lesson bundle. You should ensure files contained in the
bundle are backed up if you need the files for future use.

•

Select All highlights all files in the open folder. This action does

not apply to lesson bundles.
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•

Click Package Lesson to create a .tilb file.

•

Click Refresh to update the list of files in the open folder.

Sending lesson bundles to connected handhelds
1. In the Content Explorer, select the lesson bundle you want to send.
2. Using your mouse, "drag and drop" the lesson bundle file to a
connected handheld. You can also copy the lesson bundle, then paste
it to a connected handheld.
The lesson bundle is transferred to handheld as a folder with the
same name. Only .tns files are transferred to the handheld.

Using Screen Capture
Use Screen Capture to copy an image of the active view on your
computer or handheld. Images are copied to the clipboard and to the
TI-Nspire™ Screen Capture window. Use options in the TI-Nspire™ Screen
Capture window to save the images as .jpg files, which can be inserted
into to TI-Nspire™ applications that allow images or inserted into
documents created using other application such as Microsoft® Word.

Capturing pages in a document
1. From an open document, click

.

•

To capture the current page on your computer, select Capture
Page.

•

To capture the current page on a connected handheld, ensure the
handheld is selected, then click Capture Selected Handheld.

The image is copied to the clipboard and to the TI-Nspire™ Screen
Capture window. The
dialog opens in
the lower right corner of your desktop when the screen capture is
complete.
2. Click View it to open the TI-Nspire™ Screen Capture window.
You can also select Window > Screen Capture Window to open the
TI-Nspire™ Screen Capture window.
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3. To capture additional pages, move to the next page in the document,
then click
to select the option required to add that page to the
TI-Nspire™ Screen Capture window.
For more information about using screen capture, see Working with
TI-Nspire™ documents.

Updating the handheld OS
To install or update the operating system on a connected handheld from
the Documents workspace.
1. Ensure the updated OS file is downloaded to your computer and that
all work on the handheld is saved.
Note: You can find the latest OS files on the Education Technology
web site (http://education.ti.com).
2. Open the Content Explorer to see Connected Handhelds.
3. Select the handheld you want to update.
4. Click
, then select Install OS or select Tools > Install Handheld OS
from the menu bar. The Select Handheld OS File dialog box opens.
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5. Navigate to the folder on your computer where the operating system
file is located.
6. Select the file name, then click Install OS.
•

If you are upgrading a TI-Nspire™ CX handheld, select
TI-Nspire.tco

•

If you are upgrading a TI-Nspire™ CX CAS handheld, select
TI-Nspire.tcc

•

If you are upgrading a TI-Nspire™ handheld, select TI-Nspire.tno

•

If you are upgrading a TI-Nspire™ CAS handheld. select
TI-Nspire.tnc

7. When the confirmation message is displayed, click Yes. The Installing
OS dialog opens indicating the progress of the download.

52

Using the Documents Workspace

8. When the Information dialog opens indicating that the download is
complete, click OK. The updated operating system is installed on the
handheld. When the update is complete, the handheld reboots.
9. On the handheld, follow the prompts on the handheld to:
•

Choose a preferred language

•

Select a preferred font size

10. On the handheld, click OK when the Welcome Screen opens.
The Home screen is displayed.

Using the Documents Workspace
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Working with TI-Nspire™ documents
This section describes how to work with TI-Nspire™ documents using the
Documents workspace. Information in this chapter is for the following
TI-Nspire™ software:
•

TI-Nspire™ Teacher Software

•

TI-Nspire™ Student Software

•

TI-Nspire™ CAS Teacher Software

•

TI-Nspire™ CAS Student Software

•

TI-Nspire™ Navigator™ Teacher Software

When there are differences between the software, those differences are
described.

About documents
All work that you create and save with the desktop software is stored as
a document, which you can share with others using TI-Nspire™ software
and with those using handhelds. There are two types of documents:
•

TI-Nspire™ document (.tns file)

•

PublishView™ document (.tnsp file)

TI-Nspire™ documents
A TI-Nspire™ document consists of one or more problems and each
problem contains one or more pages. A single page is displayed in the
workspace on your screen. All work occurs in the applications within
pages. Because the TI-Nspire™ software and the TI-Nspire™ handhelds
share the same functionality, you can use the software to create
TI-Nspire™ documents that can be transferred between the software and
a handheld.

PublishView™ documents
PublishView™ documents can be printed on a standard piece of paper or
published to a web site or blog. PublishView™ documents can include
formatted text, images, and hyperlinks as well as all TI-Nspire™
applications.
For more information about creating and using PublishView™
documents, see Working with PublishView™ documents

Working with TI-Nspire™ documents
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Managing TI-Nspire™ documents
When you first open the desktop software, the Documents workspace
opens with a blank document containing one problem. You can add
applications and content to this problem to create a document.
Note: The Welcome Screen is displayed when you open the software if
the "always show this at startup" option is selected. Click an application
icon to add a problem with an active application to a new document.

Creating a new TI-Nspire™ document
To create a new TI-Nspire™ document, complete the following steps:
1. From the menu bar in the Documents workspace, select File > New
TI-Nspire™ Document or click
TI-Nspire™ Document.

on the tool bar, then select New

The new document opens in the Documents workspace and you are
prompted to select an application. By default, new documents open
in your current view: computer or handheld. To change the view, use
the View menu or click the appropriate icon in the status bar.

2. Select an application to add a problem to the document.
The problem is added to the document.

Saving TI-Nspire™ documents
To save a new document:
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1. Select File > Save Document, or click
.
The Save TI-Nspire™ Document dialog box opens.

2. Navigate to the folder where you want to save the document or
create a folder in which to store the document.
3. Type a name for the new document.
4. Click Save to save the document.
The document closes and is saved with the extension .tns.
Note: When you save a file, the software will first look in the same folder

the next time you open a file.

Saving a document with a new name
To save a previously saved document in a new folder and/or with a new
name:
1. Select File > Save As... from the menu bar.
The Save TI-Nspire™ Document dialog box opens.
2. Navigate to the folder where you want to save the document or
create a folder in which to store the document.
3. Type a new name for the document.
4. Click Save to save the document with a new name.

Opening an existing document
To open an existing document:
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1. Click File > Open Document or click
The Open dialog box opens.

.

2. Use the file browser to locate the file you want to open and click the
file to select it.
3. Click Open.
The document opens in the workspace.
Note: To select from your 10 most recent documents, click File > Recent
Documents and select a document from the drop-down list.

Using Content Explorer to locate files
The Content Explorer is a file browser that lists files on your computer
and on any connected handheld. Use the Content Explorer to:
•

Transfer files and folders between your computer and any connected
handhelds.

•

Copy and paste files, lesson bundles, and folders.

Opening Content Explorer
f From the Documents Toolbox, click
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À
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Á
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Å

Computer file browser - Contains folders and files on your computer.
Current top-level folder - The current folder. Click ¤ to navigate to
another folder. The default folder is My Documents.
Folders - Double-click the folder icon to view the files in a folder.
Files - Files in the top-level folder.
Handheld file browser - This section of the pane contains folders and
files on a connected handheld.
Context menu - Click ¤ to open the drop-down menu listing options

for working with folders and files in the Content Explorer.

Æ

Expand/collapse double arrows - Click here to expand or collapse

the Computer or Handheld file browser.
You can select files and folders in the Content Explorer file browser
pane and drag and drop them to another location:
•

Select a file or folder and drag it to another folder in the computer or
handheld browser
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•

Select a .tns or .tnsp file and drag it to the workspace to open the
document.

Understanding which files and folders you can transfer
•

You can use the file browser pane to transfer or move the following
file types between a computer and a connected handheld:
File Type

Extension

TI-Nspire™ document

.tns

Packaged lesson bundle file

.tilb

Learning Check file

.edc

Cabri™ file

.fig

Handheld operating system files

TI-Nspire™ CX Handheld

.tco

TI-Nspire™ CX CAS Handheld

.tcc

TI-Nspire™ Handheld

.tno

TI-Nspire™ CAS Handheld

.tnc

•

You cannot transfer .tnsp files to a handheld; however, you can
convert a .tnsp file to a .tns file.

•

The file folders that you can transfer may be limited depending on
the handheld software version and on the file folder structure, such
as how many levels there are within the folder.

•

If you move file folders that contain unsupported files, the supported
files are transferred, and the unsupported files are ignored.

•

All files in a lesson bundle will appear in the Content Explorer.

Saving a document to a connected handheld
From the Documents workspace, complete the following steps to save a
document to a connected handheld.
Note: Use a standard USB cable to connect a single handheld to a
computer. In the classroom, use the TI-Nspire™ Docking Station or
TI-Nspire™ CX Docking Station to connect multiple handhelds to the
computer.
1. Open the document you want to save to a handheld.
2. Select File > Save to Handheld. The Save to Handheld dialog box
opens.
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Note: You can also "drag and drop" a file from the computer pane to
a handheld listed in the Connected Handhelds pane.

3. Select the receiving handheld. If multiple handhelds are connected,
the names are listed.
4. Click Save to save the file, or Cancel to abandon the save.
If you choose the name of an existing file, a dialog will open asking
whether you want to replace the file.
To overwrite the file, click Replace. To abandon the save, click Cancel.
5. A dialog box shows that the file is being saved.
Note: Any file saved to a handheld will be saved as a .tns file.

Opening handheld documents in the software
You can open documents from a handheld directly in the software. You
can then work with the documents and save them through ordinary save
commands.
To open a document on your handheld:
f In the Content Explorer, select the document from the Connected
Handhelds browser pane.
— OR —
f Right-click, choose Open, navigate to the document, and click OK.
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Saving handheld documents in the software
To save a handheld document you have been editing in the software, do
one of the following:
f Type Ctrl + S (Macintosh®: ì“ + S).
— OR —
f Click File > Save Document.

Copying supported files and folders
To copy supported files and folders:
1. Click and hold the file you want to copy. To select multiple files, use
Ctrl + Click (Macintosh®: ì“ + Click).
2. Drag the files to the destination you want and release the mouse.
3. If a file or files exist in the target destination with the same names,
you’ll be asked whether you want to replace the files.
4. Click Yes to replace the file shown, Yes to All to replace all files, or
No to stop.
5. When you are in the process of copying a group of files, cancel the
operation by clicking Cancel. Only those files that haven’t yet been
transferred to the destination will be canceled. Other files will have
already been transferred.
Note: If you copy to a connected handheld, only .tns supported
documents can be copied.

Creating new folders
1. In the Computer or Connected Handhelds pane, click
select New Folder.

, then

2. Type a name for the folder and press Enter.

Deleting documents
File deletions on the handheld are permanent and cannot be undone, so
be sure that you want to delete the file that you select. File deletions on
your computer are sent to the Recycle bin and can be retrieved if the
Recycle bin has not been emptied.
1. Select the document you want to delete.
2. Click Edit > Delete or press the Delete key.
3. When the Warning dialog box opens, click Yes to confirm the delete.
The document is deleted.
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Working with multiple documents
When multiple documents are open, all document names are listed in
tabs at the bottom of the work area. Only one document is active at a
time, and only the active document is affected by commands from menus
or tools. You can also show thumbnail views of all open documents in the
workspace. To show thumbnails, select Window > Show Documents in
Tiles.

Á

À

Â

To switch between documents:

À

Click the tab to show a document in the work space. This
document becomes the active document. If the Show
Documents in Tiles view is open, these tabs are not shown.

Á

Use the right and left arrows to scroll through the list of
documents. These arrows are active only when there are too
many documents to fit in the window.

Â

Click the Show List icon to list all open documents. This is
useful when you have a large number of documents open and
documents names on the tabs may be truncated.

Working with multiple documents in tiled view
When multiple documents are open, you can view thumbnails of the
documents in the workspace. To change the view:
f Select Window > Show Documents in Tiles. Open documents are
shown as thumbnails in the workspace and the scroll bar become
active.
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The status bar remains available; however, document names now
appear on the thumbnail view. Select Window > Show Documents
in Tabs to view one document at time in the workspace.

Closing documents
f To close a document, click File > Close or click the Close icon on the
document tab at the bottom of the document.

f If using the tiled view, click the Close icon in the upper right corner of
the document window.

Working with applications
When you first open a new document or add a new problem to a
document, select an application from the menu.
The following illustration shows how a problem with the Lists &
Spreadsheet application appears in the work space on the right side of
the window when Handheld mode is selected.
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À

Á Â

Ã

Ä
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Á

Document name- This tab contains the document name.

Â

Settings - Enables you to change the General Settings and Graphs
and Geometry Settings for the active document or change the default
settings. See Using the Documents Workspace for information about
changing settings.

Ã

Document View - Enables you to switch between computer mode
and handheld mode.

Ä

Scaling/Boldness - When in computer view, use this scale to increase

Problem/Page counter - The first value represents the problem
number of the active page, while the second value tells you the page
number within the problem. In the example, the counter reads 1.2,
indicating Problem 1, Page 2.

or decrease the boldness of the document. When in handheld view,
use this scale to make the image larger or smaller.

Opening Document Tools
Tools for working with applications are located in the Documents
Toolbox panel on the left side of the window.
To open Document Tools:
f Select Window > Document Tools or click
Toolbox pane.

in the Documents
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The Document Tools menu opens with the tools and tool menus
specific to the application in the active problem or page. The
following illustration shows the menu for the Lists & Spreadsheet
application.

If there are multiple problems and pages in the document, the tools
specific to the application on the active page are shown in the
Document Tools menu when you select the page.

Opening context menus
Use context menus to access options specific to a selected object or the
current cursor location.
1. To access a context-sensitive menu for an application, right-click in
the work area. The following example shows the context menu for
the Lists & Spreadsheet application.
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2. Click the option name to select it. When available, click ¢ to access
actions specific to the menu option.

Working with multiple applications in a page
You can add up to four applications to a page. When you have multiple
applications on a page, the menu for the active application is displayed
in the Documents Toolbox. Using multiple applications involves two
steps:
•

Changing the page layout to accommodate multiple applications

•

Adding the applications

You can add multiple applications to a page even if an application is
already active.

Adding multiple applications to a page
By default, each page contains space to add one application. To add
additional applications to the page, complete the following steps.
1. Click Edit > Page Layout > Select Layout, or click
bar to open the page layout menu.

from the tool

There are eight page layout options available. If an option is already
selected, it is grayed out.
Highlight the layout you wish to add to the problem or page, then
click to select it. The new layout is displayed with the first application
active.
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2. Click to select an application for each new section in the problem or
page.

Swapping applications
To change the position of applications on a page with multiple
applications, “swap“ the positions of two applications.
1. Click Edit > Page Layout > Swap Application.
Note: The last active application you worked on is automatically
selected as the first application to be swapped.
2. Click on the second application to swap. This action performs the
swap.
Note: When there are only two work areas, the selected application
automatically swaps position with the other application on the work
area.
To cancel a swap, press Esc.

Selecting and moving pages with the Page Sorter
The Page Sorter is part of the Documents Toolbox. Use the Page Sorter to
list thumbnail views of all pages in the document. Use the Page Sorter to
move to different pages in your document, and to quickly move and
rearrange pages.
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À

Á

Â
À

Page Sorter - Displays thumbnail sketches of all pages in all
problems in the current document. Use the scroll bar to view pages
off the screen.

Á

Active page - The page currently highlighted in the Page Sorter and
active in the work space.

Â

Problem/Page counter - Displays the problem number followed by
the page number.

Selecting pages
The Page Sorter always indicates the active page in the work area.
•

If you are working on a page in the work space, this page is indicated
in the Page Sorter by a color border.

•

If you are actively using the Page Sorter, the active page displayed in
the work space has a color border in the Page Sorter pane.

•

Clicking on any page in the Page Sorter makes it the active page, and
it is displayed in the work space.

Rearranging pages
Use the Page Sorter to change the order of pages within a problem.
1. Click to select the thumbnail view of the page in the Page Sorter.
2. Hold down the mouse button and drag the page to the desired
position, and release to drop it in the new location.
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Grouping applications
To group up to four pages into a single page:
1. From the Documents Toolbox, click
panel.

to open the Page Sorter

2. Select the first page in the series.
3. Select Edit > Page Layout > Group.
The next page is grouped with the first page. The page layout
automatically adjusts to display all the pages in the group.
To ungroup pages:
4. Select the grouped page.
5. Select Edit > Page Layout > Ungroup.
The material becomes individual pages and applications.

Deleting an application from a page
1. Select the application you want to delete.
2. Select Edit > Page Layout > Delete App.
The application is deleted.
If you want to undo the delete, type Ctrl-Z (Macintosh®: ì “+ Z).

Deleting pages
You can delete an entire page using the delete tools on the tool bar.
1. Select the page you want to delete.
2. Select Edit > Delete or right-click and select

Delete.

Working with problems and pages
When you create a new document, a problem is added with one page.
When a document has a problem with multiple pages or multiple
problems, select Window > Page Sorter to open the page sorter view in
the Documents Toolbox to view the problems and pages.

Adding a problem to a document
A document can contain up to 30 problems. To add a new problem:
f Select Insert > Problem, or click the toolbar icon
Problem.
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and select

A new problem with one new page is added to your document.

Adding a page to a problem
Each problem can contain up to 50 pages. To add a new page to a
problem:
1. Select Insert > Page, or click the toolbar icon
Page.

and select

A new page is added to the problem.
2. Select an application to add to the page.

Copying, pasting, and deleting problems
You can copy and paste a single problem from one location to another
within the same document or a different document. You can also delete
the problem from the document.

Copying and pasting a problem
To copy and paste the problem:
1. In the Documents Toolbox, click

, to open the Page Sorter.

2. Click a problem to select it.
3. Press Edit > Copy or Ctrl + C (Macintosh®: ì“ + C).
4. Go to the location where you want the problem to appear.
5. Press Edit > Paste or Ctrl + V (Macintosh®: ì“ +V).
A duplicate problem is placed in the new location.

Deleting a problem
To delete a problem from the document:
1. Select the problem.
2. Press Edit > Delete or Ctrl+X (Macintosh®: ì“ + X).
The problem is deleted from the document.

Renaming a problem
To rename a problem:
1. Using the Page Sorter pane, select the problem name.
2. Right-click and select Rename.
The problem name box clears.
3. Type the name and click Enter.
Working with TI-Nspire™ documents
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The new name appears in bold to indicate that it has been changed.
To Undo, click the Undo key or click Edit > Undo.

Using Utilities in documents
The Utilities pane is located in the Documents Toolbox. To access the
Utilities pane:
1. Select Windows > Utilities or click

.

The Utilities pane opens in the Documents Toolsbox.
2. Click each tab to open a palette of items.
Use the Utilities pane for quick access to the following items:
•

Math templates. Contains math templates for creating two

dimensional objects, including product, sum, square root and
integral.

•

72

Symbols. Provides a symbol palette for adding special characters.
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•

Catalog. Contains all commands and functions, in alphabetical order.

•

Math operators. Contains all math functions.
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•

CAS: Unit conversions. Provides the values for standard

measurement units.

•

Libraries. Shows Public library (LibPub) objects defined in the

documents located in the MyLib folder.
Note: For more information about libraries, please see the Library
section of the documentation.
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f To open any item on the Utilities pane, click the Utilities tab, and then
click the item you want.

Inserting items from the Utilities pane
1. Open the Utilities pane.
2. Select the header that contains the function, symbol, or expression
you want to insert into your problem.
3. Double-click the item or drag and drop it into the expression. You can
also select the item and press Enter.
Move the mouse over an item to view a short description of each item
or view syntax information.

Using wizards
Wizards provide help for entering functions and performing tasks for
symbol
items in the Utilities pane such as LinRegMx and OneVar. The
appears next to items that are supported by wizards. To use a wizard:
1. In the Utilities pane, click the tab to open the set of utilities you want
to work with. For example, click Catalog.
2. Click the check box next to the Wizards on box in the lower right
corner of the pane.
3. When you begin a command or function that is supported by a
wizard, a dialog box provides help needed to use the selected
function. For example, when you select LinRegtTest from the
Catalog, the following dialog opens.
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Using colors in documents
You can use colors in the following desktop applications:
•

Data & Statistics

•

Graph

•

Geometry

•

Lists & Spreadsheet

•

Notes

You can use color in filled areas of an object, or in lines or text,
depending on the application you’re using and how you have selected
the item.
Color appears when displayed on your computer and on documents
opened on the TI-Nspire™ CX handheld. If a document containing color
is opened on a TI-Nspire™ handheld, it displays in shades of gray.
Note: For more information about how to use color in specific objects

(such as a shaded area in Data & Statistics), refer to the documentation
for that application.

Adding color from a list
To add color to a fill area, line, or text, do the following:
1. Select the item.
2. Click Edit > Color and select where you want to add color (fill, line, or
text).
3. Select the color from the list.

Adding color from a palette
To add color using the palette, do the following:
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1. Select the object.
2. Click the appropriate tool bar icon.
3. Select the color from the palette.
Note: If the icon or menu item that you want to use is not available

(grayed out) after you have selected an item, coloring is not an option
for the selection you’ve made.

Using Screen Capture
Use TI-Nspire™ Screen Capture to copy images of active pages. You can
save images as .jpg files, which can be inserted into to TI-Nspire™
applications that allow images. The image is also copied to the clipboard
and can be pasted into another application such as Microsoft® Word.

Capturing a page
1. Open a document and select the page you want to capture.
2. Click

.

•

To capture the current page on your computer, select Capture
Page.

•

To capture the current page on a connected handheld, select
Capture Selected Handheld.

Note: You can also select Tools > Screen Capture to access the
Capture Page and Capture Selected Handheld options.
The image is copied to the clipboard and to the TI-Nspire™ Screen
Capture window. The
dialog opens in
the lower right corner of your desktop when the screen capture is
complete.
3. Click View it to open the TI-Nspire™ Screen Capture window.
You can also select Window > Screen Capture Window to open the
TI-Nspire™ Screen Capture window.
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4. To capture additional pages, move to the next page in the document,
then click
page.

to select the option required to capture the selected

The page is copied to the TI-Nspire™ Screen Capture window. It
replaces the image in the clipboard.
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•

Click

to copy an image to the clipboard.

•

Click

to delete an image.

•

Click

to zoom in.

•

Click

to zoom out.

•

Click
and
toggle between Single Screen View and
Thumbnail View if there are multiple captured pages.

•

Click
to add a border to the selected image. Click
remove a border from a selected image.

•

Click

or

to

to scroll through multiple captured pages.
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Saving captured pages
You can save one image at a time, select multiple images to save, or save
all captured images.
1. In the TI-Nspire™ Screen Capture window, click
to save the
selected image or images. To save all images, click File > Save All
Screens. When you save multiple screen captures, the images are
collected in a folder named with the current date.
2. When the Save As dialog box opens, the default Screen Captures
folder is available. To save the images in a different folder, navigate
to the folder or create a new folder.
3. Type a name for the file or folder.
4. Click Save.
The file is saved in the designated location.

Printing documents
If your computer is connected to a printer, you can print an open
document.
1. Select File > Print to open the Print dialog.
2. Once you have selected the details of your print job, click Print.
The Print dialog enables you to control the following in your print job:
•

The printer

•

Print What:
–

Viewable Screen — prints what is visible in the active document

–

Print All — prints all data and pages in all open documents,
including what is not currently visible on the screen

•

Paper size

•

The range of TI-Nspire™ pages

•

The number of printed copies, up to 100

•

Layout:
–

Orientation (portrait or landscape)

–

The number of TI-Nspire™ pages to be printed on each sheet (1, 4,
or 8) (available in Viewable Screen option only)

–

Whether to allow space below each printed TI-Nspire™ page for
comments (available in Viewable Screen option only)
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•

Margins (from .25 inches to 2 inches)

•

The option to include documentation information on the printout:
–

Problem and page labels

–

Header (up to two lines)

–

Document name in the footer

•

The ability to group the pages by problem

•

Print Preview

To restore the Print defaults, click Reset.

Using print preview
You can also preview the document from the Print dialog.
f With the View Preview checkbox selected, use the arrows at the top
of the right pane to page through the pages in the preview.

Viewing document properties and copyright
information
Viewing copyright information
If a teacher has added copyright information to a document, you can
view that information.
f To view copyright information, click File > View Copyright
Information.
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Protecting a document (making a document read-only)
Note: This section applies only to the Teacher Software.

Teachers can protect documents to create a document for distribution to
your students or for other use. A student who receives a read-only
document and makes changes to it will be prompted to save the
document as a new file.
To make a document read-only:
1. Open the document.
2. Click File > Document Properties.
3. When the Document Properties dialog box opens, click the
Protection tab.

4. Select the checkbox next to Make this document Read Only.
5. Click OK.

Adding copyright information to a document
Note: This section applies only to the Teacher Software.

You can add copyright information individually to documents you create
or apply the same copyright information to all new documents.
To add copyright information to a document:
1. With the document open, click File > Document Properties.
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The Document Properties dialog box opens with the Copyright tab
visible.

2. Edit the following fields to define the copyright details:
•

Author

•

Copyright (Public Domain or Copyright).
Note: If you select Public Domain, you cannot enter a year or

owner.
•

Year

•

Owner

•

Comments

3. To add the supplied information to all new documents from this point
forward, select Apply this copyright to all new documents.
4. Click OK to apply the copyright information to the document.

82

Working with TI-Nspire™ documents

Working with Images
Images may be used for reference, assessment, and instructional
applications. This section describes using images in the various
applications.
Note: All image functionality described in this section applies to both
handhelds and computer software unless otherwise noted.

TI-Nspire™ applications that can accept images
Images can be inserted into the following TI applications:
•

Graphs - Image is set in background behind the axis and other
objects. A maximum of one image can be used in each instance of this
application but each instance can have the same or different image.

•

Geometry - Image is set in background behind the axis and other
objects. A maximum of one image can be used in each instance of this
application but each instance can have the same or different image.

•

Data & Statistics - Image is set in background behind the axis and
other objects. A maximum of one image can be used in each instance
of this application but each instance can have the same or different
image.

•

Notes - Image is set inline with text at the cursor location. You can
use multiple images in this application.

•

Question (includes Quick Poll) - Image is set inline with text at the
cursor location. You can use multiple images in this application.
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Example applications using images

The Graphs application example shown above illustrates that each page
can use the same or a different image, but only one image is allowed per
page.

The Notes application example shown above illustrates that you can use
multiple images and the image is placed in line with the text.
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Below is an example with two instances of an application running on the
same page. You can have multiple instances on a page using the Page
Layout option. For more information about Page Layout see the
"Working with TI-Nspire™ documents.

Image types available
The following file types can be used in the TI-Nspire™ applications that
accept images:
•

JPG (Joint Photographic Experts Group)

•

BMP (Device-independent Bitmap)

•

PNG (Portable Network Graphics)
The transparency feature of .png is not supported. Any transparent
.png backgrounds appear as white.

Inserting the image
There are two ways you can insert images into a document.
f Use the Insert command from the menu by browsing for the file.
or
f Paste the image into the document from the Clipboard.
Warning: When inserting a second image in applications that can only
accept one image (see “TI-Nspire™ applications that can accept images” )
the original image is replaced without warning.

Working with Images

85

Using the Insert command
1. Select the application where you want to place the picture.
For example, Graphs.
2. From the Menu bar, click Insert > Image.
Note: If the application selected does not accept images, the menu
item Image is grayed out.

3. Navigate to the image’s location and select your image.

4. Click Open.
The image appears in your application.
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Using Clipboard
These steps assume you have already copied or cut an image to the
Clipboard from a TI-Nspire™ document, image file, or another program
and have selected the image.
Copy: Edit > Copy or Ctrl + C (Mac®: Command + C)
Cut: Edit > Cut or Ctrl + X. (Mac®: Command + X)
Handheld: Ctrl + Menu (/ b) Copy or Paste

Inserting an image by pasting
1. Open the application and the document where you want to place the
image.
2. Click Edit > Paste.
PC: Ctrl + V
Mac®: Command + V
Handheld: / b + Paste.
The image is now on the page. The application type determines
whether the image displays in foreground or background. See
“TI-Nspire™ applications that can accept images” .

Inserting an image using the context menu (right-click)
1. Open the application and the document where you want to place the
image.
2. Right-click the area.
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3. Click Paste.
The image is now on the page. How the image behaves, (for example
whether it displays in foreground or background) depends on the
application’s type. See “TI-Nspire™ applications that can accept
images” .

Working with images
When working with images, you have a visual cue that the image is
selected by observing a bold and colored border around the image.

Selecting the image
Use one of these methods to select images as used in moving, resizing
and deleting images.

Software:
1. Right-click on the image to access the context menu.
2. Choose Select > Image.

Handheld:
1. Once you are at the image, click Menu.
2. When the menu is displayed, select Actions > Select > Image.
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Moving an image
You can reposition an image by moving an image using your mouse or
directional keys.
1. Open the document that includes the image you want to reposition.
2. Select image. See “Selecting the image” for instructions.
The selected image will have a bold, colored border around it.
3. Use the mouse or directional keys to move the image horizontal (left,
right) or vertical (up/down) by distinct steps.

Resizing image
1. Select the image. See “Selecting the image” for instructions.
2. Click the image. When selected the image displays a colored, bold
border.
3. Hover the pointer over the image border. The cursor will change to a
multisided-arrow. You can then hold the mouse button or if using a
handheld use the touchpad arrows to move in or out.
NOTE: If you resize by using one of the corner handles, the image
retains the same proportions as it is resized. If you resize by using one
of the side handles your image will lose its aspect ratio.
Example of resizing an image: side, corner, and move.

4. When the image is at the desired size, release.

Deleting the image
1. Open the document (if not already opened) that has the image you
want to delete.
2. Select the image. See “Selecting the image” if you need help.
The selected image will have a bold, colored border around it.
3. Select Delete from the menu, the context menu, or the keyboard.
–

Menu: Click on Edit > Delete.
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–

Context menu: Right-click. Select Delete from the options
displayed.

–

Keyboard: Press the Delete key.

–

Handheld: Select the image, then /

b

+ Delete.

Technical considerations
•

Number of images - There is no set limit on the total number of
images in the TI-Nspire™ program or on a handheld. Available
memory is the only limiting factor (other than the application
limitations as stated in “TI-Nspire™ applications that can accept
images” ).

•

Image limitations–

Memory - The maximum image size you can attempt to insert is
10 MB. This is not the actual size the image will retain, only the
maximum size that the memory accepts before inserting. The
TI-Nspire™ system automatically adjusts the image if necessary for
performance.
If a document with images cannot be opened due to low available
memory, the document is not opened and a notification is
displayed.
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–

Pixel - The resolution of an image is automatically adjusted to fit
the screen when the document is displayed.

–

Color - Maximum color depth is 65,000 colors on the computer,
TI-Nspire™ CX Handheld and TI-Nspire™ CX CAS Handheld. The
TI-Nspire™ Handheld and TI-Nspire™ CAS handheld is displayed
at a maximum of 16 shades of gray.
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Working with PublishView™ documents
Use the PublishView™ feature to create and share interactive documents
with teachers and students. You can create documents that include
formatted text, TI-Nspire™ applications, images, hyperlinks, links to
videos, and embedded videos in a format that is suitable for printing on
a standard piece of paper, publishing to a web site or blog, or for use as
an interactive worksheet.
PublishView™ features provide layout and editing features for
presenting math and science concepts in a document where TI-Nspire™
applications can be interactively and dynamically linked with supporting
media, enabling you to bring the document to life. Using the
PublishView™ feature:
•

Teachers can create interactive activities and assessments to used on
screen.

•

Teachers can create printed materials to complement documents used
on TI-Nspire™ handhelds.

•

When working with lesson plans, teachers can:
–

Create lesson plans from existing handheld documents or convert
lesson plans to handheld documents.

–

Link to related lesson plans or documents.

–

Embed explanatory text, images, video, and links to web
resources.

–

Build or interact with TI-Nspire™ applications directly from the
lesson plan.

•

Students can create reports or projects such as lab reports containing
data playback, curve fits, pictures, and video — all on the same sheet.

•

Students can print and turn in assignments on a standard piece of
paper.

•

Students taking exams can use one tool to create a document that
contains: all problems on the exam, text, images, hyperlinks, or
videos, interactive TI-Nspire™ applications, screen shots, and layout
options needed to print a document.

Software requirements
The PublishView™ feature is available in the following TI-Nspire™
software:
•

TI-Nspire™ Teacher Software and TI-Nspire™ Student Software
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•

TI-Nspire™ CAS Teacher Software and TI-Nspire™ CAS Student
Software

•

TI-Nspire™ Navigator™ Teacher Software

Note: Those using TI-Nspire™ Navigator software cannot exchange
TI-Nspire™ PublishView™ documents electronically. PublishView™
documents can be exchanged using TI-Nspire™ Navigator™ for
Networked Computers. TI-Nspire™ Navigator™ features such as
autograding and porfolio storage are not available for PublishView™
documents.

Creating a new PublishView™ document
1. From the Documents workspace, select File > New PublishView™
Document or click

and select New PublishView™ Document.

•

A blank letter-size document opens in the Documents workspace.
The orientation is portrait, which cannot be changed.

•

The default margin settings for the top and bottom margins are
one-inch. There are no settings for side margins.

•

By default, a problem is added to the document.

•

By default, the document contains the page number in a # of #
format at the bottom of the sheet.

•

The scroll bars on the right side of the screen and at the bottom of
the screen are active.

2. Add TI-Nspire™ applications and PublishView™ objects as needed to
complete the document.
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About PublishView™ documents
When working with PublishView™ documents, it is important to keep
the following points in mind:
•

PublishView™ documents are saved as .tnsp files, which distinguishes
them from TI-Nspire™ documents (.tns files).

•

When inserting PublishView™ objects into a document, the text,
image, hyperlink, or embedded video are contained in boxes that can
be moved and resized.

•

When you insert TI-Nspire™ applications, they work the same way as
pages in a TI-Nspire™ document.

•

In a PublishView™ document, objects can overlap each other and you
can control which object is on top or bottom.

•

Objects can be placed and positioned in a PublishView™ document in
a free-form fashion.

•

You can convert an existing TI-Nspire™ document to a PublishView™
document (.tnsp file).

•

When you convert a PublishView™ document to a TI-Nspire™
document (.tns file), TI-Nspire™ applications are converted.
PublishView™ objects containing text, hyperlinks, videos, and images
are not converted.
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•

You cannot create or open a PublishView™ document on a handheld.
You must convert a PublishView™ document to a TI-Nspire™
document before sending it to a handheld.

Exploring a PublishView™ document
The following example shows how you might use TI-Nspire™
applications and PublishView™ objects to build a PublishView™
document. In this example, borders are turned on to show the
boundaries around the objects. Showing borders enables you to work
with objects easily while building a document. When you are ready to
print or publish the document to the web, you can select to the hide
borders.

À
Á

Â

Ã

Å

Ä

Æ
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À

Header. In this example, the header contains the title of
the document. When the header area is active, you can
type and format text as needed.

Á

Problem break and name. In PublishView™ document,

Â

Text boxes. In this example, the introduction text and the
text in boxes 1, 2, 3, and 4 is contained in text boxes. You
can insert text and hyperlinks into a PublishView™
document using a text box. Text boxes can be resized and
positioned as needed. PublishView™ text boxes are not
retained when you convert a PublishView™ document to
a TI-Nspire™ document.

Ã

TI-Nspire™ applications. In this example, the author uses

Ä

Notes application. You can also use the TI-Nspire™ Notes

Å

Video. This is an example of a video that is embedded in a

use problem breaks to control the page layout. You can
select to hide or show problem breaks. Deleting a
problem removes the contents of the problem and
removes the space between problems when there are
multiple problems. Problem breaks also enable you to use
variables in PublishView™ documents. Variables that have
the same name are independent of one another if they
are used in different problems.

Graphs & Geometry to show the math functions. When a
TI-Nspire™ application is active in a PublishView™
document, the appropriate application menu opens in
the Documents Toolbox. You can work in a TI-Nspire™
application just as you would in a TI-Nspire™ document.
When you convert a PublishView™ document to a
TI-Nspire document, applications are retained.
application to add text to a PublishView™ document.
Because Notes is a TI-Nspire™ application, it will be
retained when you convert the PublishView™ document
to a TI-Nspire™ document. Using the Notes application
enables you to use an equation editor and can contain
TI-Nspire™ math templates and symbols.
PublishView™ document within a frame. Users can start
and stop the video using the controls. Frames containing
videos and images can be resized and positioned in the
document as needed.

Working with PublishView™ documents

95

Æ

Footer. By default, the footer area contains the page
number, which cannot be edited. You can add other text
above the page number if needed. Like the header, you
can format text as needed.

Using the status bar in a PublishView™ document
When a PublishView™ document is open, options on the status bar are
different than when working in a TI-Nspire™ document.

À
À

Á

Â

Ã

Ä Å

Document names are displayed in tabs. If multiple documents
are open, the document names are listed. You can have
TI-Nspire™ and PublishView™ documents open at the same
time. In this example, Document 1 is an inactive TI-Nspire™
document (

). Document 2 is the active PublishView™

document (

). Click the X to close a document.

Á

Click Settings to change General Settings and Graph and
Geometry Settings. You can specify settings that are specific to
an active document or set default settings for all
PublishView™ documents. When you convert a TI-Nspire™
document into a PublishView™ document, the settings in the
TI-Nspire™ document convert to the settings defined for
PublishView™ documents.

Â

Document View is not active in a PublishView™ document.
You cannot switch between computer view and handheld
view.

Ã

In TI-Nspire™ applications, use the Boldness scale to increase
or decrease the boldness of text and line thickness within
applications. Go to the left to decrease the boldness. Go to
the right to increase the boldness.
For PublishView™ objects, boldness is used to match text
within TI-Nspire™ applications to other text on the
PublishView™ sheet. It can also be used to increase the
visibility of Ti-Nspire™ applications when presenting a
document to a class.
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Ä
Å

When there are too many open document names to show in
the status bar, click the forward and backward arrows (
) to
move through the documents.
Click

to see a list of all open documents.

Saving PublishView™ documents
Saving a new document
1. Select File > Save Document, or click

.

The Save TI-Nspire™ Document dialog box opens.

2. Navigate to the folder where you want to save the document or
create a folder in which to store the document.
3. Type a name for the new document.
4. Click Save to save the document.
The document closes and is saved with the extension .tnsp.
Note: When you save a file, the software will first look in the same folder

the next time you open a file.

Saving a document with a new name
To save a previously saved document in a new folder and/or with a new
name:
1. Select File > Save As... from the menu.
The Save TI-Nspire™ Document dialog box opens.
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2. Navigate to the folder where you want to save the document or
create a folder in which to store the document.
3. Type a new name for the document.
4. Click Save to save the document with a new name.
Note: You can also use the Save As... option to convert documents from
TI-Nspire™ files to PublishView™ files or convert PublishView™ files to
TI-Nspire™ files.

Exploring the Documents workspace
When you create or open a PublishView™ document, it opens in the
Documents workspace. Use the menu options and the toolbar just as you
would when working with a TI-Nspire™ document to:
•

Navigate to existing folders and documents using Content Explorer

•

Open existing documents

•

Save documents

•

Use the copy, paste, undo, and redo options

•

Delete documents

•

Access TI-Nspire™ application-specific menus

•

Open the Variables menu in TI-Nspire™ applications that allow
variables

•

Access and insert math templates, symbols, catalog items, and library
items into a PublishView™ document

Note: For more information about the menu and toolbar options, see
Using the Documents Workspace.

Exploring the Documents Toolbox
When a PublishView™ document is active, the Documents Toolbox
contains tools needed for working with PublishView™ documents. You
can add TI-Nspire™ applications to a problem, insert parts of existing
TI-Nspire™ documents into a problem, and add PublishView™ objects.
The Documents Toolbox opens when you create a new PublishView™
document or open an existing PublishView™ document. When working
in a PublishView™ document, Page Sorter and TI-SmartView™ emulator
are not available.
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À
Á
Â

Ã

Ä

À

In a PublishView™ document:
•

Click
to open the application menu and tools needed to
work with TI-Nspire™ applications and PublishView™
objects.

•

Click
to open the Utilities panel where you can access
Math Templates, Symbols, the Catalog, Math Operators, and
Libraries.

•

Click

to open Content Explorer.

Note: For more information about Utilities and Content
Explorer, see Using the Documents Workspace.

Á

Click
to collapse a pane containing a menu. Click
expand a pane.

to
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Â

TI-Nspire™ applications. Drag and drop an icon to a problem to
insert an application:
•

Calculator

•

Graph

•

Geometry

•

Lists & Spreadsheet

•

Data & Statistics

•

Notes

•

Vernier® Dataquest

•

Question Picker (Only available in TI-Nspire™ Teacher
Software or TI-Nspire™ Navigator™ Teacher software).

Ã

TI-Nspire™ Documents. Use this tool to locate and insert

Ä

PublishView™ Objects. Use this tool to drag and drop the

existing TI-Nspire™ documents (.tns files) into a problem.
following objects into a problem:
•

Image

•

Video

•

Text box

•

Hyperlink

Using menus and the toolbar
When working in a PublishView™ document, select options from the
menus or the toolbar in the Documents workspace to work with content
and objects. When you insert an object into a PublishView™ document,
you can manipulate it using the same tools as you would when working
with a TI-Nspire™ document. In PublishView™ documents, you can:
•

Right-click on an object to open a context menu, which displays the
actions that can be performed on that object

•

Use add, insert, and paste to add objects to a PublishView™
document
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•

Use delete and cut to remove objects from a PublishView™ document

•

Move objects from one place to another within a PublishView™
document

•

Copy objects from one document and paste them into another
PublishView™ document

•

Resize and scale objects such as text boxes and images

•

Change the font face and size and apply formatting such as italics,
bold, underline, and color to text

Note: For more information about menus and the toolbar, see Using the
Documents workspace.

Using context menus
In TI-Nspire™ applications and in PublishView™ documents, context
menus are drop-down menus that provide a list of options specific to the
task you are working on. For example, when you right-click a cell while
working in the TI-Nspire™ Lists & Spreadsheet application, a context
menu opens providing a list of actions that you can perform on that cell.
When you right-click the border of a text box in a PublishView™
document, the context menu provides actions that can be performed on
the text box.

Context menus in TI-Nspire™ applications
When you insert a TI-Nspire™ application into a PublishView™
document, the application menu and the context menus associated with
that application are available and work the same way they work in a
TI-Nspire™ document.

Context menus in PublishView™ documents
In PublishView™ documents, context menus provide shortcuts to
frequently performed tasks. Context menus are specific to an object or
area:
•

The Sheet context menu provides options for working with the layout
of the sheet and document

•

Object context menus provide options for manipulating the object

•

Content-sensitive context menus provide options for working with
the content inside the object such as text or a video.
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Working with PublishView™ objects
In a PublishView™ document, text, hyperlinks, images, and videos are
contained in PublishView™ objects. You can move, resize, copy and
paste, and delete an object within a PublishView™ document. Objects
can also be positioned so that one overlaps the other.
Within a document, PublishView™ objects can exist in three states:
unselected, selected, and interactive.

State

Description

Unselected When unselected, an object
does not have handles for
repositioning and sizing. To
deselect an object, left-click
or right-click outside the
object.
In this example, borders
around the object are
showing.
Selected
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When selected, an object
will have eight square
handles framing the object.
To select an object, click the
object’s borer. When
selected, objects can be
moved and resized.
•

To move an object,
select a border and drag
the object to its new
location.

•

To resize an object, grab
a handle.

•

Right-click the border to
open a context menu
with options for
manipulating the
object.
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State

Description

Interactive

An interactive state is
indicated by a blue frame
around the object. To enter
interactive state, left-click
or right-click anywhere in
the body of the object.
When in an interactive
state, you can work with
the contents of the object.
For example, you can add
or edit text in a text box or
complete math functions in
a TI-Nspire™ application.
When in an interactive
state, context menus
contain options specific to
the contents of an object.

Inserting an object
1. In the Documents Toolbox, ensure the PublishView™ Objects menu is
open.

2. Use your mouse to select an icon and drag it to the document.
3. Release the mouse button drop the object into the document.
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Selected text
boxes and
frames can
be resized,
moved,
copied,
pasted, and
deleted.

4. Using the mouse, grab the handles to resize the object and drag it to
position the object in the document as needed.

Opening object context menus
f Right-click the border of any object in a PublishView™ document.
The context menu opens to provide access to delete, copy/paste, cut,
and bring to front/send to back actions.

Resizing an object
1. Click any border around the object to select it. The border becomes a
bold blue line and the handles are active.
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2. Move your mouse over one of the handles to activate the resizing
tool.

3. Grab one of the handles and drag in the direction needed to make
the object larger or smaller.
4. Click outside the object to save the new size.

Moving an object
To move an object to another location on the page:
1. Click any border around the object to select it. The border becomes a
bold blue line and the handles are active.
2. Move your cursor over one of the borders to activate the positioning
tool.

3. Click to grab the object. The horizontal and vertical alignment guides
are activated at the top and bottom of the object. Use the grid lines
to position the object on the page.
vertical
alignment
guide
horizontal
alignment
guide

4. Drag the object to a new location on the page.
5. Release the mouse button to drop the object in its new location.
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Overlapping objects
You can position objects so that one is on top of another. You can control
the stacking order to specify which object is positioned in front or behind
the other. Overlapping objects have many practical uses when presenting
information in the classroom. For example, you can create a "curtain
control" by placing and empty text box over other objects. Then, you can
move the text box to reveal the items below it one at a time.

To change the position of an object in the stacking order:
1. Click the border of the object you want to position to select it, then
right-click to open the context menu.

2. Click Send to back or Bring to front to move the selected object to
the desired position.

Deleting an object
To delete an object from a sheet:
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1. Click any border of the object to select it. When an object is selected,
the border is blue and the handles are active.
2. Press the Delete key to delete the text box or right-click a border,
then select Delete from the context menu.

Choosing a working folder for PublishView™ objects
Use the Choose Your Working Folder field in the PublishView™ Objects
pane to select a folder for storing PublishView™ documents and related
files.
1. Ensure the PublishView™ Objects pane is open.

2. Click

.

The Choose Your Working Folder window opens.

3. Navigate to the folder where you want to store video and image files.
4. Click Open to choose the working folder.
The selected folder becomes the working folder and the folder name
is displayed in the Choose your working folder field. Previews of
supported images and video files in the folder are shown in the
PublishView™ objects pane.
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5. To add an image or video file to a PublishView™ document, select the
file and drag and drop it onto the active sheet.

Working with TI-Nspire™ applications
Note: For additional information about the TI-Nspire™ applications, see
the appropriate chapter in this guidebook.

Adding an application to a problem
To add a TI-Nspire™ application to a problem in a PublishView™
document:
1. Choose one of the following actions to select an application:
•

From the TI-Nspire™ Applications pane in the Documents Toolbox,
use the mouse pointer to point to the application and drag it to
the problem.

•

From the menu bar, select Insert and choose an application from
the drop-down menu.

•

Right-click inside the sheet to open the context menu, select
Insert and choose an application from the drop-down menu.

The application is added to the sheet.
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2. Using your mouse, grab the handles to resize or position the
application object as needed.
3. Click outside the application frame to accept the dimensions.
4. To open the menu for the active TI-Nspire™ application, click inside
the application. The menu opens in the Documents Toolbox above
the TI-Nspire™ Applications pane.
Right-click on an application element, such as a cell or function to
open the context menu for that item.

5. To work in the application, select an option from the application
menu. Click

to collapse the application menu pane.
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Adding existing TI-Nspire™ documents
Use the TI-Nspire™ Documents pane to open an existing TI-Nspire™
document to add to a PublishView™ document. When you open an
existing TI-Nspire™ document, all pages of the document appear in the
preview pane. You can drag and drop complete problems or individual
pages onto the PublishView™ sheet.

Choosing a working TI-Nspire™ document
To choose a working document:
1. In the Documents Toolbox, ensure the TI-Nspire™ Documents pane is
open.

2. Click

.

The Choose Your Working Document window opens.

3. Navigate to the folder where the TI-Nspire™ document is stored:
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•

Click ¤ in the Look in: field to use a file browser to locate a
folder.

•

From an open folder, click
hierarchy

to move up a level in the folder
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•

Click

to return to the default home folder

•

Click

to add a new folder to open folder on your computer.

•

Click

to list folders and files. To show details, click

.

4. Select the file, then click Open.
The TI-Nspire™ document opens in the TI-Nspire™ Documents pane.

5. To add the TI-Nspire™ document to the PublishView™ document,
drag and drop one page at a time or one problem at a time to the
PublishView™ sheet.
If you are adding a problem with multiple pages, the pages are
stacked on top of each other on the PublishView™ sheet. Move the
top page to see the other pages.
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Working with problems
Like a TI-Nspire™ document, a PublishView™ document consists of one
or more problems.
Problems are used to control the layout of a PublishView™ document so
that you can isolate variables. When variables with the same name are
used in multiple problems, variables can have different values. To add
problems to PublishView™ documents, open the Sheet context menu or
use the options on the Insert menu in the Documents workspace. When
adding problems, keep the following guidelines in mind:
•

By default, a new PublishView™ document contains one problem.

•

You can insert a problem after any existing problem.

•

You cannot insert a problem in the middle of an existing problem.

•

A new problem break is always inserted after the selected problem.

•

Inserting a problem break adds empty space below the break.

•

Any object between two problem breaks is part of the problem above
the break.

•

The last problem includes all sheets and objects below the last
problem break.

•

Problem breaks are not relative to any object, which lets you move
objects within a problem without affecting the problem break
location.

Adding a problem
To add a problem to an open PublishView™ document:
1. Right-click anywhere on the sheet, then select Insert > Problem.
The problem is added to the document below any existing problems.
The problem break provides a visible divider between problems.

2. To name the problem, highlight the default text, type a name, then
click outside the text box to save the name.
The problem break is saved.

If a document has multiple problems, use the scroll bar on the right
side of the document to move up and down through the problems.
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Managing problem breaks
Problem breaks are used to separate problems and variable sets.
•

Every problem has a problem break.

•

A problem break becomes visible when a problem is added to a
document.

•

A problem break is represented by a dashed line with the name of the
problem positioned on the left side of the sheet.

•

By default, the problem name is shown as <Name of problem>.
Highlight the default text to type a new name for the problem.

•

Problem names do not have be unique. Two problems can have the
same name.

Hiding and showing problem breaks
You can select to hide or show problem breaks in a PublishView™
document. By default, problems breaks are shown.
1. Right-click in any blank area of the document (outside of any object)
to open the sheet context menu.
2. Select Layout Options.
The Show/Hide Options dialog box opens.
Note: You can also select View > PublishView™ Layout Options.

3. Deselect the Show problem breaks option to hide problem breaks in
the document. Select the option to return to the default setting and
show the problem breaks.
4. Click OK to close the dialog.

Renaming a problem
1. Click the existing problem name on the problem break line.
2. Type a new name for the problem.
3. Click outside the text box to save the new name.

Deleting a problem
To delete a problem, complete one of the following actions:
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f Select the problem break and click

on the right side of the break.

f Select Edit > Delete.
f Right-click the problem break and select Delete.
f Select the problem break and press the Delete or Backspace key.
When you delete a problem, all objects contained in the problem are
removed and the space between the selected problem break and the
next problem break is removed.

Organizing PublishView™ sheets
A PublishView™ document can have multiple sheets. A single sheet is
displayed in the workspace on your screen. All work occurs in the
PublishView™ objects and TI-Nspire™ applications within sheets.

Adding sheets to a problem
To add a sheet to a problem:
f Select Insert > Sheet.
The sheet is added to the problem and the numbering increments by
one.

Opening the sheet context menu
f Right-click in any blank area (outside of any object) in a
PublishView™ sheet.
A context menu opens with options for inserting problems, pages,
applications, and PublishView™ objects, edit options for removing
space or deleting a page, and options for hiding and showing
problem breaks and object borders.

Page numbering
In a PublishView™ document, page numbering is displayed in the
bottom margin (footer). By default, numbering is placed in the center of
the PublishView™ sheet in a # of # format. You cannot edit or delete
page numbering.
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Working with headers and footers
PublishView™ documents contain space at the top and bottom of a sheet
to add a header or a footer. Headers and footers can contain the date,
the document name, the lesson plan name, the class name, your school’s
name, or any other information needed to identify a document.
By default, headers and footers do not contain content and boundaries
for the header and footer are hidden. To activate a header or footer for
editing, click inside the top or bottom margin. When activated, a text
box with a light gray border is displayed.

Inserting and editing text in headers and footers
1. Click inside the top or bottom margin.
The text box borders in the margin become visible and the object
space is disabled. The cursor is placed in the header or footer space
and the formatting menu opens.
header

footer

2. Type the text.
•

The default font is TI-Nspire™ true type, 12 pt, normal.

•

By default, text is centered horizontally and vertically.

•

Text can be aligned: left, center, right, or justified.

•

Text that does not fit within the text box horizontally will wrap to
the next line.

•

Text that does not fit within the text box vertically will not be
shown, but text is retained. (If you delete text, the hidden text will
appear.)
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3. Complete one of the following actions to save the text:
•

Single-click anywhere outside the header or footer text box to
save the text.

•

Press Esc to save the text.
The PublishView™ sheet becomes active and the formatting menu
closes.

Showing and hiding borders
By default, borders are displayed when you insert an object into a
problem. When you select to hide borders, the selection applies to all
objects in the document and to objects that you add to the document. To
hide the border:
1. Right-click in any blank area of the sheet (outside of any object) to
open the context menu.
2. Select Layout Options.
The Layout Options dialog box opens.
Note: You can also select View > PublishView™ Layout Options.

3. Deselect the Show object borders option to hide the borders around
the objects in the problem. Select the option to return to the default
setting and show borders.
4. Click OK to close the dialog.

Adding and removing space
To manage how PublishView™ objects appear on a sheet, you may need
to add or delete space between objects.
Note: You can add and remove vertical space between objects using this
method. To add or remove horizontal space between objects, move the
object.

Adding space
1. Right-click in the area outside of any object where you want to add
space. The context menu opens.
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2. Select Edit > Add/Remove Space. The Add/Remove Space tool
becomes active.

Add/Remove
Space tool

3. Use your mouse to position the tool to the exact place where you
want to add space.
4. Click the tool, then drag down to select the amount of space you
want to add. As you select the amount of space to be added, it is
indicated in green.
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5. Press the Enter key to add the space in between the objects. You can
adjust the amount of space by dragging up and down before you
press Enter.

Removing space
1. Right-click in the area outside of any object where you want to
remove space. The context menu opens.
2. Select Edit > Add/Remove Space. The Add/Remove Space tool
becomes active.

Add/Remove
Space tool

3. Use your mouse to position the tool to the exact place where you
want to remove space.
4. Click the tool, then drag up to select the amount of space you want
to remove. As you select the amount of space to be removed, it is
indicated in red.
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5. Press the Enter key to remove the space in between the objects. You
can adjust the amount of space by dragging up and down before you
press Enter.
Note: If there is not enough space on the sheet to accommodate the
objects, the objects won’t be moved when space is removed.

Deleting blank sheets from problems
You can delete a sheet that does not contain any TI-Nspire™ applications
or PublishView™ objects from a problem. To delete a blank sheet from a
problem:
1. Delete any TI-Nspire™ applications, PublishView™ objects, move or
delete any problem breaks from the sheet.
2. Place your cursor inside the sheet you want to delete.
3. Right-click inside the blank sheet to open the context menu.
4. Select Edit > Delete Sheet.
The blank sheet is removed from the problem.

Adding text to a PublishView™ document
In a PublishView™ document, there are three ways to add text:
•

Insert a PublishView™ text box to enter free-form text or copy text
from other sources into the document. For example, you can place a
PublishView™ text box next to an image and type a description in a
text box. You can also copy and paste text from .doc, .txt, and .rtf
files. Use PublishView™ text boxes when you need options for
emphasizing and formatting text. PublishView™ text boxes are not
converted when you convert a PublishView™ document to a
TI-Nspire™ document. You may want to use a PublishView™ text box
to add text that you don’t want handheld users to see.

•

Use the TI-Nspire™ Notes application. You should use the Notes
application when you need an advanced equation editor and when
you need to use TI-Nspire™ math templates and symbols. Superscript
and subscript are also easier to use in the Notes application. You
should also use Notes when you are planning to convert the
PublishView™ document to a TI-Nspire™ document for use on a
handheld and you want handheld users to see the text.

•

Add text in TI-Nspire™ applications that allow text just as you would
in a TI-Nspire™ document.

Inserting text into a text box
1. Ensure the PublishView™ Objects pane is open.
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2. Use your mouse to select

and drag it to the problem.

3. Release the mouse button drop the text box into the problem.

4. Using the mouse, grab the handles to resize the text box or position
in the problem as needed.
5. Click outside the text box to save the size and position.
6. Click "Type your text here."
The formatting menu opens and the text becomes active.

Text box is in an
interactive state
for adding or
editing text.

7. Type the new text or copy and paste text from another file.
8. Apply formatting as needed.
9. Click outside the text box to save the text.
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Formatting and editing text
The options for editing and formatting text are located on a formatting
toolbar attached to the text box when the text box is active. Formatting
options for editing text include:
•

Changing the font, font size, and font color

•

Applying bold, italics, and underline formatting

•

Applying the following text horizontal alignment options: left, right,
centered, and justified.

•

Inserting hyperlinks

Launching edit mode
f Click inside a text box to launch edit mode.
•

The formatting menu opens.

•

The text is selectable for editing.

Opening the content context menu
f Right-click inside a text box containing text or a hyperlink.
The formatting menu and context menu open providing shortcuts to
cut, copy, and paste.

Using hyperlinks in PublishView™ documents
In PublishView™ documents, use hyperlinks to:
•

Link to a file

•

Link to a web site on the Internet

You can add a hyperlink to an open document or you can convert any
text within a text box to a hyperlink. When a hyperlink is added, the
formatting of the text is underlined and the font color is blue. You can
change the formatting of the hyperlinked text without losing the
hyperlink.
When you link files, it is best to store the files on a network datashare or
online storage site before creating the hyperlinks. This enables you to
freely share your PublishView™ document with anyone who has access
to the datashare or storage site and the links will remain accessible. Links
to files on your local hard drive should only be used if you do not plan to
share the document.
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If you choose use local links, you can rename the PublishView™
document or move it to a different location on your computer and the
links will remain intact. However, be sure to keep the target files in the
same location. If you move the files or if the path name changes, the
links to the files will no longer work.
If a link is broken, an error message is displayed when you click the link:
•

Cannot open the specified file

•

Cannot open the specified web page

Linking to a file
You can link to any file on your computer. If the file type is associated
with an application on your computer, it will launch when you click the
link.
Complete the following steps to add a link to a file to a PublishView™
document.
1. Ensure the PublishView™ Objects pane is open.

2. Click

, then drag and drop the icon onto the sheet.

The Add Hyperlink dialog box opens.
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3. Type the name of link in Text field. For example, this can be the name
of the document.
4. Click

to select Link to a file.

The Select file to insert as a hyperlink dialog box opens.

5. Navigate to and select the file you want to link to, then click Insert.
The path name is inserted into the Address field in the Add Hyperlink
dialog box.
6. Click OK.
A text box containing the hyperlink is added to the PublishView™
document.

7. Using the mouse, grab the handles to resize the text box or grab any
border to position the text box in the document as needed.
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Linking to a web site
Complete the following steps to add a link to a web site.
1. Ensure the PublishView™ Objects menu is open.
2. Click

, then drag to icon to the document to open the Add

Hyperlink dialog box.

3. Type the name of link in Text field. For example, this can be the name
of a web site.
4. Click

to select Link to a page on the Internet.

Your browser opens to your default web site.
5. Navigate to the web site or file on a web site that you want to link to.
6. Copy the URL, then paste it in the Address field in the Add Hyperlink
dialog box.
7. Click OK.
A text box containing the hyperlink is added to the PublishView™
document.

8. Using the mouse, grab the handles to resize the text box or grab any
border to position the text box in the document as needed.

Editing a hyperlink
To change the name of a hyperlink, change the path, or change the URL,
complete the following steps.
1. Using your mouse, right-click the hyperlink text, then select Edit
hyperlink.
The Edit Hyperlink dialog box opens.
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2. Make corrections as needed:
•

Type corrections to the hyperlink name in the Text field.

•

Click
to open the Select a file to add as a hyperlink
dialog box and use the file browser to navigate to the folder
where the file is located.

•

Click
to open a browser and navigate to a web site to copy
and paste the correct the URL in the Address field.

3. Click OK to save the changes.

Converting existing text to a hyperlink
1. Click inside the text box to activate edit mode and open the
formatting menu.
2. Select the text you want to convert to a hyperlink.
3. Click

.

The Add Hyperlink dialog box opens with the selected text in the Text
field.
4. Click

to create a link to a file.

—OR—
Click

to create a link to page on a web site.

Removing a hyperlink
Use this process to remove a link from text inside a text box. The text
remains in the document.
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1. Using your mouse, right-click the hyperlink text.
2. Select Remove hyperlink.
The hyperlink formatting is removed from the text and the text is no
longer clickable.
Note: To remove both the text and hyperlink, delete the text. If a text
box contains only the linked text, delete the text box.

Working with images
Images can be added to PublishView™ documents as PublishView™
objects or can be added inside TI-Nspire™ applications that support
images. Supported files types are .bmp, .jpg, and .png files.
Note: If a TI-Nspire™ application is active in the PublishView™
document, the image is added to the TI-Nspire™ page if you select
Insert > Image from the menu bar or context menu. If there is no
TI-Nspire™ document active, the image is added as a PublishView™
object. Only images inside TI-Nspire™ applications convert to TI-Nspire™
documents (.tns files).

Inserting an image
1. Ensure the PublishView™ Objects pane is open.

2. Click

, then drag to icon to the document.

The Choose an image to insert into PublishView™ dialog box
opens.
Note: By default, the Texas Instruments preloaded images folder is
displayed.
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3. Navigate to the folder where the image file you want to insert is
located, then highlight the file name.
4. Click Insert image.
The image is added to the PublishView™ sheet.

5. Using the mouse, grab the handles to resize the text box or grab any
border to position the text box in the document as needed.

Moving images
1. Click the frame containing the image to select it.
2. Move your cursor over the edge of the image to activate the
positioning tool.
3. Drag and drop the image to its new location on the PublishView™
sheet.
Note: Objects can overlap each other on a PublishView™ sheet.
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Resizing images
1. Click the frame containing the image to select it.
2. Move your cursor over one of the blue handles to activate the
resizing tool.
3. Drag the handle to make the image smaller or bigger.

Deleting images
f Click the image to select it, then press the Delete key.
—OR—
f Right-click a handle to open the context menu, then select Delete.

Working with video files
You can embed a Flash (.flv) video file in a PublishView™ document and
play the video directly from the PublishView™ document.
Note: You can also insert a link to a video that will launch in a new
browser window or media player window. See Working with Hyperlinks.

Inserting a video
1. Ensure the PublishView™ Objects pane is open.

2. Click

, then drag the icon to the document.

The Choose a video to insert into PublishView™ window opens.
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3. Navigate to the folder where the video file you want to insert is
located, then highlight the file name.
4. Click Insert video.
An object containing the embedded video is added to the
PublishView™ sheet. By default, the resizing and positioning handles
are active.

5. Using the mouse, grab the handles to resize the object or grab any
border to position the object in the document as needed. For
example, you may want to position the object containing the video
above or below a text box that contains text introducing the video.
6. To play the video, click the forward arrow.

Using the video console
The video console enables users to control when to start and stop the
video.

À Á

Â

Ã

The console contains the following controls:

À

Click
video.

to start the video. When playing, click

to stop the

Á

As the video plays, the time elapsed is shown in minutes and
seconds.

Â

When the video starts, the length of the video is shown in
minutes and seconds.
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Ã

Shows how high or low the volume is. You cannot control the
volume with this control. Use the volume control on your
computer to increase or decrease the volume.

Using the video context menu
f Right-click on the box containing the video to open the video-specific
context menu.

Option

Function

Settings

Click to disable or enable hardware
acceleration.

Global Settings

Opens the Adobe® Flash® Player Help web
site.

About Adobe® Flash®
Player 10

Opens the Adobe® Flash® Player web site.
Open this site to find out which version you
have or download a more current version of
the player.

Adjusting Adobe® Flash® Player settings
For information about Adobe® Flash® Player 10, please refer to Flash®
Player Help at http://www.macromedia.com/support/documentation/.

Converting documents
You can convert PublishView™ documents (.tnsp files) to TI-Nspire™
documents (.tns files) for display on handhelds. You can also convert
TI-Nspire™ documents to PublishView™ documents.
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Converting a document creates a new document — the original
document remains intact and is not linked to the new document. If you
make changes to one document, the changes are not reflected in the
other document.

Converting PublishView™ documents to TI-Nspire
documents
You cannot open a PublishView™ document (.tnsp file) on a handheld.
However, you can convert the PublishView™ document to a TI-Nspire™
document that can be transferred to and opened on a handheld. When
you convert a PublishView™ document to a TI-Nspire™ document:
•

Only the TI-Nspire™ applications become part of the TI-Nspire™
document.

•

PublishView™ objects such as text boxes, images, hyperlinks, and
videos are not converted.

•

Text contained in PublishView™ text boxes is not converted; however,
text in a TI-Nspire™ Notes application is converted.

•

If images are contained in a TI-Nspire™ application, they are
converted; however, images contained in PublishView™ objects are
not converted.

Complete the following steps to convert a PublishView™ document
(.tnsp file) to a TI-Nspire™ document (.tns file).
1. Open the PublishView™ document to be converted.
2. Select File > Convert to > TI-Nspire™ Document.
•

The new TI-Nspire™ document opens in the Documents
workspace.

•

All supported TI-Nspire™ applications are part of the new
TI-Nspire™ document.

•

Starting from top to bottom, then left to right, the layout of the
TI-Nspire™ document is based on the order of the TI-Nspire™
applications in the PublishView™ document.

•

–

Every TI-Nspire™ application in a PublishView™ document will
appear as a page in the converted TI-Nspire™ document. The
order of the pages in the TI-Nspire™ document is based on the
layout of the TI-Nspire™ applications in the PublishView™
document.

–

If two or more problems are at the same level, the order is left
to right.

Problem breaks are maintained.
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•

The new TI-Nspire™ document is not linked to the PublishView™
document.

3. When work in the document is complete, click
to save the
document in the current folder or select File > Save As... to save the
document in a different folder.
Note: If the document has never been saved, both the Save and Save
as options allow saving in a different folder.

Note: You can also use the Save as... option to convert a
PublishView™ document to a TI-Nspire™ document.
Note: If you try to convert a PublishView™ document that does not
contain TI-Nspire™ pages or applications, an error message is displayed.

Converting TI-Nspire™ documents to PublishView™
documents
You can convert existing TI-Nspire™ documents to PublishView™
documents, which enables you to take advantage of the richer layout
and editing features for printing, generating student reports, creating
worksheets and assessments, and publishing documents to a web site or
blog.
Complete the following steps to convert a TI-Nspire™ document to a
PublishView™ document:
1. Open the TI-Nspire™ document you want to convert.
2. Select File > Convert to > PublishView™ Document.
•

The new PublishView™ document opens in the Documents
workspace.

•

By default, there are six objects per page.

•

When converted, each problem from the TI-Nspire™ document
will start a new sheet in the PublishView™ document.

•

Problem breaks are maintained.

3. When work in the document is complete, click
to save the
document in the current folder or click File > Save As... to save the
document in a different folder.
Note: You can also use the Save as... option to save a TI-Nspire™
document as a PublishView™ document.
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Printing PublishView™ documents
You can print reports, worksheets, and assessments created using the
PublishView™ feature. To print a document:
1. Select File > Print.
The Print dialog box opens. A preview of the document is shown on
the right side of the dialog box.

2. Select a printer from the drop-down menu.
Note: The Print what field is disabled.
3. Select Paper Size from the drop-down menu. Options are:
•

Letter (8.5 x 11 inches)

•

Legal (8.5 x 14 inches)

•

A4 (210 x 297 mm)

4. Select the number of Copies you want to print.
5. In the Print Range area, select to print all pages in the document, a
range of pages, or the current page only.
Note: By default, top and bottom margins are set to one-inch and are
maintained when printing a PublishView™ document. There are no
side margins. PublishView™ sheets print just as they appear in the
workspace.
6. If needed, select or deselect the boxes to:
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•

Print Problem Breaks and Names.

•

Print Headers

•

Print Footers

•

Show object borders

7. Click Print.
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Embedding documents in web pages
Using the Export features in the TI-Nspire™ software along with the
TI-Nspire™ Document Player, you can embed both TI-Nspire™ documents
and PublishView™ documents within HTML pages. You can then publish
the HTML documents as web pages or share them using email, datashare,
or an online storage site.
By default, the embedded documents are displayed in the TI-Nspire™
Document Player when opened. Anyone can view and interact with the
embedded TI-Nspire™ or PublishView™ documents within the
TI-Nspire™ Document Player — even if you don’t own TI-Nspire™
software.

Using embedded web pages
There are two ways to create embedded web pages:
•

Use the Export functions in the TI-Nspire™ software to generate the
code needed to embed a document in a web page.

•

Create your own HTML code using a text editor or HTML editor. Code
examples are shown in this document.

To use embedded web pages:
•

You must be connected to the Internet to load the
TI-Nspire™ Document Player and view the embedded document.

•

If publishing a document to the web, you will need to post the
original TI-Nspire™ or PublishView™ documents online and update
the HTML source code to reflect the URL of the online document.

•

You can embed documents that are already available online. For
example, you can embed a document from the TI Activities Exchange
web site.

•

You can embed documents in any container that supports HTML and
Java™ applets. For example, you can embed documents in Learning
Management Systems such as Moodle or Blackboard™.

•

You can embed a web page in a Microsoft® PowerPoint presentation.
This requires a third-party add-in for PowerPoint. Some add-in
utiltities are often available at no cost such as the add-in available
from Live Web (http://skp.mvps.org/liveweb.htm).

Viewing embedded web pages
To view embedded TI-Nspire™ and PublishView™ documents, you must
have:
Embedding documents in web pages
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•

•

A Web browser
–

Microsoft® Internet Explorer® 7.0 and above

–

Mozilla® FireFox® 4.0 and above

–

Google® Chrome® 5.0 and above

–

Apple® Safari® 5 and above

Java™ Version 6 Update 22 (version 1.6.0_22) or later

If you plan to view PublishView™ documents containing video files, you
must have Adobe® Flash® Player 10.

Using TI-Nspire™ HTML Inline Frames
TI-Nspire™ and PublishView™ documents are embedded using an HTML
Inline Frame or "iframe." You can embed your TI-Nspire™ or
PublishView™ document by typing the iframe code into an HTML
document. When you create an iframe using an HTML or text editor, the
embedded iframe code might look like the code in the following
example. When creating your own code for the iframe, you will need to
know the web address of the embedded document and include this
address in your code.
Example: Hard-coded iframe
<iframe
src="http://education.ti.com/go/nspireplayer?nspirefile=http://my.site.
com/myfile.tns"
width="700"
height="500"
scrolling="no"
frameborder="0">
</iframe>

Line breaks are not recognized in HTML source code. You may see the
iframe code strung together on a single line when you view the source
code in a text editor or HTML editor. To make the code easier to view,
you can manually add line breaks or enable Word Wrap. The following
example shows the code without line breaks.

<iframe src="http://education.ti.com/go/nspireplayer?
nspirefile=http://my.site.com/myfile.tns" width="700" height="500"
scrolling="no" frameborder="0"></iframe>
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Iframe tags and attributes
The HTML code is opened and closed with iframe tags: <iframe> and
</iframe>. The iframe tags tell the web browser to display an embedded
window on a web page. Within the iframe code, you’ll see attributes and
attribute values that control the content and appearance of the frame.
Attribute values are usually enclosed in quotation marks.

Using the Source (src) attribute
In the iframe example, the first attribute is the source attribute indicated
by the "src=" code. The value of this attribute is specific to TI-Nspire™
content. The value can be modified to define the location of the
embedded document and the tools available within the embedded
document.
The source attribute contains the Internet address (URL) of the
TI-Nspire™ Document Player, which is:

http://education.ti.com/go/nspireplayer
--OR-http://education.ti.com/go/nspireplayer/3.0.1
You can add parameters the the source attribute to control the
appearance of the embedded TI-Nspire™ Document Player. These
parameters are optional. For more information, see Customizing the
embedded Document Player.

Defining the nspirefile parameter
The nspirefile parameter is always last in the line of code and specifies
the URL or the file system address (path) of the document you are
embedding. You may need to modify this parameter to enable sharing
your embedded page with others.
The path of the document can be an absolute address or a relative
address:
•

Absolute address - Identifies a specific and unique location or path
that is not defined by reference to any other address. When using an
absolute address, you must specify the full URL. If you move the
documents, the URL must be modified.

•

Relative address - Identifies a location in relation to another
location. When using a relative address, the URL contains only the file
name, which means your document must be in the same directory as
the embedded web page. As long as your document and the .html
file containing the embedded document are in the same folder, the
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URL will find the document even if you move the folder. To use a
relative address, see Using dynamically-generated iframes.

Using other iframe attributes
Other iframe attributes that control the appearance of the iframe on the
web page are width, height, scrolling, and frame border. The values for
these attributes are standard and are not specific to TI-Nspire™ content.
The following table contains a list of standard iframe attributes for your
reference. For more information about iframe attributes, see
http://www.w3schools.com/TAGS/tag_iframe.asp.

Attribute

Description

align

Specifies the alignment of an iframe according to
surrounding elements. If used, values are left,
right, top, middle, or bottom. The align attribute
will work, but is no longer widely used. Styles are
widely used today.
To use styles to center the Document Player on a
page, surround the iframe with division (div)
tags:
<div style="text-align:center">
[insert code for iframe]
</div>

frameborder

Specifies whether or not to display a border
around an iframe. Values are:
1 = show border
0 = no border

height

Specifies the height of the frame in pixels.

longdesc

The URL that points to the page containing a
long description of the content in the iframe.

marginheight

Defines the top and bottom margins in pixels.

marginwidth

Defines the left and right margins in pixels.

name

The name of the iframe.

scrolling

Specifies whether or not to show scrollbars in an
iframe. Values are yes, no, or auto.

src

The URL of the document contained in the
iframe.
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Attribute

Description

width

Defines the width of the iframe in pixels.

Using dynamically-generated iframes
To use relative address, you must use a dynamically-generated iframe.
This code generates an HTML iframe when the page is loaded. The
"nspirefile" parameter holds the location and file name of the
TI-Nspire™ or PublishView™ document that is to be shown on the page.
If the "nspirefile" parameter contains only the file name instead of the
full URL, you must upload the TI-Nspire™ or PublishView™ document to
your web server and ensure that it resides in the same folder as your blog
or web page.

<script type="text/javascript"
src="http://education.ti.com/html/nspireplayer/js/ticreateiframe.js"></
script>
<script type="text/javascript">
tiDeployPlayer.tiCreateIframePlayer(
// IFRAME attributes.
{
src : 'http://education.ti.com/go/nspireplayer',
width : '640',
height : '480',
scrolling : 'no',
frameborder : '0'
},
// TI-Nspire(TM) Document Player parameters.
{
nspirefile : 'myfile.tns'
}
);
</script>

Line breaks are not recognized in HTML source code. You may see the
iframe code strung together on a single line when you view the source
code in a text editor or HTML editor. To make the code easier to view,
you can manually add line breaks or enable Word Wrap. The following
example shows the code without line breaks.

<script type="text/javascript"
src="http://education.ti.com/html/nspireplayer/js/ticreateiframe.js"></
script>
<script type="text/javascript">
tiDeployPlayer.tiCreateIframePlayer({src :
'http://education.ti.com/go/nspireplayer', width : '640', height :
'480', scrolling : 'no', frameborder : '0' },{ nspirefile :
'myfile.tns'});</script>
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Using the TI-Nspire™ Document Player
The TI-Nspire™ Document Player launches automatically when you open
an HTML document that contains an embedded TI-Nspire™ or
PublishView™ document.The TI-Nspire™ Document Player plays directly
from the Internet and does not require any other Texas Instruments
handhelds or software.
Note: If this is your first time opening the player on your computer, you
are asked to accept the license agreement. This is only needed once for a
specific machine.

Exporting to a web page
Use the File > Export Web Page option to create a stand-alone web page
that can be used as is or that can be modified.
1. Open the TI-Nspire™ document or PublishView™ document you want
to embed in a web page.
2. Select File > Export Web Page.
The Web Page Text dialog box opens.

3. Type the title of the web page in the Web page title field. The title
will centered at the top of the web page. This is also the default
name for the HTML file.
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4. If you want to include additional text above the iframe, type the text
in the Text above the embedded window field.
To include text below the iframe, type the text in the Text below the
embedded window field.
5. Click Export.
The Save Web Page window opens.

6. In the Save in field, navigate to the folder where you want to save
the file.
7. In the File Name field, type the name of the file if different than the
default name.
8. Do not change the file type. By default, the file type is .html.
9. Click Save.
The .html file is saved to your computer. The embedded web page
automatically opens in your default web browser. If you move your
exported .html file to another folder, you must also move the
associated TI-Nspire™ or PublishView™ document.
When the TI-Nspire™ document or PublishView™ document is
exported to a web page, a copy is made of the document. This copy is
saved with the same names as the exported HTML file and will be
saved in the folder where you save the HTML file.
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À
Á
Â
Ã
Ä
Å
Æ

Exploring the web page

À

Browser window title bar. The Texas Instruments default title is
shown here.

Á

The absolute URL or file system path identifying where the .html
document is located.

Â

Web browser menu bars and tool bars.

Ã

Title of the embedded web page as specified in the Web page
title field.

Ä

The text as specified in the Text above the embedded window
field. Text that appears below the frame is specified in the Text
below the embedded window field.

Å

The iframe containing the embedded document.
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Æ

The TI-Nspire™ Document Player tool bar. These tools enable
you to interact with the document within the TI-Nspire™
Document Player.
•

Open another TI-Nspire™ or PublishView™ document on
your computer.

•

Save the original TI-Nspire™ or PublishView™ document.
Any changes you made in the TI-Nspire™ Document Player
window are not saved.

•

Link to your online storage site. For example, Google
Docs, ADRIVE, DROPBOX, or BOX.NET. When you link to a
site, the document path is copied to the clipboard and can be
pasted into the sharing site’s upload field. You can also add
your own sites such as your Blackboard™ or Moodle site.

•

Print the original embedded document or print the
document with changes you made in the TI-Nspire™
Document Player.

•

Undo the last change you made.
Note: The only changes you can make are mouse-driven. The
player does not accept text edits or keyboard input.

•
•

Redo the last change you made.
Reset -- Resets the document back to its original state
before any changes were made.

For more information about the TI-Nspire™ Document Player,
see the online TI-Nspire™ Document Player guide.

Customizing an embedded TI-Nspire™ Document
Player
The following example shows the iframe code needed to embed a
document that will be stored on the Texas Instruments Activities
Exchange or on the education.ti.com web site.
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<iframe src="http://education.ti.com/go/nspireplayer? lock_toolbar=yes&
openDoc=no&nspirefile=http://education.ti.com/xchange/US/Math/Algeb
raI/11340/From_Expressions_to_Equations.tns" width="700"
height="500" scrolling="no" frameborder="0"></iframe>
--OR--

<script type="text/javascript"
src="http://education.ti.com/html/nspireplayer/js/ticreateiframe.js"></scri
pt>
<script type="text/javascript">
tiDeployPlayer.tiCreateIframePlayer(
// IFRAME attributes.
{
src : 'http://education.ti.com/go/nspireplayer',
width : '360',
height : '290',
scrolling : 'no',
frameborder : '0'
},
// TI-Nspire(tm) Document Player parameters.
{
nspirefile :
'http://education.ti.com/xchange/US/Math/AlgebraI/11340/
From_Expressions_to_Equations.tns ',
lock_toolbar:'yes',
openDoc:'no'
}
);
</script>
Notice the parameters lock_toolbar=yes and openDoc=no. These settings
were used to customize the TI-Nspire™ Document Player so that it
launches with the toolbar locked in the expanded (visible) state and with
the Open icon hidden. The following table contains a list of
TI-Nspire™ Document Player parameters. When adding parameters to
the iframe code, be sure to separate each parameter with an ampersand
character (&).
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Attribute

Description

toolbar

Determines if the toolbar is expanded or
collapsed when the application is opened. If the
parameter is not specified, the toolbar opens in
the expanded state. To collapse the toolbar when
the application is opened, set this parameter to
"No."

lock_toolbar

When this paramter is set to "No," the toolbar
hide arrow is removed and the state of the
toolbar is locked. If this parameter is not
specified, the toolbar arrow is shown and the
toolbar is unlocked.

openDoc

Controls the visibility of the Open icon in the
toolbar. To hide the Open icon, set this parameter
to "No." If not specified, the Open icon is shown.
The nspirefile parameter must also be set for
this setting to be accepted.

save_local

Controls the visibility of the Save Local Copy icon
in the toolbar. To hide the Save Local Copy icon,
set this parameter to "No." If not specified, the
Save Local Copy icon is shown. The nspirefile
parameter must also be set for this setting to be
accepted.

save_online

Controls the visibility of the Save Online icon in
the toolbar. To hide the Save Online icon, set this
parameter to "No." If not specified, the Save
Online icon is shown. The nspirefile parameter
must also be set for this setting to be accepted.

cardId

Limits the visibility of a document to a single
page in the embedded window. The value of the
cardId is the ordinal page number of the page
within the TI-Nspire™ document or
PublishView™ document being embedded. The
nspirefile parameter must also be set for this
setting to be accepted.
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Attribute

Description

locale

By default, the language setting for Document
Player is set by the operating system. The locale
attribute enables you to manually change the
preferred language. Values are:
da = Danish
de = German
en = English
es = Spanish
fi = Finnish
fr = French
it = Italian
nl = Netherlands (Dutch)
no = Norwegian
pt = Portuguese
sv = Swedish
zh_CN = Simplified Chinese
zh_TW = Traditional Chinese

nspirefile

Identifies the storage location of the
TI-Nspire™ document or PublishView™
document to be embedded. The value can be the
absolute URL, the file system path, or the relative
address.
If using the relative address, you can use only
document file name (for example, "myfile.tns").
The Document Player assumes the document is in
the same directory as the exported .html
document, which makes the exported web page
portable. This means you can put the .html
document and the embedded document in the
same folder, then copy that folder anywhere and
the page will still work with no changes to the
source code.
This is useful when you want to share files with
someone via email but don’t want to post the file
online.
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Using Export to generate HTML source code
The Export options in all versions the TI-Nspire™ software enable you to
easily and automatically generate the required HTML code and iframes
needed to embed a document in an iframe. The code generated when
using Export produces the iframe each time the web page is loaded using
JavaScript. This is more flexible and robust than the hard-coded iframe.
For example, using JavaScript enables you to use relative addressing to
refer to your embedded documents. With relative addressing, the web
page will find and display your document as long as the document is
stored in the same folder as the HTML file. This is especially helpful when
sharing offline web pages.

Export options
TI-Nspire™ software provides two options for exporting documents in
HTML format:
•

Export Web Page

Use this option to produce a complete HTML document containing an
embedded window for your TI-Nspire™ or PublishView™ document
and supplementary text. This stand-alone web page can be used
without any changes or embellished using third-party software.
•

Export HTML to Clipboard

Use this option to produce a code snippet that can be pasted into
existing web pages or blogs. A code snippet contains a few lines of
HTML code that embeds a window into an existing page.
Both the full HTML document and the code snippet can be easily edited
using any text editor or HTML editor. Editing the HTML document
enables you to:
•

Change the source location of the embedded TI-Nspire™ or
PublishView™ document, which may be required to publish or share
the HTML document.

•

Modify the HTML to open the TI-Nspire™ or PublishView™ document
in a dedicated browser window.

•

Change the appearance of the embedded or dedicated window
containing the TI-Nspire™ or PublishView™ document.

Viewing the source code
After the web page is created, you can view and edit the source code.
The source code can be modified using any text editor or third-party
HTML editor. To view the source code:
f From your web browser’s menu bar, select View > Source.
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Note: The option for viewing source code may differ depending on
your default browser.
—OR—
f Open a text editor such as Notepad, then open the HTML file within
the text editor.
The source code is displayed.
Note: In some browsers, viewing the source code opens a text editor.
The following example shows source code that contains comments to
help anyone unfamiliar with HTML to understand and successfully
modify the code.
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<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01
Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<!-Thanks for creating a web page containing a TI-Nspire(tm) or
PublishView(tm) document. This page can easily be modified to fit your
needs. If you are not familiar with HTML, here are some basics to get you
started:
HTML DOCUMENTS
HTML documents are text documents that define a web page.
The text itself is known as source code. You are viewing source code now.
HTML documents become web pages when opened in a browser.
HTML documents have a Header (usually hidden information) and a Body
(displayed content).
TAGS
The appearance of your page is controlled by "tags".
Tags are surrounded by angle brackets <> .
Some elements require a start tag <> and an end tag </> .
LINES
Lines in the source file mean nothing when displayed as a web page.
Instead, tags are used to control lines on the page.
<br> creates a line break, just like hitting Enter key on your keyboard.
<p> creates a new paragraph. The browser will typically put empty space
around this tag.
COMMENTS
Comments are used to explain the source file and are not displayed on the
web page.
<!-- begin a comment.
- -> end a comment.
See http://www.w3.org/TR/REC-html40/struct/global.html for more
information on HTML.
That's it!
Your page starts below.
-->
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<head>
<!-- The line below tells the browser the Title of your Web Page. This may
be displayed in title bar of your browser. -->
<title>TI-Nspire&trade; Interactive Web Page</title>
<!-- The lines below help browsers and search engines quickly get
information about your page. These are not displayed on the page. -->
<meta name="author" content="Your Name">
<meta name="keywords" content="Your Keywords">
<meta name="description" content="Your Page Description">
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="keywords" content="&quot;ti-nspire document
player&quot;,&quot;nspire document player&quot;,&quot;tinspire&trade; document player&quot;,texas instruments, education.ti.com,
ti-nspire, ti nspire, nspire, tinspire, nspire cas, ti-nspire cas, computer,
software, publishview, publish view, publishview(tm), tns file, tnsp file,
document player, ti-nspire player, nspire player, player, interactive math,
mathematics, cas, student understanding, interactive classroom, educator's
classroom computer">
</head>
<body bgcolor="#FFFFFF" TEXT="#000000">
<!-- Note the background color and text color are included with the "body" tag. You can find out more
about color codes here: http://en.wikipedia.org/wiki/Web_colors -->
<!--The lines below create a high level header centered on the page. It is very common to show the page
title in this way. -->
<center>
<font size="5"><b>INSERT TITLE FROM DIALOG</b></font> <br>
</center>
<!--The line below creates a visible line across the page. It automatically adjusts to a % of the window
width.-->
<hr width="80%" align="center">
<!--Remove comment tags from the line below to create a bold section title. .-->
<!-- <font size="4"><b>Instructions</b></font> <br> -->
<!--The text below will appear above your embedded TI-Nspire(tm) or PublishView(tm) document. You
might use this space for instructions for the embedded activity. Spacing and returns are ignored. Word
wrapping will happen automatically. -->
<p>
THIS AREA CONTAINS "TEXT ABOVE" FROM WEB PAGE TEXT DIALOG.
</p>
<!--The section below embeds the TI-Nspire document in your web page.-->
<p>
THIS AREA CONTAINS THE CODE SNIPPET THAT EMBEDS THE TI-NSPIRE(TM) OR
PUBLISHVIEW(TM) DOCUMENT
</p>
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<!--The text below will appear below your embedded TI-Nspire(tm) or PublishView(tm) document. You
might use this space for guiding questions related to the activity. Spacing and returns are ignored. Word
wrapping will happen automatically. -->
<p>
THIS AREA CONTAINS "TEXT BELOW" FROM WEB PAGE TEXT DIALOG.
</p>
<!--The line below creates a visible line across the page. It automatically adjusts to a % of the window
width.-->
<hr width="80%" align="center">

<!-Insert related links.
Insert links using the examples below as a guide. Type or paste the URL
between quotation marks. Type the link text (visible on the page) after the
URL bracket and before the ending tag '<a/>'. Note you can use comment
tags to hide links without deleting them from the source code.
-->
<p>
<font size="1">
<a
href="http://education.ti.com/educationportal/preference/selectCountry.do
">Texas Instruments Education Technology<a/> <br>
<!-- <a
href="http://education.ti.com/calculators/timathnspired/">MathNspired.c
om<a/> <br> -->
</font>
</p>
<!-Insert an email link.
Remove comment tags from the line below, then type your email after
"mailto:"
-->
<!-- <a href="mailto:username@yourserver.com">E-mail the
author</a> -->
<!-Insert an image.
Copy and paste the line below into the body of your document where you
want the image to appear. Remove the comment tags, then replace the old
image source URL or file name a new one. You might also want to provide
alternate text (alt=) in case the image file is not available.
NOTE: If your image is not on the web, when you publish your page, you
will need to upload your image file along with your html file.
-->
<!-- <img src="type_document_name.here" alt="This text appears if the
image is not available" /> -->
</body>
</html>
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Exporting HTML to the clipboard
Use the HTML to Clipboard feature create a code snippet that can be
pasted into a blog, existing web page, or other HTML-compatible
container that supports Java applets. A snippet is not a full web page
because the source code does not contain the identifying information,
headers, and body section needed to publish a stand-alone web page.
1. Open the TI-Nspire™ document or PublishView™ document that you
want to export.
2. Select File > Export > HTML to Clipboard.
The code is copied to the clipboard.
3. Paste the snippet into a blog or other existing web page.

Editing the code snippet
To preview or edit the snippet before pasting it to a web page or blog,
paste the code into a text editor.
1. Open a new document in any text editor such Notepad (Windows®)
or TextEdit (Macintosh®).
2. Paste the code into the text editor. The following code is an example
of how the snippet may look when you copy it and open it in a text
editor.
<!-- START: TI-Nspire(TM) Document Player -->
<!-Paste the code below into the body of an existing web page or blog. The code will generate an HTML iframe when the page
is loaded. Note the 'nspirefile' parameter holds the location and file name of the TI-Nspire(TM) or PublishView(TM)
document that is to be shown on the page. If 'nspirefile' contains only a file name instead of a full URL, be sure to upload the
TI-Nspire or PublishView document to your web server and place it in the same folder as your blog or web page. Also, be
sure the 'nspirefile' string contains no backslash characters '\'. Use forward slash characters '/' instead.
-->
<script type="text/javascript" src="http://education.ti.com/html/nspireplayer/js/ticreateiframe.js"></script>
<script type="text/javascript">
tiDeployPlayer.tiCreateIframePlayer(
// IFRAME attributes.
{
src : 'http://education.ti.com/go/nspireplayer',
width : '640',
height : '480',
scrolling : 'no',
frameborder : '0'
},
// TI-Nspire(TM) Document Player parameters.
{
nspirefile : 'myfile.tns'
}
);
</script>
<!-- END: TI-Nspire(TM) Document Player -->

3. Edit the code snippet if needed.
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4. Save the file using the .html file extension. You can use any name you
choose to name the file; however, you must ensure the file extension
is .html.
Note: If you are using a word processing application such as
Microsoft® Word to edit the HTML file, save the file as plain text.
5. Open the file using your Internet browser (File > Open).
The embedded window is displayed in the web browser window.

Storing and sharing your documents
Once you create an HTML document, you will want to share it with
colleagues and students. You have the following options for sharing
embedded TI-Nspire™ documents and PublishView™ documents:
•

Publish your HTML document as a web page on the Internet.

•

Attach your HTML document to an email.

•

Save your HTML document on a file share on your school’s intranet.

•

Save your HTML file to a flash drive.

•

Paste a code snippet into an existing web page, blog, online course
page, or other HTML-compatible container.

Storing documents to be shared online
When you create an HTML page using the TI-Nspire™ export functions, a
window is embedded in the web page. The documents and the
TI-Nspire™ Document Player themselves are not embedded in the HTML
page. The HTML code loads the document and the TI-Nspire™ Document
Player from whereever they are stored when the HTML page is opened in
a browser. This means:
•

You must be connected to the Internet to view shared documents and
load the TI-Nspire™ Document Player.

•

The shared documents must be stored in a place where all viewers can
access them.

The Export feature produces HTML code that contains a relative address
to the file being exported. The URL contains only the file name, which
means your document must be in the same directory as the embedded
web page. As long as your document and the .html file containing the
embedded document are in the same folder, the URL will find the
document even if you move the folder.
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<script type="text/javascript"
src="http://education.ti.com/html/nspireplayer/js/ticreateiframe.js"></scri
pt>
<script type="text/javascript">
tiDeployPlayer.tiCreateIframePlayer(
// IFRAME attributes.
{
src : 'http://education.ti.com/go/nspireplayer',
width : '640',
height : '480',
scrolling : 'no',
frameborder : '0'
},
// TI-Nspire(TM) Document Player parameters.
{
nspirefile : 'myfile.tns'
}
);
</script>
Modifying the nspirefile parameter
If you have placed your file in the shared location, change the
nspirefile parameter to reflect the new URL or path where the
document is stored. The URL or path to a shared document is typically
easy to find. Often, right-clicking the URL or path name copies a shortcut
to the document, which you can paste into the iframe.
1. Place your document on a shared location. For example, a shared
network drive or web site.
2. Copy the path or URL.
3. Open the HTML page in a text editor to view and modify the code.
4. Replace the nspirefile parameter by pasting the new URL or path
over the existing URL or path name.
5. Save the updated HTML file.
If your shared document is located on a shared network drive, the
updated iframe might look like this:

<iframe
src="http://education.ti.com/go/nspireplayer?nspirefile=file:/P:/MathDepa
rtment/Algebra/Lessons/myfile.tns" width="360" height="290"
scrolling="no" frameborder="0"></iframe>
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-- OR --

<script type="text/javascript"
src="http://education.ti.com/html/nspireplayer/js/ticreateiframe.js"></scri
pt>
<script type="text/javascript">
tiDeployPlayer.tiCreateIframePlayer(
// IFRAME attributes.
{
src : 'http://education.ti.com/go/nspireplayer',
width : '640',
height : '480',
scrolling : 'no',
frameborder : '0'
},
// TI-Nspire(TM) Document Player parameters.
{
nspirefile : 'file:/P:/MathDepartment/Algebra/Lessons/myfile.tns'
}
);
</script>
If you uploaded your document to a location on the Internet, the iframe
might look like this:

<iframe src="http://education.ti.com/go/nspireplayer?nspirefile=
http://dl.dropbox.com/u/10849702/myfile.tns" width="360" height="290"
scrolling="no" frameborder="0"></iframe>
--OR--
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<script type="text/javascript"
src="http://education.ti.com/html/nspireplayer/js/ticreateiframe.js"></scrip
t>
<script type="text/javascript">
tiDeployPlayer.tiCreateIframePlayer(
// IFRAME attributes.
{
src : 'http://education.ti.com/go/nspireplayer',
width : '640',
height : '480',
scrolling : 'no',
frameborder : '0'
},
// TI-Nspire(TM) Document Player parameters.
{
nspirefile : 'http://dl.dropbox.com/u/10849702/myfile.tns'
}
);
</script>
After you have placed your document in a shared location and modified
the iframe, opening the HTML file automatically launches the
TI-Nspire™ Document Player and displays your embedded document a
your default web browser. Anyone accessing the document must be
connected to the Internet and have access to the shared file to view it.

Storing and sharing files offline
You can also share your documents with others to be opened and viewed
offline. You can send the HTML file to others as an email attachment or
on a flash drive. The recipient can save the file on their hard drive, then
open the document in their web browser or text editor.

Launching a dedicated TI-Nspire™ Document
Player window
You can use JavaScript to add a link to your web page that will launch
the TI-Nspire™ Document Player in a dedicated window. The example
code provided produces a link that launches a document from the
Activities Exchange on education.ti.com in a dedicated window.
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<a href="javascript: void(0)"
onclick="window.open('http://education.ti.com/go/nspireplayer?nspirefi
le=http://education.ti.com/xchange/US/Math/AlgebraI/11340/From_Ex
pressions_to_Equations.tns','_blank','width=800, \height=600,
\directories=no, \location=no, \menubar=no, \resizable=yes,
\scrollbars=no, \status=no, \toolbar=no'); return false;"> Click here </a>
The first parameter after "window.open" is the same as the source (src)
attribute in the embedded iframe. The other attributes in the script
control the appearance of the browser components surrounding the
dedicated window.
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Using the Scratchpad
The Scratchpad is a feature of the TI-Nspire™ handheld that lets you
quickly:
•

Evaluate math expressions.

•

Graph functions.

Opening and closing the Scratchpad
f From the Home screen, press » to open the Scratchpad.
The first time you open the Scratchpad, a blank page opens with the
Calculator active.

f Press » to alternate between the Calculate and Graph pages.
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f Press b to see the Scratchpad Calculate or Scratchpad Graph menu.
These menus are subsets of the TI-Nspire™ menus for the Calculator
and Graphs & Geometry applications. For complete listings of those
menus, refer to the documentation for those applications.
f Press d to close the Scratchpad.

Calculating with the Scratchpad
From the Scratchpad Calculate page, enter a math expression on the
entry line, then press · to evaluate the expression. Expressions display
in standard mathematical notation as you enter them.
Each evaluated expression and result becomes part of the Scratchpad
history, displayed above the entry line.

Entering simple math expressions
Note: To enter a negative number, press v and then enter the number.
Suppose you want to evaluate
1. Select the entry line in the work area.
2. Type 2 l 8 to begin the expression.

3. Press ¢ to return the cursor to the baseline, and then complete the
expression by typing:

r 43 p 12

4. Press · to evaluate the expression.
The expression displays in standard mathematical notation, and the
result displays on the right side of the page.

Note: You can force a decimal approximation in a result by pressing

/ · instead of ·.
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Pressing / · forces the approximate
result.
Note: Results formatting can also be adjusted in Settings. See Working
with documents on the TI-Nspire™ handheld for more information about
Settings.

Inserting items from the Catalog
You can use the Catalog to insert functions and commands, units,
symbols, and expression templates into the entry line.
1. Press k to open the Catalog. By default, the first tab is displayed,
which lists all commands and functions in alphabetical order.
Catalog
for a nonCAS
handheld

Catalog for
a CAS
handheld
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2. If the function you are inserting is visible in the list, select it and press
· to insert it.
3. If the function is not visible:
a) Press a letter key to jump to the entries that begin with that letter.
b) Press ¤ or £ as necessary to highlight the item you are inserting.
c) Click a numbered tab to list functions by category: math functions,
symbols, math templates, library objects, and value for standard
measurement units (CAS).
d) Press · to insert the item into the entry line.

Using an expression template
Templates help you enter matrices, piecewise functions, systems of
equations, integrals, derivatives, products, and other math expressions.

For example, suppose you want to evaluate

1. Press t to open the Template palette.
2. Select

to insert the algebraic sum template.

The template appears on the entry line with small blocks representing
elements that you can enter. A cursor appears next to one of the
elements to show that you can type a value for that element.

3. Use the arrow keys to move the cursor to each element’s position, and
type a value or expression for each element.

4. Press · to evaluate the expression.
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Inserting expressions using a wizard
You can use a wizard to simplify entering some expressions. The wizard
contains labeled boxes to help you enter the arguments in the
expression.
For example, suppose you want to fit a y=mx+b linear regression model
to the following two lists:
{1,2,3,4,5}
{5,8,11,14,17}
1. Press k 1 to open the Catalog and show the alphabetic list of
functions.
2. Click inside the list, and then press L to jump to the entries that
begin with “L.”
3. Press ¤ as necessary to highlight LinRegMx.
4. If the Wizards On option is not checked: Press e e to highlight
Wizards On, press · to change the setting, then press e e to
highlight LinRegMx again.
LinRegMx
function in a
non-CAS
handheld
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LinRegMx
function in a
CAS
handheld

5. Press ·.
A wizard opens, giving you a labeled box to type each argument.

6. Type {1,2,3,4,5} as X List.
7. Press e to move to the Y List box.
8. Type {5,8,11,14,17} as Y List.
9. If you want to store the regression equation in a specific variable,
press e, and then replace Save RegEqn To with the name of the
variable.
10. Select OK to close the wizard and insert the expression into the entry
line.
The expression is inserted along with statements to copy the
regression equation and display the variable stat.results, which will
contain the results.
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LinRegMx {1,2,3,4,5},{5,8,11,14,17},1: CopyVar stat.RegEqn,f1:
stat.results
The Scratchpad then displays the stat.results variables.
Note: You can copy values from the stat.results variables and paste
them into the entry line.

Viewing the history
Each evaluated expression and result becomes part of the Scratchpad
history, displayed above the entry line.
f Press £ or ¤ to scroll through the history.

À
À

Current entry/total entries

Copying a history item to the entry line
You can quickly copy an expression, subexpression, or result from the
history into the entry line.
1. Press £ or ¤ to move through the history and select the item that
you want to copy.
2. Optionally, select part of the expression or result by using Shift in
combination with the arrow keys.

3. Press · to copy the selection and insert it into the entry line.
Using the Scratchpad
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Clearing the history
When you clear the history, all variables and functions defined in the
history retain their current values. If you clear the history by mistake, use
the undo feature.
f From the Actions menu, select Clear History.
(Press b 1 5.)
All expressions and results are removed from the history.

Editing Scratchpad expressions
Although you cannot edit a Scratchpad Calculate expression in the
history, you can copy all or part of an expression from the history and
paste it to the entry line. You can then edit the entry line.

Inserting elements into the entry line
1. Press e, ¡, ¢, £, or ¤ to position the cursor in the expression. The
cursor moves to the closest valid position in the direction that you
press.
2. Type the elements or insert them from the Catalog.

Selecting part of an expression
You can delete, cut, or copy a selected part of an expression.
1. Press ¡, ¢, £, or ¤ to move the cursor to a starting point in the
expression.
2. Press and hold g and press ¡, ¢, £, or ¤ to select.
–

To delete the selection, press ..

–

To cut the selection to the Clipboard, press / X.

–

To copy the selection to the Clipboard, press / C.

–

To paste the selection to a new entry line in Scratchpad, press

/ V.
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Graphing with the Scratchpad
From the Scratchpad Graph page, click the Entry Line Expand button
to display the entry line and type an expression to graph. The entry line
displays the required format for typing a function. The default graph
type is Function, so the form f1(x)= displays.
1. Choose Graph Type from the menu, and select a graph type.
For example,
•

To graph a scatter plot, press b 3 4. Click var to choose
variable to plot as x and y for sn.

•

To graph a function, press b 3 1.

The entry line changes to display the expression format for the
specified graph type. You can specify multiple functions of each
graph type.
2. Type an expression and any other parameters required for the graph
type.

3. Press · to graph the function, or press ¤ to add another function.
If necessary, you can use press b 4 to choose a tool on the
Window/Zoom menu and adjust the viewing area.
When you graph the expression, the entry line disappears to show an
uncluttered view of the graph. If you select or trace a function, that
function displays on the entry line. You can change a function by
editing its expression or grabbing and changing the graph.
As you graph multiple functions on the axes, the label containing the
expression displays for each. You can define and graph a maximum of
99 functions of each type.
4. Use the b key to explore and analyze the graphed function by
tracing it, finding points of interest, or assigning a variable in the
expression to a slider.

Viewing the function table
f To display a table of values for the current function, press b 2 5.
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f To hide the function table, click the graph and then press b 2 5.

Changing the appearance of the axes
As you work with graphs, the Cartesian axes are displayed by default.
You can change the appearance of the axes in the following ways:
1. Press b 4 and choose the Zoom tool to use.
2. Select the axes and press / b 3 to activate the Attributes tool.
a) Press 9 or : to move to the attribute to change. For example,
choose the end style attribute.
b) Press 7 or 8 to choose the style to apply.
c) Change any other attributes of the axes as required for your work,
then press d to exit the attributes tool.
3. Adjust the axes scale and tic mark spacing manually.
a) Click and hold one tick mark, and move it on the axis. The spacing
and number of tic marks increases (or decreases) on both axes.
b) To adjust the scale and tic mark spacing on a single axis, press and
hold g, and then grab and drag a tic mark on that axis.
4. Change axis end values by double-clicking them and typing new
values.
5. Adjust the location of the axes. To move the existing axes without
resizing or rescaling them, click in and drag an empty region of the
screen until the axes are in the desired location.
6. Change the axes’ scales by pressing b 4 1.
Type the values of your choice over the current values for x-min,
x-max, y-min, and y-max and click OK.
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7. Press b 2 1 to hide or show the axes.
•

If the axes are shown on the page, selecting this tool hides them.

•

If the axes are hidden on the page, selecting this tool redisplays
them.

Tracing a graphed function
Graph Trace moves through the points of a graphed function,
parametric, polar, sequence, or scatter plot. To enable the trace tool:
1. Press b 5 1 to move across the points in a graphed function in
Trace model.

2. (Optional) To change the step increment for tracing, press
b 5 3.
After you type a different step increment, the Graph Trace tool moves
across the graph in steps of that size, instead of moving at the default
step automatically defined with a function.
3. Use Graph Trace to explore a graphed function in the following ways:
•

Move to a point and hover to move the trace cursor to that point.

•

Press 7 or 8 to move from point to point on the function’s graph.
The coordinates of each point traced displays.

•

Press 9 or : to move from one function’s graph to another, or to a
scatter plot. The point’s coordinates update to reflect the new
location of the trace. The trace cursor is positioned on the point of
the new graph or plot with the closest x value to the last point
identified on the previously traced function or graph. You can
trace multiple functions as described in Tracing all graphs.
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•

Type a number and press · to move the trace cursor to that
value on the function’s graph.

•

Create a persistent point that remains on the graph while in
Graph Trace mode by pressing · when the trace point reaches
the point you want to label.

•

Trace through and identify the points at which the function has
no defined x or y value (a discontinuity). The string undef displays
instead of a value when you move over a point that is not defined
for the function.

Notes:
•

When you select or trace a function on the work area, that
function displays on the Edit Line.

•

When you trace beyond the initially visible graph, the screen pans
to show the area being traced.

4. Exit Graph Trace by pressing d or by choosing another tool.

Finding points of interest
You can use the tools on the Analyze Graph menu to find a point of
interest in a specified range of any graphed function. Choose a tool to
find zero, the minimum or maximum, the point of intersection or
inflection, or the numeric derivative (dy/dx) or Integral on the graph.
1. Select the point of interest that you want to find on the Analyze
Graph menu. For example, to find a zero, press b 6 1.
The icon for the selected tool displays at the top left on the work
area. Point to the icon to view a tooltip about how to use the selected
tool.
2. Click the graph you want to search for the point of interest, then click
a second time to indicate where to start the search for the point.
The second click marks the lower bound of the search region and a
dotted line displays.
Note: If you are finding the derivative (dy/dx), click the graph at the
point (numeric value) to use for finding the derivative.
3. Press 3 or 4 to move the dotted line that marks the search region, then
click the point at which you want to stop the search (upper bound of
the search region).
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4. Press · at the point to start the search. The tool shades the range.
If the search region you specified includes the point of interest, a
label for the point displays. If you change a graph that has points of
interest identified, be sure to check for changes in points of interest.
For example, if you edit the function on the entry line or manipulate
a plot, the point where the graph intersects zero can change.
The labeled points of interest remain visible on the graph. You can
exit the tool by pressing d or choosing another tool.

Working with variables in the Scratchpad
Scratchpad variables are shared between Scratchpad Calculate and
Scratchpad Graph, but not with any TI-Nspire™ documents. If you use the
same name for a Scratchpad variable and a variable in a document, no
conflict occurs unless you attempt to copy expressions between
documents and the Scratchpad.

Saving the Scratchpad contents
You can save the Scratchpad Calculate page, the Scratchpad Graph page,
or both as a TI-Nspire™ document.
1. Press ~, then select Save to Document.
2. Press ·.
The Save to Document dialog box opens.
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3. Select the page or pages to save.
4. If a document is open, select either New or Current document.
5. Click Save.
•

If you selected to save to an open document, the Scratchpad
pages are added to the document.

•

If you selected to save to a new document:
–

Click Yes when the Save dialog box opens.

–

Type a name for the document.

–

Click Save to save the new document.

Clearing Scratchpad contents
Complete the following steps to delete the calculations and graphing
work from the Scratchpad application.
1. Press ~, then select Clear Scratchpad.
2. Press · to delete the Scratchpad contents.
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Getting started with the Calculator application
The Calculator application gives you a place to enter and evaluate math
expressions. You can also use it to define variables, functions, and
programs. When you define or edit a variable, function, or program, it
becomes available to any TI-Nspire™ math and science learning
technology application—such as Graphs & Geometry—that resides in the
same problem.
You can also use Calculator to define library objects, such as variables,
functions, and programs, which are accessible from any problem of any
document. For information on creating library objects, see the
“Libraries” section of the documentation.

À

Á

Â

À

Calculator menu – This menu is available anytime you are in the
Calculator work area using the Normal view mode. The menu in this
screen snapshot may not exactly match the menu on your screen.

Á

Calculator work area
–

Enter a math expression on the entry line and then press · to
evaluate the expression.

–

Expressions display in standard mathematical notation as you
enter them.
Calculator
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–

Â

Entered expressions and results show in the Calculator history.

Example of Calculator variables used in another application

Calculator menu
Use the Calculator menu to enter and evaluate a variety of math
expressions.
Actions
Define

Inserts the Define command.

Recall Definition

Lets you view, reuse, or modify a
function or program that you have
defined.

Delete Variable

Inserts the delVar command.

Clear a-z

Deletes all variables with singleletter names.

Clear History

Deletes all expressions in the
Calculator history.

Insert Comment

Lets you insert text.

Library

Lets you refresh all libraries, set
LibPub or LibPriv access, insert a “\”
character, or create a library
shortcut.

Lock

Inserts Lock, unLock, or
getLockInfo().

Number
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Convert to Decimal

Inserts ¢Decimal command.

Approximate to Fraction

Inserts ¢approxFraction().

Factorise

Inserts factor().

Least Common Multiple

Inserts lcm().

Highest Common Factor

Inserts gcd() function.

Remainder

Inserts remain().

Calculator

Number
Fraction Tools

Lets you select propFrac(),
getNum(), getDenom().
CAS: comDenom()

Number Tools

Complex-Number Tools

Lets you select round(), iPart(),
fPart(), sign(), mod(), floor(), or
ceiling().
Lets you select conj(), real(),
imag(), angle(), ¢Polar, ¢Rect,

or the absolute value template.

Algebra
Numerical Solve

Inserts nSolve().

Solve System of Linear Equations Opens the Solve a System of
Linear Equations wizard.
Polynomial Tools

Lets you open the Find Roots of
a Polynomial wizard or select
PolyRoots() or cPolyRoots().

CAS: Algebra
Solve

Inserts solve().

Factorise

Inserts factor().

Expand

Inserts expand().

Zeroes

Inserts zeros().

Complete the Square

Inserts completeSquare().

Numerical Solve

Inserts nSolve().

Solve System of Equations

Lets you open the Solve a
System of Equations or the
Solve a System of Linear
Equations wizard.
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CAS: Algebra
Polynomial Tools

Lets you open the Find Roots of
a Polynomial wizard or select
polyRemainder(),
polyQuotient(), polyGcd(),
polyCoeffs(), polyDegree(),
PolyRoots(), or cPolyRoots().

Fraction Tools

Lets you select propFrac(),
getNum(), getDenom(), or
comDenom().

Convert Expression

Lets you select ¢cos, ¢sin, or

¢Exp.
Trigonometry

Lets you select tExpand() or
tCollect().

Complex

Lets you select cSolve(),
cFactor(), or cZeros().

Extract

Lets you select left() or right().

Calculus
Numerical Derivative at a Point

Opens the Derivative at a Point
wizard.

Numerical Integral

Inserts The Definite integral
template.

Sum

Inserts the Sum template.

Product

Inserts the Product template.

Numerical Function Minimum

Inserts nfMin().

Numerical Function Maximum

Inserts nfMax().

CAS: Calculus
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Derivative

Inserts the Derivative template.

Derivative at a Point

Opens the Derivative at a Point
wizard.

Calculator

CAS: Calculus
Integral

Inserts the Integral template.

Limit

Inserts the Limit template.

Sum

Inserts the Sum template.

Product

Inserts the Product template.

Function Minimum

Inserts fMin().

Function Maximum

Inserts fMax().

Tangent Line

Inserts tangentLine().

Normal Line

Inserts normalLine().

Arc Length

Inserts arcLen().

Series

Lets you select taylor(), series(), or
dominantTerm().

Differential Equation
Solver

Inserts deSolve().

Implicit Differentiation

Inserts impDif().

Numerical Calculations

Lets you select nDerivative(),
centralDiff(), nInt(), nfMin(), or
nfMax()

Probability
Factorial (!)

Inserts !.

Permutations

Inserts nPr().

Combinations

Inserts nCr().

Random

Lets you select rand(), randInt(),
randBin(), randNorm(), randSamp(),
or RandSeed.

Distributions

Lets you select from several
distributions, such as Normal Pdf,
Binomial Cdf, and Inverse F.
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Statistics
Stats Calculations

Lets you select from several statistics
calculations, such as one-variable
analysis, two-variable analysis, and
regressions.

Stats Results

Inserts the stat.results variable.

List Math

Lets you select from several list
calculations, such as minimum,
maximum, and mean.

List Operations

Lets you select from several list
operations, such as sorting, filling, and
converting to a matrix.

Distributions

Lets you select from several
distributions, such as Normal Pdf,
Binomial Cdf, and Inverse F.

Confidence Intervals

Lets you select from several
confidence intervals, such as t interval
and z interval.

Stat Tests

Lets you select from several tests such
as ANOVA, t test, z test.

Matrix & Vector
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Create

Lets you open the Create a Matrix
wizard or insert newMat(), identity(),
diag(), randMat(), Fill, subMat(),
augment(), colAugment(), or
constructMat().

Transpose

Inserts T.

Determinant

Inserts det().

Row-Echelon Form

Inserts ref().

Reduced Row-Echelon
Form

Inserts rref().

Simultaneous

Inserts simult().
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Matrix & Vector
Norms
Dimensions

Lets you select norm(), rowNorm(), or
colNorm().
Lets you select dim(), rowDim(), or
colDim().

Row Operations

Lets you select rowSwap(), rowAdd(),
mRow(), or mRowAdd().

Element Operations

Inserts “dot” operators such as .+ (dot
add) and .^ (dot power).

Advanced

Inserts trace(), LU, QR, eigVl(),
eigVc(), or charPoly(),

Vectors

Inserts unitV(), crossP(), dotP(),
8Polar, 8Rect ,8Cylind, or 8Sphere.

Finance
Finance Solver

Displays the Finance Solver.

TVM Functions

Inserts tvmN(), tvmI(), tvmPV(),
tvmPmt(), or tvmFV().

Amortization

Inserts amortTbl(), bal(), GInt(), or
GPrn().

Cash Flows

Inserts npv(), irr(), or mirr().

Interest Conversion

Inserts nom() or eff().

Days between Dates

Inserts dbd().

Functions & Programs
Program Editor

Lets you view, open for editing,
import, or create a new program or
function.

Func...EndFunc

Inserts a template for creating a
function.

Prgm...EndPrgm

Inserts a template for creating a
program.
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Functions & Programs
Local

Inserts the Local command.

Control

Lets you select from a list of function
and program-control templates, such
as If...Then...EndIf, While...EndWhile,
Try...Else...EndTry, and error-handling
and warning-related items.

Transfer

Inserts transfer commands Return,
Cycle, Exit, Lbl, Stop, or Goto.

I/O

Inserts input/output commands Disp,
Request, RequestStr, or Text.

Mode

Inserts commands for setting or
reading modes, such as display digits,
angle mode, base mode, and others.
Also lets you get the current language
information.

Add New Line

Starts a new line within a function or
program definition.

Entering and evaluating math expressions
Entering simple math expressions
Note: To enter a negative number on the handheld, press v. To enter a
negative number on a computer keyboard, press the hyphen key (-).
Suppose you want to evaluate
1. Select the entry line in the Calculator work area.
2. Type 2^8 to begin the expression.

3. Press ¢ to return the cursor to the baseline.
4. Complete the expression:
–

Type *43/12.
Handheld: Type r 43 p 12.
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5. Press · to evaluate the expression.
The expression displays in standard mathematical notation, and the
result displays on the right side of the Calculator.

Note: If a result does not fit on the same line with the expression, it
displays on the next line.

Controlling the form of a result
You might expect to see a decimal result instead of 2752/3 in the
preceding example. A close decimal equivalent is 917.33333..., but that’s
only an approximation.
By default, Calculator retains the more precise form: 2752/3. Any result
that is not a whole number displays in a fractional or (CAS) symbolic
form. This reduces rounding errors that could be introduced by
intermediate results in chained calculations.
You can force a decimal approximation in a result:
•

By pressing shortcut keys.
–

Windows®: Press Ctrl+Enter to evaluate the expression.

–

Macintosh®: Press “+Enter to evaluate the expression.

–

Handheld: Press / · instead of · to evaluate the
expression.

Pressing / · forces the approximate
result.
•

By including a decimal in the expression (for example, 43. instead of
43).
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•

By wrapping the expression in the approx() function.

•

By changing the document’s Auto or Approximate mode setting to
Approximate.
–

From the File menu, select Settings > Document Settings.
Handheld: Press ~ 1 7.

Note that this method forces all results in all of the document’s
problems to approximate.

Inserting items from the Catalog
You can use the Catalog to insert system functions and commands,
symbols, and expression templates into the Calculator entry line.
1. Click the Utilities tab, and click
Handheld: Press k 1.
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to display the Catalog.

Note: Some functions have a wizard that prompts you for each
argument. Those functions are shown with an indicator. To receive
the prompts, select Wizards On.
2. If the item you are inserting is visible in the list, select it and press
· to insert it.
3. If the item is not visible:
a) Click inside the list of functions, and then press a letter key to
jump to the entries that begin with that letter.
b) Press ¤ or £ as necessary to highlight the item you are inserting.
Help, such as syntax information or a short description of the
selected item, appears at the bottom of the Catalog.
c) Press · to insert the item into the entry line.
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Using an expression template
The Calculator has templates for entering matrices, piecewise functions,
systems of equations, integrals, derivatives, products, and other math
expressions.

For example, suppose you want to evaluate

1. On the Utilities tab, click

to display the templates.

Handheld: Press t.
2. Select

to insert the algebraic sum template.

The template appears on the entry line with small blocks representing
elements that you can enter. A cursor appears next to one of the
elements to show that you can type a value for that element.

3. Use the arrow keys to move the cursor to each element’s position, and
type a value or expression for each element.

4. Press · to evaluate the expression.

Creating matrices
1. On the Utilities tab, click

184

Calculator

to display the templates.

Handheld: Press t.
2. Select

.

The Create a Matrix dialog box displays.

3. Type the Number of rows.
4. Type the Number of columns, and then select OK.
Calculator displays a template with spaces for the rows and columns.
Note: If you create a matrix with a large number of rows and
columns, it may take a few moments to appear.
5. Type the matrix values into the template, and press · to define the
matrix.

Inserting a row or column into a matrix
f To insert a new row, hold down Alt and press Enter.
f To insert a new column, hold down Shift and press Enter.
Handheld:
f To insert a new row, press @.
f To insert a new column, press g ·.

Inserting expressions using a wizard
You can use a wizard to simplify entering some expressions. The wizard
contains labeled boxes to help you enter the arguments in the
expression.
For example, suppose you want to fit a y=mx+b linear regression model
to the following two lists:
{1,2,3,4,5}
{5,8,11,14,17}
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1. On the Utilities tab, click

to display the Catalog.

Handheld: Press k 1.
2. Click an entry in the Catalog, and then press L to jump to the entries
that begin with “L.”
Handheld: Press L.
3. Press ¤ as necessary to highlight LinRegMx.
4. Click the Wizards On option, if it is not already selected:
Handheld: Press e e to highlight Wizards On, press · to
change the setting, and then press e e to highlight LinRegMx
again.
5. Press ·.
A wizard opens, giving you a labeled box to type each argument.

6. Type {1,2,3,4,5} as X List.
7. Press e to move to the Y List box.
8. Type {5,8,11,14,17} as Y List.
9. If you want to store the regression equation in a specific variable,
press e, and then replace Save RegEqn To with the name of the
variable.
10. Select OK to close the wizard and insert the expression into the entry
line.
Calculator inserts the expression and adds statements to copy the
regression equation and display the variable stat.results, which will
contain the results.
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LinRegMx {1,2,3,4,5},{5,8,11,14,17},1: CopyVar stat.RegEqn,f2:
stat.results
Calculator then displays the stat.results variables.

Note: You can copy values from the stat.results variables and paste
them into the entry line.

Creating a piecewise function
1. Begin the function definition. For example, type the following.
Define f(x,y)=

2. On the Utilities tab, click

to display the templates.

Handheld: Press t.
3. Select

.

The Piecewise Function dialog box displays.

4. Type the Number of Function Pieces, and select OK.
Calculator displays a template with spaces for the pieces.
5. Type the expressions into the template, and press · to define the
function.
6. Enter an expression to evaluate or graph the function. For example,
enter the expression f(1,2) on the Calculator entry line.
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Creating a system of equations
1. On the Utilities tab, click

to display the templates.

Handheld: Press t.
2. Select

.

The Create a System of Equations dialog box displays.

3. Type the Number of Equations, and select OK.
Calculator displays a template with spaces for the equations.
4. Type the equations into the template, and press · to define the
system.

Deferring evaluation
You don’t have to complete and evaluate an expression as soon as you
begin typing it. You can type part of an expression, leave to check some
work you did on another page, and then come back to complete the
expression later.

Working with variables
When you first store a value in a variable, you give the variable a name.
•

If the variable does not already exist, Calculator creates it.

•

If the variable already exists, Calculator updates it.

Variables within a problem are shared by TI-Nspire™ math and science
learning technology applications. For example, you can create a variable
in Calculator and then use or modify it in Graphs & Geometry or Lists &
Spreadsheet within the same problem.
For detailed information about variables, refer to the guidebook chapter
“Using variables.”
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CAS: Working with measurement units
A list of pre-defined constants and measurement units is available in the
Catalog. You can also create your own units.
Note: If you know a unit’s name, you can type the unit directly. For
example, you can type _qt to specify quarts. To type the underscore
symbol on the handheld, press / _.

CAS: Converting between measurement units
You can convert a value between any two units within the same category
(such as length).
Example: Using the Catalog, convert 12 meters to feet. The desired
expression is 12·_m¢_ft.
1. Type 12 on the entry line.
2. On the Utilities tab, click

to display the unit conversions.

Handheld: Press k 3.

3. Select the Length category to expand the list of pre-defined length
units.
Handheld: Scroll to the Length category, and press ·.
4. Scroll to meter.
Handheld: Scroll to _m (noting the meter hint in the Help window).
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5. Press · to paste _m to the entry line.

6. Select the Conversion Operator (¢) at the top of the Units list, and
press · to paste it to the entry line.

7. Select _ft from the Length category, and press ·.

8. Press · to evaluate the expression.

CAS: Creating a user-defined unit
As with the pre-defined units, user-defined unit names must begin with
an underscore symbol.
Example: Using the pre-defined units _ft and _min, define a unit named
_fpm that lets you enter velocity values in feet per minute and convert
velocity results to feet per minute.
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Now you can use the new velocity unit _fpm.

Creating user-defined functions and programs
You can use the Define command to create your own functions and
programs. You can create them in the Calculator application or in the
Program Editor and then use them in other TI-Nspire™ applications.
For information on programming with the Program Editor, see the
“Programming” and “Libraries” sections of the documentation.

Defining a single-line function
Suppose you want to define a function named cube() that calculates the
cube of a number or variable.
1. On the Calculator entry line, type Define cube(x)=x^3 and press
·.

The message “Done” confirms that the function has been defined.
2. Type cube(2) and press · to test the function.

Defining a multiple-line function using templates
You can define a function consisting of multiple statements entered on
separate lines. A multiple-line function may be easier to read than one
with multiple statements separated by colons.
Note: You can create multiple-line functions only by using the Define
command. You cannot use the := or & operators to create multiple-line
definitions. The Func...EndFunc template serves as a container for the
statements.
As an example, define a function named g(x,y) that compares two
arguments x and y. If argument x > argument y, the function should
return the value of x. Otherwise, it should return the value of y.
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1. On the Calculator entry line, type Define g(x,y)=. Do not press ·
yet.

2. Insert the Func...EndFunc template.
–

From the Functions & Programs menu, select Func...EndFunc.

Calculator inserts the template.

3. Insert the If...Then...Else...EndIf template.
–

From the Functions & Programs menu, select Control, and then
select If...Then...Else...EndIf.

Calculator inserts the template.

4. Type the remaining parts of the function, using the arrow keys to
move the cursor from line to line.

5. Press · to complete the definition.
6. Evaluate g(3,-7) to test the function.
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Defining a multiple-line function manually
f To start each new line without completing the function definition,
hold down Alt and press Enter
Handheld: Press @ instead of pressing ·.
As an example, define a function sumIntegers(x) that calculates the
cumulative sum of integers from 1 through x.
1. On the Calculator entry line, type Define sumIntegers(x)=. Do not
press · yet.

2. Insert the Func...EndFunc template.
–

From the Functions & Programs menu, select Func...EndFunc.

Calculator inserts the template.

3. Type the following lines, pressing @ or Alt+Enter at the end of each
line.

4. After typing Return tmpsum, press · to complete the definition.
5. Evaluate sumIntegers(5) to test the function.

Defining a program
Defining a program is similar to defining a multiple-line function. The
Prgm...EndPrgm template serves as a container for the program
statements.
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As an example, create a program named g(x,y) that compares two
arguments. Based on the comparison, the program should display the
text “x > y” or “x  y” (showing the values of x and y in the text).
1. On the Calculator entry line, type Define prog1(x,y)=. Do not press
· yet.

2. Insert the Prgm...EndPrgm template.
–

From the Functions & Programs menu, select Prgm...EndPrgm.

3. Insert the If...Then...Else...EndIf template.
–

From the Functions & Programs menu, select Control, and then
select If...Then...Else...EndIf.

4. Type the remaining parts of the function, using the arrow keys to
move the cursor from line to line. Use the Symbol Palette to type the
““ symbol.

5. Press · to complete the definition.
6. Execute prog1(3,-7) to test the program.
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Recalling a function or program definition
You might want to reuse or modify a function or program that you have
defined.
1. Display the list of defined functions.
–

From the Actions menu, select Recall Definition.

2. Select the name from the list.
The definition (for example, Define f(x)=1/x+3) is pasted into the
entry line for editing.

Editing Calculator expressions
Although you cannot edit an expression in the Calculator history, you can
copy all or part of an expression from the history and paste it to the entry
line. You can then edit the entry line.

Positioning the cursor in an expression
f Press e, ¡, ¢, £, or ¤ to move the cursor through the expression.
The cursor moves to the closest valid position in the direction that you
press.
Note: An expression template may force the cursor to move through its
parameters, even though some parameters may not be exactly in the
path of the cursor movement. For example, moving upward from the
main argument of an integral always moves the cursor to the top limit.

Inserting into an expression in the entry line
1. Position the cursor at the point where you want to insert additional
elements.
2. Type the elements that you want to insert.
Note: When you insert an open parenthesis, Calculator adds a temporary
close parenthesis, displayed in gray. You can override the temporary
parenthesis by typing the same parenthesis manually or by entering
something past the temporary parenthesis (thereby implicitly validating
its position in the expression). After you override the temporary gray
parenthesis, it is replaced with a black parenthesis.
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Selecting part of an expression
1. Position the cursor at the starting point in the expression.
Handheld: Press ¡, ¢, £, or ¤ to move the cursor.
2. Press and hold g and press ¡, ¢, £, or ¤ to select.

Deleting all or part of an expression on the entry line
1. Select the part of the expression to delete.
2. Press ..

Financial calculations
Several TI-Nspire™ functions provide financial calculations, such as time
value of money, amortization calculations, and return on investment
calculations.
The Calculator application also includes a Finance Solver. It lets you
dynamically solve several types of problems, such as loans and
investments.

Using the Finance Solver
1. Open the Finance Solver.
–

From the Finance menu, select Finance Solver.

The solver displays its default values (or previous values, if you have
already used the solver in the current problem).

2. Enter each known value, using e to cycle through the items.
–
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The help information at the bottom of the solver describes each
item.
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–

You might need to temporarily skip the value that you want to
calculate.

–

Make sure to set PpY, CpY, and PmtAt to the correct settings (12,
12, and END in this example).

3. Press e as necessary to select the item that you want to calculate,
and then press ·.
The solver calculates the value and stores all the values in “tvm.”
variables, such as tvm.n and tvm.pmt. These variables are accessible to
all TI-Nspire™ applications within the same problem.

Finance functions included
In addition to the Finance Solver, TI-Nspire™ built-in finance functions
include:
•

TVM functions for calculating future value, present value, number of
payments, interest rate, and payment amount.

•

Amortization information such as amortization tables, balance, sum
of interest payments, and sum of principal payments.

•

Net present value, internal rate of return, and modified rate of
return.

•

Conversions between nominal and effective interest rates, and
calculation of days between dates.

Notes:
•

Finance functions do not automatically store their argument values or
results to the TVM variables.

•

For a complete list of TI-Nspire™ functions, refer to the Reference
Guide.
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Working with the Calculator history
As you enter and evaluate expressions in the Calculator application, each
entry/result pair is saved in the Calculator history. The history gives you a
way to review your calculations, repeat a set of calculations, and copy
expressions for reuse in other pages or documents.

Viewing the Calculator history
The history of the expressions you have entered accumulates above the
entry line, with the most recent expression at the bottom. If the history
does not fit in the Calculator work area, you can scroll through the
history.
Note: You may notice a processing slowdown when the history contains
a large number of entries.
f Press £ or ¤ to scroll through the history.

À
À

Current entry/total entries

Copying a Calculator history item to the entry line
You can quickly copy an expression, subexpression, or result from the
history into the entry line.
1. Press £ or ¤ to move through the history and select the item that
you want to copy.
2. Optionally, select part of the expression or result by using Shift in
combination with the arrow keys.
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Note: The float setting for the current document may limit the
number of decimal places displayed in a result. To capture the result
in its full precision, select it either by scrolling with the up and down
arrow keys or by triple-clicking it.
3. Press · to copy the selection and insert it into the entry line.

Copying a history item to another application
1. Press £ or ¤ to move through the history and select the item that
you want to copy.
2. Optionally, select part of the expression or result by using Shift in
combination with the arrow keys.
3. Use the standard key shortcut for copying a selection.
–

Windows®: Press Ctrl+C.

–

Macintosh®: Press “+C.

–

Handheld: Press / C.

4. Place the cursor at the location where you want the copy.
5. Paste the copy.
–

Windows®: Press Ctrl+V.

–

Macintosh®: Press “+V.

–

Handheld: Press / V.

Note: If you copy an expression that uses variables into a different
problem, the values of those variables are not copied. You must define
the variables in the problem where you paste the expression.

Deleting an expression from the history
When you delete an expression, all variables and functions defined in the
expression retain their current values.
1. Drag or use the arrow keys to select the expression.
Handheld: Use the arrow keys.
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2. Press ..
The expression and its result are removed.

Clearing the Calculator history
When you clear the history, all variables and functions defined in the
history retain their current values. If you clear the history by mistake, use
the undo feature.
f To clear the history,
–

From the Actions menu, select Clear History.

All expressions and results are removed from the history.
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Using Variables
A variable is a defined value that can be used multiple times in a
problem. You can define a value or function as a variable within each
application. Within a problem, variables are shared by
TI-Nspire™ applications. For example, you can create a variable in
Calculator, then use or modify it in Graphs & Geometry or Lists &
Spreadsheet within the same problem.
Each variable has a name and a definition and the definition can be
changed. When you change the definition, all occurrences of the variable
in the problem are updated to use the new definition. In the TI-Nspire™
software, a variable has four attributes:
•

Name - User-defined name assigned when the variable is created.

•

Location - Variables are stored in memory.

•

Value - Number, text, mathematical expression, or function.

•

Type - Type of data that can be stored as a variable.

Note: Variables created with the Local command within a user-defined
function or program are not accessible outside that function or program.

Linking values on pages
Values and functions created or defined in one application can interact
with other applications (within the same problem) to share data.
When using linked items, keep in mind:
•

Values can be linked between applications on one page or between
different pages of the same problem.

•

All applications are linked to the same data.

•

If the linked value is changed in the original application, the change
is reflected in all linked usages.

Defining a variable is the first step in linking values.

Creating variables
Any portion or attribute of an object or function created within an
application can be stored as a varible. Examples of attributes that can
become variables are the area of a rectangle, the radius of a circle, the
value contained in a spreadsheet cell or the contents of a row or column,
or a function expression. When you create a variable, it is stored in
memory.
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Types of variables
You can store the following data types as variables:
Data type

Examples

Expression
2.541.25E62pxmin/102+3i(xN2)2
List

{2, 4, 6, 8}

Matrix

1 23
3 69

{1, 1, 2} {"red", "blue", "green"}

This can be entered as: [1,2,3;3,6,9]

Character string

“Hello”

“xmin/10”

“The answer is:”

Function,
program

myfunc( arg )

Measurement

area, perimeter, length, slope, angle

ellipse( x, y, r1, r2 )

When you click
or press h on a handheld to open the list of stored
variables, a symbol indicates the type.

Creating a variable from a Calculator value
This example shows how to create a variable using a handheld. Complete
the following steps to create a variable named num and store the result of
the expression 5+8 3 in that variable.
1. On the Calculator entry line, type the expression 5+8^3.

2. Press ¢ to expand the cursor to the baseline.
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3. Press / h and then type the variable name num.

This means: Calculate 5+8 3 and store the result as a variable named
num.
4. Press ·.
Calculator creates the variable num and stores the result there.

Creating a variable in the computer software
When creating a variable in the computer software, use the following
conventions. As alternatives to using & (store), you can use “:=” or the
Define command. All of the following statements are equivalent.
5+8 3 & num
num := 5+8 3
Define num=5+83

Checking a variable’s value
You can check the value of an existing variable by entering its name on
the Calculator entry line. When you type the name of a stored variable, it
appears in bold type.
f On the Calculator entry line, type the variable name num and press
·.
The value most recently stored in num displays as the result.

Automatically creating variables in Graphs & Geometry
In the Graphs and Geometry applications, functions defined on the entry
line are automatically stored as variables.
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In this example, f1(x)=x3 is a variable definition, which allows it to be
displayed in other applications including a table in the Lists &
Spreadsheet application.

Creating a variable from a Graphs & Geometry value
1. Click to select the value to store as a variable.

2. Click
.
Handheld: Press h.
The Variables options are displayed with Store Var highlighted.

3. Press ·. VAR := appears before the selected value. This is the
default name.
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4. Replace the default name VAR with the variable name you want to
give the value.
5. When the variable name is typed, press ·.
The value is saved to that variable name, and the stored value or its
name appears in bold text to indicate it is a stored value.

Note: You can also share a Graphs & Geometry axis end value with other
applications. If necessary, click Actions, Show/Hide Axes End Values to
display the end values on the horizontal and vertical axes. Click the
number for an end value to highlight it in the entry field. Name the
variable and store it for use with other applications by using any method
described in Step 2.

Automatically creating variables in Lists & Spreadsheet
Naming a list at the top of a Lists & Spreadsheet column automatically
stores that value as a list variable. This variable can be used in other
applications including Data & Statistics.
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Creating a variable from a Lists & Spreadsheet cell value
You can share a cell value with other applications. When defining or
referring to a shared cell in Lists & Spreadsheet, precede the name with
an apostrophe (‘).
1. Click the cell that you want to share.

2. Click
to open the Variables menu.
Handheld: Press h.

3. Select Store Var.
A formula is inserted into the cell with var as a placeholder for a
variable name.

4. Replace the letters “var” with a name for the variable, and press ·.
The value is now available as a variable to other applications within
the same problem.
Note: If a variable with the name you specified already exists in the
current problem space, Lists & Spreadsheet displays an error message.

206

Using Variables

Using (linking) variables
Sharing, or linking, the variables you create is a powerful tool for math
exploration. The display of linked variables is automatically updated
when the variable’s value changes.

Linking to shared variables
To use a stored variable:
1. Display the page and select the location or object to which you want
to link a variable.
2. Select the Variables tool h.
The Variables options are displayed. The software knows which types
of variables will work in the location or with the object selected and
will only display those variables.
3. Use 9 and : to scroll the list, or type part of the variable name.
As you type, the system displays a list of variables that begin with the
letters you typed. Typing part of the name enables you to locate a
variable more quickly if the list is long.
4. When you locate and highlight the name of the variable you want to
use, click the name or press ·.
The selected variable value is linked.

Linking a Lists & Spreadsheet cell to a variable
When you link a cell to a variable, Lists & Spreadsheet keeps the cell
value updated to reflect the current value of the variable. The variable
can be any variable in the current problem and can be defined in Graphs
& Geometry, Calculator, or any instance of Lists & Spreadsheet.
Note: Do not link to a system variable. Doing so could prevent the
variable from being updated by the system. System variables include ans,
StatMatrix, and statistics results (such as RegEqn, dfError, and Resid).
1. Click the cell that you want to link to the variable.
2. Open the VarLink menu:
, then click Cell.

–

Click

–

Handheld: Press h.

The VarLink menu displays.
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3. Under Link To, scroll to the name of the variable and click it.
The cell shows the value of the variable.

Using a variable in a calculation
After storing a value in a variable, you can use the variable name in an
expression as a substitute for the stored value.
1. Enter the expression:
–

Type 4*25*num^2 on the entry line, and press Enter.

–

Handheld: Type 4 r 25 r num^2 on the entry line, and press

·.
Calculator substitutes 517, the value currently assigned to num, and
evaluates the expression.

2. Enter the expression:
–

Type 4*25*nonum^2, and press Enter.

–

Handheld: Type 4 r 25 r nonum^2 on the entry line, and press

·.

CAS: Because the variable nonum has not been defined, it is treated
algebraically in the result.

Because the variable nonum has not been defined, the expression
returns an error message.

Entering multiple statements on the entry line
To enter several statements on a single line, separate them with a colon
(“:”). Only the result of the last expression is shown.
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Setting variable values with a slider
In the Graphs and Geometry applications, a slider control lets you adjust
or animate the assignment of values for a numeric variable. Use a slider
to represent multiple variable values in a continuous range.
1. From the Document Tools menu, select Actions > Insert Slider.
Handheld: Press b 1 A to insert a slider.

The slider displays on the work area. If you need to adjust or animate
value selection for more than one variable, you can repeat this step
and insert multiple sliders.
Note: You can access the context menu to Pin a slider to its location
and prevent unintentional movement.
2. Click the slider to activate it and press e to move between the
slider scale and the variable’s value.
3. Use ¡ and ¢ to move the slider on the scale.
4. Press Enter to select the value.
Access the context menu and choose Settings to view or change the
default slider settings.

Naming variables
Variable and function names that you create must meet the following
naming rules.
Note: In the unlikely event that you create a variable with the same
name as one used for statistical analysis or by the Finance Solver, an error
condition could occur. If you begin entering a variable name that is
already in use in the current problem, the software shows the entry in
bold to let you know.
•

Variable names must be in one of the forms xxx or xxx.yyy. The xxx part
can have 1 to 16 characters. The yyy part, if used, can have 1 to 15
characters. If you use the xxx.yyy form, both xxx and yyy are required;
you cannot start or end a variable name with a period “.”
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•

Characters can consist of letters, digits, and the underscore character
(_). Letters can be U.S. or Greek letters (but not Π or p), accented
letters, and international letters.

•

Do not use c or n from the symbol palette to construct a variable
name such as c1 or n12. These may appear to be letters, but they are
treated internally as special symbols.

•

You can use uppercase or lowercase letters. The names AB22, Ab22,
aB22, and ab22 all refer to the same variable.

•

You cannot use a digit as the first character of xxx or yyy.

•

Do not use spaces.

•

If you want a variable to be treated as a complex number, use an
underscore as the last character of the name.

•

CAS: If you want a variable to be treated as a type of unit (such as _m
or _ft), use an underscore as the first character of the name. You
cannot use subsequent underscores in the name.

•

You cannot use an underscore as the first character of the name.

•

You cannot use a preassigned variable, function, or command name,
such as Ans, min, or tan.
Note: For a complete list of TI-Nspire™ functions, refer to the
Reference Guide.

•

Library documents and library objects are subject to additional
naming restrictions. For details, see the “Libraries” section of the
documentation.

Here are some examples:
Variable names

Valid?

Myvar, my.var

Yes

My var, list 1

No. Contains a space.

a, b, c

Yes

Log, Ans

No. Preassigned to a system function or variable.

Log1, list1.a, list1.b

Yes

3rdTotal, list1.1

No. xxx or yyy starts with a digit.
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Locking and unlocking variables
Locking lets you protect variables from modification or deletion. Locking
prevents unintended changes to a variable.

Time and altitude lists can be
locked to ensure problem fidelity

Reference function f1 can be
locked to prevent unintended
change

Variables you cannot lock
•

System variable Ans

•

stat. and tvm. variable groups

Important information about locked variables
•

To lock variables, use the Lock command.

•

To modify or delete a locked variable, you must first unlock the item.

•

Locked variables display a lock icon on the variable menu list.

•

The Lock command clears the Redo/Undo history when applied to
unlocked variables.
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Examples of locking
Lock a,b,c

Locks variables a, b, and c from the Calculator
application.

Lock mystats.

Locks all members of variable group mystats.

UnLock func2

Unlocks variable func2.

lm:=getLockInfo(var2) Retrieves the current lock status of var2 and

assigns that value to lm in the Calculator
application.
For details about Lock, UnLock, and getLockInfo(), refer to the
Reference Guide section of the documentation.

Updating a variable
If you want to update a variable with the result of a calculation, you
must store the result explicitly.
Entry

Result

a := 2

2

a

8

3

a

2

a := a3

8

a

8

2
a &a

64

a

64

Comment

Result not stored in variable a.

Variable a updated with result.

Variable a updated with result.

Reusing the last answer
Each instance of Calculator automatically stores the last calculated result
as a variable named Ans. You can use Ans to create a chain of
calculations.
Note: Do not link to Ans or any system variable. Doing so could prevent
the variable from being updated by the system. System variables include
statistics results (such as Stat.RegEqn, Stat.dfError, and Stat.Resid) and
Finance Solver variables (such as tvm.n, tvm.pmt, and tvm.fv).
As an example of using Ans, calculate the area of a garden plot that is 1.7
meters by 4.2 meters. Then use the area to calculate the yield per square
meter if the plot produces a total of 147 tomatoes.
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1. Calculate the area:
–

On the Calculator entry line, type 1.7*4.2, and press Enter.

–

Handheld: On the Calculator entry line, type 1.7 r 4.2, and press

·.

2. Reuse the last answer to calculate the yield per square meter:
–

Type 147/ans, and press Enter to find the yield.

–

Handheld: Type 147 p ans, and press

3. As a second example, calculate

· to find the yield.

and then add 2*log(45).

–

Type 3.76/(-7.9+sqrt(5)), and press Enter.

–

Handheld: Type 3.76 p (v7.9+sqrt(5)), and press

·.

4. Reuse the last answer:
–

Type ans+2*log(45), and press Enter.

–

Handheld: Type ans+2 r log(45), and press ·.

Temporarily substituting a value for a variable
Use the “|” (such that) operator to assign a value to a variable for just a
single execution of the expression.

Using Variables

213

Removing a linked variable
1. Select the linked variable.
2. Press h.
The Variables options display.
3. Select Unlink.
The link is removed from the value, and the value displays without
any bolding.
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Graphs & Geometry
Getting started with Graphs & Geometry
The Graphs & Geometry application enables you perform the following
tasks.
•

Graph and explore functions, including 3D functions.

•

Create and explore geometric shapes.

•

Animate points on objects or graphs and explore their behavior.

•

Graph data collected by the Data Collection tool.

•

Explore graphical and geometric transformations.

•

Explore and investigate concepts of calculus.

•

Link to data created by other applications and utilize it in
Graphs & Geometry.
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Graphs & Geometry tool menu
Sample Graphs & Geometry work area in Graphing View
Sample tool icon (Trace tool) shows tooltip on hover
Sample Function graph (from function expression on the entry line)
Sample Graphs & Geometry entry line (for the Function Graph Type)
Entry Line Expansion button (click to show/hide the entry line)
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Æ

Function History button (click to show/hide all graphed functions of
the type and next available function)

À

Á

Â

À
Á
Â

Sample Graphs & Geometry work area in Plane Geometry View
Sample tool icon (Regular Polygon tool) shows tooltip on hover
Sample shape (regular polygon)

Graphs & Geometry menu
The Graphs & Geometry menu appears immediately above the work
area. To display the menu on the Handheld, press b.
Note: In the 3D Graphing view, the menu shows commands for working
with 3D graphs specifically.
When you select a tool from the menu, the tool’s icon displays in the
upper left corner of the Graphs & Geometry work area. You can hover
over the tool icon to view tooltips.
Actions
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Pointer

Selects, moves, and manipulates
objects.

Select

Lets you select the background image
or select objects in part of the work
area by placing a dashed-line box
around them.

Hide/Show

Enables you to hide or display
selected objects in the work area.

Graphs & Geometry

Actions
Attributes

Enables you to change the attributes
of a selected object in the work area.
Attributes vary depending upon the
object selected.

Delete All

Removes all objects (such as graphs,
shapes, points, and text) from the
work area.

Text

Lets you type alphanumeric text on
the work area. You can type numeric
values to apply to objects and type
expressions for graphing functions.

Coordinates and
Equations

Displays the coordinates of a point or
the equation of a line or circle.

Calculate

Opens the calculate tool to perform
calculations using measurements,
numerical values, or calculation
results. This tool is different from the
Calculator application.

Redefine

Redefines a previously defined point
to a new location. For example, you
can redefine a point in free space to a
location on an object, or redefine a
point from one object to another.

Insert Slider

Adds a slider object to let you easily
modify a numeric variable. A slider
also lets you animate the assigment
of different numeric values to the
variable.

View
Graphing

Places the work area in graphing mode
and displays the Cartesian axes in the
work area with an entry line below.

Graphs & Geometry
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View
Plane Geometry

Places the work area in geometry mode
and displays a work area with a scale, but
no axes, grid, or entry line until you
select Show Analytic Window from the
View menu.

3D Graphing

Displays a work area for defining and
graphing functions of the form z(x,y).
Also changes the Graphs & Geometry
menu to show commands for 3D
graphing.

Hide (Show) Analytic
Window

Opens a small graphing window on a
plane geometry work area. Places the
Graphs & Geometry work area in
modeling mode. This tool can be used
only after Plane Geometry is selected.

Hide (Show) Axes

Hides the axes if they are currently
displayed on the page. Displays the axes
if none are displayed on the page.

Show (Hide) Grid

Turns the grid on or off for the work area
or the analytic window. Objects can be
attached to the grid when the grid is
displayed.

Hide (Show) Entry Line Hides or displays the entry line on the
page.
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Show (Hide) Scale

Toggles between showing and hiding the
scale legend on the work area. When the
scale is shown, the value and/or units can
be changed to desired values/units. This
applies only to geometric constructions.

Show (Hide) Axes End
Values

Toggles between showing and hiding the
lowest value and highest value on the
horizontal and vertical axes.

Show (Hide) Table

Toggles between showing and hiding a
table of values associated with a graph.

Graphs & Geometry

View
Hide (Show) Object
Selection Guides

Toggles between showing and hiding the
label information for objects in the work
area. Hide the object selection guides to
keep an uncluttered display as you work
near objects with information labels.

Graph Type
Function

Displays the function mode entry line at the
bottom of the work area.

Parametric

Displays the parametric mode entry line at
the bottom of the work area. This display
shows the t-min, t-max, and t-step values.
The defaults are 0-2p for t-min, t-max, and
p/24 for t-step.

Polar

Displays the Polar mode entry line at the
bottom of the work area. This display shows
the q-min, q-max, and q-step values. The
defaults are 0-2p for q-min and q-max, and
p/24 for q-step.

Scatter Plot

Displays the Scatter Plot mode entry line at
the bottom of the work area.

Sequence

Displays a Sequence mode entry line for a
time plot or web plot, or displays an entry
line for a custom plot.

Diff Eq

Displays an editor for defining and graphing
ordinary differential equations.

Window/Zoom
Window Settings

Lets you specify the minimum and
maximum values for the x-axis and
y-axis. You can also set the axis
scaling increment between tics.

Zoom - Box

Enables you to define an area that
you want to enlarge.
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Window/Zoom
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Zoom - In

Enables you to define the center
point of the zoom in location. The
Zoom In factor is approximately 2.

Zoom - Out

Enables you to define the center
point of the zoom out location. The
Zoom Out factor is approximately 2.

Zoom - Standard

Automatically sets x-min, x-max, ymin, and y-max to center the origin.
The x and y scale factors are equal.
This is the default axes setting when
Graphs & Geometry is first added to
a page.

Zoom - Quadrant 1

Automatically sets x-min, x-max,
y-min, and y-max to emphasize the
first quadrant. The x and y scale
factors are equal.

Zoom - User

If you have modified any window
settings (such as x-min), Zoom-User
saves the present settings. If you
have not modified any window
settings since last selecting ZoomUser, Zoom-User restores those
settings.

Zoom - Trig

Automatically sets x-min and x-max
to integer multiples of p. The x and y
scale factors are equal.

Zoom - Data

Redefines the axes so that all
statistical data points are displayed.

Zoom - Fit

Recalculates y-min and y-max to
include the minimum and maximum
y values of all functions between the
current x-min and x-max. Hidden
functions are not included.

Zoom - Square

Recalculates y-min and y-max so that
the vertical scale is the same as the
horizontal scale.
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Window/Zoom
Zoom - Decimal

Recalculates x-min, x-max, y-min,
and y-max so that the origin is
centered and resolution is set to.1
(one tenth).

Trace
Graph Trace

Activates a trace point on the graph,
enabling you to trace functions. Applies
to function graphs only.

Trace All

Activates trace points on all graphs on
the work area, enabling you to trace
multiple functions simultaneously.

Trace Step

Enables you to set the Graph Trace
increment automatically, or by
specifying a numeric trace step value.

Geometry Trace

Enables you to view the pathway of a
geometric or analytic object (such as a
function graph) on the work area.
Earlier portions of the pathway are
automatically removed to reduce
screen clutter.

Erase Geometry Trace

Halts geometric trace and erases all
persistent pathways on the work area.

Analyse Graph

Zero

Finds zeros of a function (if any exist
within the specified range.)

Minimum

Finds the minimum within a specified
range.

Maximum

Finds the maximum within a specified
range.
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Analyse Graph

Intersection

Finds a point at which the selected
function intersects another (if such a
point exists within the specified range).

Inflection (CAS)

Finds a point of inflection within the
specified range.

dy/dx

Finds the derivative at the point clicked
on a function graph.

Integral

Finds the integral over a specified
bound.

Points & Lines
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Point

Constructs a point defined in free space,
on an object, or at the intersection of
two objects.

Point On

Constructs a point defined on an object.
When the object is a function graph, the
coordinates are displayed.

Intersection Point(s)

Constructs a point at each intersection of
two selected objects.

Line

Constructs a line defined by two points
or by a point and a direction. You can
press g while creating a line to limit
its orientation, relative to an axis, by 15increments.

Segment

Constructs a segment, defined by two
end points, which may be created or
defined in free space or on a defined
object. You can press g while
creating a segment to limit its
orientation, relative to an axis, by 15increments.
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Points & Lines
Ray

Constructs a ray, defined by two points
or by a point and a direction, extending
infinitely. You can press g while
creating the ray to limit its orientation,
relative to an axis, by 15- increments.

Tangent

Creates a tangent line.

Vector

Constructs a vector with magnitude and
direction defined by two points. You can
press g while creating the vector to
limit its orientation, relative to an axis,
by 15- increments.

Circle arc

Creates an arc defined by three points.

Measurement
Length

Displays the distance between two
selected points or the length of a
segment, perimeter, circumference, or
radius.

Area

Displays the area of a selected polygon
or circle.

Slope

Displays the slope of a selected line or
segment. A vertical slope is represented
by %.

Angle

Displays the measure of an angle
defined by three selected points.

Shapes
Circle

Constructs a circle by defining the center
point at the first click and the radius by
the second click. You can press g while
creating the circle to constrain the radius
to integer values.
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Shapes
Triangle

Rectangle

Constructs a triangle, defined by three
points (vertices), which may be created or
defined in free space or on a defined
object. You can press g while creating
a triangle to limit its orientation, relative
to an axis, by 15- increments.
Constructs a rectangle. You can press

g while creating a rectangle to limit
its orientation, relative to an axis, by 15increments.
Polygon

Constructs an n-sided polygon. Each click
defines a vertex, and the polygon is
completed by clicking the initial vertex or
by pressing ·. You can press g
while creating a polygon to limit its
orientation, relative to an axis, by 15increments.

Regular Polygon

Constructs an n-sided regular polygon.

Construction
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Perpendicular

Constructs a line perpendicular to a
selected line, segment, ray, vector, axis,
or side of a polygon, and passing
through a created or selected point.

Parallel

Constructs a line parallel to a selected
line, segment, ray, vector, axis, or side
of a polygon, and passing through a
created or selected point.

Perpendicular Bisector

Constructs a perpendicular line that
bisects two points, a segment, or side
of a polygon.

Angle Bisector

Constructs a line that bisects an angle
identified by three selected points
where the second point is the vertex.
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Construction
Mid Point

Constructs a midpoint of two selected
points, a segment, or side of a
polygon.

Locus

Constructs the locus of a point or
object defined by the movement of a
driver point along a pathway.

Compass

Constructs a circle from a center point
with a radius defined by a selected
segment or the distance between two
points.

Measurement transfer

Transfers an entered or measured
value to a selected object, axis, or
function graph. If the original value
changes, the change is also reflected in
the transferred measurement.

Transformation
Symmetry

Creates the image of an object rotated
180- around a point.

Reflection

Creates the image of an object reflected
across a line, segment, ray, vector, axis, or
side of a polygon.

Translation

Creates the image of an object translated
by a specified vector.

Rotation

Creates the image of an object rotated
around a point by a specified angular
value.

Enlargement

Creates the image of an object dilated
from a point by a specified factor.
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Using keystroke shortcuts
Use keystroke shortcuts to simplify tasks that you can perform in the
Graphs & Geometry application.
Keystrokes:

Task accomplished:

.
g

Removes a selected object from the work area.

+ (+) - (-)

When a number is under the pointer, the + and keys enable you to change the number of
displayed digits.

<>

When a number is under the pointer, the < and >
keys decrease or increase a value.

/μ

Displays application hints on the TI-Nspire™
handheld.

e

Move to functional areas of the application in the
following order: the entry line, Entry Line
Expansion button, Slider, Animation panel, or Data
Collection Console (when present), and then to
the work area. Edits (if any) are committed when
you e out of a field. Press g e to move
through the tab stop areas in reverse order, or
press d to jump to a graph on the work area.

£¤

Moves up and down among menu options and
through functions in the function history list.
When using the Trace tool, enables you to move to
a different graph when more than one graph is on
the page.

¡¢

Moves along the entry line, one space or one
button at a time. When using the Trace tool,
moves the trace cursor along the graph, either left
or right. When viewing an attribute list, steps
through the options for one attribute.

Constrains certain objects as you draw. Press while
drawing a circle with the Circle tool, or while
drawing objects with linear components. For
example, you can constrain a ine to multiples of 15
degrees, or constrain a circle to integer radius
values.

Note: When using the TI-Nspire™ software, you
can press Alt while pressing an arrow key to move
selected objects one pixel on the work area.
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Using the context menu
The context menu provides access to the tools most commonly used with
the selected objects. Different options can appear on the context menu
depending on the active object or the task you are performing.
You can display the context menu for an object in one of the following
ways.
f Handheld: Move the pointer to the object and then press / b.
f Windows®: Right-click the object.
f Macintosh®: Hold “ and click the object.
Many of the options that appear on the context menu provide
convenient access to functionality that is also available from menus. The
context menu can include the following options that are not available on
the application menus.
•

Click Recent to view and access the 9 most recently used tools. Recent
shows tools used for any Graphs & Geometry application, regardless
of the document in which they were used.

•

The Label option lets you show a persistent label near a selected
object.

•

The Color option lets you change the line color or fill color of selected
objects (such as a function graph, shape, or point).
Note: Color is supported for the TI-Nspire™ software in
Normal/Desktop view. If you are working in the Handheld view or
using the TI-Nspire™ handheld, the colors display as shades of gray.

•

The Edit Relation option moves the focus to the entry line for editing
the selected function.

•

The Convert to Analytic and Convert to Geometric options change
text created in one view to text that will display in the other. For
example, select the text box and click Convert to Geometric on the
context menu to change text you created in Graphing View to text
that will display in Plane Geometry view.

•

The Attach option lets you create a text chain, constraining the
relative horizontal or vertical position of one text object with respect
to another text object of the same type (analytic or geometric).

•

The Group option lets you group multiple objects and move them
simultaneously. A single label (rather than multiple label displays)
reduces screen clutter

•

The Pin option lets you pin objects to prevent accidental moves as you
make other changes on the work area. You can pin points, shapes,
Graphs & Geometry
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angles, values, text, graphed functions, the axes, and the work area
background.
Other options that are appropriate for various objects also display on the
context menu. See Working with Documents in the TI-Nspire™ software
for more information about using color in documents and changing the
Graphs & Geometry application’s settings for the default plot label
display.

Using the work area
The work area provides a space for drawing and working with objects
such as graphed functions, shapes, or points and lines.
When you select a graph or position the mouse over a graphed function,
the expression for the corresponding graph displays on the work area.
You can select multiple graphs to display their expressions.
The top left corner of the work area displays a tool icon when you
activate most tools. You can hover over the tool icon to display tips to
help you use the tool.

Grabbing and dragging items in the work area
Dragging lets you move and manipulate items. For example, you can
drag a text label to move it or drag a circle’s perimeter to resize it.
1. Point to the item.
The pointer changes to show that you can grab or manipulate the
item.
2. Use the mouse to grab and drag the item.
Handheld: Hold down x to grab the item, use the touchpad or
clickpad to drag it, and then press x again to release it.

Panning the work area
f To see different portions of the work area, click and hold on an empty
region until the pointer changes to ù, and then drag.

Adding text
You can add text to the work area to label objects, or to summarize the
results of your analysis of a graph. Use the Text tool to type numerical
values, formulas, or other information in the work area.
1. From the Actions menu, select Text.
2. On the work area, click the location for adding text. You can attach
text to an object by clicking the object.
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A text box with a blinking cursor appears at the location you selected.
3. Type the text.

4. Press · to anchor the text on the work area.
You can create a text chain by using the Attach tool on the context
menu to connect text objects of the same type to each other. Detach
disassociates chained text from a text chain. Spacing, alignment, and
updating of calculated value text is handled automatically for
chained text.
Note: You cannot include pinned text, text hidden using the
Show/Hide tool, or geometric scale values in a text chain.
5. You can customize text objects to suit your needs.
•

•

Use context menu options to change text objects.
–

Convert text created in Graphing View to geometric text.

–

Convert text created in Plane Geometry View (outside of the
analytic window) to analytic text.

–

Attach analytic or geometric text to text of the same type.

Use the Text tool to enter numerical values that the
Graphs & Geometry application can interpret as numbers. You can
use these numeric text entries for calculations, or for specifying
measurements.

6. Press d or choose another tool to exit the Text tool.

Working with multiple objects
You can select multiple objects with the Pointer tool or Select tool, and
then use other tools to perform certain actions on several objects at
once. As you move around and over objects, helpful details display, such
as information about the object type, object state (for example, pinned,
locked, or grouped).
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Notes:
•

•

Do not select a pinned object if you plan to move or group all of the
selected objects together. You cannot move pinned objects, and
including pinned objects in a group pins the group.
The e tooltip displays when you hover over a component object.
This indicates that you can press e to move among the component
objects and select them individually.

•

Read the object labels to ensure you do not select unintended
objects.

Selecting objects using the Pointer tool
1. Click the first object that you want to select.
The object flashes to indicate selection, and displays with a thicker
line style (bold) when you hover over it.

2. Click the second object.
You can continue clicking objects to select all of the objects that
interest you. As each object is selected, it flashes with the others in
the selection. You can deselect an individual object by clicking that
object again, or deselect the entire selection by pressing d or by
clicking on a part of the work area that contains no object.

Selecting objects with the Select tool
1. From the Actions menu, choose Select.
2. Click a point near the boundary of the part of the work area
containing objects that you want to select.
3. Move the pointer across the desired selection region. A dotted box
outline appears around the selection area as you move.
4. Click the point on the opposite boundary to complete selection.
The objects in the selection box flash. You can double-click the work
area to begin marking another selection, or press d to exit the
Select tool.
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Canceling selection
f Cancel the selection of objects in a selection box in the following
ways.
•

Cancel selection of all objects by pressing d or by clicking on a
space with no objects.

•

Cancel selection for one object by clicking the object a second
time.

Deleting selections
f To delete one or more selected objects, press ..
You cannot delete the origin, the axes, or locked points and values,
even if they are selected. Objects that are pinned and/or grouped can
be deleted.

Moving selections
1. Hover over one of the flashing objects in a selection of multiple
objects.
2. Grab and drag the object. All objects in the selection move together.
3. Click at the location of your choice to complete the move.
Notes:
•

If an unmovable object is included in a selection, then you must move
the objects individually. You cannot move the origin, the axes, or a
pinned object as part of a multiple-object selection.

•

Specific movements are supported for certain objects. For example,
you can press an arrow key to move an object attached to the grid
one point at a time.

Working with color
Color changes made in the software display in shades of gray when you
work on documents using a TI-Nspire™ handheld that does not support
color. Color is preserved when you move documents back to the
software.

Changing the color of a function or the axes
1. Select the axes or the function.
2. Access the context menu and choose Color > Line Color.
3. Select the color to apply.

Changing the line or fill color of objects
1. Select the object or objects.
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2. Access the context menu and choose Color > Line Color or Color >
Fill Color.
3. Select the color to apply to the objects.

Understanding attributes
The following table lists the attributes available for objects. The list of
available attributes depends upon the object you select. To view
attributes, select the Attributes tool. When an object is selected, a list of
the attributes available for that object displays on the work area. You can
choose an attribute and select an option to change the appearance of
the selected object. Attributes indicated with an asterisk support
entering a number to indicate a value for the attribute.
Name

Options

Available for use on

Line Weight

Thin, Medium,
Thick

Line, Tangent,
Segment, Ray, Vector,
Circle, Circle arc,
Triangle, Polygon,
Regular Polygon,
Rectangle, Graphed
Functions, Integrals

Line Style

Continuous,
Dotted, Dashed

Line, Tangent,
Segment, Ray, Vector,
Circle, Circle arc,
Triangle, Polygon,
Regular Polygon,
Rectangle, Graphed
Functions, Polar
Equations, Integrals,
Parametric Plots

Animation

Unidirectional
Animation
Speed*,
Alternating
Animation
Speed*

Point, Point On

Lock/
Unlock

Object is
unlocked, Object
is locked

Point, Point On,
Intersection Point,
Length, Area, Angle,
Circle Arc
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Icon(s)

Graphs & Geometry

Name

Icon(s)

Options

Available for use on

Custom
Precision

Current value: n* Length, Area, Angle,
Slope

Point Style

Circle, Empty
circle, Square,
Empty square,
Cross, Plus, Thin
(small circle),
Large, Empty
Large

Activation

Point is activated, Scatter Plot elements
Point is
unactivated

Graph
Appearance

Graph is
Graphed Functions,
continuous,
Parametric and Polar
Graph is discrete, graphs
Number of
Points*, Step
Size*, T
Minimum*, T
Maximum*, q
Minimum*, q
Maximum*,

Axes Style

Grid, No Grid

Axes
Settings

Axes user
Axes
settings, Axes
quadrant 1
settings, Axes trig
settings, Axes stat
settings, Axes
standard settings,
Axes decimal
settings

Axes End
Style

No arrows,
Positive arrows,
All arrows

Point, Point On,
Intersection Point,
Circle Arc

Axes

Axes
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Name

Icon(s)

Options

Available for use on

Axes Tic
Labels

Tic labels are
shown, Tic labels
are hidden

Axes

End Values
of Axes

End values are
Axes
shown, End
values are hidden

Line
Equation
Type

Cartesian (y=_),
Canonical (_=0)

Line, Tangent,
Segment, Ray, Vector

Equation
Type

Canonical (...=0),

Circle

Plot Points

Points are not
Scatter Plots
connected, Points
are connected

Labels

f, f( ), f( )=,
y=f( ), y=,

Graphed Functions

Sequence
Type

Time plot, Web
plot

Sequence plots

Cartesian (...=r2)

Changing an attribute of an object
You can change attributes to change the appearance of objects such as
shapes, lines, graphed functions, and axes.
1. From the Actions menu, choose the Attributes tool.
2. Select the object that you want to change. The list of the attributes
for the selected object displays.
3. Use 9 and : to move through the list of icons for attributes.
4. Highlight the icon for the attribute you want to change and use
7 or 8 to move through the options. For example, highlight the Line
Weight option, and use 7 or 8 to move to Thick, Thin, or Medium.
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As you move through the options, you can review the changes on the
work area. For example, you can see the line weight for the selected
object change from Thin to Medium as you preview the line weight
options.
Note: You can enter a numeric value instead of selecting an option to
change an animation speed attribute for a supported object, or to set
the step size, number of points, minimum values, or maximum values
for supported graph types.
5. Press · to apply the option to the attribute.

Locking measured values and points
Locking measured values and points can be useful when you need to
prevent inadvertent change, or for explorations in which object
manipulations are constrained such that the locked measurement
remains constant.
1. From the Actions menu, select Attributes.
2. Select the value or point that you want to lock.
3. Use 9 and : to locate the Lock attribute.
4. Use 7 or 8 to select Lock.

Initial rectangle with locked
perimeter

5. Click or press · to lock the value or point.
A lock icon appears near the locked value or point.
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In this case, a rectangle is created with the desired perimeter, and
then both the perimeter and area values are displayed. The perimeter
value is locked. As you manipulate the rectangle, the perimeter
remains unchanged but the area changes. When the optimum area
displays, you can measure the sides to obtain the necessary
dimensions.

Graphs & Geometry views
The Graphs & Geometry application has three separate views. Each is
tailored to specific types of explorations:
•

In Graphing view, the work area contains axes for graphing 2D
functions. The view includes an entry line where you can type and
edit the expressions to be graphed.

•

In Plane Geometry view, you can explore geometric objects. You can
optionally use the Plane Geometry view in modeling mode (that is,
Plane Geometry view with an analytic window added for working
with objects in an axis system).

•

In 3D Graphing view, the menu and work area change to let you
graph and explore 3D functions of the form z(x,y). The section
“Graphing 3D functions” in this chapter discusses 3D features.

When you add a new document, problem, or page, you can choose
Graphs or Geometry separately. The software adds a
Graphs & Geometry application in the selected view.

Summary of view differences
The following table describes some work area differences between the
Plane Geometry view and the Graphing View.
Feature

Graph Area

Plane Geometry Area

Aspect Ratio

Adjustable; initially 1:1

Always 1:1 (static)

Units of Measure

Generic (displayed as u)

User-defined (per scale)

Area Graph Type

Cartesian (default) or
Polar

Euclidian
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Feature

Graph Area

Plane Geometry Area

Uses

•

•

Construct,
manipulate,
transform, and
measure Euclidean
objects

•

Display labels and
informative text

Behavior

Define , graph, and
manipulate
functions to:
–

Graph
functions of
the form f (x)

–

Create scatter
plots

–

Graph polar
equations

–

Graph
parametric
equations

–

Graph
sequences

•

Construct,
manipulate, and
measure analytic
objects

•

Display
coordinates,
equations, labels,
and informative
text

Analytic objects must
remain in the analytic
area.

Geometric objects can
be displayed as a layer
behind the analytic
area, but they remain
geometric in nature.

Using the Graphing View
The following items display initially when you launch Graphing View.
•

Cartesian axes in the Zoom Standard format (1:1 scale)

•

Entry line from which you can graph up to 100 functions

The axes, entry line, and grid can all be displayed or hidden. All objects
created in Graphing View are analytic objects, so no scale displays for
shapes you draw (such as a circle or triangle). The Show Scale tool has no
effect.
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Creating an object in the Graphing View
When you create an object in the Graphing View, it is an analytic object,
and all points of the object reside on the graph plane. When you change
the axes scale, you automatically affect the appearance of the object. If
you calculate a value associated with the object such as the area, only
generic units are assigned (u for unit). These objects remain associated
with the coordinate plane until you delete them or redefine them to the
plane geometry area.
Note: When working with a modeling view work area (Plane Geometry
view with analytic window), you cannot move an analytic object onto the
plane geometry area.

Customizing the work area
Panning views
Panning lets you explore nearby objects, parts of graphs, or plots.
f Grab any empty space in the work area, and drag it.
The pointer changes to ù as you pan.
Note: Panning works in both the Graphing View and the Plane Geometry
View. In Plane Geometry View with the Analytic Window shown, you can
pan each view independently.

Showing/hiding the axes and other elements
In the Graphing View or in the Analytic Window in Plane Geometry View,
You can selectively show or hide the axes, grid, entry line, and end values
of the axes. You can show or hide the Scale indicator in any view.
Note: You can also hide or show the entry line by clicking
lower left corner of the work area.
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or

at the

f From the View menu, select the elements that you want to show or
hide. In this example, the grid is shown and the axes and entry line
are hidden.

Changing the appearance of the axes
The axes attributes tool lets you change display attributes such as end
arrows, end values, tic mark labels, and zoom settings.
1. From the Actions menu, select Attributes.
2. Click either axis.
3. Press 9 and : to move to the desired attribute, and then press
7 and 8 to choose the option to apply.

Zooming/rescaling the work area
Use one of the following methods to change the scale of the Graphing
View or the Analytic Window in Plane Geometry View.
f From the Window / Zoom menu, select one of the Zoom tools
(Zoom - Box, Zoom - In, or Zoom - Out), or select one of the
predefined Zoom settings. The initial setting is Zoom - Standard.
f Select an axis end value, press · to edit it, and type a new value.
Graphs & Geometry
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f Grab any tick mark on an axis, and drag it to rescale the view.
The aspect ratio of the axes is retained as you drag. To modify the
scale of only one axis, hold g as you drag.
f From the Window / Zoom menu, select Window Settings. In the
Window Settings tool, type the end values XMin, XMax, YMin, or
YMax. To set custom spacing of the tic-marks and grid, click the down
arrow for XScale or YScale, and type a value.

Default range and domain

Extended domain

Note: You can store an axis end value as a variable and then access it
outside of the Graphs & Geometry application. Select the end value in
the work area, and then click

(or press h) to store the value.

Inserting a background image
You can insert an image as a background for a Graphs & Geometry page.
The file format of the image can be .bmp, .jpg, or .png.
1. From the Insert menu, select Image.
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2. Navigate to the image you want to insert, select it, and then click
Open.
The image is inserted as a background.
For more information, refer to the Working with Images chapter.

Adjusting variable values with a slider
A slider lets you easily explore the effects of adjusting a numeric variable
through a range of values. You can control a slider's location and visual
appearance, and its adjustment range and step size.

À
Á
Â
Ã

Ä
À
Á
Â

Horizontal slider showing variable name, current value, and range.

Ã
Ä

Slider track

Vertical slider
Slider “thumb” that you can drag to adjust the current value of the
variable

Minimized sliders with arrows to adjust the variable’s current value

Inserting a slider
You can insert sliders on a Graphs page, a Geometry page, or a
Data & Statistics page.
1. From the Actions menu, select Insert Slider.
A gray image of a horizontal slider with default settings attaches
itself to the pointer.
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2. Drag to position the slider, and click to release it.

3. Press · to accept the default name (such as V1), or type the name
of a numeric variable that you want to assign and then press ·.

Setting up the slider
You can change many slider settings, such as Minimum and Maximum, by
clicking parts of the slider. Some settings, such as Step Size, are accessible
only through the Slider Settings dialog.
1. Right-click in the slider to display its context menu, and select
Settings to display the Slider Settings dialog.
Handheld: Point to the slider, press / b, and select Settings.
2. Use the Slider Settings dialog to enter settings for the slider. Each
setting is described below. Settings that accept a numeric value also
accept an expression that evaluates to a numeric value.
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Variable

Specifies which variable is assigned to the slider.
Type an available numeric variable name, or click
the drop-down arrow and select a name from the
list.

Value

Sets the current value of the variable.

Minimum

Sets the lowest value in the slider range (left or
bottom end point on the track).

Maximum

Sets the highest value in the slider range (right or
top end point on the track).

Step Size

Sets the size of the increment between values. The
default setting is Automatic. To enter a specific size,
click the drop-down arrow, select Enter Size, and
type a positive numeric value.

Style

Click the drop-down arrow to choose Horizontal or
Vertical.

Graphs & Geometry

Display Digits

Specifies the display format of the variable’s current
value. Choose Auto to display the value according to
the Document Settings option. Click the drop-down
arrow to choose from floating-point or fixed
formats.

Show Variable

Shows or hides the variable name in the slider.

Show Scale

Shows or hides the scale in a maximized slider.

Adjusting a slider variable’s current value
f After setting up a slider, use one of these methods to adjust the
current value:
–

Grab the slider thumb (

or

) and drag it.

–

Click the slider thumb, and then press 9, :, 7, or 8.

–

Click after the “=” or press e as necessary to select the current
value, and type a numeric value.

–

Click a new position on the track.
Note: Any time the variable’s current value is outside the slider’s
defined range, the thumb is not displayed. To bring the value
inside the slider’s range, click the slider track or arrows.

Repositioning a slider on the page
f Grab and drag any empty space in the slider’s selection rectangle, or
click an empty space in the slider and then press 9, :, 7, or 8.

Mimimizing a slider
f To minimize a slider and display only the variable name, current
value, and direction arrows, access the slider’s context menu and
select Minimize.

f To further minimize a slider and show only the arrows, access its
context menu and uncheck Show Variable.

Stretching a slider
f Grab the Minimum or Maximum end point on the track, and drag it.
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Note: Stretching or shrinking a slider affects only the length of the
track. The Minimum and Maximum values do not change.

Animating a slider
An animated slider steps repeatedly through its range, using the slider’s
Step Size.
f Access the slider’s context Menu and select Animate.
Note: To stop the animation, click Stop Animate. Animation also
stops if you lock the slider’s associated variable.

Removing a slider
Removing a slider does not delete the variable associated with the slider.
1. Click in the slider’s selection rectangle to select it.
2. Press ..

Tips for using sliders
Use multiple sliders for a variable
•

You can assign the same variable to multiple sliders. This lets you see
the effect of adjusting a variable by different step sizes or through
different ranges.

Deselect a slider
•

To deselect a slider, click another part of the work area, press d, or
press e e to move to another element in the work area.

Associate a different variable with a slider
•

Click the text box for the variable name and type the name of the
numeric variable to use.

•

With the slider active, click the h button to select a variable from
the list.

Using the Trace tools
Graphs & Geometry provides two trace tools:
•
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Graph Trace - point-to-point trace of the graph for a function,
parametric or polar equation, scatter plot, or sequence.

Graphs & Geometry

•

Geometry Trace - trail of functions or objects.

See Using the Plane Geometry View for details about using the Geometry
Trace tool.

Tracing a graph or plot
Graph Trace moves over the points of a graph or plot and displays value
information.
1. From the Trace menu, select Graph Trace:

2. (Optional) From the Trace menu, select Trace Step to change the step
increment.
3. Use Graph Trace to explore a graph or plot in the following ways:
–

Move to a point and hover to move the trace cursor to that point.

–

Press 7 or 8 to move the trace cursor from point to point and
display the coordinates or values of each point.

–

Press 9 or : to move from one graph to another. The point’s
coordinates update to reflect the new location of the trace. The
trace cursor is positioned on the point of the new graph or plot
with the closest x value to the last point identified on the
previously traced graph. You can trace multiple functions as
described in Tracing all graphs.

–

Type a number and press · to move the trace cursor to that
independent value on the graph or plot.
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–

Create a persistent point that remains on the graph while in
Graph Trace mode by pressing · when the trace point reaches
the point you want to label.

–

Trace through and identify the points at which the graph has no
defined value (a discontinuity) for a coordinate. The coordinate
pair (x, undef) displays when you trace a point with an undefined
x coordinate.

Notes:
–

When you select or trace a graph or plot on the work area, that
relation displays on the entry line.

–

When you trace beyond the initially visible graph, the screen pans
to show the area being traced.

4. Exit Graph Trace by pressing d or by choosing another tool.

Tracing all graphs
The Trace All tool works like Graph Trace, but allows tracing multiple
functions simultaneously. With several functions graphed on the work
area, perform the following steps:
Note: The Trace All tool traces only function graphs, not plots of other
relations (polar, parametric, scatter, sequence).
1. Choose Trace All from the Trace menu.
A vertical line indicates the x value of the trace and a trace point
appears on each function graphed on the work area.
2. Press 7 or 8 to move the trace point along each graph on the work
area simultaneously.
3. Exit Trace All by pressing d or by choosing another tool.

Working with relations
The entry line under the work area lets you specify relations in the
format supported for each graph type.

Using the entry line
The entry line displays at the bottom of the work area. You can specify
multiple relations for each graph type. The default graph type is
Function, so the form f1(x)= displays.
1. To graph a function, select a graph type.
–
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To graph a function, select Function on the Graph Type menu.
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Function mode entry line

The work area and entry line change to function mode. Type an
expression for the function after the equal sign.
–

To graph a parametric equation, select Parametric on the Graph
Type menu.

Parametric mode entry line

Type expressions for xn(t) and yn(t). Specifying alternate values for
the default t-min, t-max, and t-step displayed is optional.
–

To graph a polar equation, select Polar on the Graph Type menu.

Polar mode entry line

Type an expression for rn(q). Specifying alternate values for the
default q-minimum and q-maximum, and q-step displayed is
optional.
–

To graph a scatter plot, select Scatter Plot on the Graph Type
menu.

Scatter Plot mode entry line

The work area and entry line change to scatter plot mode. Click
var to choose variable to plot as x and y for sn. You can also type
the name of a variable that already exists, or define a list as
comma-separated elements enclosed within brackets, for
example: {1,2,3}.
–

Choose the option for the type of sequence you want to plot.
To plot a web plot or time plot of a sequence, select Sequence on
the Graph Type menu and choose Sequence.
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Sequence mode entry line

To plot a phase plot of a sequence, select Sequence on the Graph
Type menu and choose Custom.

Sequence mode - Custom entry line

The work area and entry line change to show parameters needed
for the selected sequence mode. Specify the parameters required
for the plot type. You can use the Attributes tool to change
between the Time plot and Web plot of a sequence.
2. Press · to graph the relation.
When you press · to graph the expression, Graphs & Geometry
hides the entry line and shows an uncluttered view of the graph.
3. Take one of the following actions to continue your work:
–

To graph the one relation and then immediately specify another,
press :.

–

To graph the relation and activate the Entry Line Expansion
button

, press e.

After you graph f1(x) and redisplay the entry line, the entry line
displays f2(x)= to enable you to enter another function. If you
select or trace a function, that function displays on the entry line.
As you graph multiple relations on the graph axes,
Graphs & Geometry labels each, unless the Graphs & Geometry
setting "Automatically hide plot labels" is checked.. You can
define and graph a maximum of 99 of each type. For example, you
use function mode to specify functions (f1(x) - f99(x) ). You can
rename relations using custom names, for example, g1(x).
Note: The entry line is automatically hidden when you are not
entering or editing relations. To display it at any time, press / G.
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Displaying relation history
Show the entry line, and then click the Function History button
to
display a history of the relations typed on the entry line. The list displays
relations in the order of entry (top to bottom), with the most recent
entry closest to the entry line. Use 9 and : to move up and down the list.

Use the relation history list to edit or delete relations.

Finding points of interest
You can use the tools on the Analyse Graph menu to find a point of
interest in a specified range of a function graph. Choose a tool to find
zero, the minimum or maximum, the point of intersection, or the
derivative (dy/dx) or Integral.
Note (CAS): You can also find the point of inflection.
1. Select the point of interest on the Analyse Graph menu. For example,
select Minimum to find the minimum point.
The icon for the selected tool displays at the top left on the work
area. Point to the icon to view a tooltip about using the selected tool.
2. Click the graph you want to search for the point of interest.
When you point to the plot, a dotted line displays for marking the
part of the graph to search for the point of interest.
Notes:
–

If you are finding the derivative, click the graph at the point at
which you want to find the derivative.

–

You can choose tools for finding points of interest from the
context menu. If you select the Integral tool or the Derivative tool
from the context menu with a function graph selected, that
function is used for finding the point of interest.
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3. Press 3 or 4 to move the dotted line to the lower bound of the search
region.
Note: You can also type a number to use as the lower bound for the
search region and press ·.
4. Press · to mark the lower bound for the search region. The tool
shades the range.
5. Repeat steps 3 and 4 to set the upper bound of the search region.
If the search region you specified includes the point of interest, a
label for the point displays. If you change a graph that has points of
interest identified, check for changes in points of interest. For
example, if you edit the function on the entry line or manipulate a
plot, the point where the graph intersects the y axis can change.
You can exit the tool by pressing d or choosing another tool. The
labeled points of interest remain visible on the graph.

Specifying a function with domain restrictions
You can use the entry line or the Calculator application to specify a
function with domain restrictions. For multiple domain restrictions on a
function, use the piecewise function, piecewise().
In the following example, a function with a domain that is less than 2
and greater than -2 is specified on the entry line:
1. Press / G to display the entry line.
2. Type piecewise(3, x > -2 and x < 2) on the entry line.
3. Press · to graph the function.
Graphs & Geometry reformats the expression on the entry line and
graphs the expression:
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Graphing a family of functions
A family of functions differ by one or more parameters and can be
specified with a single expression. To graph a family of functions:
1. Type an expression for a family of functions on the entry line. To
specify a family of functions:
–

Specify the parameters as one expression for multiple functions
using the format
f1(x) = {-1,0,1,2} * x + {2,4,6,8}
or
f1(x) = m*x | m = {1,2,3}.

–

Enclose the lists of numbers or lists of variables in curly brackets.
Specify parameters to graph a family of up to 16 functions.

For example, four functions are denoted with the expression:
f1(x) = {-1,0,1,2} * x + {2,4,6,8}.
The first function to be evaluated is y = -1 * x + 2 and the second is
0 * x + 4.
2. Press · to graph the family of functions specified.
Graphs & Geometry creates and displays a separate graph object for
each member of the family of functions.
Each function is labeled (f1_1, f1_2) to indicate its sequence in the
expression. You can select, analyze, or trace the graphs to explore
them.
Note: Editing a single function graph to change it to a family of
functions is not supported.

Graphs & Geometry

251

Creating a time plot or web plot sequence
You can use the Sequence graphing mode to plot a time plot or web plot
from the entry line.
•

A Time plot plots n on the horizontal axis against the value of the
sequence at each term, u1(n), on the vertical axis. A time plot is useful
for identifying patterns in sequence values.

•

A Web plot plots the sequence value for a preceding index, such as
u1(n-1), on the horizontal axis against the value of the sequence for
the current index, such as u1(n), on the vertical axis. A web plot is
useful for analyzing the long-term behavior of a recursive sequence
(as with a convergence or oscillation).

1. Specify the parameters required for the type of sequence plot you
want:
–

The u1(n)= expression field is where you enter or edit the
sequence. Type the expression that defines the sequence. The
term index, n is a series of consecutive integers that starts with
zero or any positive integer. The sequence name can include
letters, numbers, and parentheses in the formats: u1, u1(n), u1(),
myseq, myseq(n), or myseq(). (If you type the sequence name in
the format u1() or myseq(), the application automatically adds
the n.)

–

The expression you type for a sequence can reference a variable
assigned to work with a slider.

–

The Initial Terms parameter is the first term to evaluate for a
recursive sequence. If the sequence expression references more
than one prior term, such as u1(n-1) and u1(n-2), then you must
type additional initial terms. Separate multiple terms with
commas.

–

The nStep range is the minimum index, maximum index, and the
increment used for graphing.

For example, in the u1(n) field, type the expression 2*u1(n-1) + 1. No
initial term or step range entry is required in this case.
2. After entering the parameters, press · to graph the sequence
specified.
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The sequence plot includes a point for each term of the sequence.
Note: If you plot a sequence and the variable used to specify it is later
changed to another type (such as to a Function), the plotted sequence
is automatically deleted.
3. Click the sequence graph and use Graphs & Geometry tools to explore
the graphed sequence.
–

Click the sequence graph to see its expression and the label for the
graph.

–

Animate a slider assigned to use a variable included in a sequence
expression to observe changes in the plot.

–

Right-click the work area and choose Graph Trace on the context
menu to move through and highlight values for the sequence.
Handheld: Press / b and select Graph Trace to move
through and highlight values on the sequence graph.

–

Press / T to display or hide a table of the values found while
evaluating the sequences at consecutive integer values.
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–

Grab and drag the point that represents an initial term. As you
drag the term, its value changes. The sequence definition on the
entry line is updated automatically with the changes you make by
manipulating a term.

Creating a custom plot for a sequence
A custom plot lets you show the relationship between two sequences by
plotting one sequence on the x axis and the other on the y axis.
When you define a custom plot, you specify the variable names of two
defined sequences (from the Graphs & Geometry application) and assign
each to an axis. This section demonstrates how to create a custom plot
using the Predator-Prey model from biology to determine the numbers
of rabbits and foxes that maintain population equilibrium.
rabbit(n) = rabbit(n-1) * (1 +.05-.001 * fox(n-1))
fox(n) = fox(n-1) * (1 +.0002* rabbit(n-1) -.03), where:
.05 = the growth rate of rabbits if there are no foxes,
.001 = the rate at which foxes can kill rabbits,
.0002 = the growth rate of foxes if there are rabbits,
.03 = and the death rate of foxes if there are no rabbits.
1. On the Graph Type menu, choose Sequence and select Sequence.
Use the model equation to define rabbit and fox sequences over a
cycle of 400 generations. Assume that there are 200 rabbits and 50
foxes initially.
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Note: For a less cluttered view, choose Hide/Show on the Actions
menu to hide the rabbit(n) and fox(n) sequences on the work area.
2. On the Graph Type menu, choose Sequence and select Custom.
3. Type rabbit(n) as the x-axis sequence, and then press e and type
fox(n) as the y-axis sequence.

Note: You can also click h to choose the name of a previously
defined sequence, or specify the name of a new sequence that you
can define later.
4. Press e to move to the next line, and set the nstep and the range for
n. For this example, n is set between 1 and 400 and the nstep is the
default value, 1.
5. Press · to create the custom plot.
Note: Choose Zoom - Fit on the Window/Zoom menu to adjust the
window settings.

6. Explore the custom plot by grabbing and dragging the point that
represents the initial term.

As you drag the point, its value changes and the rabbit and fox initial
terms are automatically updated.
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In this example, manipulating the intial term demonstrates that the
point of equilibrium in the rabbit and fox populations over the cycle
of 400 generations = (150, 50).

Graphing differential equations
You can study linear and non-linear differential equations and systems of
ordinary differential equations (ODEs), including logistic models and
Lotka-Volterra equations (predator-prey models). You can also plot slope
and direction fields with interactive implementations of Euler and
Runge-Kutta methods.
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Slope field
A solution curve passing through the intitial condition
ODE editor:
–

Checkbox for designating this ODE as active or inactive

–

y1 ODE identifier

–

Expression k·y1 defines the relation

–

Fields (1,1) for specifying initial condition

–

Buttons for adding initial conditions and setting plot parameters

Slider to control coefficient k of the ODE

Graphs & Geometry

To graph a differential equation:
1. On the Graph Type menu, select Diff Eq.
The entry line displays an ODE edit field for defining the next
available ODE. The ODE is automatically assigned an identifier, such
as “y1.”

Note: You can type a replacement identifier and then use that
identifier in the relation on the right side of the “=” symbol.
2. Move to the relation field and enter the expression that defines the
relation. For example, you might enter -y1+0.1*y1*y2.

3. Enter the initial condition for the independent value x0 and for y10.
Notes:
–

The x0 value(s) are common to all the ODEs in a problem but can
be entered or modified only in the first ODE. They are displayed as
non-editable for the other ODEs.

–

You can delete an existing initial condition by clearing its x0 and
y0 fields.

4. If you want to study multiple initial conditions for the current ODE,
click the Add Initial Condition button
5. Click the Edit Parameters button
parameters.

and enter the conditions.
to view or set the plot
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6. Refer to the summary of settings following this procedure. Select a
numerical Solution Method and any additional plot parameters. You
can change these parameters as needed.
7. Select OK.
8. To enter additional ODEs, press down arrow to display the next ODE
edit field.
When you press · or press the up or down arrow keys to move
among ODEs that you have defined, the graph is updated to reflect
any changes. One solution to the ODE is graphed for each IC specified
for each active ODE (selected by checkbox).

Summary of Differential Equation settings
Solution Method

Selects Euler or Runge-Kutta as the numerical
solution method.

Iterations Between
Plot Step

Computational accuracy for Euler solution
method only. Must be an integer value >0. To
restore the default, select the down-arrow
and select Default.
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Error Tolerance

Computational accuracy for Runge-Kutta
solution method only. Must be a floatingpoint value |1×10-14. To restore the default,
select the down-arrow and select Default.

Field

None - No field is plotted. Available for any

number of ODEs, but required if three or
more 1st-order ODEs are active. Graphs a
combination of the solution and/or values of
one or more ODEs (according to userconfigured Axes settings).
Slope - Plots a field representing the family of

solutions to a single 1st-order ODE. Exactly
one ODE must be active. Sets Axes to Default
(x and y). Sets Horizontal axis to x (the
independent variable). Sets Vertical axis to y
(the solution to the ODE).
Direction - Graphs a field in the phase plane

representing the relationship between a
solution and/or values of a system of two
1st-order ODEs (as specified by the Custom
Axes setting). Exactly two ODEs must be
active. Axes: user-configured (neither axis can
be x).
Axes

Default (x and y) - Plots x on the x axis and y

(the solutions to the active differential
equations) on the y axis.
Custom - lets you select the values to be
plotted on the x and y axes respectively. Valid
entries include:

•

x (the independent variable)

•

y1, y2, and any identifiers defined in the
ODE editor

•

y1’, y2’, and any derivatives defined in

the ODE editor
Plot Start

Sets the independent variable value at which
the solution plot starts .

Plot End

Sets the independent variable value at which
the solution plot stops.

Plot Step

Sets the increment of the independent
variable at which values are plotted.
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Field Resolution

Sets the number of columns of field rendering
elements (line segments) used to draw a slope
or direction field. You can change this
parameter only if Field = Direction or Slope.

Direction Field at x=

Sets the independent variable value at which
a direction field is drawn when plotting nonautonomous equations (those that refer to x).
Ignored when plotting autonomous
equations. You can change this parameter
only if Field = Direction.

Using the Text tool to enter functions
You can graph a function, including a function of the form “y=”, by
typing the expression into a text box. To graph a function this way:
1. From the Actions menu, select Text:
2. Click the work area to place the text box. Type the function you want
to graph.

3. Drag the text box to the axis and drop it.
Graphs & Geometry graphs the function.
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Regardless of how you specify a function, each function is labeled for
identification.

Graphing inequalities
You can use the entry line for the Function graph type to define a
function that uses a symbol other than the equal sign.
1. Position the cursor to the right of the equal sign.
2. Press . or Backspace to delete the equal sign.
A list of symbols displays.
3. Select or type the desired sign(s) to express the inequality.
Note: You can also type two symbols, such as > and = to express
greater than or equal, or use the Catalog’s Symbol Palette to choose
from the inequality symbols: >, <, {, and |.
4. Type the rest of the inequality expression and press · to graph the
expression.
The expression, as typed, displays when you hover at the boundary of
the graph. The shading on the graphs of inequalities shows the values
that satisfy the inequality. If you graph two inequalities that overlap,
the area of overlap is shaded darker than either of the individual
inequality graphs.

Renaming f(x)
The default naming convention for functions is fn(x). (The number
represented by n increases as you specify more functions.) You can
replace the default name with a name of your choice.
1. Place your cursor to the right of the = sign in the entry line.
2. Select the default characters.
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3. Type the letters/numbers for the system you want to use, and then
type the function that you want to graph.

4. Press · to graph the function.
Notice that the label shown next to the graph is identical to what you
entered.

Note: To continue the custom naming convention, you must
manually rename each function as you enter it.

Editing functions
You can edit graphed functions, one function at a time. To edit a
function:
1. Use one of the following methods to access the function:
–

Press d and double click the function label on the graph.

–

Click the Entry Line Expansion button
the function.

, or press £ to move to

The expression displays in a text box or in the entry line.
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2. Move the cursor to the portion of the function you want to change.
3. If you are adding to the expression, type the new characters into the
function.
If you need to delete a portion of the function, remove the unneeded
characters and type any new characters.
4. Press · to graph the revised function.

Hiding a function on the work area
1. From the Actions menu, select Hide/Show.
The Hide/Show tool icon displays at the top of the work area.
2. Click the graph of any functions that you want to hide. You can also
click any other type of object that you want to hide.
Objects you click while the tool is active appear dimmed.
3. Press d to exit the Hide/Show tool.
The hidden function disappears. To redisplay hidden objects, repeat
the steps above.
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Deleting a function
1. Select the function by clicking its graph.
2. Delete the function by pressing Backspace or ..
The function is removed from the work area and from the list of
graphed functions.

Manipulating functions
Some functions allow you to translate, stretch and/or rotate them by
grabbing and manipulating the graph.
f From the Actions menu, choose Pointer, and then move to the graph
that you want to manipulate.
The pointer changes to indicate supported manipulation (for
example, to õ , ö, or é) when you hover on a graphed function that
you can grab and manipulate.
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As you change the graph, the expression for the graph updates to
reflect changes. You can manipulate the following types of functions:
•

Linear function; y=b

•

Linear function; y=ax+b

•

Quadratic function; y=a(x-b)2+c

•

Quadratic function; y=ax2+bx+c

•

Exponential function; y=exp(ax+b)+c

•

Exponential function; y=b*exp(ax)+c

•

Exponential function; y=d*exp(ax+b)+c

•

Logarithmic function; y=a*ln(cx+b)+d

•

Sinusoidal function; y=a*sin(cx+b)+d

•

Cosinusoidal function; y=a*cos(cx+b)+d
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Manipulating a linear function

Initial function graph

Function translated along the x-axis.
(Notice the revised function label) To
translate, grab near the middle of the
graph, and then drag.

Manually rotated function. To rotate, grab and
drag near the ends of the graph.
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Manipulating a quadratic function

Original quadratic function

Manually rotated function. To
stretch, grab away from the
vertex of the graph, and then
drag.

Function translated on the x-axis

Function translated on the y-axis

To translate, grab and drag near the vertex of the graph.
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Manipulating a sine or cosine function

Original sine function

Translation manipulation along the
y-axis.

Rotation manipulation of the sine
function. To stretch, grab away from the
axis of vertical symmetry of the graph,
and then drag.

Translation manipulation along the
x-axis.

To translate, grab and drag near the axis of vertical symmetry of the graph.

Finding the derivative at a point (the slope)
This method uses the Analyse Graph menu. Alternatively, you could
create a tangent on the graph to help visualize the slope and then use
the Measurement menu to measure it.
1. From the Analyse Graph menu, select dy/dx.
2. Click the point on the graph at which you want to find the derivative.
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The value of the derivative at the selected point displays on the
graph.

Note: To find the derivative at a specific value of x or y, use the
context menu of the point to show its coordinates, and then edit the
x or y coordinate.

Viewing function tables
You can show a table of function values for any function in the current
problem.
While viewing the table, you can change the settings for the table,
delete columns, add values for multiple functions, and edit the
expression that defines a function. For details, refer to Using Lists &
Spreadsheet.

Showing the table
f From the View menu, select Show Table.
The table displays in a split screen, showing columns of values for the
currently defined functions.
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At the top of each column, you can choose the function to display in
the column.

Hiding the table
f Click in the Graphs & Geometry window to display its menu, and then
select Hide Table on the View menu.

Using the Plane Geometry View
The plane geometry view includes a scale by default, but includes no axes
or entry line on the work area.
f Change to Plane Geometry View from the View menu by selecting
Plane Geometry View.
The display refreshes to clear the axes and entry line and display a
default scale. Any graphs or drawings created in Graphing View are
not displayed on the plane geometry area.
Note: Any geometric constructions created while in the Plane
Geometry View are retained and displayed along with any previously
created graphs.

Creating an object in Plane Geometry View
You can choose Geometry on an empty page of a document to work in
Plane Geometry View. The shapes, points, and lines you create while in
this view are geometric objects. Geometric objects can have an assigned
scale, such as centimeters, instead of u for units (as used with Graphing
View).
When working in modeling mode (that is, in Plane Geometry View with
an analytic window), you can move a geometric object into the graphing
work area. The object remains a geometric object, and is not associated
with the axes. For example, you can move a vertex of a triangle, but since
the object is not tied to a coordinate plane, no coordinates display for
the vertex.
The examples below show a modeling work area and the two types of
objects: A is an analytic object while B is a geometric object.
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Although the two circles appear to be identical, they do not behave in
the same way. Analytic objects are affected when the graph area is
altered. In the next example, the axes were altered. Notice that only
Circle A’s appearance is affected by the change.

If you create an object with the axis hidden, the object is a geometric
object. However, if you create an analytic object and later hide the axis,
the object remains an analytical one.

Triangle as it appears in Graphing View. The
unlabeled vertex remains a geometric point.
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Using the analytic window
The analytic (graphing) window is available in the Plane Geometry View.
It adds an analytic (graphing) window on top of a portion of the plane
geometry work area. This provides a combination work area that enables
you to use both work area types without having to change the view.
1. Confirm that the work area is in Plane Geometry View.
2. From the View menu, select Show Analytic Window.
A small graphing window opens on the lower left corner of the plane
geometry work area. See Working with functions for more
information about graphing.
Graphing area

Plane
Geometry
area

Modeling view - shows the previous two views and
the work done on both.

3. Use the modeling view to work with analytic and geometric objects.
You can perform the following actions:
–

Use the View menu to show or hide the axes, axes end values,
scale, and grid.

–

Resale the axes using the Window > Zoom tools or by dragging tic
marks.

–

Grab an empty area of the screen and drag it to pan through the
work area.

4. Select Hide Analytic Window to remove the analytic window from
the work area:

Working with Cabri™ II Plus files
You can open Cabri™ II Plus Figures (.fig) files in Graphs & Geometry.
Each .fig file converts to one Graphs & Geometry page with converted
figures and one Notes page with conversion messages.

Opening a Cabri™ II Plus file
To open a Cabri™ II Plus figures (.fig) file in Graphs & Geometry:
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1. From the File menu, select Open Document.
2. On the Open TI Nspire Document dialog, click Files of Type and
choose Cabri™ II Plus Figures (*.fig).
3. Click the .fig file that you want to open in Graphs & Geometry and
click Open.

Using Geometry Trace
The Geometry Trace tool enables you to leave a visible trail of an object
when it is moved on the work area. The movement can be done manually
or by using the Animation tool.
Note: The trace trail cannot be selected or manipulated.
1. Create an object or function.
2. From the Trace menu, select Geometry Trace.
3. Click the object or function and manually grab and move the object,
or select a point and use the Attributes tool to set animation.
If you use animation, the point must be selected for Geometry Trace
as well as animation. See Changing an attribute of an object for
details.
4. Observe the Geometry Trace results.
In the following example, a line segment was drawn and selected for
Geometry Trace. Movement of the segment was done manually.

The amount of trace track displayed on the work area depends upon
the amount of movement.
•

If the object moves very little, then the entire track remains
displayed until you erase it.

•

If the object moves a lot, the track can obscure a significant
portion of the work area. In this case, the older portions of the
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track fade out to prevent the work area from becoming obscured
by the track.

Erasing Geometry Trace
The easiest way to remove the trace tracks from the work area is to select
the Erase Geometry Trace tool.
f From the Trace menu, select Erase Geometry Trace.
When selected, this tool removes immediately all trace tracks from
the work area.

Grouping objects
You can group objects on the work area to maintain the positioning of
the objects and to perform certain actions on all of the objects in the
group. You can drag and move the objects in a group.
1. Select the objects to group.
Note: Do not include pinned objects if you plan to move the group.
Including a pinned object in a group creates a pinned group.
For details about selecting the objects to group, see Selecting objects
with the Pointer tool or Selecting objects with the Select tool.
2. With selected objects flashing, choose Group from the context menu.
Handheld: Press / b.
Macintosh®: Press and hold “ and click the group.
Windows®: Right-click a selected object in the group.
The objects are grouped on the work area. When you hover over or
click an object in the group of objects, the label “group” displays. You
can ungroup the objects by clicking any object in the group and
selecting Ungroup from the context menu.

Pinning objects
You can pin points, shapes, angles, values, text, graphed functions, the
axes, and the work area background to prevent accidental moves as you
manipulate other objects on the work area.
1. Select one or more objects to pin.
For details about selecting several objects to pin, see Selecting objects
with the Pointer tool or Selecting objects with the Select tool.
2. Select Pin on the context menu.
Handheld: Press / b.
Macintosh®: Press and hold “ and click the object.
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Windows®: Right-click the object.
Pinned objects are labeled with the object type (“circle” or “axes”)
and display a pin icon. You can select the object and choose Unpin
from the context menu to return the object to its original state.
Notes:
–

The work area does not display a label when pinned. You cannot
grab the work area to pan the view if the work area is pinned.

–

Pinning an object to another object does not prevent
manipulation of the “pinned -to” object. For example, a point
pinned to a graphed function does not prevent manipulation of
the graphed function.

–

You can still edit a pinned object in some cases. For example, you
can edit the x and y coordinates of a pinned point. The point can
move to reflect an edit of values, but not in response to
manipulation.

–

For an object that includes a Lock attribute, locking is disabled
after you pin the object.

–

When you point to a pinned object, the pointer does not change
to one that allows translation or grab-and-drag actions.

Working with points and lines
Use the Points & Line tools to draw the following types of points and
lines. Point and line tools also let you name, label, or redefine points.
•

Points: Point, Point on, Intersection point(s)

•

Lines

•

Segments

•

Rays

•

Tangent

•

Vectors

•

Circle arcs

Working with points
There are three tools for creating points:
•

Point

•

Point On

•

Intersection Point
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Creating a point
You can create a point using the Point tool. Create a point on on the
work area, or on an object such as a graph or shape.
1. From the Points & Lines menu, select the Point tool.
2. Move to the work area, and click to create a point.
3. Work with the point using the Pointer tool from the Actions menu.
For example, select the point using the Pointer tool and drag it to
move it.

Notes:

–

A point that is pinned displays the pin icon and is not movable.

–

You can also create a point by typing an opening parenthesis and
comma-separated coordinates. For example, activate the Point
tool, type (3,5), and then press · to create a point with abscissa
3 and ordinate 5.

Creating a point on an object
1. From the Points & Lines menu, choose Point On.
2. Click on the object you want to create a specific point on, then click
to place the point.
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3. Work with the point using the Pointer tool from the Actions menu.
For example, use the Attributes tool from the Actions menu to
animate the point on the object.

Defining points of intersection
Use this tool to find points at which two graphs intersect.
1. From the Points & Lines menu, select the Intersection Point tool.
2. Click each graph to find points of intersection.
The first intersection point between the two graphs is drawn. If the
graphs intersect in more than one place, all intersection points are
drawn.
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Labeling (identifying) the coordinates of a point
You can identify the coordinates of any analytic point using the
Coordinates and Equations tool.
Note: An analytic point is one created in the Graphing View, or within
the analytic window of the Plane Geometry View.
1. Create a point.
You can also create a point on an object using the Point On tool.
2. From the Actions menu, select Coordinates and Equations.
3. Move the pointer toward the point’s location. The coordinates
display.
4. Click to select the point. The point blinks to indicate selection.
5. Move to the place where you want to anchor the point coordinaties
and press ·.

If you move the point to a different location, the new coordinates are
updated to the new position.
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Naming a point
You can name points and vertices in either the Graphing or Plane
Geometry view. Because they are not tied to a specific coordinate, names
remain unchanged if you alter the location of any portion of an object.
1. Right-click the item to display its context menu, and select Label.
Handheld: Hover over the point, press / b, and select Label.
2. Type the name for the point in the text box.
(Optional) You can name a point as you create it by typing a letter or
name immediately after you define the point. For example, when
creating a triangle, type the letter “x” after creating the first vertex.
Type “y” and “z”for the remaining two vertices as you create them.

Redefining a point
You can redefine a point from a point on the work area to an object,
from one object to another, or from the analytic window to the Plane
Geometry View work area (or from the geometric work area to the
analytic window).
1. Create a point, or decide which existing point you want to redefine.

2. From the Actions menu, select the Redefine tool.
3. Click the point you want to redefine, then click the object or work
area at the location for the redefinition.
The point moves to the object or new location.
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Working with linear objects
The linear objects you can create and explore are located on the
Points & Lines menu. Graphs & Geometry creates “smart” lines and rays.
This means that only a portion of the line or ray is displayed. This feature
reduces clutter on the work area.

Creating a line
1. From the Points & Lines menu, select the Line tool.
2. Click a location to start the line.
This click defines one point on the line.
Note: If you press and hold g while creating the line, you limit its
orientation (relative to the x-axis or the horizontal aspect of the
screen), by 15- increments.
3. Move and click again to define the direction and second point of the
line.
Graphs & Geometry draws the line.

Creating a ray
1. From the Points & Lines menu, select the Ray tool.
2. Click to define the endpoint of the ray.
Note: If you press and hold g while while creating the ray, you
limit its orientation, relative to the x-axis or the horizontal aspect of
the screen, by 15- increments.
3. Move the pointer and click again to define the direction of the ray.
Graphs & Geometry draws the ray.
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Lengthening the visible part of a line or ray
1. On the Actions menu, select Pointer.
2. Grab the end of the visible line or ray, and drag to lengthen or
shorten it.

Creating a segment
1. From the Points & Lines menu, select Segment.
2. Click to define the first endpoint of the segment.
Note: If you press and hold g while creating the segment, you
limit its orientation (relative to the x-axis or the horizontal aspect of
the screen), by 15- increments.
3. Move the pointer and click again to define the second endpoint of
the segment.
Graphs & Geometry draws the segment on the page.

Creating a segment with a defined midpoint
With the Mid Point tool, you can define a midpoint on an existing line
segment, between two specified points on a line, or between two points
as you create the points. (When you select the second point, the
midpoint is created.)
1. From the Construction menu, select Mid Point.
2. Click at the location to start the segment.
As you move the pointer, a second point, the midpoint, appears.
3. You can move the segment in any direction until you click on the
work area a second time.
With the second click, the segment is anchored and the midpoint
remains identified.
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4. If you are defining the midpoint of a segment that already exists, click
the segment.
The midpoint is created.

Modifying segments with midpoints
1. On the Actions menu, select Pointer.
2. Select the segment and drag it to a new location without changing its
orientation or length, or select one endpoint and drag it to a new
location.
If just an endpoint is moved and if the length of the segment
changes, then the midpoint is repositioned to remain at the middle of
the segment.

Creating a parallel line
You can create a parallel line with respect to any existing line on the
work area including the axes, and the side of any triangle, square,
rectangle and polygon.
1. From the Construction menu, select Parallel.
2. On the work area, click once on an existing line, segment, or axis.
This click identifies the reference line for the new parallel line you are
creating.
3. Move the pointer away from the reference line, axis, or segment.

Parallel line following the pointer

Notice that a dotted line displays, representing the parallel line.
4. When the dotted line is in the desired position, click again to anchor
it on the work area.
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Anchored parallel line

Note: You can also click first on the work area and then select the
reference line to create the parallel line.

Creating a perpendicular line
You can create a perpendicular line with respect to any existing line or
segment in the work area including the axes, and the side of any
triangle, square, rectangle or polygon.
1. From the Construction menu, select the Perpendicular tool.
2. Click a point on the work area through which the perpendicular line
should pass. A dotted line shows the position for the perpendicular
line.

Perpendicular line before anchoring to
page

3. Click again to anchor the perpendicular line. The dotted line changes
to a solid line.
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Anchored perpendicular line

Note: Alternatively, you can double-click the line or segment to
create at the point where you want the perpendicular line to
intersect.
4. (Optional) On the Actions menu, select the Pointer for moving the
perpendicular line to a different location on the reference line.
5. (Optional) Click the intersection point and drag the point and
perpendicular line to the new location.

Creating a vector
1. From the Points & Lines menu, select the Vector tool.
2. On the work area, click the spot from which the vector originates.
3. Move the pointer in the direction of the vector.
A dotted line follows the pointer as you move about the area.

Vector following the pointer after identification
of the endpoint

4. When the vector is in the correct position, click to anchor the vector
on the work area.
The dotted line changes to a solid line.
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Moving a vector
1. From the Actions menu, select Pointer.
2. Click on any point other than the endpoint and drag the vector to the
desired location.

Resizing a vector
f Select an end point and drag it to increase or decrease the magnitude
of the vector.
Note: If the endpoint is located on an axis or another object, you can
only move the endpoint of the vector along that object.

Creating a tangent
You can create a tangent by identifying a specific point on an existing
object or function. To create a tangent line:
1. From the Points & Lines menu, select Tangent.
2. On the work area, select the point at which you want the tangent
drawn.
A dotted tangent line blinks on the work area.
3. Press · to anchor the tangent on the work area.

Tangent of an object

Creating and working with shapes
You can use the Shape tools to draw many different geometric shapes.
•

Circles

•

Triangles

•

Rectangles

•

Polygons

•

Regular Polygons
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When you use a shape tool, the pointer becomes a pencil. As you create
any shape that includes a linear portion (for example a ray, segment, or
triangle), you can enable custom alignment.
•

Align a linear portion of the shape to either the horizontal or the
vertical axis.

•

Press g to orient the linear portion of a shape in 15 degree
increments relative to the x axis.

For precise shape definition, you can type the coordinates of a shape’s
defining points in parentheses instead of clicking. For example, to create
a circle with a center point at (-1,4) type (-1,4) when prompted for the
center point.
Tool

Press · after these steps:

Circle

1. Click the work area to position the circle’s center point.
2. Move outward from the center point to size the circle.
A dotted circumference displays.

Triangle

1. On the work area, click once to establish the first
vertex of the triangle.
2. Move to the location for the second vertex and click
the work area a second time. The side of the triangle
displays as a dotted line.
3. Move to the location for the last vertex. As you move,
all sides of the triangle are shown as dotted lines.
4. Click the work area a third time to create the final
vertex and anchor the triangle on the work area. The
sides are defined by solid lines

Rectangle

1. Click once to establish the first corner of the rectangle.
2. Move to the location for the second corner, and click
again. One side of the rectangle displays.
3. Move away from the side of the rectangle. Move in the
direction that corresponds to the rectangle orientation
of your choice. The outline of the rectangle appears on
the work area.
4. When the rectangle is the correct size, click again to
anchor the rectangle to the work area.
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Tool

Press · after these steps:

Polygon

1. On the work area, click once to establish the first point
of the polygon.
2. Move the location for the second point and click the
work area a second time. The side of the polygon is
shown as a dotted line.
3. Move to the location of the next point. As you move
the pointer, the polygon’s sides display as dotted lines.
4. Continue to move and click the work area to create as
many sides as needed. After you press · to
complete the polygon, the sides display as solid lines.

Regular
Polygon

1. Click once on the work area to establish the center
point of the regular polygon.
2. Move the pointer away from the center point and click
on the work area again to establish the first vertex and
radius.
A 16-sided regular polygon is formed. The number of
sides displays near the center point in brackets; for
example, {16}.
–

To reduce the number of sides, select a vertex and
move the pointer in a clockwise motion around
the perimeter of the polygon.

–

To increase the number, select a vertex and move
the pointer in a counter-clockwise motion.

The number of sides of the polygon displays as you
move the pointer.
Circle arc

1. Click once on the work area to establish the first point
of the arc.
2. Move in the direction you want the arc to take and
click on the work area again to establish the second
point.
3. Move away from the second point to establish the
length of the circle arc and click on the work area a
third time. An arc displays.

Creating a shape
1. From the Shapes menu, select the tool for the shape you want to
draw.
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The pointer displays as a pencil to indicate that the Shape tool is
active. You can hover over the icon for the tool to view tips for
drawing a shape.
2. Move the pointer to the location of your choice on the work area.
A dotted line, shape, or partial shape displays to help you visualize
the completed shape.
3. Click once to establish the first point of the shape.
Note: You can press the keys to affect the sizing of some shapes as
you draw them. For example, if you press and hold g while
creating a circle, the radius is limited in length to integers.
4. Move the pointer away from the first point as required to position
the second point of the shape.
The direction and movement of the pointer can establish height,
orientation, or angles for a shape. A dimmed representation of the
shape or a partial shape displays to guide you.
5. Click the work area again to establish the second point or complete
the shape. You will need to move and position the pointer as many
times as required for the shape you are drawing.
You can move the pointer to the shape tool icon at the top of the
work area to read tips for creating a shape.
6. When all points or angles are in position, press · to complete the
shape.
You can perform actions to explore the shapes you draw. For
example, you can move a shape around the work area, resize it,
change its attributes, and pin it to the work area or an axis. You can
explore and analyze shapes using tools such as the measurement or
transformation tools.

Sizing and positioning shapes
1. From the Actions menu, select the Pointer.
2. Hover over a shape to change the pointer to ÷. You can click and
drag a circle’s perimeter to resize it, or click and drag a point to resize
a polygon, rectangle, or triangle.
3. Click and hold the selected area to change the pointer to { .
4. Drag to resize the selection.
5. Move a shape by grabbing and dragging the center point (circle) or a
side (triangle, rectangle, or polygon).
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Identifying equations for circles and lines
You can display the equation of any Analytic object (constructed in the
Graphing View, or within the Analytic Window of the Plane Geometry
View) and label it on the screen.
1. From the Actions menu, select Coordinates and Equations.
2. Click the circle or line to select it.
The equation for the circle or line displays and the object blinks on
the screen.
3. Press · to anchor the equation on the screen.

Note: If you approach a defined point on the line or the center point
of a circle, the coordinates for that point display instead of the
equation. Move the pointer away from the defined point to obtain
the equation of the object.

Measuring objects
You can obtain various measurements from the objects you draw. These
measurements include finding areas, lengths, angles, and slopes.
Measurement values are dynamic. If you measure sides and angles of a
triangle, for example, and then alter the triangle, the measurement
values update automatically.
To change the displayed precision of an area, length, angle, or slope
measurement, point to it and then press + or -.

Measuring length
You can use the Length tool to measure the length of a segment, circle
arc, or vector. The length tool can also measure the side or perimeter of a
polygon, the circumference of a circle, the distance between two points,
the distance from a point to a line, ray, segment, or vector, and the
distance from a point to a circle.
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Note: Measurements made on Graphing View objects and lines have
generic units, u. Measurements made on Plane Geometry View objects
and lines have the unit value you create. The default unit value is
centimeters (cm).

Measuring length of a segment, circle arc, or vector
1. From the Measurement menu, select the Length tool.
2. Click or press · to select the object. The target segment, circle arc,
or vector blinks.
3. Click or press · to anchor the measurement on the work area.
Note that a line segment can be part of a triangle, rectangle, or
polygon.

Measuring distance between two points, a point and a
line, or a point and a circle:
1. From the Measurement menu, select the Length tool.
2. Select the first point.
3. Select the second point or a point on the line or circle. The selected
length blinks.
4. Click or press · to anchor the value on the work area.
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In this example, length is measured
from the center of the circle to the
upper left vertex of the polygon.

Finding the circumference of a circle or the perimeter of a
polygon, rectangle or triangle
1. From the Measurement menu, select the Length tool.
2. Click the object to measure its circumference or perimeter.
3. Press · to anchor the measured value on the work area.

Measured circumference and perimeter

Measuring one side of a triangle, rectangle, or polygon:
1. From the Measurement menu, select the Length tool.
2. Point to the side that you want to measure.
Initially, the perimeter of the object displays, along with a visual
reminder that you can use e to measure the side instead.
3. Press e to display the length of the side, and click to attach it to the
pointer.
4. Position the measurement, and click or press · to anchor it on the
work area.
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Finding the area of a circle, polygon, rectangle, or triangle
1. From the Measurement menu, select Area.
2. Click the object to measure its area.
3. Press · to anchor the measured value on the work area.

Areas of a circle and a polygon

Finding the measure of an angle
1. From the Measurement menu, select Angle.
2. Click a point on one side of the angle to be measured.
3. Click the vertex of the angle you want to measure.
When you move the pointer, the measure of the angle displays near
the second point clicked.

4. Click on a point on the second side of the angle to be measured to
anchor the value on the work area.

Defining an angle with three points
You can define and measure an angle by selecting three points on the
work area.
1. From the Measurement menu, select the Angle tool.
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2. Click once on the work area and move to the next point. The first click
represents one side of the angle. As you move to the next point, a
dotted line shows the path used for angle measurement.
3. Click a second time on the work area. The second click represents the
vertex. As you move to the next point, Graphs & Geometry calculates
the measurement of the angle and displays it on the work area.
If you are defining an angle with a specific measurement, you can
change the path to adjust the angle size.
4. Click a third time on the work area, or press ·. The third click
represents the second side of the angle and anchors the three points.

The measurement remains visible and close to the angle even if you
change the size of the angle. If you alter the angle, the measurement
updates to reflect the new value.
Notes:
–

The value of any angle will always be between 0- and 180- in
degree mode or between 0- and p in radian mode.

–

The default angle measure is in radians for measurements within
Graphing View or an Analytic Window, and in degrees for
measurements within Plane Geometry View. To change it, change
the document settings.

Repositioning a measured value
1. From the Actions menu, select Pointer.
2. Select and drag the measurement to the desired location.

Finding the slope of a line, ray, segment, or vector
1. From the Measurement menu, select Slope.
2. On the work area, press · to select the object.
3. Press · to anchor the value on the work area.
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The slope remains visible and close to the object even if you alter the
slope. Note that the value changes as the object is moved.
Note: If the object is vertical, the slope value is -% or +%. If the object is
horizontal, the slope value is 0.

Transferring measurements
The Measurement Transfer tool lets you transfer a numeric value to an
object. The transferred value remains linked to the original value. If you
adjust the length of the initial measurement, all objects created with that
measurement are adjusted automatically to reflect the change.
The tool can use any measured value or numerical text entry as the value
to transfer.
You can transfer the value to:
•

An axis -This creates a point on the axis at a distance equal to the
transferred value.

•

A new circle - This creates a circle with a radius equal to the
transferred value. If you later delete the original value, the circle is
also deleted.

•

An existing circle - This defines an arc on the circle. You set the
starting point, and the transferred value is used to create the ending
point.

•

A ray or vector - This creates a second point on the ray or vector at the
transferred value, as measured from the object’s endpoint.
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Example: Transferring a numerical text entry to an axis
1. From the Actions menu, select Text, and then click to create a text
box on the work area.

2. Type the number that you want to transfer, and and press · to
anchor it.
3. Press d to exit the Text tool.
4. From the Construction menu, select Measurement Transfer.
5. Click the number to transfer, and then click the desired axis.
The value is marked by the addition of a point on the axis. In this
example, the point has been labeled to show its coordinates.

Example: Creating a circle using a transferred
measurement
1. Create a triangle from the Shapes menu, and then use the
Measurements menu to measure the length of one side. This length
will be used as the radius for a new circle.
2. From the Construction menu, select Measurement Transfer.
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3. Click the measured value that you created in step 1.
4. From the Shapes menu, select Circle.
A new circle is created with a radius equal to the transferred value.
5. Move the pointer to position the circle, and click to anchor it.

6. Press d to exit the tool, and then reshape the triangle to explore
the effect on the circle.

Example: Transferring a measurement onto a circle
1. Create a circle using the Circle tool on the Shapes menu.
2. Create a line segment using the Points menu, and use the
Measurements menu to create a measurement of its length. This
length will be used as the length of an arc on the circle.
3. From the Construction menu, select Measurement Transfer.
4. Click the measured value that you created in step 2.
5. Click the circle.
A point representing the start of the arc follows the pointer as you
move around the circle.
6. Position the starting point, and then click to anchor the arc.
The measurement is transferred in a counter-clockwise direction, and
the starting and ending points of the value are marked by points.
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7. Press d to exit the tool, and then move the end points of the
original line segment to explore the effect on the arc. You can also
move the arc by dragging its starting point.
Note: If you measure the distance between the two points on the
circle, the value will be less than the transferred measurement. This is
because you are measuring a straight line between the points, not
the arc formed between the points. The arc’s length is the transferred
measurement.

Using the Calculate tool
The Calculate tool enables you to perform arithmetic calculations using
measured and entered values. An example best shows how this tool is
used.
1. Create an object and display measurements for it. In this example, a
triangle is constructed and its angles are measured using the Angle
tool on the Measurements menu.

2. From the Actions menu, select Text.
3. Type the formula for the calculation. In this example, the formula
adds the measurements of the three angles.
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4. From the Actions menu, select Calculate tool.
5. Click the formula you created.
You are prompted to select a value for each term in the formula.
6. Click each angle measurement when prompted.
Note: If you have stored a measurement as a variable, you can select

it when prompted by clicking
. If the name of a stored
measurement matches a term in the formula, you can press “L” when
prompted for that term.
When all variables in the formula have values, the answer displays on
the work area.

7. Press · to anchor the result.

Transforming objects
You can apply transformations to drawn objects, and some can be
applied to functions. When working with functions, the axes are most
frequently involved and may be required. Object transformations can
occur without the use of axes as a reference point.
The transformations supported by Graphs & Geometry are:
•

Symmetry with respect to any point, including the origin

•

Reflections with respect to any straight line, including the axes
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•

Translations along any vector, including vectors on the axes

•

Rotations about any point, including the origin, and any angle

•

Enlargements from any point, including the origin, with any factor

The first step in any transformation is to create an object or the graph of
a function.

Exploring symmetry
1. Create an object.
2. From the Points & Lines menu, select Point.
3. Click the work area to create the point of symmetry.
4. From the Transformation menu, select Symmetry.
5. Select the object, then select the point.
The symmetrical image displays.

Exploring reflection
1. Create an object.
2. Create a line or segment about which the object will be reflected.
3. From the Transformation menu, select Reflection.
4. On the work area, select the reflection line or segment.
5. Select the object.
The object reflection displays.
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6. To anchor the reflection, click on the page, or press ·.

Exploring translation
1. Create an object to translate (duplicate).
2. (Optional) Create a vector to indicate the distance and direction of
translation.
3. From the Transformation menu, select Translate.
4. Indicate the distance and the direction of translation by performing
one of the following actions.
–

Click the vector, or

–

Click the work area to indicate the distance between the object
and the translation object, then click a second time to indicate the
direction of translation.

5. Click the translation object. The translated object displays.
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Exploring rotation
1. Create the shape or graph the function to rotate.
2. (Optional) You can optionally create the point to rotate around and
the angle for specifying the angle of the rotation.
3. From the Transformations menu, select Rotation.
4. If you defined the point of rotation and angle of rotation before
activating the tool, start the rotation by clicking the object first,
clicking the point of rotation next, and clicking the angle of rotation
last.
Or,
With the Rotation tool active and no pre-defined point and angle,
specify the point to rotate around and the angle of rotation.
a) Type the opening parenthesis and type the x and y coordinates of
the point to rotate the object around and press ·.
b) Type the measurement to use for the angle of rotation and
press ·.

The object is recreated in the rotated position as defined by the
rotation point and angle of rotation.

Exploring Enlargement
1. Create an object to enlarge by dilation.
2. Create a point that is the center for the Enlargement.
3. From the Actions menu, select Text and type a value to establish the
size of the Enlargement. You can also measure an existing length to
establish the sizing for the Enlargement.
Note: If you specify a large sizing value, you may have to use the
Zoom tools or pan the display to view the enlarged object.
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4. Press · to anchor the sizing value on the work area.
5. From the Transformation menu, select Enlargement.
6. Click the object, the center point, and the sizing value before moving
toward the object.
Note: You can also specify center point coordinates and the sizing
value of the Enlargement by typing the numbers after an opening
parenthesis.

The Enlargement appears on the work area.

Performing other investigations
You can investigate other scenarios by bisecting segments, lines, and
angles, or by creating a Locus.
•

Bisecting a segment

•

Bisecting an angle

•

Finding the Locus

Bisecting a segment
1. From the Construction menu, select Perpendicular Bisector.
2. Click the segment.
The perpendicular bisector displays.
Note: If the segment is not already present on the work area, you can
create one by selecting two different points.

302

Graphs & Geometry

Bisecting an existing segment (bisector not
anchored on page)

3. Click once more to anchor the bisector on the work area.
Note: A segment can be one side of a triangle, rectangle, or a
polygon.

Bisecting an angle
1. From the Construction menu, select Angle Bisector.
Note: If no angle is present on the work area, you can create one by
selecting three different points.
2. Click to define the first side of the angle.
3. Click to define the vertex of the angle.
4. Click to define the second side of the angle.
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Creating an angle bisector by defining three
points. The second point represents the vertex of
the angle.

The bisector line appears and is anchored on the work area when you
select the third point.
Note: If you select the Pointer tool and move one point of the
created angle, the angle bisector moves so that it always bisects the
angle.

Creating a locus
The Locus tool enables you to explore the range of motion of one object
with respect to another object as constrained by a shared point.
1. Create a segment, line, or circle.
2. Create a point on the segment, line or circle.
Point defined on the line segment.

3. Create another object that uses the defined point created in the
previous step.
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Circle created to use the
defined point on the segment.

4. From the Construction menu, select the Locus tool.
5. On the work area, select the object defined to share the point (this is
the object to vary).
6. Select the point shared by the objects (this is the object to constrain).
The continuous locus displays.

7. Move the point on the first construction.
The second construction deforms to follow the locus point.
Two examples of the radius
change of the circle as the locus
moves along the line segment.
The radius is labeled to better
show the change.

Graphs & Geometry

305

You can create and explore other designs using the Locus tool.

Locus created using a point and a segment.

Animating points
You can animate a point on a line, ray, axis, vector, graph, segment or
circle. In addition, you can also animate points on multiple objects in the
work area at one time.

Animating a point on an object
1. From the Points & Lines menu, select Point On.
2. Click the object to create the point on, and then click the location for
the point.
3. From the Actions menu, select Attributes. The Attributes tool
displays.
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4. Press £ or ¤ to move to the animation attribute and press ¡ or ¢ to
move to either the unidirectional or alternating animation speed
attribute.
5. Type a number from 1 - 9 to set the speed. The default speed is 0.
The higher the number you type, the faster the animation speed.

6. Animation begins automatically when you select the speed and
direction.
Press + and - on the computer keyboard or handheld to
increase/decrease the speed of ongoing animation incrementally.

The animation control panel
Once a point is animated, a floating control panel displays on the page.
You can move this panel by dragging it to a new location.
When animation is active, the panel contains a Reset
Pause

and a

button. When either button is pressed and animation is reset

or paused, the Pause button changes to a Start
controls affect all animated points on a page.

button. These

Panel when animation is active

Panel with animation paused/reset
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Changing the animation of a point in motion
To change the speed of a point’s movement or the direction of
animation:
1. Reset or pause the animation.
a) Select the Attributes tool.
b) Select the point you want to change.
c) When the list of attributes displays, select an animation attribute.
2. To change the speed, type a new number.
3. To change the direction of animation, press 78.
4. Press the Start

button.

The point moves at the new speed and/or in the new direction you
selected.

Pausing and resuming animation
1. To pause the animation on a page, click the Pause
2. To restart animation, click the Start

button.

button.

Resetting animation
Selecting the Reset button
not only pauses animation but also
returns the animated point to its initial coordinate position on the object
when animation was first started. If multiple points are animated on the
page, all are returned to their original locations when you select Reset.

Stopping animation
To stop the animation of an object:
1. Select the Pause

or Reset

button on the control bar.

2. Display the Animation attribute for the point.
3. Change the speed to 0 (zero).
4. Click an empty area of the screen to apply the change, or press ·.
5. Select Start to resume animation if other animated points were
temporarily stopped.
If no other animated points are on the page, the animation control
box does not reappear when the velocity is set to 0.
Note: If you have multiple points in motion on one page and want to
permanently stop the animation of all objects, when motion is
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paused or stopped, display the list of attributes for each point and
change the velocity to 0.

Graphing 3D functions
The 3D Graphing view lets you enter functions of the form z(x,y) and
view and explore them in three-dimensional space.
While you are in the 3D Graphing view, you can define, rotate, resize,
and trace 3D graphs. You can set the colors and other visual attributes of
a selected graph, and you can customize the 3D viewing environment.

Á
À

Â

Ä

Ã
À

3D Graphing menu. This menu is specific to 3D Graphing and is
accessible from the Graphs & Geometry View menu.

Á

Icon of the current 3D tool (Rotation tool in this example). Press d
to close the tool and return to the Pointer tool.

Â
Ã
Ä

Sample 3D graph
Entry line with expression that defines the graph
Legend displaying orientation of the axes

Defining a 3D graph
Each 3D graphing page can show multiple graphs.
1. From the View menu, select 3D Graphing.
2. If the entry line is hidden, click the Show Entry Line button

.

3. Type the expression that defines the graph.
4. Press · to draw the graph.

Displaying the context menu of a 3D graph
Some 3D graphing features are accessible only through context menus.
Graphs & Geometry
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1. If necessary, press d to return to the Pointer tool.
2. Point to the graph to select it.
The selected graph displays in gray.
3. Use the applicable method to display the context menu.
–

Handheld: Press / b.

–

Windows®: Right-click.

–

Macintosh®: Hold “ and click.

Editing a 3D graph
1. Display the graph’s context menu, and then select Edit Relation.
- or Click the Show Entry Line button
arrows to display the expression.

, and then use the up/down

2. Modify the existing expression, or type a new expression in the entry
line.
3. Press ·.

Setting the appearance of a 3D graph
To set wire and surface color:
1. Display the graph’s context menu, select Color, and then select
Line Color or Fill Color.
2. Click a color swatch to apply it.

To set custom plot colors:
Custom plot colors can make it easier to see the shape characteristics of
the graph. You can assign different colors to its top and bottom surfaces
or choose to have the graph colored automatically, based on height or
steepness. You can also set the wire color.
1. Display the graph’s context menu, and then select Color >
Custom Plot Color.
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2. Select one of the three Surface color options: Top/bottom color, Vary
color by height, or Vary color by steepness.
–

If you choose Top/bottom color, click the color swatches to select
colors for the top and bottom surfaces.

–

If you choose to vary color by height or steepness, colors are
determined automatically.

3. To set the Wire color, click the color swatch and select a color.

To set other attributes of a graph:
1. Display the graph’s context menu, and then select Attributes. You
can set the following attributes for the selected graph.
–

format: surface+wire, surface only, or wire only

–

x resolution (enter a value in range 2-200*, default=21)

–

y resolution (enter a value in range 2-200*, default=21)

–

transparency (enter a value in range 0-100, default=30)

–

shading (controls highlights, enter a value in range 0-100,
default=50)

* Handhelds are limited to a maximum display resolution of 21,
regardless of the value entered.
2. Set the attributes as you like. If necessary, refer to “Changing an
attribute of an object” in this chapter.
3. Press · to accept the changes.
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Showing and hiding 3D graphs
To hide a 3D graph:
f Display the graph’s context menu, and then select Hide.

To show a hidden 3D graph:
1. From the Actions menu, select Hide/Show.
The Hide/Show icon

appears and all hidden graphs show in gray.

2. Click a graph to change its hide/show state.
3. To return to the Pointer tool, press d.

Customizing the 3D viewing environment
To set the background color:
f Display the context menu for the work area, and then select
Background Color.

To show or hide specific view elements:
f From the View menu, select the item to show or hide. You can choose
items such as the 3D box, axes, box end values, and legend.

To set the visual attributes of the box and axes:
1. Display the context menu for the box, and then select Attributes. You
can set the following attributes.
–

show or hide tic labels

–

show or hide end values

–

show or hide arrows on axes

–

show 3D or 2D arrow heads

2. Set the attributes as you like. If necessary, refer to “Changing an
attribute of an object” in this chapter.
3. Press · to accept the changes.

To shrink or magnify the 3D view:
f From the Range/Zoom menu, select Shrink Box or Magnify Box.

To change the Range settings
f On the Range/Zoom menu, select Range Settings. You can set the
following parameters.
–
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XMin (default=-5)
XMax (default=5)
XScale (default=Auto) You can enter a numeric value.
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–

YMin (default=-5)
YMax (default=5)
YScale (default=Auto) You can enter a numeric value.

–

ZMin (default=-5)
ZMax (default=5)
ZScale (default=Auto) You can enter a numeric value.

–

eye q¡ (default=35)
eye f¡ (default=160)
eye distance (default=11)

Rotating the 3D view
To rotate manually:
1. Press R to activate the Rotation tool (required only for the TI-Inspire™
handheld with Clickpad).
2. Press any of the four arrow keys to rotate the graph.

To rotate automatically:
Auto rotation is equivalent to holding down the right arrow key.
1. From the Actions menu, select Auto Rotation.
The Auto Rotation icon

appears, and the graph rotates.

2. (Optional) Use the up and down arrow keys to explore the rotating
graph.
3. To stop the rotation and return to the Pointer tool, press d.

To view from specific orientations:
1. If necessary, press d to return to the Pointer tool.
2. Use letter keys to select the orientation:
–

Press Z, Y, or X to view along the z, y, or x axis.

–

Press letter O to view from the default orientation.

Tracing in the 3D view
To start tracing:
1. From the Trace menu, select z Trace.
The z Trace icon
and the trace plane appear, along with a text line
showing the current "z=" trace value.
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2. To move the trace, hold down Shift and press the up or down arrow
key.
The "z=" text is updated as you move.

3. (Optional) Use the four arrow keys to rotate the view and see how
the trace plane and the graph intersect.
4. To stop tracing and return to the Pointer tool, press d.

To change the trace settings:
1. From the Trace menu, select Trace Setup.

2. Enter or select the settings, and click OK to apply them.
3. If you are not already tracing, your new settings take effect the next
time you trace.

Animating a 3D graph with a slider
1. Insert a new problem and select the 3D Graphing view.
2. From the Actions menu, select Insert Slider, click to position it, and
type time as the variable name.
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3. Display the slider’s context menu, select Settings, and enter the
following values.
Value: 3.8
Minimum: 3.2
Maximum: 4.4
Step Size: 0.1
4. In the entry line, define the function shown here:

5. Drag the slider thumb to see the effect of varying time.

6. Add visual interest. For example, try:
–

Rotating the graph.

–

Hiding the box, axes, and legend.

–

Setting the graph’s format attribute to show the surface only.

–

Changing the graph’s transparency and shading attributes.

–

Changing the background color and graph fill color.
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7. To animate the graph, display the slider’s context menu, and select
Animate. (To stop, select Stop Animate from the context menu.)
You can combine manual or auto rotation with the slider animation.
Experiment with the x and y resolution to balance curve definition
against animation smoothness.
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Using Lists & Spreadsheet
Getting started with tabular data
The Lists & Spreadsheet application gives you a place to work with
tabular data.
•

Store numeric data, text, or math expressions.

•

Define a table cell in terms of the contents of other cells.

•

Define an entire column based on the contents of another column.

•

Share columns of data as list variables with other TI-Nspire™ math
and science learning technology applications. Also share individual
cells as variables.

•

Work with variables created in the Graphs & Geometry and Calculator
applications.

•

Collect tables of real-world data from sensors.

•

Generate columns of data based sequences that you define.

•

Plot table data using the Data & Statistics application.

•

Generate a table of values for a function.

•

Copy and paste table data from the Lists & Spreadsheet application to
other computer applications, such as TI Connect™ software and
Excel® spreadsheet software.

•

Perform statistical analysis on lists of data.
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The menu and work area
À

Á

Â

Ã

Ä
À

Lists & Spreadsheet menus (available when a Lists & Spreadsheet work
area is active).

Á
Â

Sample Lists & Spreadsheet work area

Ã
Ä

Lists & Spreadsheet data plotted in the Data & Statistics application

Click horizontal and vertical scroll bars to view more rows and
columns

Entry line

Lists & Spreadsheet menu
Actions

Move Column

Lets you reposition the current column.

Resize

For a selected column, lets you set the
width to maximum, minimum, or a
custom width.
For a selected row, lets you set a custom
row height.

Select
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Selects an entire row or column, or helps
you insert a range of cells into a cell
formula.

Actions

Go To

Jumps to the specified cell, such as d16
or g20.

Recalculate

Recalculates results of all cell formulas
and generates new results for random
functions such as rand(), randInt(), and
randSamp().

Sort

Lets you sort the selected columns of the
spreadsheet based on the contents of a
single column.

Insert
Insert Cell

Inserts a cell.

Insert Row

Inserts a row above the current row.

Insert Column

Inserts a column before the current
column.

Data
Generate Sequence

Displays a dialog box for creating a
sequence.

Data Capture

Allows manual or automatic capture of
variable data from the Graphs &
Geometry, Calculator, or Data &
Statistics applications, or within the
Lists & Spreadsheet application. Press
/ ^ (period ).
Macintosh®: “+ . (period).

Fill

Lets you repeat the contents of a
selected cell or range of cells
horizontally or vertically.
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Data
Clear Data

Removes data from the selected
column or columns. Does not clear list
names or column formulas. After the
data has been cleared, column
formulas are recalculated in the
selected columns.

Summary Plot

Uses the Data & Statistics application
to graph summary data from one
X or Y List and one Summary List.
Categorical data is plotted as a bar
chart, and numeric data is plotted as a
histogram.

Quick Graph

Uses the Data & Statistics application
to graph one or two selected columns
of data as a dot plot, dot chart, or
scatter plot.

Statistics

Stat Calculations

Lets you select from several statistics
calculations, such as one-variable
analysis, two-variable analysis, and
regressions.

Distributions

Lets you calculate and plot several
distributions, such as Normal Pdf,
Binomial Cdf, and Inverse F.

Confidence Intervals

Lets you calculate several confidence
intervals, such as t interval and
z interval.

Stats Tests

Lets you perform and plot several
hypothesis tests such as t test, z test,
and ANOVA.

Table

Switch to Table/Switch to
Lists & Spreadsheet
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Toggles the table view when you press
/ T. (Macintosh®: “+T.)

Table

Delete Column

Removes the current column.

Choose

Lets you select an available function
for displaying in the current column.

Edit Expression

Lets you change the expression
associated with the table of values
without leaving the table.

Edit Table Settings

Lets you change the viewing
parameters for the table.

The Parts of a Spreadsheet
A spreadsheet includes a column letter at the top of each column and a
row number on the left of each row. The top two rows and the row
numbers remain in place as you scroll. You can name a column of data to
make it available as a list variable in TI-Nspire™ applications.

ÀÁÂ

Æ

Ã
Å
Ç

Ä
À
Á
Â
Ã
Ä
Å

Column reference letter

Æ
Ç

Naming zone (first tab stop - column names and formulas)

Column name cell for defining a column as a list variable
Column formula cell for generating a column of data
Row reference number
Entry line (includes cell reference for current cell)
Cells - Any empty (void) element in a list displays as an underscore
(“_”). Any value that cannot fit in a cell’s width is truncated. Hover
over the cell to display the complete value.

Data zone (second tab stop - body cells)
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Navigating in a spreadsheet
You can select any cell to view or edit its contents. When a spreadsheet is
larger than the Lists & Spreadsheet work area, you can move to different
parts of the spreadsheet by using the e key and by pressing shortcut
keys.
•

Press e to move between the body of the spreadsheet (data zone)
and the column names and formulas (naming zone).

•

Press ¡, ¢, £, and ¤ to move through the spreadsheet one cell at a
time (move between cells within a zone). The arrow keys move the
cursor from cell to cell and scroll as necessary to keep the selected cell
in view.

•

Move across several cells at a time by pressing Page up, Page Dn,
Home, and End.
Handheld: Press / 9 (Page up), / 3 (Page Dn), / 7

(Home), and / 1 (End) keys.
•

Use the Go To command on the Actions menu to select a specific cell.
Type the cell’s column letter and row number (such as G16).

•

Press · to put the selected cell in Edit mode.

•

Drag the scroll bar to move vertically without changing the cell or
block of cells selected.

Creating and sharing spreadsheet data as lists
You can define a column as a named list of elements of the same type of
data. After defining a list, you can link to it from the Graphs & Geometry,
Calculator, or Data & Statistics applications, and from other instances of
the Lists & Spreadsheet application within the current problem.
Note: Lists & Spreadsheet can display a maximum of 2500 elements in a
list.

Sharing a spreadsheet column as a list variable
You share a column of data by naming it as a list variable.
Note: Avoid defining variables that use the same names as those used
for statistical analysis. In some cases, an error condition could occur.
Variable names used for statistical analysis are listed in the TI-Nspire™
Reference Guide, under the stat.results entry.
1. Move to the column’s name cell (the top cell of the column) by
clicking the cell or pressing £ as necessary.
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2. Type a name for the list variable, and press ·.
The column is now available as a list variable to other TI-Nspire™
applications.
3. Create elements in the list the same as you would create data in
spreadsheet cells. For example, you can type the data into each cell or
use a formula to generate a column of data.
Notes:
•

If a variable with the name you specified already exists in the current
problem, Lists & Spreadsheet displays an error message.

•

When you select the column formula cell of a list, it displays the list
name in an expression similar to width:=.

•

Lists can contain empty elements (denoted by “_”) .

•

You can refer to a specific element in a named list from the Calculator
application. Use the list name and the element’s position within the
list. In a list named Heights, for example, refer to the first element as
Heights[1]. The expression Heights[2] refers to the second element,
and so on.

Linking to an existing list variable
Linking a column to an existing list variable lets you easily view and edit
the values in the list. The list can be any shared list in the current problem
and can be defined in Graphs & Geometry, Calculator, or any instance of
Lists & Spreadsheet.
After you link a column to a list, Lists & Spreadsheet automatically shows
any changes that you make to the list with other TI-Nspire™ applications.
1. Click the column formula cell (the second cell from the top) of the
column that you want to link to the variable.
2. Type the name of the list variable you want to link to.
- or Click
on the toolbar (press h on the handheld), click Link To,
and select the variable you want to link to.
3. Press ·.
The column shows the list elements.
Notes:
•

You cannot link to the same variable multiple times on the same
page.
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•

Use caution if you link to a system variable. Doing so could prevent
the variable from being updated by the system. System variables
include ans and statistics results (such as stat.results, stat.RegEqn, and
stat.Resid).

Inserting an element in a list
When you insert an element in a list, the remaining elements shift
downward to create space. No other columns are affected.
f From the Insert menu, select Insert Cell.

Deleting an element from a list
When you delete an element, the remaining list elements shift upward to
close the gap. The upward shift affects only the selected column.
1. Select the cell of the element to delete.
2. Display the context menu for the cell, and select Delete Cell.
Note: If you press . or Backspace to clear the contents of the cell
instead of deleting the list element, the element is assigned a value of
0 (zero). The remaining list elements do not shift.

Creating spreadsheet data
You can enter numeric values, text, or formulas into body cells. Column
formula cells can contain formulas only. (Column formulas are discussed
under Generating columns of data.)
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Data examples
Entry

Remarks

1.234

Simple numeric entry

“Green”

Text - Enclose categorical data (such as the names of
colors used in a study) within quotes to distinguish
them from variable names. On the Handheld, press
/ r to enter quoted data.

=a3*length

Formula - Consists of an “=” symbol followed by an
expression.
You can type the expression or use the Catalog and
expression templates to build it. For details, see the
Calculator section.
To ensure a decimal result instead of a fraction,
type one of the integers in the expression as a
decimal. For example, type 1.0 instead of 1.

Typing a math expression, text, or spreadsheet formula
1. Double-click the cell to select it and put it in edit mode.
Note: If the cell is already selected, you can press · or click the
entry line.
2. Type the expression, text, or formula. Be sure to enclose text entries in
quotes and start formula entries with an “=” symbol.
As you enter the data, it appears in the cell and on the entry line
simultaneously.
3. Press · to complete the entry and move down to the next cell.
– or –
Press e to complete the entry and move right to the next cell.
The Lists & Spreadsheet application automatically recalculates any
cells that are dependent on the cell you entered. If you have shared
the cell, and other TI-Nspire™ applications are linked to the cell, the
other applications are also updated.
Note: Empty cells in a spreadsheet display as a void represented by an
underscore (_). The underscore is automatically added to empty cells
when a list is named or when an empty cell is referenced in a formula.
When you plan to perform calculations on a range of cells, be sure to
notice the location of void cells. Cells without a value can affect
calculations. For example, if you include a void cell in the range for a
sum such as “=b2+c2,” the result of the calculation is void (_).
Using Lists & Spreadsheet

325

Inserting a cell range into a formula
The Select Range feature lets you insert a cell range (such as a1:b3) into a
formula by selecting the range instead of typing cell addresses into an
argument.
Suppose you want to calculate the mean of a range of cells.
1. Type “=mean(“ in the cell that will contain the result.

2. From the Actions menu, choose Select > Select Range.
A dotted selection rectangle appears around the cell that contains
the formula.
3. Select the range of values for which you want to calculate the mean.
Move to the first cell in the range, then hold g while pressing the
arrow keys.
The dotted selection rectangle moves to enclose the cells you specify
for the range. The formula is updated as you select.

4. Press · to complete the formula, evaluate the formula, and
display the result.
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Working with cells
Working with color
The Lists & Spreadsheet application displays black text and cells with a
white background by default. You can change the color of cells and text
to emphasize or distinguish data. The colors and the order in which color
is assigned is based on the TI-Nspire™ color palette. See Changing the
color of cells and Changing the color of text for more details.
Color changes made in the software display in shades of gray when you
work on documents on the TI-Nspire™ handheld. Color is preserved
when you move documents back to the software.

Changing the fill color of cells
1. Select the cells to fill with color. You can choose one or more cells in
any adjacent cells, columns, or rows.
2. Access the context menu and choose Color > Fill Color.
3. Select the color to apply to the cells. The color of the selected cells
changes.
Note: If you combine color text and color cells, choose colors carefully to
ensure visibility as you work with documents in the software and on the
handheld.

Changing the color of text
1. Select the cells that contain the text to change. You can choose one or
more cells in any adjacent cells, columns, or rows.
2. Access the context menu and choose Color > Text Color.
3. Select the color to apply to the text. Empty cells in the selection area
will show the color change when text is added.

Understanding cell references in formulas
Use a cell reference to use data from a cell or range of cells in a formula.
The calculation results update automatically when values in cells change.
Relative references include only the cell’s column letter and row number
(for example, E7). A relative reference describes where a cell is in relation
to other cells of the spreadsheet. The Lists & Spreadsheet application
keeps track of relative cell references and adjusts the reference
automatically when surrounding cells shift (because of actions you
perform, such as column deletions or cell insertions).
Follow these guidelines to specify cell references:
•

Include a column letter and row number in a relative reference.
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•

Include the $ symbol before both the column letter and the row
number to specify an absolute reference.

•

Include a colon (:) between a two cell references to specify a range of
cells.

Absolute references include the $ symbol before the column letter and
before the row number (for example, $B$16). Absolute references always
refer to the cell in a specific position in the spreadsheet. The application
does not automatically adjust the cell reference when cell positions
change.

Typing a cell reference in a formula
1. Double-click the cell and type the formula. See the Calculator section
for details about inserting symbols and operators from the Catalog.
2. Move to the appropriate position in the formula and type the cell
reference. Use the format for a relative reference (B3), absolute
reference ($B$2), or range of cells (A1:A4).
Note: You can select Recalculate from the Actions menu to update

all references and formula results in a spreadsheet.

Deleting the contents of cells
1. Click a cell to select it, or use the arrow keys to move to the cell.
Note: If you are deleting a range of cells, select a cell at one end or
corner of the range and then use g with the arrow keys to select
the remaining cells in the range.
2. Press ..
Note: Any cell that uses a formula with an absolute reference to
deleted data will show an error. A cell that uses a formula with a
relative reference to deleted data is updated to use the data currently
in the referenced position.

Copying cells
When you copy cells, any formulas in the original cells are copied to the
destination cells.
1. Select the cell to copy by clicking it, or use the arrow keys to move to
the cell.
Note: If you are copying a range of cells, select a cell at one end or
corner of the range and then use g with the arrow keys to select
the remaining cells in the range.
2. Copy the selected cells by pressing / C (Macintosh®: “+C).
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3. Select the cell where you want to duplicate the copied cell. If you are
copying a block of data, select the cell that will become the upper left
corner of the copied block.
4. Paste the selected cells by pressing / V (Macintosh®: “+V).
Important: Paste copied data into a cell that is in the same mode as
the cell from which the data was originally copied. Otherwise, a
formula could paste as a string enclosed in quotes instead of a
formula.

Filling adjacent cells
You can repeat a cell’s formula or value throughout adjacent cells within
the row or column. You can also repeat a range of cells horizontally or
vertically. If you fill from a range that contains a simple sequence (such as
2, 4, 6), the sequence continues in the filled cells.
1. Select the cell that contains the value or formula to repeat.
Note: If you are repeating a range of cells, drag to select the range,
or select a cell at one end of the range and then use g with the
arrow keys to select the remaining cells.
2. From the Data menu, select Fill.
3. Use the arrow keys or drag to select the range that will hold the
repetitions.
4. Press ·.
The value, formula, or pattern that you selected for duplication is
repeated over the selected range.

Sharing a cell value as a variable
You can share the value of a cell with other TI-Nspire™ applications by
storing it as a variable. When you define or refer to a shared cell or
variable in Lists & Spreadsheet, the name is preceded with an
apostrophe (‘).
1. Select the cell that you want to share.
2. Click

on the toolbar, and click Store Var to store the cell’s value.

Handheld: Press / h (or press h and select Store Var).
A formula is inserted into the cell with var as a placeholder for a
variable name.
3. Type over the letters “var” with a name for the variable, and press
·. Use a variable name that does not exist in the current problem.
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The value is shown in bold to indicate that it is now available as a
variable to other TI-Nspire™ applications.

Linking a cell to a variable
When you link a cell to a variable, Lists & Spreadsheet keeps the cell
value updated to reflect the current value of the variable. The variable
can be any variable in the current problem and can be defined in
Graphs & Geometry, Calculator, Data & Statistics, or any instance of
Lists & Spreadsheet.
1. Select the cell that you want to link to a variable.
2. Click

on the toolbar, and click Link to.

Handheld: Press / h (or press h and select Link to).
The VarLink menu displays.
3. Under Link To, press £, and ¤ to scroll to the name of the variable.
4. Press ·.
The cell shows the value of the variable.
Note: Use caution if you link to a system variable. Linking could prevent
the variable from being updated by the system. System variables include
statistics results (such as Stat.RegEqn, Stat.dfError, and Stat.Resid) and
finance-solver variables (such as tvm.n, tvm.pmt, and tvm.fv).

Working with rows and columns of data
Selecting a row or column
f To select a row, move to the top of the column and click the column
reference letter. To select a row, move to the leftmost cell of the row
and click the row reference number. Press d to cancel the selection.
Handheld: Hold down £ to move past the top cell, or hold down ¡
to move past the leftmost cell.
f To extend a selection to adjacent rows or columns, hold down g
and press ¡, ¢, £, or ¤.

Resizing a row or column
1. Select the row or column that you want to resize.
2. From the Actions menu, select Resize then select an option.
3. Choose a resizing option for a column or row.
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–

For a column, choose Resize Column Width, Maximize Column
Width, or Minimize Column Width.

–

For a row, you can choose Resize Row Height.

The tools that minimize and maximize the column width work
automatically. You must manually adjust the size to use the Resize
Column Width and Resize Row Height tools.
4. To resize manually, use ¡ and ¢ to resize the column, or use £ and ¤
to resize the row, and then press ·.

Inserting an empty row or column
1. Select a column or row where you want to insert the new data.
2. From the Insert menu, select either Row or Column.
–

If you are inserting a row, the remaining rows shift down to create
space for the new row.

–

If you are inserting a column, the remaining columns shift right to
create space.

Note: If other cells contain formulas with relative references to a
displaced row or column, those references adjust accordingly.

Deleting entire rows or columns
You can delete a row, column, group of rows, or group of columns. When
you delete a row or column, the remaining rows or columns move up or
left to fill the gap.
1. Select the column or row that you want to delete.
2. (Optional) To select adjacent rows or columns to delete, hold down
g and press ¡, ¢, £, or ¤.
3. Press ..
The selected rows or columns are deleted.
Note: If other cells contain formulas that refer to the deleted row or
column, those cells show an error. Relative references to cells whose
positions have changed because of a deletion adjust accordingly.

Copying rows or columns
1. Select the column or row that you want to copy.
You can click the column letter to copy a column, or click the row
number to copy a row.
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2. (Optional) To select adjacent rows or columns to copy, hold down
g and press ¡, ¢, £, or ¤.
3. Copy the column or row by pressing / C (Macintosh®: “+C).
4. Move to any cell in the row or column where you want to place the
copied items.
5. Paste the selected column or row by pressing / V
(Macintosh®: “+V.).
The copied row or column is pasted in place, replacing the previous
contents.
Note: If you copy a named column, it is pasted with the name
removed to prevent a variable conflict.

Moving a column
1. Select the column that you want to move.
2. From the Actions menu, select Move Column.
An insertion bar appears.
3. Press ¡ or ¢ to place the insertion bar at the column’s new position,
and then press ·.
Note: Relative references to any cell in a position is affected by the
move adjust accordingly.

Clearing column data
The Clear Data command lets you remove the data from selected
columns. Clear Data does not delete the column, and it does not clear a
column’s name or formula.
After clearing the data, Lists & Spreadsheet recalculates column formulas
for the selected columns. This makes Clear Data useful for capturing a
fresh set of data from another application or selectively generating a
fresh column of random numbers.
1. Select the column or columns that you want to clear.
2. From the Data menu, select Clear Data.
Note: If a recalculated formula produces the same data as before, it
may appear that the Clear Data command has failed.
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Sorting data
You can sort a selected area of the spreadsheet in ascending or
descending order. You select which column in the selected area will be
used as the key for the sort. When the sort moves data up or down in the
key column, the corresponding data in the other selected columns is also
moved up or down. This preserves the integrity of each row.
Note: Sorting is based on numeric values. If you select a key column that
contains text, you could get unexpected results.
1. Select the range of cells.

2. From the Actions menu, select Sort.
The Sort dialog box displays.
3. Select the column letter to use for ordering.
4. Select Descending or Ascending as the sort method, and then select
OK.

Note: Sorting a column that is defined by a formula will remove the
fomula, because it may not be valid after the sort.

Generating columns of data
You can create a column of values based on the contents of another
column. You can also create a column based on any of several types of
sequential data.
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Entering a formula in a column’s formula cell tells the Lists & Spreadsheet
application that you want to apply the formula to all cells in the column,
not just to a single cell.

À

À
Á
Â

Á

Â

Column formula based on a variable
Column formula based on another column
Column formula that generates a sequence

Notes:
•

If you generate data in a column that already contains one or more
cell values, Lists & Spreadsheet asks for confirmation before replacing
the existing values. Proceeding removes all of the existing values in
the column.

•

If you edit a cell manually in a column of generated data,
Lists & Spreadsheet asks for confirmation before replacing the
generated data. Proceeding removes the generated data for the
entire column.

Creating column values based on another column
1. Click the column formula cell (the second cell from the top) of the
column where you want to use a formula.
Lists & Spreadsheet inserts the leading equal sign (=) for the formula.
If the column is a named list, Lists & Spreadsheet inserts listname:=
followed by the cursor.
2. Type the expression for the formula after the = and press ·. Use
brackets ([]) after any column letter you include in the formula. For
example, type =a[]^2 to create a column of values in which each cell
is the square of the corresponding cell of column A.
Lists & Spreadsheet shows the formula in the formula cell and fills the
column with the results.
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Generating a column of random numbers
1. Click the column formula cell (the second cell from the top) of the
column.
Lists & Spreadsheet inserts the leading equal sign (=) for the formula.
If the column is a named list, Lists & Spreadsheet inserts listname:=
followed by the cursor.
2. Type the expression for generating the random numbers. You can use
the Catalog to insert an expression instead of typing characters.
RandInt(1,6,20)

This example places 20 random integers in the column.
3. Press · to generate the numbers.
4. To generate (Recalculate) a new set of random numbers, press / R
(Macintosh®: “+R).

Generating a numerical sequence
1. Select any cell in the column in which you want to generate the
sequence.
2. From the Data menu, select Generate Sequence.
The Sequence dialog displays.
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3. Type the Formula that will be applied to the column values.
4. Type any starting numbers required by the sequence in the Initial
Terms field and separate them with commas.
5. Type a starting value for the independent variable (n0).
6. Type a maximum number of values to be generated (nMax).
7. Type the step value (nStep).
8. (Optional) Type a maximum value for the sequence in the Ceiling
Value field.
9. Select OK.
Lists & Spreadsheet shows the formula in the formula cell and fills the
column with the results.
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Graphing spreadsheet data
You can graph the data in a spreadsheet using Quick Graph or Summary
Plot. Lists & Spreadsheet cells that contain no data are not represented
by data points on graphs.

Using Quick Graph
You can easily create a dot plot of the data in one column or a scatter
plot of two adjacent columns by using the Quick Graph feature. This
feature displays the graphed data using the Data & Statistics application.
To create a scatter plot:
1. Name both of the columns to declare them as lists.

2. Select both columns.

3. From the Data menu, select Quick Graph.
A Data & Statistics application is added to the page with the plotted
data. The leftmost of the two lists is plotted on the x axis, and the
other list is plotted on the y axis.
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4. (Optional) Use the Data & Statistics features to analyze or visually
enhance the graph.
Note: Refer to Using Data and Statistics for information about
analyzing and exploring graphs.

Creating a summary plot from a summary table
In this example, you create a summary table from raw data and then use
the table to generate a summary plot. For an example of how to create a
similar chart directly from the raw data, refer to the “Using
Data & Statistics” chapter.

raw data

summary table for eye color based on
raw data

A summary table contains an X (or Y) List and a Summary List.
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•

The X (or Y) List contains numeric or string values (such as 1999 or
“color”). Numeric values result in a histogram. String values identify
the categories for a bar chart.

•

The Summary List contains numeric values (such as count, frequency,
or probability) for each element in the other list.

To create a summary plot:
Note: For situations in which you already have a summary table, you can
skip the first two steps.
1. Create a list that holds the category identifiers. For this example,
name the list “color” and enter strings for eye color. Enclose category
names in quotes to prevent them from being interpreted as variables.

2. Create the summary list. For this example, name the list “counts” and
enter the total count for each of the eye colors.

3. Select either list by clicking the top cell of the column and pressing £.
4. From the Data menu, select Summary Plot.
The Summary Plot dialog displays.
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5. If necessary, use e and the arrow keys to select the correct lists for
X List and Summary List.
6. In the Display On field, select how to display the summary plot in the
Data & Statistics application.
•

Select Split Page to place the chart on half of the current page.

•

Select New Page to add the chart on a new page.

The summary plot displays with the list names along the axes and a
summary plot symbol in the lower left corner of the chart window.

Note: In this example, the X List contains string data, so the summary
plot displays as a bar chart. The category strings from the list display
beneath the bars.

Exchanging data with other computer software
You can use the TI-Nspire™ desktop software to copy table data to and
from software outside the TI-Nspire™ applications, such as TI DataEditor
(in the TI Connect™ software) and Excel® spreadsheet software.
For example, you can copy:
•
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The values of individual cells, a range of cells, or an entire list from
TI DataEditor.
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•

The values (not the underlying formulas) of individual cells, a range
of cells, or an entire column from an Excel® spreadsheet.

•

A number from TI DataEditor.

•

The value of a matrix from TI DataEditor.

Example - copying data from TI DataEditor
1. Open the TI Connect™ software.
2. Display the TI DataEditor.
3. If necessary, open the file containing the number, list, or matrix that
you want to copy.

4. Drag to select the values that you want to copy. To copy an entire list,
click the top cell in the list.

5. Click Edit > Copy.
6. In Lists & Spreadsheet, click the cell where you want the data to be
pasted.
If you have copied a range of cells, they will be pasted so that the
upper-left corner of the range is positioned at the selected cell. Any
data in those cells will be overwritten.
7. Click Edit > Paste.
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Copying cells from an Excel® spreadsheet
You can copy up to 26 columns and 2500 rows from an Excel®
spreadsheet to a Lists & Spreadsheet application.
1. Drag to select the values that you want to copy from the Excel®
spreadsheet. To copy an entire column, click the column identifier at
the top of the column.
Note: If you select non-contiguous columns in the Excel®
spreadsheet, they will be pasted as contiguous columns in Lists &
Spreadsheet.
2. Press / C to copy cells.
3. In Lists & Spreadsheet, click the cells where you want the data to be
pasted.
If you are copying a range of cells, they will be pasted so that the
upper-left corner of the range is positioned at the selected cell. Any
data in those cells in will be overwritten.
4. Press / V to paste the copied cells into Lists & Spreadsheet.
Note: Categorical data must be enclosed in quotes (“ “) after the
data is pasted.

Capturing data from Graphs & Geometry
You can use Lists & Spreadsheet application to capture information about
objects in the Graphs & Geometry application. For example, you could
track changes in the area of a triangle as you change the length of a side
in the Graphs & Geometry application.
Captured values will replace values in the column. If you prefer, you can
remove all data from a column before starting a new capture by
selecting Clear Data on the Data menu.
You can select manual or automatic capture as the method of capturing
data.
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•

With manual capture, you trigger the capture of each data element
by pressing a key combination. Press / ^ to capture on a
Windows® operating system, or press “ ^ to capture on a
Macintosh® operating system.

•

With automatic capture, the capture of each data value is triggered
automatically when you move or animate the target in Graphs &
Geometry.

Capturing data manually
1. Make sure the data value that you want to capture is linked to a
variable name.
2. Select the column formula cell (the second cell from the top) of the
column in which you want to capture the values.
Note: Captured values will replace values in the column.
3. From the Data menu, select Data Capture, and then select Manual
Data Capture.
A capture expression is inserted into the colum formula cell with var
as a placeholder for the name of the variable you are capturing.

4. Replace the letters “var” with the name of the variable to capture
from Graphs & Geometry. For example, type area.
The formula cell now contains an expression similar to
=capture(area,0).

Note: The argument “0” tells Lists & Spreadsheet that you want to

trigger each capture manually.
5. Press ·.
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6. From the Graphs & Geometry application, change the object with a
measured value stored as the variable (area, in this example)
referenced in the data capture expression.
7. Each time you are ready to capture the current value of area, press
the capture keys.
Windows®: Hold down / and press . (the period key).
Macintosh®: Hold down “ and press . (the period key).
Handheld: Press / ^.
The current area value is added to the end of the list as a list element.

Capturing data automatically
When you capture data automatically, you can specify that you want the
captures to be triggered by:
•

Changes in the captured variable only.

•

Changes in the captured variable or additional variables.

This lets you set up multiple columns of synchronized captures, such as
the x and y coordinates of a moving object.

To capture automatically
1. Clear all columns that you will be using for the captured data.
2. Make sure any data values that you want to capture are linked to
variable names.
3. Select the column formula cell (the second cell from the top) of the
column in which you want to capture the values.
4. From the Data menu, select Data Capture and then select
Automated Data Capture.
A capture expression is inserted into the column formula cell with var
as a placeholder for the name of the variable you are capturing.
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5. Replace the letters “var” with the name of the variable to capture.
For example, type objpathX. Alternatively, you can select the variable
name from the Variables menu.
The formula cell now contains an expression similar to
=capture(objpathX,1).

Note: The argument “1” tells Lists & Spreadsheet that you want the
captures to be triggered by the variable change.
6. If you want the capture to also be triggered by changes in an
additional variable or variables, type a comma after the 1, and then
type the variable name or the name of a list that itemizes the
variables.
The formula cell wil contain an expression similar to
=capture(objpathX,1,objpathY).

7. Press · to complete the formula.
8. If you are capturing multiple columns of synchronized data, set up
the additional columns. For example, you might set up a second
capture variable using
=capture(objpathY,1,objpathX).
9. When you are ready to capture the values, begin moving the object
or start the animation that affects it in Graphs & Geometry.
Each captured value is added to the end of the list.

Using table data for statistical analysis
Tools on the Statistics menu provide access to wizards that help you
perform statistical analyses on the data in table columns. You specify the
location of the data, and Lists & Spreadsheet stores the results in two
columns: one for the result names, and one for the corresponding values.
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Plotting statistical data
Some statistics wizards include a Draw check box. By default, the box is
not checked. Checking this box creates a Data & Statistics work area on
the page, displays the calculated results in Lists & Spreadsheet, and draws
the results of the statistical analysis in the Data & Statistics work area.
Note: For functions that support the Draw option, the option is available
only if you enter the function in a column formula cell.

Draw check box
(as shown in the
z Test wizard).

Statistics Input Descriptions
The following table describes the different inputs used in
Lists & Spreadsheet wizards.
Input

Description

m0

Hypothesized value of the population mean that
you are testing.

s

The known population standard deviation; must be
a real number > 0.

List

The name of the list containing the data you are
testing.

Frequency List

The name of the list containing the frequency
values for the data in List. Default=1. All elements
must be integers | 0. The frequency values can also
be typed as a list, in the format {1, 1, 3, 2}.

v, Sx, n

Summary statistics (mean, standard deviation, and
sample size) for the one-sample tests and intervals.

s1

The known population standard deviation from the
first population for the two-sample tests and
intervals. Must be a real number > 0.
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Input

Description

s2

The known population standard deviation from the
second population for the two-sample tests and
intervals. Must be a real number > 0.

List 1, List 2

The names of the lists containing the data you are
testing for the two-sample tests and intervals.

Frequency 1
Frequency 2

The names of the lists containing the frequencies
for the data in List 1 and List 2 for the two-sample
tests and intervals. Defaults=1. All elements must be
integers | 0.

v1, Sx1, n1, v2,
Sx2, n2

Summary statistics (mean, standard deviation, and
sample size) for sample one and sample two in twosample tests and intervals.

Pooled

Specifies whether variances are to be pooled for
2-Sample t Test and 2-Sample t Interval.

p0

The expected sample proportion for 1-Prop z Test.
Must be a real number, such that 0 < p0 < 1.

x

The count of successes in the sample for the
1-Prop z Test and 1-Prop z Interval. Must be an
integer | 0.

n

The count of observations in the sample for the
1-Prop z Test and 1-Prop z Interval. Must be an
integer > 0.

x1

The count of successes from sample one for the
2-Prop z Test and 2-Prop z Interval. Must be an
integer | 0.

x2

The count of successes from sample two for the
2-Prop z Test and 2-Prop z Interval. Must be an
integer | 0.

n1

The count of observations in sample one for the
2-Prop z Test and 2-Prop z Interval. Must be an
integer > 0.

n2

The count of observations in sample two for the
2-Prop z Test and 2-Prop z Interval. Must be an
integer > 0.
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Input

Description

C-Level

The confidence level for the interval instructions.
Must be | 0 and < 100. If it is | 1, it is assumed to be
given as a percent and is divided by 100.
Default=0.95.

RegEQ

The prompt for the name of the function where the
calculated regression equation is to be stored.

Statistical calculations
Performing a statistical calculation
You can perform statistical calculations to analyze data. The following
example fits a y=mx+b linear regression model to two lists.
1. Select the column formula cell (second cell from the top) in column A.
2. From the Statistics menu, select Stat Calculation, and select Linear
Regression (mx+b) to choose the regression model.
The Linear Regression (mx+b) dialog box opens and displays fields
for typing or selecting each argument. Because you selected a cell in
advance, the column for X List is already filled in with the column
letter of the list with a cell selected.
3. Press e to move to the Y List box and click the drop-down arrow to
select a named list.
4. To store the regression equation in a specified variable, press e and
replace Save RegEqn To with the name of the variable.
5. Press e as necessary to move to the 1st Result box and type c[] as
the column letter for the first result column.
6. Select OK.
Lists & Spreadsheet inserts two columns: one containing the names of
the results, and one containing the corresponding values.
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Note: The results are linked to the source data. For example, if you
change a value in column A, the regression equation is updated
automatically.

Storing statistical results
Lists & Spreadsheet stores statistical results using a variable-group name
with the format stat.nnn, where nnn is the result name (for example,
stat.RegEqn and stat.Resid). The use of standard names for variables
makes it easier to identify and use the statistical variables later. If you
want to use a custom variable group instead of the standard name, you
can edit the formula in the column formula cell.
You could use the following formula to store the results in the variable
group MystatsB.
=LinRegMx(a[],b[],1 ): CopyVar Stat., MystatsB.

Later, you could view the results by entering the following expression
in the Calculator application or in another column of the
Lists & Spreadsheet application:
MystatsB.results

Supported statistical calculations
The Stat Calculations menu lets you select from the calculations
described below. For a complete description of inputs and outputs, refer
to the TI-Nspire™ Reference Guide details for the function name that is
in parentheses.

One-Variable Statistics (OneVar) analyzes data with one
measured variable. You can specify an optional frequency list. The
statistical data returned using this analysis technique are:
•

sample mean, x

•

sum of the data, Σx
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•

sum of the squared data, Σx 2

•

sample standard deviation, s x

•

population standard deviation, s x

•

sample size, n

•

X-min

•

first quartile, Q1

•

median

•

third quartile, Q3

•

X-max

•

sum of squared deviations, SSx = Σ ( x – x ) 2

Two-Variable Statistics (TwoVar) analyzes paired data. List 1 is the
independent variable. List 2 is the dependent variable. You can specify an
optional frequency list. The statistical data returned using this analysis
technique are:
For each list:
•

sample mean, x or y

•

sum of the data, Σx or Σy

•

sum of the squared data, Σx 2 or Σy 2

•

sample standard deviation, sx = sn-1x or sy = sn-1y

•

population standard deviation, sx = snx or sy = sny

•

X-min or Y-min

•

first quartile, Q1X or Q1Y

•

median

•

third quartile, Q3X or Q3Y

•

X-max or Y-max

•

sum of squared deviations, Sex = Σ ( x – x ) 2 or Say = Σ ( y – y ) 2

Additional data:
•

sample size for each data set, n

•

Σxy
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•

correlation coefficient, R.

Linear Regression (mx+b) (LinRegMx) fits the model equation
y=ax+b to the data using a least-squares fit. It displays values for m (slope)
and b (y-intercept).

Linear Regression (a+bx) (LinRegBx) fits the model equation
y=a+bx to the data using a least-squares fit. It displays values for a
(y-intercept), b (slope), r2, and r.

Median-Median Line (MedMed) fits the model equation y=mx+b
to the data using the median-median line (resistant line) technique,
calculating the summary points x1, y1, x2, y2, x3, and y3.
Median-Median Line displays values for m (slope) and b (y-intercept).

Quadratic Regression (QuadReg) fits the second-degree
polynomial y=ax2+bx+c to the data. It displays values for a, b, c, and R2.
For three data points, the equation is a polynomial fit; for four or more,
it is a polynomial regression. At least three data points are required.

Cubic Regression (CubicReg) fits the third-degree polynomial
y=ax 3+bx 2+cx+d to the data. It displays values for a, b, c, d, and R2. For
four points, the equation is a polynomial fit; for five or more, it is a
polynomial regression. At least four points are required.

Quartic Regression (QuartReg) fits the fourth-degree polynomial
y=ax 4+bx 3+cx 2+dx+e to the data. It displays values for a, b, c, d, e, and
R2. For five points, the equation is a polynomial fit; for six or more, it is a
polynomial regression. At least five points are required.

Power Regression (PowerReg) fits the model equation y=axb to
the data using a least-squares fit on transformed values ln(x) and ln(y). It
displays values for a, b, r2, and r.
Exponential Regression (ExpReg) fits the model equation y=abx to
the data using a least-squares fit on transformed values x and ln(y). It
displays values for a, b, r2, and r.
Logarithmic Regression (LogReg) fits the model equation
y=a+b ln(x) to the data using a least-squares fit on transformed values
ln(x) and y. It displays values for a, b, r2, and r.
Sinusoidal Regression (SinReg) fits the model equation
y=a sin(bx+c)+d to the data using an iterative least-squares fit. It displays
values for a, b, c, and d. At least four data points are required. At least
two data points per cycle are required in order to avoid aliased frequency
estimates.
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Note: The output of SinReg is always in radians, regardless of the
Radian/Degree mode setting.

Logistic Regression (d=0) (Logistic) fits the model equation
y=c/(1+a*eLbx) to the data using an iterative least-squares fit. It displays
values for a, b, and c.

Logistic Regression (dƒ0) (LogisticD) fits the model equation
y=c/(1+a*e(Lbx))+d to the data using an iterative least-squares fit. It
displays values for a, b, c and d.

Multiple Linear Regression (MultReg) calculates multiple linear
regression of list Y on lists X1, X2, …, X10.

Distributions
Calculating distributions
You can calculate a distribution to fit the Normal Pdf distribution model.
1. Select the column formula cell (second cell from the top) in column A.
2. From the Statistics menu, select Distributions, and select Normal
Pdf to choose the Distribution model.
The Normal Pdf dialog box opens and displays fields for typing or
selecting the arguments for the calculation.
–

Press e as necessary to move from field to field and provide
each argument. You can type values, or select them from the drop
down list:

–

X Value: Click the drop-down arrow to choose any list in the
problem to provide the x values for the calculation.

–

Mean: Type a value for the mean or click the drop-down arrow to
choose a variable that contains the mean.

–

Standard Deviation: Type a value for the standard deviation or
choose a variable that contains the standard deviation.

3. Click the Draw check box to see the distribution plotted in Data &
Statistics.
Note: The Draw option is not available for all distributions.
4. Select OK.
Lists & Spreadsheet inserts two columns: one containing the names of
the results, and one containing the corresponding values. The results
are plotted in Data & Statistics.
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Note: The results are linked to the source data. For example, you can
change a value in Column A, and the equation updates automatically.

Supported Distribution functions
The following distributions are available from the Lists & Spreadsheet
application. For complete information regarding these functions, refer to
the TI-Nspire™ Reference Guide details for the function name that is in
parentheses.
•

To return a single distribution result based on a single value, enter the
function in a single cell.

•

To return a list of distribution results based on a list of values, enter
the function in a column formula cell. In this case, you specify a list
(column) that contains the values. For each value in the list, the
distribution returns a corresponding result.
Note: For distribution functions that support the draw option
(normPDF, t PDF, c2 Pdf, and F Pdf), the option is available only if you
enter the distribution function in a formula cell.

Normal Pdf (normPdf) computes the probability density function
(pdf) for the normal distribution at a specified x value. The defaults are
mean m=0 and standard deviation s=1. The probability density function
(pdf) is:

1
f ( x ) = -------------- e
2πσ

– ( x – μ )2
– -----------------2
2σ ,σ

>0

This distribution is used to determine the probability of the occurrence of
a certain value in a normal distribution. The draw option is available
when Normal PDF is invoked from a formula cell.
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When you access distributions from the formula cell, you must select a
valid list from the pull-down to avoid unexpected results. If accessed
from a cell, you must specify a number for the x-value. The distribution
returns the probability that the value you specify will occur.

Normal Cdf (normCdf) computes the normal distribution probability
between Lower Bound and Upper Bound for the specified mean, m
(default=0) and the standard deviation, s (default=1). You can click the
Draw (Shade area) check box to shade the area between the lower and

upper bounds. Changes to the initial Lower Bound and Upper Bound
automatically update the distribution.
This distribution is useful in determining the probability of an occurrence
of any value between the lower and upper bounds in the normal
distribution. It is equivalent to finding the area under the specified
normal curve between the bounds.

Inverse Normal (invNorm) computes the inverse cumulative normal
distribution function for a given area under the normal distribution curve
specified by mean, m, and standard deviation, s.
This distribution is useful in determining the x-value of data in the area
from 0 to x<1 when the percentile is known.

t Pdf (tPdf) computes the probability density function (pdf) for the
t-distribution at a specified x value. df (degrees of freedom) must be > 0.
The probability density function (pdf) is:

[ ( df + 1 )/2 -]
f(x) = Γ
-------------------------------Γ ( df ⁄ 2 )

2

– ( df + 1 )/2

( 1 + x /df )
---------------------------------------------πdf

This distribution is useful in determining the probability of the
occurrence of a value when the population standard deviation is not
known and the sample size is small. The draw option is available when
t Pdf is invoked from a formula cell.

t Cdf (tCdf) computes the Student-t distribution probability between
Lower Bound and Upper Bound for the specified df (degrees of freedom).
You can click the Draw (Shade area) check box to shade the area
between the bounds. Changes to the initial Lower Bound and Upper Bound
automatically update the distribution.
This distribution is useful in determining the probability of the
occurrence of a value within an interval defined by the lower and upper
bound for a normally distributed population when the population
standard deviation is not known.
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Inverse t (invt) computes the inverse cumulative t-distribution
probability function specified by Degrees of Freedom, df, for a given area
under the curve.
This distribution is useful in determining the probability of an occurrence
of data in the area from 0 to x<1. This function is used when the
population mean and/or population standard deviation is not known.
c2 Pdf (c2 Pdf()) computes the probability density function (pdf) for
the c2 (chi-square) distribution at a specified x value. df (degrees of
freedom) must be an integer > 0. The probability density function (pdf)
is:

1
df/2 df ⁄ 2 – 1 – x/2
f ( x ) = -------------------- ( 1/2 ) x
e ,x ≥ 0
Γ ( df ⁄ 2 )
This distribution is useful in determining the probability of the
occurrence of a given value from a population with a c2 distribution. The
draw option is available when c2 Pdf is invoked from a formula cell.
c2 Cdf (c2 Cdf()) computes the c2 (chi-square) distribution probability
between lowBound and upBound for the specified df (degrees of freedom).
You can click the Draw Shade area check box to shade the area between
the lower and upper bounds. Changes to the initial lowBound and
upBound automatically update the distribution.
This distribution is useful in determining the probability of the
occurrence of value within given boundaries of a population with a c2
distribution.
F Pdf (F Pdf()) computes the probability density function (pdf) for the
F distribution at a specified x value. numerator df (degrees of freedom)
and denominator df must be integers > 0. The probability density function
(pdf) is:

Γ [ ( n + d )/2 ] n n/2 n/2 – 1
– ( n + d )/2
f ( x ) = ---------------------------------- ⎛ --- ⎞ x
( 1 + nx/d )
,x ≥ 0
Γ ( n/2 )Γ ( d/2 ) ⎝ d ⎠
where

n = numerator degrees of freedom
d = denominator degrees of freedom

This distribution is useful in determining the probability that two
samples have the same variance. The draw option is available when F Pdf
is invoked from a formula cell.
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F Cdf (F Cdf()) computes the F distribution probability between
lowBound and upBound for the specified dfnumer (degrees of freedom) and
dfDenom. You can click the Draw (Shade area) check box to shade the
area between the lower and upper bounds. Changes to the initial
lowBound and upBound automatically update the distribution.
This distribution is useful in determining the probability that a single
observation falls within the range between the lower bound and upper
bound.

Binomial Pdf (binomPdf()) computes a probability at x for the
discrete binomial distribution with the specified numtrials and probability
of success (p) on each trial. The x parameter can be an integer or a list of
integers. 0{p{1 must be true. numtrials must be an integer > 0. If you do
not specify x, a list of probabilities from 0 to numtrials is returned. The
probability density function (pdf) is:
n–x
n x
f ( x ) = ⎛ ⎞ p ( 1 – p ) ,x = 0,1,...,n
⎝x ⎠

where n = numtrials
This distribution is useful in determining the probability of success in a
success/failure trial, at trial n. For example, you could use this distribution
to predict the probability of getting heads in a coin toss on the fifth toss.

Binomial Cdf (binomCdf()) computes a cumulative probability for
the discrete binomial distribution with n number of trials and probability
p of success on each trial.
This distribution is useful in determining the probability of a success on
one trial before all trials are completed. For example, if heads is a
successful coin toss and you plan to toss the coin 10 times, this
distribution would predict the chance of obtaining heads at least once in
the 10 tosses.

Poisson Pdf (poissPdf()) computes a probability at x for the discrete
Poisson distribution with the specified mean, m, which must be a real
number > 0. x can be an integer or a list of integers. The probability
density function (pdf) is:
–μ x

f ( x ) = e μ ⁄ x! ,x = 0,1,2,...
This distribution is useful in determining the probability of obtaining a
certain number of successes before a trial begins. For example, you could
use this calculation to predict the number of heads that would occur in
eight tosses of a coin.
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Poisson Cdf (poissCdf()) computes a cumulative probability for the
discrete Poisson distribution with specified mean, l.
This distribution is useful in determining the probability that a certain
number of successes occur between the upper and lower bounds of a
trial. For example, you could use this calculation to predict the number of
heads displayed between coin toss #3 and toss #8.

Geometric Pdf (geomPdf()) computes a probability at x, the
number of the trial on which the first success occurs, for the discrete
geometric distribution with the specified probability of success p. 0{p{1
must be true. x can be an integer or a list of integers. The probability
density function (pdf) is:

f(x) = p(1 – p)

x–1

,x = 1,2,...

This distribution is useful in determining the likeliest number of trials
before a success is obtained. For example, you could use this calculation
to predict the number of coin tosses that would be made before a heads
resulted.

Geometric Cdf (geomCdf()) computes a cumulative geometric
probability from lowBound to upBound with the specified probability of
success, p.
This distribution is useful in determining the probability associated with
the first success occurring during trials 1 through n. For example, you
could use this calculation to determine the probability that heads display
on toss #1, #2, #3, ..., #n.

Confidence Intervals
Supported Confidence Intervals
The following confidence intervals are available from the Lists &
Spreadsheets application. For complete information regarding these
functions, refer to the TI-Nspire™ Reference Guide details for the
function name that is in parentheses.

z Interval (zInterval) computes a confidence interval for an
unknown population mean, m, when the population standard deviation,
s, is known. The computed confidence interval depends on the userspecified confidence level.
This test is useful in determining how far from a population mean a
sample mean can get before indicating a significant deviation.
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t Interval (tInterval) computes a confidence interval for an unknown
population mean, m, when the population standard deviation, s, is
unknown. The computed confidence interval depends on the userspecified confidence level.
This test is useful in examining whether the confidence interval
associated with a confidence level contains the value assumed in the
hypothesis. Like the z Interval, this test helps you determine how far
from a population mean a sample mean can get before indicating a
significant deviation when the population mean is unknown.

2-Sample z Interval (zInterval_2Samp) computes a confidence
interval for the difference between two population means (m1Nm2) when
both population standard deviations (s1 and s2) are known. The
computed confidence interval depends on the user-specified confidence
level.
This test is useful in determining if there is statistical significance
between the means of two samples from the same population. For
example, this test could determine whether there is significance between
the mean college entrance test score of female students and the mean of
college entrance test score of male students at the same school.

2-Sample t Interval (tInterval_2Samp) computes a confidence
interval for the difference between two population means (m1Nm2) when
both population standard deviations (s1 and s2) are unknown. The
computed confidence interval depends on the user-specified confidence
level.
This test useful in determining if there is statistical significance between
the means of two samples from the same population. It is used instead of
the 2-sample z confidence interval in situations where the population is
too large to measure in order to determine the standard deviation.

1-Prop z Interval (zInterval_1Prop) computes a confidence
interval for an unknown proportion of successes. It takes as input the
count of successes in the sample x and the count of observations in the
sample n. The computed confidence interval depends on the userspecified confidence level.
This test is useful in determining the probability of a given number of
successes that can be expected for a given number of trials. For instance,
casino examiners would use this test to determine if observed payouts for
one slot machine demonstrate a consistent pay out rate.
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2-Prop z Interval (zInterval_2Prop) computes a confidence
interval for the difference between the proportion of successes in two
populations (p1-p2). It takes as input the count of successes in each
sample (x1 and x2) and the count of observations in each sample
(n1 and n2). The computed confidence interval depends on the userspecified confidence level.
This test is useful in determining if two rates of success differ because of
something other than sampling error and standard deviation. For
example, a bettor could use this test to determine if there is an
advantage in the long run by playing one game or machine versus
playing another game or machine.

Linear Reg t Intervals (LinRegtIntervals) computes a linear
regression t confidence interval for the slope coefficient b. If the
confidence interval contains 0, this is insufficient evidence to indicate
that the data exhibits a linear relationship.

Multiple Reg Intervals (MultRegIntervals) computes multiple
regression prediction confidence interval for the calculated y and a
confidence for y.

Stats Tests
Supported Statistical tests
Hypothesis tests are available from the Lists & Spreadsheets application.
For complete information regarding these functions, refer to the
TI-Nspire™ Reference Guide details for the function name provided in
parentheses.
Some of the wizards for Stats Tests display a Draw check box. By default,
the box is not checked. Checking the box creates a Data & Statistics work
area on the page and plots the results in that work area.

z test (zTest) performs a hypothesis test for a single unknown
population mean, m, when the population standard deviation, s, is
known. It tests the null hypothesis H0: m=m0 against one of the
alternatives below.
•

Ha: mƒm0

•

Ha: m<m0

•

Ha: m>m0

This test is used for large populations that are normally distributed. The
standard deviation must be known.
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This test is useful in determining if the difference between a sample
mean and a population mean is statistically significant when you know
the true deviation for a population.

t test (tTest) performs a hypothesis test for a single unknown
population mean, m, when the population standard deviation, s, is
unknown. It tests the null hypothesis H0: m=m0 against one of the
alternatives below.
•

Ha: mƒm0

•

Ha: m<m0

•

Ha: m>m0

This test is similar to a z-test, but is used when the population is small and
normally distributed. This test is used more frequently than is the z-test
because small sample populations are more frequently encountered in
statistics than are large populations.
This test is useful in determining if two normally distributed populations
have equal means, or when you need to determine if a sample mean
differs from a population mean significantly and the population
standard deviation is unknown.

2-Sample z Test (zTest_2Samp) tests the equality of the means of
two populations (m1 and m2) based on independent samples when both
population standard deviations (s1 and s2) are known. The null
hypothesis H0: m1=m2 is tested against one of the alternatives below.
•

Ha: m1ƒm2

•

Ha: m1<m2

•

Ha: m1>m2

2-Sample t Test (tTest_2Samp) tests the equality of the means of
two populations (m1 and m2) based on independent samples when
neither population standard deviation (s1 or s2) is known. The null
hypothesis H0: m1=m2 is tested against one of the alternatives below.
•

Ha: m1ƒm2

•

Ha: m1<m2

•

Ha: m1>m2
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1-Prop z Test (zTest_1Prop) computes a test for an unknown
proportion of successes (prop). It takes as input the count of successes in
the sample x and the count of observations in the sample n. 1-Prop z Test
tests the null hypothesis H0: prop=p0 against one of the alternatives
below.
•

Ha: propƒp 0

•

Ha: prop<p0

•

Ha: prop>p 0

This test is useful in determining if the probability of the success seen in a
sample is significantly different from the probability of the population or
if it is due to sampling error, deviation, or other factors.

2-Prop z Test (zTest_2Prop) computes a test to compare the
proportion of successes (p1 and p2) from two populations. It takes as
input the count of successes in each sample (x1 and x2) and the count of
observations in each sample (n1 and n2). 2-Prop z Test tests the null
hypothesis H0: p1=p2 (using the pooled sample proportion Ç) against one
of the alternatives below.
•

Ha: p1ƒp2

•

Ha: p1<p2

•

Ha: p1>p2

This test is useful in determining if the probability of success seen in two
samples is equal.
c2GOF (c2GOF) performs a test to confirm that sample data is from a
population that conforms to a specified distribution. For example, c2
GOF can confirm that the sample data came from a normal distribution.
c2 2-way Test (c22way) computes a chi-square test for association on
the two-way table of counts in the specified Observed matrix. The null
hypothesis H 0 for a two-way table is: no association exists between row
variables and column variables. The alternative hypothesis is: the
variables are related.

2-Sample FTest (FTest_2Samp) computes an F-test to compare two
normal population standard deviations (s1 and s2). The population
means and standard deviations are all unknown. 2-Sample FTest, which
uses the ratio of sample variances Sx12/Sx22, tests the null hypothesis
H0: s1=s2 against one of the alternatives below.
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•

Ha: s1ƒs2

•

Ha: s1<s2

•

Ha: s1>s2

Below is the definition for the 2-Sample FTest.

Sx1, Sx2

=

Sample standard deviations having n 1 – 1
and n 2 – 1 degrees of freedom df,
respectively.

F

=

df(x, n 1 – 1 , n 2 – 1 )

=

Sx1
F-statistic = ⎛ ---------⎞

2

⎝ Sx2⎠

Fpdf( ) with degrees of freedom df, n 1 – 1 ,
and n 2 – 1

p

=

reported p value

2-Sample FTest for the alternative hypothesis
α

p =

∫

σ1 > σ2 .

f ( x ,n 1 – 1 ,n 2 – 1 )dx

F

2-Sample FTest for the alternative hypothesis
F

p =

∫

σ1 < σ2 .

f ( x ,n 1 – 1 ,n 2 – 1 )dx

0

2-Sample FTest for the alternative hypothesis s1ƒs2. Limits must satisfy

the following:

p--- =
2
where:

∞

L bnd

∫

f ( x ,n 1 – 1 ,n 2 – 1 ) dx =

0

∫

f ( x ,n 1 – 1 ,n 2 – 1 ) d x

Ubnd

[Lbnd,Ubnd] = lower and upper limits

The F-statistic is used as the bound producing the smallest integral. The
remaining bound is selected to achieve the preceding integral’s equality
relationship.
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Linear Reg t Test (LinRegtTest) computes a linear regression on the
given data and a t test on the value of slope b and the correlation
coefficient r for the equation y=a+bx. It tests the null hypothesis H0: b=0
(equivalently, r=0) against one of the alternatives below.
•

Ha: bƒ0 and rƒ0

•

Ha: b<0 and r<0

•

Ha: b>0 and r>0

Multiple Reg Tests (MultRegTest) computes a linear regression on
the given data, and provides the F test statistic for linearity.
Refer to the TI-Nspire™ Reference Guide for information about
MultRegTests.

ANOVA (ANOVA) computes a one-way analysis of variance for
comparing the means of two to 20 populations. The ANOVA procedure
for comparing these means involves analysis of the variation in the
sample data. The null hypothesis H0: m1=m2=...=mk is tested against the
alternative Ha: not all m1...mk are equal.
The ANOVA test is a method of determining if there is a significant
difference between the groups as compared to the difference occurring
within each group.
This test is useful in determining if the variation of data from sample-tosample shows a statistically significant influence of some factor other
than the variation within the data sets themselves. For example, a box
buyer for a shipping firm wants to evaluate three different box
manufacturers. He obtains sample boxes from all three suppliers. ANOVA
can help him determine if the differences between each sample group
are significant as compared to the differences within each sample group.

ANOVA 2-Way (ANOVA2way) computes a two-way analysis of
variance for comparing the means of two to 20 populations. A summary
of results is stored in the stat.results variable.
The two-way ANOVA analysis of variance examines the effects of two
independent variables and helps to determine if these interact with
respect to the dependent variable. (In other words, if the two
independent variables do interact, their combined effect can be greater
than or less than the impact of either independent variable additively.)
This test is useful in evaluating differences similar to the ANOVA analysis
but with the addition of another potential influence. To continue with
the ANOVA box example, the two-way ANOVA might examine the
influence of box material on the differences seen.
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Selecting an Alternative Hypothesis (ƒ < >)
Most of the inferential stat editors for the hypothesis tests prompt you to
select one of three alternative hypotheses.
•

The first is a ƒ alternative hypothesis, such as mƒm0 for the z Test.

•

The second is a < alternative hypothesis, such as m1<m2 for the
2-Sample t Test.

•

The third is a > alternative hypothesis, such as p1>p2 for the
2-Prop z Test.

To select an alternative hypothesis, move the cursor to the appropriate
alternative, and then press ·.

Selecting the Pooled Option
Pooled (2-Sample t Test and 2-Sample t Interval only) specifies whether

the variances are to be pooled for the calculation.
•

Select No if you do not want the variances pooled. Population
variances can be unequal.

•

Select Yes if you want the variances pooled. Population variances are
assumed to be equal.

To select the Pooled option, select Yes from the drop down box.

Working with function tables
The Lists & Spreadsheet application lets you show a table of function
values for any function in the current problem. You can change the
settings for the table, delete columns, add values for multiple functions,
and edit the expression that defines a function without leaving the
Lists & Spreadsheet application.

Switching to a Table
1. While working in the Lists & Spreadsheet application, press / T
(Macintosh®: “ T) to switch to a table.
The Lists & Spreadsheet application disappears and an empty table
displays with a list of the functions that are available in the problem.
Note: If you have previously shown a table for a function from the
Lists & Spreadsheet application, the table includes that function by
default.
2. Choose the name of the function for which you want to display
values.
Values for the function you selected display in the first column of the
table.
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3. To move through adjacent cells of the table, press £ or ¤. Press e
to move from the body of the table (cells) to the top two rows (cells
for column names and formulas).
4. To hide the table of values and return to the Lists & Spreadsheet
application, repeat Step 1.

Making changes from a table
You can change the table of function values using the tools on the Table
menu.
f To remove a column from the table, select any cell and choose Delete
Column.
f To display the list of functions, click a cell in a column and select
Choose. Choose a cell in an empty column unless you are replacing
values already displayed. Click a function in the list to add its values to
the column.
Note: You can also click the drop-down arrow on the top cell of a

column to display the list of functions in the problem.
f To change the expression that defines a function, choose Edit
Expression. You can also edit the expression directly on the entry line
beneath the table.
Note: When you edit the expression for a function, that function
automatically changes in the application used to define the function.
For example, if you edit a Graphs & Geometry function in the table,
the table values and graph of the function are both updated.
f To change the default table settings, choose Edit Table Settings.
The Table dialog displays. Press e to move from field to field and
type or select new values for the default table settings:
–

Table Start: Type the value to use as the first value in the table of
values.

–

Table Step: Type a value for the interval between values.

–

Independent and Dependent: Click the drop-down arrow to
choose Auto or Ask as the method for populating a column with
the values of the independent and dependent variables. Auto
populates the table starting at the defined table start value and
displays an independent and dependent value for each step. Ask
lets you select a cell and press · to generate a value for a cell.
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Using Data & Statistics
The Data & Statistics application provides tools to:
•

Visualize sets of data in different types of plots.

•

Directly manipulate variables to explore and visualize data
relationships. Data changes in one application are dynamically
applied to all linked applications.

•

Explore central tendency and other statistical summary techniques.

•

Fit functions to data.

•

Create regression lines for scatter plots.

•

Graph hypothesis tests and results (z- and t-tests) based on summary
statistics definitions or data.

Á
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Â
Ã
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Data & Statistics tool menu
Work area
Add Variable regions on x-axis and y-axis

Normal Probability Plot with expression (click line to display)
Data point with coordinates (hover to display xlist variable data with
Expected z)
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Data & Statistics menu
The Data & Statistics menu provides tools to graph and explore data, to
modify data representations by using different plots, and to perform and
plot statistical analyses.
Handheld: Press b to open the Tools menu.
Plot type
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Dot Plot

Depicts data in a dot plot. This is the
default plot type for a single numeric
variable.

Box Plot

Displays data in a box plot.

Histogram

Displays data in a histogram.

Normal Probability
Plot

Displays data in a normal probability plot.
Data is grouped against the z-value that
corresponds to its quartile/normal score.
This plot type is useful for checking for
normality and determining the
appropriateness of a normal model.

Scatter Plot

Displays data in scatter plot form. This is
the default plot type for two numeric
variables.

X-Y Line Plot

Displays data as an x-y line plot.

Dot Chart

Displays data in a dot chart. This is the
default plot type for categorical data.

Bar Chart

Displays vertical or horizontal bars to
represent cases in categories of data.

Pie Chart

Displays a circle with segments to represent
the cases in each category of data.
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Plot Properties
Connect Data Points

Draws a line between each point on a
scatter plot. Lines are connected in the
order in which the data appears for the
variable on the horizontal axis. This is the
same as the X-Y Line plot type.

Histogram Properties

Determines how histogram data displays in
the work area.
Histogram Scale lets you adjust the

Frequency, Percent, and Density properties
of the histogram.
•

Frequency - displays data by
occurrence in the data set.

•

Percent - displays data by each bin’s
percent value of the whole data set.

•

Density - displays data by data density.

Bins displays a dialog for setting the
histogram values for bin width and
alignment.

Extend Box Plot
Whiskers/ Show Box
Plot Outliers

Extend Box Plot Whiskers extends the
whiskers to the min and max of the data.
Show Box Plot Outliers stops the whiskers
at 1.5 * Interquartile Range and shows
outliers as individual dots.
Note: If there are no points outside of
1.5 * Interquartile Range, there may
appear to be no whisker change.

Show/Hide All Labels

Displays or hides labels for categorical
data. Each bar or wedge is labeled.

Add X Variable

Adds a variable to the horizontal axis
when no variable is assigned.

Add X Summary List

Lets you display plots from frequency
tables, probability distribution tables, or
other summary data.

Remove X Variable

Removes the display of the variable
assigned to the horizontal axis without
changing the vertical axis.
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Plot Properties
Add Y Variable

Adds a variable to the vertical axis to
support the plotting of multiple variables.

Add Y Summary List

Lets you display plots from frequency
tables, probability distribution tables, or
other summary data.

Remove Y Variable

Removes the display of the variable
assigned to the vertical axis without
changing the horizontal axis.

Force Numeric X

Treats the variable on the x-axis as numeric
although the default is categorical (list of
strings). The categorical data label is
replaced by an axis with numbers.
Note: Forcing a numeric variable is
supported only when there are numbers in
the list.

Force Categorical X

Treats the variable on the x-axis as a
categorical variable (list of strings). The
numeric axis is replaced by labels for
categorical data.

Force Numeric Y

Treats the variable on the y-axis as a
numeric variable although the default is
categorical (list of strings). The categorical
data label is replaced by an axis with
numbers.
Note: Forcing a numeric variable is
supported only when there are numbers in
the list.

Force Categorical Y

Makes Data & Statistics treat a numeric
variable assigned to the y-axis as a
categorical variable (list of strings). The
numeric is replaced by labels for
categorical data.

Split Categories by
Variable

Lets you split a category (such as a chart of
eye colors) by an additional category (such
as gender).

Remove Split Variable Removes the split variable added by the
previous menu item.
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Plot Properties
Clear All

Removes the variable assignments from
the axes. This enables you to start your
work again.

Actions
Remove

Removes selected items from the work
area.

Hide/Show Text

Hides or shows selected text.

Insert Text

Adds a text box with multiple lines for
typing notes in the work area. You can
edit, move, resize, remove, and hide text
boxes.
To go to the next line in a text box, press
Alt ·. On the handheld, press @.

Insert Slider

Inserts a slider object for dynamically
changing the value of a numeric variable.

Select all Points

Selects all points in the work area.

Select Image

Selects the background image.

Sort

Sorts the data in List, Value, or Alpha order.

Analyse
Remove

Removes a selected Movable Line,
Regression, Plotted Value, or Plotted
Function.

Add Movable Line

Adds a line you can position and reposition
in the work area. This can be used for
manual fit.

Lock Intercept at
Zero/Unlock
Movable Line
Intercept

Locks the intercept of a movable line at
zero.
Note: This tool is only available when a
movable line is present in the work area.

Plot Function

Lets you graph a function in the work area.
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Analyse
Shade Under
Function

Lets you select and shade a region under a
function or distribution curve.

Regression

The regression tools calculate and display a
selected regression model for the plotted
data. Regression is only available on Scatter
plots or X-Y line plots.
You can show or hide the following
regression models:
Linear (mx+b)
Linear (a+bx)

Median-Median
Quadratic
Cubic
Quartic
Power
Exponential
Logarithmic
Sinusoidal
Logistic (d=0)
Logistic (dƒ0)
Residuals

The residuals tools display information
about the residuals of the selected model.
These tools are available when a scatter
plot and one or more lines, regressions, or
plotted functions are on the work area.
Show/Hide Residual Squares displays the

squares of residuals.
Show/Hide Residual Plot plots the

residuals against the explanatory variable.
The residual is the difference between the
observed value (data) and the value
calculated by a regression or function.
Plot Value
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Lets you graph a statistical value on the
axis. Examples of values that can be plotted
are a number, mean, median, and standard
deviation.

Analyse
Show Normal PDF

Overlays the normal probability density
function using the mean and the standard
deviation of the data in the histogram.
Note: This tool is available when a
histogram is present.

Graph Trace

Lets you trace the graph from Plot
Function, Show Normal PDF, Add Movable
Line, distribution curves, regressions, case
plots, dot plots, scatter plots, X-Y line plots,
box plots, histograms, bar charts, pie
charts, or multiple plots.

Window/Zoom
Window Settings

Displays a Window Settings dialog that
enables you to enter values that define the
work area window. Values you can set
include the x-min, x-max, y-min, and y-max
values for the axes.

Zoom - Data

Adjusts the zoom factor so that all plotted
data appears in the work area.

Zoom In

Enables you to zoom in on a plot based
upon the selection of a center point. The
Zoom In factor is approximately 2.

Zoom Out

Enables you to zoom out on a plot based
upon the selection of a center point. The
Zoom Out factor is approximately 2.

Getting started with the Data & Statistics
application
The Data & Statistics application lets you explore and visualize data and
graph inferential statistics. The Lists & Spreadsheet application can work
in conjunction with the Data & Statistics application. The
Lists & Spreadsheet Summary Plot and Quick Graph tools automatically
add a Data & Statistics application to show plots. A list that you create in
a problem (using the Lists & Spreadsheet or Calculator applications) can
be accessed as a variable in any TI-Nspire™ application in that problem.
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Using the default case plot
The Data & Statistics application plots numeric and string (categorical)
data from variables. When you add a Data & Statistics application to a
problem that includes lists, a default case plot displays on the work area.
The case plot is like having a stack of cards with information on them and
scattering the cards randomly on a table. You can click a dot to see the
information on that “card.” You can drag a dot to “group” the “cards”
by the caption variable.

f Click the variable name displayed after Title to use the case plot.
–

Choose <None> to remove the default case plot.

–

Choose the name of a variable to have it replace the current case
plot variable.

–

Hover over any data point to see the summary information.

–

Drag any data point toward an axis to see how the points group.

–

Activate the Graph Trace tool and press 7 or 8 to move across
points.

When you add a variable to either axis, the plot for that variable replaces
the default case plot. The default case plot redisplays if you remove the
plotted variable from each axis.

Navigating in the Data & Statistics application
You can plot variables by clicking the Add Variable region in the center
of the horizontal and vertical axes. The work area displays data points to
represent the values in variables. You can press e to move among
these functional areas.
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Using the axes
The horizontal and vertical axes include an Add Variable region near the
center. You can click the Add Variable region of an axis to view a list of all
variables available in the problem, or display the context menu to use
tools to help you work with data.

Using the context menu
The context menu provides access to the tools most commonly used with
the selected object. The context menu displays different options
depending on the active object and the task you are performing.
f To display the context menu for an object.
Windows®: Right-click the object.
Macintosh®: Hold “ and click the object.
Handheld: Point to the object and press / b.
The context menu includes the Color option. You can use the Color
option to change the data to the color of your choice.
Other options that are appropriate for various plots also display on the
context menu.

Selecting data and displaying summary information
When you hover over part of a plot, the Data & Statistics application
displays summary information for the data it represents.
1. Hover at an area of interest in a plot to display data values or
summary information. For example, you can hover over the center of
a box plot to display the median summary data.
2. Click once to select a representation of data in a plot.
Data points are shown with a bold outline to indicate selection. You
can click a point a second time to deselect it, or click additional points
to add to the selection.

Plotting variables
To plot variables, start with a problem that includes a Data & Statistics
application and lists created in the Lists & Spreadsheet application or the
Calculator application.
1. Click the Add Variable region near the center of an axis.
If no variable is plotted on the axis, the tooltip Click or Enter to add
variable displays.

2. Click the tooltip Click or Enter to add variable.
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A list displays the names of available variables.

3. Click the name of the variable to plot.
Note: By convention, the independent variable is shown on the
x-axis.
The default plot for one variable is a dot chart. The data points in the
default case plot reposition to represent the elements of the selected
variable in a dot chart.
4. (Optional) Click the Add Variable region near the center of the
remaining axis to plot a second variable.
The default plot for two variables is a scatter plot. The data points
shift to represent the elements of both variables as a scatter plot.
5. (Optional) Repeat Steps 1-3 to choose additional variables to plot on
the vertical axis.

The name of each variable that you add is appended to the label on
the axis. The default data point shape changes to help you distinguish
data, and a legend displays to identify the shapes.
6. Change, analyze, or explore the plotted data.
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–

Remove or change the variable on an axis by clicking the Add
Variable region again.

–

View the plotted data in another supported plot type by selecting
a tool from the Plot Types menu.

–

Choose the Graph Trace tool on the Analyse menu and press
7 or 8 to move across the data points in the plot.

–

The lists that you plot as variables can include incomplete or
missing cases. (A case is the data contained in a row of cells in the
Using Data & Statistics

Lists & Spreadsheet application.) The Lists & Spreadsheet
application displays a void as an underscore (“_”), and
Data & Statistics plots no data point for a void cell.

Manipulating plotted data
You can manipulate data points on the Data & Statistics work area to
explore their effects. For example, you could explore how a specific
group of values affects the median.
You can move a data point only in directions allowed by its definition. If
a list is defined with a formula in Lists & Spreadsheet, the points in
Data & Statistics may not move because of the formula’s restrictions. For
example, you can manipulate a plot that represents the result of y=x, but
you can only move along a line.
You cannot move points that represent data in a locked variable or data
that represents a categorical value.

To move plotted data:
1. On the Data & Statistics work area, click a representation of data—
such as a histogram bin or a whisker of a box plot—that is not locked
or restricted by a formula.

The pointer changes to an open hand to show that the data can be
moved.
2. Drag the selection to explore how different values of the point affect
the plot.
As you drag, the changing value displays on the work area.

Overview of raw and summary data
You can create plots directly from raw data or from a summary table.
Using Data & Statistics
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raw data

summary table for eye color based on
raw data

•

Raw data consists of a single list, such as a list of eye colors. When you
create a plot of raw data, Data & Statistics counts the occurrences for
you. Plotting raw data directly gives you flexibility in analyzing it.

•

A summary table consists of two lists, such as eye colors (the
X or Y List) and counts of eye-color occurrences (the Summary List).
For an example that creates a summary table and then plots it, refer
to the “Using Lists & Spreadsheet” chapter.

Working with numeric plot types
Plots can represent the data from a variable in a variety of ways.
Choosing the appropriate plot can help you visualize the data. For
example, you may be able to observe the shape and spread of the data in
one plot type and another type may be useful for determining the best
method for statistically evaluating data. Use Data & Statistics to create
the following types of numeric plots.
•

Dot Plot

•

Box Plot

•

Histogram

•

Normal Probability

•

Scatter Plot

•

X-Y Line

Creating dot plots
Dot plots, also known as dot-frequency plots, represent one variable
data. Dot plots are the default plot type for numeric data. When you plot
a variable as a dot plot, one dot represents each value in the list. Each dot
displays on the axis at a point that correspond to the value.

378

Using Data & Statistics

1. To create a dot plot, click the Add Variable region in the center of an
axis and click the name of a numeric variable. For more details, see
Plotting variables.
2. (Optional) To split a dot plot by category, click the Add Variable
region on the other axis and choose the list that contains the
corresponding category data.
3. (Optional) To plot multiple dot plots, choose Add X Variable on the
Plot Properties menu and select a numeric variable from the list that
displays.
A second dot plot appears on the work area and the name of the
plotted variable is added to both axis labels.
4. Explore the plotted data.
–

Hover over a data point to display data values.

–

Click and drag a dot to move it. As you move a point, the values
associated with it change on the work area display and in the list
for the variable.

–

Activate the Graph Trace tool and press 7 or 8 to move across the
data points in the plot in list order. Points enlarge and display a
bold outline as you move across them in Trace mode.

Creating box plots
The Box Plot Tool plots one-variable data in a modified box plot.
“Whiskers” extend from each end of the box, either to 1.5 times the
interquartile range or to the end of the data, whichever comes first.
Points that are a width of 1.5 * Interquartile Range past the quartiles
plot individually, beyond the whiskers. These points are the potential
outliers. When no outliers exist, x-min and x-max are the prompt for the
end of each whisker.
Box plots are useful for comparing two or more sets of data that use the
same scale. If a dataset is large, a box plot can also be useful in exploring
data distribution.
1. Click the Add Variable region in the center of an axis. The default plot
for one numeric variable is a dot plot. See Plotting variables for more
details about plotting data.

Using Data & Statistics

379

Note: If two variables are plotted in the work area, you can create a
dot plot by removing one variable. Choose Remove X Variable or
Remove Y Variable from the Plot Types menu.
2. On the Plot Types menu, select Box Plot.

A modified box plot displays on the Data & Statistics work area.
Note: You can split a box plot by category by adding a list that
contains corresponding categorical data to the y-axis.
3. (Optional) To add additional variables for comparing box plots on the
same axis, click Add X Variable on the Plot Properties menu.
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For example, you can use multiple boxplots to compare the
distributions of sample proportions. In the example, true proportion
is .5 and sample size varies from n=20 to n=40 to n=90.
Notes:
–

You can create a box plot with frequency by choosing Add X
Variable or Add Y Variable on the Plot Properties menu.

–

You can specify a variable multiple times as you choose variables
to plot as box plots.

–

The variable used to provide frequency information is added to
the label on the horizontal axis in the format:
x_variablename{frequencylist_name}.

4. Point and click the regions of the box plot to explore and analyze the
data it represents.
–

Hover over a region or over a whisker to display the details for the
portion of the plot that interests you. The label for the quartile
that corresponds to your selection displays.

–

Click a region of the box plot to select the data points or whiskers.
Click again to remove the selection.

–

You can select any box plot that does not include frequency data
and choose Dot Plot on the context menu to change the plot
type.

–

Drag a selection to move it and explore other possibilities for the
data.

–

Use the arrow keys to move a data point one pixel at a time.

–

Activate the Graph Trace tool and press 7 or 8 to move across dots
and regions of the plot. As the trace cursor moves, the values for
Q1, the median, Q3, and whisker ends/outliers display.

5. Change the plot from a modified box plot to a standard box plot by
choosing Extend Box Plot Whiskers on the Plot Properties menu.
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The box plot is redrawn as a standard box plot with extended
whiskers.
The standard box plot’s whiskers use the minimum and maximum
points in the variable and outliers are not identified. The whiskers on
the plot extend from the minimum data point in the set (x-min) to the
first quartile (Q1) and from the third quartile (Q3) to the maximum
point (x-max). The box is defined by Q1, Med (median), and Q3.
Note: You can select Show Box Plot Outliers on the Plot Properties
menu to return to the modified box plot.
When you have a numeric list with a corresponding categorical list, you
can create a box plot split by category. Adding the categorical list splits
the box plot by category. A split box plot is useful for comparing the
spread of various populations.

Plotting histograms
A histogram plots one-variable data and depicts the distribution of data.
The number of bins displayed depends on the number of data points and
the distribution of these points. A value that occurs on the edge of a bin
is counted in the bin to the right.

Creating a histogram
1. Select the data that you want to plot as a histogram.
–

For horizontal orientation, choose Add X Variable.

–

For vertical orientation, choose Add Y Variable.

2. From the Plot Types menu, select the Histogram tool.
In this example, the data from the box plot separates into points and
moves to form the bins of a histogram.
The histogram plots on the Data & Statistics work area.
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3. Explore the data in the bins of the histogram.
–

Hover over a bin to see the information for that bin.

–

Adjust the width and number by dragging the side of a bin.

–

Click a bin to select it. Click the bin again to deselect it.

–

Drag a selection to move it.
Note: The bars are not movable in categorical plots.

–

Activate the Graph Trace tool and press 7 or 8 tto move across the
bins and display values.

Creating a histogram with frequency or summary data
1. On a Lists & Spreadsheet page, create two lists: one containing the
“bins,” such as heights in a population (ht), and the other containing
the frequencies of those heights (freq).

2. On a Data & Statistics page, access the context menu on the x axis,
and select Add X Variable with Summary List.
3. Select ht as the X List and freq as the Summary List.
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Note: It is up to you to set the data and bins in a meaningful way
when using summary data.
4. Explore the data in the bins of the histogram.
–

Hover over a bin to see the information for that bin.

–

Adjust the width by dragging the side of a bin.

–

Click a bin to select it. Click the bin again to deselect it.

–

Activate the Graph Trace tool and press 7 or 8 tto move across the
bins and display values.

Modifying histogram bins
1. To modify histogram bins, select Histogram Properties on the Plot
Properties menu and choose Bin Settings.
The Bin Settings dialog displays.
2. Type values to set width and alignment of the bins that represent
histogram data:
–

To specify bin width, type a value in Width.

–

To specify bin placement, type a value in Alignment.

Note: You can also modify the bins by clicking and grabbing the edge
of any bin and dragging it to the desired size.
3. Click OK to apply the changes.
The bins of the histogram are redrawn using the values set. Both the
data represented by the bins and the value you type for the
alignment affect the placement of bins on the scale.

Adjusting the histogram scale of raw data
1. On the Plot Properties menu, select Histogram Properties and
choose Histogram Scale.
The Histogram Scale dialog displays.
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2. Choose the format for the scale of the histogram.
–

Frequency - displays data based upon the number of values that
occur within each bin (interval) on the histogram. This is the
default data representation when you create a histogram.

–

Percent - displays data in the histogram by each group’s percent

value of the whole data set.
–

Density - displays data based upon the density of each value
within the variable.

3. Click OK to complete the scale change.

Creating a normal probability plot
A normal probability plot shows one set of data against the
corresponding quartile (z) of the standard normal distribution. You can
use normal probability plots to judge the appropriateness of the normal
model for your data.
1. Choose or create the data you want to use for a normal probability
plot. Use a named list from Lists & Spreadsheet or Calculator.
2. Plot the data in one of the following ways:
–

Create a dot plot by selecting a column and choosing Quick
Graph.

–

Add a Data & Statistics work area. Click the Add Variable region
on an axis and select the data list name to plot the variable.

3. On the Plot Types menu, select Normal Probability Plot.
The data graphs in the Data & Statistics work area. You can examine
the graph to compare the normal variable against the quartile.
4. Explore the data represented in the normal probability plot.
–

Hover over a data point to display its value.

–

Click to select a data point. Click again to deselect it.

–

Click on multiple data points to select them.

–

Activate the Graph Trace tool and press ¡ or ¢ to move across the
data points and display values.

Creating a Scatter Plot
A scatter plot shows the relationship between two sets of data. You can
also plot a scatter plot by using the Quick Graph tool in the
Lists & Spreadsheet application.
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1. In the Data & Statistics work area, click the Add Variable region and
select the variable that contains the data you want to see represented
on an axis.
The plot of the selected variable displays on the axis.
2. Click the Add Variable region of the other axis and select the variable
containing the data you to plot.
The data points shift to represent the data in the selected variable.

3. Analyze and explore the data in the plot.
–

Click a point to select it.

–

Hover over a data point to view the summary data.

–

Work with the data using the available tools on the Analyse
menu. For example, choose the Graph Trace tool and press ¡ or ¢
to move across the plot.

4. Optional: To plot additional lists against the x-axis, right-click the
y-axis and select Add Variable.

Creating an X-Y line plot
An X-Y line plot is a scatter plot in which the data points are plotted and
connected in order of appearance in the two variables. Like scatter plots,
these plots depict the relationship between two sets of data.
By convention, the left-most column of data is represented on the
horizontal axis.
1. Create a scatter plot. See Creating a scatter plot for details.
2. On the Plot Types menu, select the XY Line Plot tool.
The data points within each set are connected to each other by a line.
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Note: The dots are connected in the order that they appear in the list
variable on the horizontal axis. To change the order, use the sort tool
in Lists & Spreadsheet.
3. Analyze and explore the data in the plot.
–

Hover over a data point to view the summary data.

–

Work with the data using the available tools on the Analyse
menu. For example, choose the Graph Trace tool and press the
arrow keys to move across the dots in the plot and view the
values.

Working with categorical plot types
You can sort and group data using the categorical plot types:
•

Dot Chart

•

Bar Chart

•

Pie Chart

The categorical plot types can be used to compare the representations of
data across different plots. When the same variable (list) is used for a dot
chart and a bar chart or pie chart in a problem, selecting a data point or
segment in one of the plots selects the corresponding data point,
segment, or bar in all other plots that include the variable.

Creating a dot chart
The default plot type for categorical data is the dot chart.
When one variable is plotted, the value of each cell is represented as one
dot, and the dots are stacked at the point on the axis that corresponds to
the cell value.
1. In Lists & Spreadsheet, create a spreadsheet that includes at least one
column of string values that can be used as categories for data.
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Note: To type a string in Lists & Spreadsheet, enclose the characters in
quotes.
2. Add a Data & Statistics page to the problem.
Notes:
–

You can also use the Lists & Spreadsheet Quick Graph tool to
automatically add a Data & Statistics page and plot the selected
column.

–

The new Data & Statistic work area displays a default case plot
with a title, variable name, and unplotted data points for the
variable. You can click the variable name in the title to choose
another variable for previewing, or drag a default data point
toward an axis to plot the current variable.

3. Move near the center of either axis and click the Add List region. The
list of variables displays.
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4. Click the list that contains the categories you want to use for sorting
data.

A dot chart plots in the work area. The application labels the axis with
the variable name and shows a dot for each instance of a category.
5. Explore the plotted data.
–

Hover over a dot in the plot to display data values.

–

Click a dot to select it. Click the dot a second time to deselect it or
remove it from a selection of multiple dots.

–

Activate the Graph Trace tool and press 7 or 8 tto move across the
points in list order. Dots display a bold outline as you move across
them in Trace mode.

Creating a bar chart
Like dot charts, bar charts display categorical data. The length of a bar
represents the number of cases in the category.
1. Click the Add Variable region of either axis and choose the name of a
categorical variable. See Creating a dot chart for details.
2. On the Plot Types menu, select Bar Chart.
The dot chart changes to a bar representation of the data.
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3. Explore the data in the plot.
–

Hover over a bar to see a category summary (the number of cases
and percentage among all categories).

–

Activate the Graph Trace tool and press 7 or 8 move across the
bars and view summary information.

Creating a bar chart from a frequency table or summary
data
1. On a new Data & Statistics page, create a bar chart with frequency or
summary data by choosing Add X Variable on the Plot Properties
menu.
Note: You can also create a bar chart with frequency by choosing
Add Variable with Summary List from the context menu of the Add
Variable region of an axis.
2. Select the desired variable from the pop-up.
3. Set the height of the bars with the summary variable by selecting Add
Summary List from the Plot Properties menu.
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4. Select the summary list from the pop-up.
The bar chart plots on the work area. The icon in the lower left corner
indicates that this plot was generated from summary data.

5. Hover over a bar to see a category summary, or use the Graph Trace
tool on the Analyse menu to move across all of the bars displaying
the summaries.
6. (Optional) Add summary lists to create a comparative bar chart.

Creating a pie chart
A pie chart represents categorical data in a circular layout and uses an
appropriately proportioned segment for each category.
1. Create a dot chart on the work area.
2. On the Plot Types menu, select Pie Chart.
The dots move by category into the segments of the pie chart.
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3. Hover over a segment to see the summary for the category, or use the
Graph Trace tool on the Analyse menu to move across each segment
displaying all of the summaries. The summary shows the number of
cases for the category and the percentage among all cases.
Note: You can switch to a pie chart from a bar chart generated from
summary data.

Creating a comparative bar chart
This might be used to explore data in a 2-way table.
1. Enter the raw data on a Lists & Spreadsheet page.

2. From the Insert menu in the toolbar, select Data & Statistics.
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Note: Your screen may differ, depending on the data you entered.
3. Click the Click to add variable field, and select eyecolor as the
variable for the x axis.
4. On the Plot Type menu, select Bar Chart.
The frequency of the eyecolor data is plotted.

5. To split the eyecolor data by gender, select the Plot Properties menu,
select Split Categories by Variable, and then select gender.

Splitting a numeric plot by categories
You can use a categorical split to sort the values plotted on an axis.
1. Open a problem that includes a Lists & Spreadsheet page, or create
data to be plotted in the Lists & Spreadsheet application.
In this example, lists contain dog breed and weight information.
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2. Click the column letter (A) to highlight the breed column.
3. On the Lists & Spreadsheet Data menu, select the Quick Graph tool.
The Quick Graph tool adds a Data & Statistics page. Data & Statistics
plots the variable and labels the horizontal axis.

4. To plot the numeric data for each category, hover on the Add
Variable region near the center of the vertical axis and click the
tooltip Click or Enter to add variable.
The list of available variables displays.
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5. On the list of variables, click the name of the numeric variable.

Data & Statistics labels the vertical axis and plots the numeric data for
each category.

Exploring data
You can manipulate and explore plotted data.
•

Select and move points or data bins

•

Change the type of plot

•

Rescale the graph

•

Add a movable line

•

Show regression lines

•

Show residual squares

•

Show a residual plot
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Moving points or bins of data
1. Click and hold the desired point or bin.
The cursor changes to ÷.
2. Drag the point or bar to the new location and release it. Moving the
point changes the values for x and y.

If you are working with data from Lists & Spreadsheet, the data that
corresponds to the original point or bar automatically updates in the
original column(s) in Lists & Spreadsheet as you move the point.
You can also move points or bins by changing the numbers in the
Lists & Spreadsheet or Calculator applications. Data will update in all
of the representations.

Moving multiple points
1. Position the pointer over each data point that you want to select.
When the pointer changes to ÷, click to add the point to the
selection.
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Alternatively, you can drag a selection rectangle around the points to
select them.

2. Drag any of the selected points to move them all.
Note: When a list is defined in Lists & Spreadsheet as a formula, the
movement of points is restricted to positions that satisfy the formula.

Sorting plotted categories
You can sort plotted categories in list order, value order, or alphabetically
by category name.
1. Click the work area that contains the plotted data.
2. On the Actions menu, select Sort, and select the type of sort.

Months listed chronologically but plotted by value
(amount of rain)

Note: You can customize the order of the categories by clicking a label
and dragging it.

Plotting a value
You can plot a value on an existing plot. It displays as a vertical line in the
work area.
1. From the Analyse menu, select Plot Value.
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A text box with a default expression opens in the work area.
Plot value
entry box

2. Type the value you want to plot, and press ·. In this example, the
value is v1:= mean(cost).
The line is drawn at that value, perpendicular to the axis. If you have
multiple plots on the work area, a plot value segment displays for
each plot.
Note: If you use a frequency table to generate a histogram, reference
the frequency list in your expression. For example, type the
expression ”v1:= mean(cost, frequency)” in the plot value entry box.
3. Click the line to display the value.
Note: Double-click the value to edit the expression.

Plot value line with value displayed

You can use Plot value for a single number or any expression that
evaluates to a number. If the value is dependent on the data, like
mean, when you drag a point or make changes in the
Lists & Spreadsheet application, the line updates to reflect the
change, allowing for investigation of the influence of points on the
calculation.
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Removing a plotted value
1. Select the plotted value line.
2. From the Actions menu, select Remove Plotted Value.

Changing the plot type
You can change the plot type, to view different representations of data.
f On the Plot Type menu, select a new plot type. Only the supported
plot types are available. For example, only univariate plot types are
available when a single variable plotted on an axis.
The data representation changes to the new plot format.
Note: Options are unavailable on the menu if the plotted data
cannot be represented by the plot type. For example, if a scatter plot
is displayed in the work area, you cannot create a box plot without
first removing the variable from the y-axis.

Rescaling a graph
You can change the scale of the axes by using translation and
Enlargement:
Enlargement region

Translation region

Enlargement
region

Translation
region

Enlargement
region

The cursor changes to indicate whether translation (ö) or Enlargement
(ô) is available in zones on the axes.

Translation
A translation slides a set of axes a fixed distance in a given direction. The
original axes have the same shape and size.
1. Position the cursor over a tic mark or label in the middle third of the
axis. The cursor changes to ö.
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2. Click to grab. The cursor changes to ù. Drag the cursor to the desired
position and release.

Enlargement
Enlargement retains the shape of the axes, but enlarges or reduces the
size.
1. Position the cursor over a tic mark or label near the ends of the axis.
The cursor changes to ó on the vertical axis or ô on the horizontal
axis.

2. Click to grab. The cursor changes to ÷. Drag the cursor to the desired
position and release.

Adding a movable line
You can add a movable line to a plot. Moving and rotating the line on
the work area changes the function that describes it.
f From the Analyse menu, select Add Movable Line.
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The movable line displays and is labeled with a function that
describes it. For this example, Data & Statistics stores the expression
for the movable line in the variable m1.

Rotating a movable line
1. Click and grab on either end of the line.
The cursor changes to é.
2. Drag to rotate and change the slope of the line.

The function m1(x) is updated for the changes in the position of the
movable line.

Changing the intercept
1. Click in the middle of the movable line.
The cursor changes to ö.
2. Drag to change the intercept.
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The number at the end of the equation changes to show the change
in the intercept.
Note: The movable line is stored as a function that can be used for
prediction in the Calculator application.

Locking the intercept at zero
You can lock the intercept of the movable line at zero.
f From the Analyse menu, select Lock Intercept at Zero.
You can unlock the intercept by choosing Unlock Movable Line
Intercept on the Analyse menu.

Tracing a movable line
You can trace a movable line to predict and analyze values.
1. Click the line.
The cursor changes.
2. From the Analyse menu, select Graph Trace to enable Trace mode for
the line. Rotation of the line is not supported in Trace mode.
3. Press ¡ or ¢ (left or right arrow keys) to trace the movable line.
If the plotted variables change, points on the graph and the line are
updated automatically.

Showing a line of regression
You can show a line of regression when you have a scatter plot or an X-Y
line plot on the work area. Studying the line of regression can help you
understand the relationship between two variables.
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1. With a scatter plot or X-Y line plot of two variables on the work area,
select the Analyse menu, choose Regression and view the list of
regressions.
2. Click the type of regression line to show. For example, choose Show
Linear (mx+b) to plot a linear regression line as shown in the
following example.

When the line of regression is selected, the expression for the line
displays.

Showing residual squares
You can display residual squares on a plot. Residual squares can help you
assess the appropriateness of the model for your data.
Note: This tool is only available when a regression or movable line is
present in the work area.

f From the Analyse menu, select Residuals > Show Residual Squares.

The sum of squares is updated as the line or data changes.
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Showing a residual plot
You can show a residual plot to determine how well a line fits data. The
work area must include a scatter plot and one or more movable lines,
regressions, or plotted functions for Show Residual Plot to be available.
f With a scatter plot, line of regression, and/or movable line in the
work area, select the Analyse menu, and select Show Residual Plot >
Residuals.

Notes:
•

With multiple regressions or functions and movable lines plotted, you
can select each by clicking the line to show its residual plot.

•

Click and hold a dot on the residual plot to see the residual.

•

The residual plot for the selected regression or function displays in
the work area.

•

For consistency in comparing sets of data, residual plots do not rescale
when you move from one function or regression to another.

•

Select a function or regression before a showing residual plot. If no
function or regression is selected and there are several plotted, Data
& Statistics arbitrarily selects the function or regression for showing
the residual plot.

•

Axes can be adjusted by clicking and dragging.

Removing a residual plot
f With a scatter plot, line of regression, and/or movable line in the
work area, select the Analyse menu, and select Hide Residual Plot.

Using Window/Zoom tools
Use the Window/Zoom tools to redefine the graph to better view points
of interest. The Window/Zoom tools include:
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•

Window Settings: displays a Window Settings dialog that lets you
enter the x-min, x-max, y-min, and y-max values for the axes.

•

Zoom - Data: adjusts the zoom factor to display all plotted data.

•

Zoom - In: lets you to define the center point of the zoom in location.
The Zoom In factor is approximately 2.

•

Zoom - Out: lets you define the center point of the zoom out
location. The Zoom Out factor is approximately 2.

Using the Window Settings tool
1. On the Window/Zoom menu, select Window Settings.
2. The Window Settings dialog opens. The current values for x-min,
x-max, y-min, and y-max display in the fields.
Note: Only the appropriate boxes are editable, depending on
whether there are one or two axes in the work area.
3. Type the new values over the old values.
4. Select OK to apply the changes and redraw the plot.

Using the Zoom Data tool
f On the Window/Zoom menu, select Zoom Data.
The work area rescales to display all plotted data.

Using the Zoom In tool
1. On the Window/Zoom menu, select Zoom In.
2. In the work area, click the center point of the area of interest. This
will be the center of the zoom in action.
The plot redraws to focus and enlarge the portion of the plot
centered about the point you selected in the previous step.

Using the Zoom Out tool
1. On the Window/Zoom menu, select Zoom Out.
2. In the work area, click the center point of the area of interest. This
will be the center of the zoom out action.
The plot redraws to display a larger portion of the plot, centered
about the point you selected in the previous step.

Graphing Functions
You can graph functions by typing them in Data & Statistics, or you can
graph functions defined in other applications.
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Graphing functions using the Plot Function tool
You can use the Plot Function tool to plot functions in a work area that
already includes a plot on the axes. Plot Function lets you specify and
graph a function for comparison to an existing plot.
To use the Plot Function tool:
1. Create or open a problem that includes variables (from Lists &
Spreadsheet) that are plotted on a Data & Statistics work area. Ensure
that your work area contains both a horizontal axis and a vertical axis
scale.
2. From the Analyse menu, select Plot Function.
A function entry field displays in the work area.

Plot Function
entry field

Plot from
variables

Note: You can edit the function’s expression typed in the entry field.
However, the function graphed in Data & Statistics cannot be
manipulated or moved around the work area. To do that, use Graphs
& Geometry.
3. Type the function in the entry field, and press ·.
Note: You can rename the function by typing over f1(x): with another
name, if you choose.
The function graphs in the work area and is saved as a variable for
use in other applications.
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Function
graph

Function
equation

Entering functions from other applications
You can enter a function that has been defined as a variable in another
application, such as Lists & Spreadsheet, Graphs & Geometry or
Calculator.
1. Add a variable to each axis. You can access any variables defined in a
Lists & Spreadsheet or Calculator application in your problem from
the variable list.
2. From the Analyse menu, select Plot Function.
A function entry field displays in the work area.

3. Click h.
A list of variables available in the problem displays.
4. Click to select the variable containing the function you want to plot.

In the example below, the variable a contains the function f(x)=x2.
Using Data & Statistics

407

5. Press ·.
The function plots in the work area.

Editing a function
You can edit a function and update it on the work area.
1. You can edit a function by double-clicking the equation and then
making changes as required.
2. Press · after making all changes and the updates display in the
work area.

Using Data & Statistics functions in other applications
Data & Statistics functions are stored as variables, and may be used in
other applications, in the same manner as any other variable. Support for
all function types is included.
Note: Function numbers increment to use the next available. If you have
defined f1(x) and f2(x) in Graphs & Geometry, the first function you
create in Data & Statistics will be f3(x).

Using Show Normal PDF
You can approximate data plotted in the Data & Statistics work area
against the normal probability density function. The tool overlays the
normal probability density function using the mean and the standard
deviation of the data in the histogram.
To show the normal probability density function for plotted data:
1. Add a variable to the x-axis.
2. On the Plot Types menu, select Histogram.
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Note: Show Normal PDF is available only when histogram is the plot
type.
3. From the Analyse menu, select Show Normal PDF.

The normal PDF for the graph plots in the work area. The expression
used to calculate the PDF displays when selected.
You can select Hide Normal PDF on the Analyse menu to remove the
PDF.

Using Shade Under Function
Use Shade Under Function to find the area of a selected region under a
function graphed in the work area.
1. Select any function graphed in the Data & Statistics work area. For
example, select a previously graphed normal PDF.
2. From the Analyse menu, select Shade Under Function.
The cursor becomes a dotted vertical line and the boundary +/- ˆ
displays when you position the mouse near the boundary on the left
or right. You can click when ˆ displays to set it as a boundary.
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3. Select a point on the curve and click to indicate where to start
shading under the function. The direction in which you move next
determines whether the region shaded is on the left, right, or center
of the curve.
4. Select a point on the curve and click to indicate the end boundary of
the shaded area. A region under the function is shaded based on the
points you selected.
You can work with Shade Under Function in the following ways:
–

Select the region to display the values for data points in the
shaded area.

–

To remove the shading, right-click or /-click the shaded region
and choose Remove Shaded Region.

–

To change the fill color of the shaded area, right-click or /-click
the shaded region, choose Color, choose Fill, and click a color.

–

Use plot value to set the boundary to an exact number. When a
boundary for shading is set to a plotted value, you can change the
plotted value to update the shading.

–

Edit a shaded region by clicking and dragging the edge at the
starting or ending boundary.

Using Graph Trace
Graph Trace lets you move from one point on a graph to another in order
to analyze variations in the data. You can use Graph Trace mode to
explore the data for the following graphs.
•

Graphs from Plot Function and Show Normal PDF

•

Distribution curves (created in the Lists & Spreadsheet application)

•

Movable Lines
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•

Regressions

•

Case plots

•

Dot plots

•

Scatter plots and X-Y line plots

•

Box plots

•

Histograms

•

Bar charts

•

Pie charts

1. From the Analyse menu, select Graph Trace.
2. Press ¡ or ¢ to move across the plot.
The data representations enlarge and display with a bold outline as
you move across them in Trace mode.

Customizing your workspace
Working with color
All data points for a plotted variable display in the same color to
distinguish them from the data points of other variables. Data plotted by
category and split plots automatically display in different colors to help
you distinguish the data.
To emphasize or distinguish certain parts of your work, you can change
the default color for a variable’s data.
•

Apply fill colors to objects, such as shading, or change the color for a
variable’s data points.

•

Apply color to plotted lines (such as lines of regression) or movable
lines.

TI-Nspire™ handhelds without color show color objects in shades of gray.
The color information is preserved in the document unless you change
color from the handheld. If you choose to, you can work in grayscale
mode to view objects in the desktop software similarly to how they
appear on the handheld.

Inserting a background image
When using the computer software, you can insert an image as a
background for a Data & Statistics page. The file format of the image can
be .bmp, .jpg, or .png.
1. From the Insert menu, select Image.
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2. Navigate to the image that you want to insert.
3. Select it, and then click Open.
The image is inserted as a background.
For more information, refer to the Working with Images chapter.

Working with text
The Insert Text tool lets you type text to describe details related to plots
on the work area.
1. From the Actions menu, select Insert Text.
A text box displays.
2. Type notes or descriptions in the text box.

3. Customize the text to suit your needs.
–

Move the cursor over the edges of the text box to drag the
borders and change the width or height.

–

Click and grab the text box to move it near objects that relate to
the text.

–

Scroll to view additional text in a box by clicking the arrows at the
top and bottom edge.

–

Click outside of the text entry box to exit the Text tool.

–

Hide text by selecting the Actions menu and choosing Hide Text.

–

Change the color of text.

Adjusting variable values with a slider
A slider lets you easily explore the effects of adjusting a numeric variable
through a range of values. You can control a slider's location and visual
appearance, and its adjustment range and step size.
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Horizontal slider showing variable name, current value, and range.

Ã
Ä

Slider track

Vertical slider
Slider “thumb” that you can drag to adjust the current value of the
variable

Minimized sliders with arrows to adjust the variable’s current value

Inserting a slider
You can insert sliders on a Graphs page, a Geometry page, or a
Data & Statistics page.
1. From the Actions menu, select Insert Slider.
A gray image of a horizontal slider with default settings attaches
itself to the pointer.

2. Drag to position the slider, and click to release it.

3. Press · to accept the default name (such as V1), or type the name
of a numeric variable that you want to assign and then press ·.
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Setting up the slider
You can change many slider settings, such as Minimum and Maximum, by
clicking parts of the slider. Some settings, such as Step Size, are accessible
only through the Slider Settings dialog.
1. Right-click in the slider to display its context menu, and select
Settings to display the Slider Settings dialog.
Handheld: Point to the slider, press / b, and select Settings.
2. Use the Slider Settings dialog to enter settings for the slider. Each
setting is described below. Settings that accept a numeric value also
accept an expression that evaluates to a numeric value.
VariableSpecifies which variable is assigned to the slider. Type an
available numeric variable name, or click the drop-down arrow and
select a name from the list.
ValueSets the current value of the variable.
MinimumSets the lowest value in the slider range (left or bottom end
point on the track).
MaximumSets the highest value in the slider range (right or top end

point on the track).
Step SizeSets the size of the increment between values. The default
setting is Automatic. To enter a specific size, click the drop-down
arrow, select Enter Size, and type a positive numeric value.
StyleClick the drop-down arrow to choose Horizontal or Vertical.

Display DigitsSpecifies the display format of the variable’s current
value. Choose Auto to display the value according to the Document
Settings option. Click the drop-down arrow to choose from floatingpoint or fixed formats.
Show VariableShows or hides the variable name in the slider.
Show ScaleShows or hides the scale in a maximized slider.

Adjusting a slider variable’s current value
f After setting up a slider, use one of these methods to adjust the
current value:
–

414

Grab the slider thumb (

Using Data & Statistics

or

) and drag it.

–

Click the slider thumb, and then press 9, :, 7, or 8.

–

Click after the “=” or press e as necessary to select the current
value, and type a numeric value.

–

Click a new position on the track.
Note: Any time the variable’s current value is outside the slider’s
defined range, the thumb is not displayed. To bring the value
inside the slider’s range, click the slider track or arrows.

Repositioning a slider on the page
f Grab and drag any empty space in the slider’s selection rectangle, or
click an empty space in the slider and then press 9, :, 7, or 8.

Mimimizing a slider
f To minimize a slider and display only the variable name, current
value, and direction arrows, access the slider’s context menu and
select Minimize.

f To further minimize a slider and show only the arrows, access its
context menu and uncheck Show Variable.

Stretching a slider
f Grab the Minimum or Maximum end point on the track, and drag it.

Note: Stretching or shrinking a slider affects only the length of the
track. The Minimum and Maximum values do not change.

Animating a slider
An animated slider steps repeatedly through its range, using the slider’s
Step Size.
f Access the slider’s context Menu and select Animate.
Note: To stop the animation, click Stop Animate. Animation also
stops if you lock the slider’s associated variable.
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Removing a slider
Removing a slider does not delete the variable associated with the slider.
1. Click in the slider’s selection rectangle to select it.
2. Press ..

Tips for using sliders
Use multiple sliders for a variable
•

You can assign the same variable to multiple sliders. This lets you see
the effect of adjusting a variable by different step sizes or through
different ranges.

Deselect a slider
•

To deselect a slider, click another part of the work area, press d, or
press e e to move to another element in the work area.

Associate a different variable with a slider
•

Click the text box for the variable name and type the name of the
numeric variable to use.

•

With the slider active, click the h button to select a variable from
the list.

Inferential Statistics
You can explore hypothesis tests and probability distributions in the
Data & Statistics application after entering the data on a
Lists & Spreadsheet page.

Drawing inferential statistics plots
The following example uses the Draw option of the normCdf() function
to plot a distribution model.
1. On a Lists & Spreadsheet page, select the column-formula cell (second
cell from the top) in column A.
2. From the Statistics menu, select Distributions, and select
Normal Cdf.
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3. Enter the plot parameters into the Normal Cdf wizard.
4. Click the Draw check box to see the distribution plotted and shaded
in Data & Statistics.
Note: The Draw option is not available for all distributions.
5. Select OK.

Exploring inferential statistics plots
After drawing the plot in the previous example, you can explore the
effect of changing the upper bound.
f On the Data & Statistics plot, drag the vertical line that represents the
upper bound toward the left or right.
As you drag, the formula is updated and the shaded area is
recalculated.
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417

418

Using Data & Statistics

Using Notes
The Notes application lets you create and share text documents using the
TI-Nspire™ handheld and computer software. Use Notes to:
•

Create study notes to reinforce learning, demonstrate your
understanding of classroom concepts, and to review for exams.

•

Edit collaboratively by assigning different roles to individuals using
your document so that any edits appear in a different text format.

•

Create math expressions.

•

Perform calculations using math expression boxes.

Getting started with the Notes application
To add a blank Notes page to an existing or new document:
•

In a new document, select Add Notes from the menu.

•

In an existing document, select Notes from the Insert menu

•

From a handheld, click
to open a new document with a notes
page or add a notes page to an open document.

The Notes work area is displayed in Default mode.

Using the Notes menu
Options on the Notes menu enable you to:
•

Perform actions such as evalulate and approximate expressions

•

Select a template:
–

Q&A for questions and answers

–

Proof for an outline structure containing statements and reasons
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–

Default for freeform text entry

•

Insert math expressions, shapes, comments, or images

•

Format the text in a note

•

Customize a math expression

•

Perform calculations

Opening Notes
On your desktop, the Notes menu icons are displayed in Documents
Toolbox panel. With the Notes application active, click
Notes menu.

On a handheld, press b to open the Notes menu.

420

Using Notes

to open the

À

Á
À

Notes tool menu – This menu is available anytime you are in the Notes
work area.

Á

Notes work area -- The area where you enter and format text.

Using templates
Use the options on the Templates menu to select a format for your Notes
page.

Menu
Name

Menu Option

Function

2: Templates
1: Q&A

Creates a template to enter
question and answer text.

2: Proof

Creates a template to enter
statement and reason text.

3: Default
4:Hide Answer (Q&A)

Lets you enter freeform text.
Toggles to show or hide the
Answer in a Q&A format.
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Selecting a template
Complete the following steps to select and apply a template:
1. From the Notes menu, click

.

2. From the drop-down menu, select the template you want to apply.
Handheld: From the Notes work area, press b, then press ¢ to
display the menu options.

The Notes page is displayed in the format you selected.

Using the Q&A template
Use the Q&A template to create questions and answers. You can show or
hide the answer so you can create questions for review and hide the
answers. When you use the document as a study aid, you can verify that
your answers are correct.
Press e to move the text cursor between the Question and Answer
areas of the template.

Using the proof template
The proof template provides an outline structure for statements and
corresponding reasons.
Press e to move the text cursor between the Statements and Reasons
areas of the template.
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Formatting text in Notes
Use the formatting tools on the Text options menu to specify bold, italic,
underlined, subscript, or superscript text.

Menu
Name

Menu Option

Function

4: Format

2: Bold

Toggles the selected text between
bold and not bold, and removes all
other formatting.

3: Italic

Toggles the selected text between
italic and not italic, and removes all
other formatting.

4: Underline

Toggles the selected text between
underlined and not underlined, and
removes all other formatting.

5: Subscript

Toggles the selected text between
subscripted and not subscripted, and
removes all other formatting.

6: Superscript

Toggles the selected text between
superscripted and not superscripted,
and removes all other formatting.
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Selecting text
f Select the text.
–

Drag from the starting point to the ending point to select the text.

–

Handheld: If you are using the Q&A or Proof template, press e

to place the cursor in the area containing the text. Use the
touchpad to place the cursor at the start or end of the text to be
selected. Hold down g, and use the touchpad to select the
text.

Applying a text format
f To apply a text format, select the text in the Notes work area, then do
the following:
–

On the Format menu, select the name of the format to apply.

–

Handheld: Press b to display the Notes menu. On the Format

menu, select the name of the format to apply.

Note: You can restore the text to normal by reapplying the same
format.

Using color in Notes
When working in the Notes application on a desktop, use the

(fill

color) or the
(text color) options on the Documents workspace tool
bar to emphasize words, calculations, and formulas.
You can also apply color to text when working in the Notes application
on the TI-Nspire™ CX handheld.
Note: If you transfer a document that contains color to a TI-Nspire™
handheld, the colors are converted to gray scale.
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Changing text colors
By default, Notes text is black. Complete the following steps to change
the color of the text.
1. Select the text you want to change to another color. You can select a
sentence, a phrase, a word, or a single letter. You can also select a
calculation or a formula.
2. From the Documents workspace tool bar, click

.

From a handheld, press ~, then select Edit > Text Color.
3. When the Text Color palette is displayed, click a color to apply it to
the selected text.

Applying a background color
Use a background color to emphasize text in a note by using the fill color
tool to apply a background color. Complete the following steps to apply
a background color.
1. Select the text you want to highlight with a background color.
2. From the Documents workspace tool bar, click

.

From a handheld, press ~, then select Edit > Fill Color.
3. When the Fill Color palette is displayed, click a color to apply it to the
selected area.

Inserting Images
When working in the Notes application on a desktop, use the Images
option on the Insert menu to add an image to a Notes page.
Note: The option for inserting an image is not available when working
on a handheld. However, you can transfer a file containing an image
from your computer to a TI-Nspire™ CX handheld and colors are
retained. If transferred to a TI-Nspire™ handheld, the colors in the image
are converted to gray scale.
1. Select Insert > Image from the Documents workspace tool bar. The
Insert Image window opens.
2. Navigate to the folder where the image is located.
3. Select the image, then click Open to insert the image into the Notes
work area. Valid files types are .jpg, .png, or .bmp.
4. To type text around the image, place the cursor in front of the image
or after the image, then type the text.
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Resizing an image
Complete the following steps to resize an image.
1. Click on the image to select it.
2. Move the mouse pointer to the edge of the image. The pointer
changes to a left-right arrow symbol.
3. Click the mouse and hold to enable the { tool, then drag the image
to make it smaller or larger.
4. Release the mouse button when the image is sized correctly.
For detailed information about inserting images, refer to the Using
Images chapter.

Inserting math expressions, shapes, or comments
When working with the Notes application on a handheld, open the Insert
menu to insert a math expression, shape, or a comment.

Menu
Name

Menu Option

Function

3: Insert
1: Math Box - / M

Lets you insert a math
expression.

2: Shape

Marks the selected text as an
angle, triangle, circle, line,
segment, ray, or vector.

3: Comment

Lets you enter text that is
italicized and prefaced with
Teacher or Reviewer.

Inserting comments
You can insert Teacher or Reviewer comments into a Notes application.
Comments are easy to distinguish from the original text.
1. Define the type of comments you’re inserting (Teacher or Reviewer):
–
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On the Insert menu, select Comment, and then select Teacher or
Reviewer.
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–

Handheld: While in the Notes work area, press b to display the
Notes menu. Press Insert > Comment, and then either Teacher or
Reviewer.

2. Enter your text.
Text that you enter appears in italics.

Inserting geometric shape symbols
You can use geometric shape symbols to designate selected text as
geometric objects, such as an angle, circle, or line segment.
f To insert a shape symbol, position the cursor where you want it, then
do the following:
–

On the Insert menu, select Shapes, and then select the shape to
apply.

–

Handheld: Press b to display the Notes menu. On the Insert
menu, select Shapes, and then select the shape to apply.
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Entering math expressions
You can include math expressions in Notes text, using the same tools as in
other TI-Nspire™ applications.
Math expression boxes have attributes that allow you to control how the
expression displays.

Menu
Name

Menu Option

Function

5: Math Box Options
1: Math Box Attributes

2: Show Warning Info

3: Show Error

When a math box is selected,
this option opens a dialog box
allowing you to customize the
math box. You can hide or
show input or output, turn off
calculation for the box, insert
symbols, change display and
angle settings, and allow or
disallow the wrapping of
expressions and the display of
warning indicator after they
have been dismissed. You can
change the attributes of
multiple selected math boxes
at the same time.
Displays a warning indicator
after the warning has been
dismissed.
Displays an error after the
error has been dismissed.

Entering an expression
1. In the Notes work area, place the cursor where you want the
expression. Then do the following:
–

Windows®: On the Insert menu, select Math Expression Box or
Ctrl + M.

–
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Macintosh®: Press ì“+ M.
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Handheld: Press b to display the Notes menu. On the Insert
menu, select Math Expression Box.

–

2. Type the expression. You can use the Catalog, if necessary, to insert a
function, command, symbol, or expression template.

Evaluating and approximating math expressions
You can evaluate or approximate one or more expressions and display
the results. You can also convert selected text and multiple math
expression boxes into a single math expression box. Notes automatically
updates expressions and any variables used.

Menu
Name

Menu Option

Function

1: Actions

1: Evaluate - ·

Evaluates the expression.

2: Approximate / ·

Approximates the expression.

3: Evaluate and replace

Replaces the selected part of
the expression with the result.

4: Deactivate

Deactivates the current or
selected item (box or boxes)

5: Deactivate All

Deactivates all boxes in the
current Notes application.

6: Activate

7: Activate All

Activates the current or
selected previously
deactivated item.
Activates all boxes in the
current Notes application.

Evaluating or approximating an expression
f To evaluate or approximate an expression, place the cursor anywhere
in the math expression box and then do the following:
–

Windows®: On the Actions menu, select Evaluate or
Approximate. You can also use Enter to evaluate or Ctrl + Enter
to approximate.

–

Macintosh®: Press “ + Enter to approximate.
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Handheld: Press b to display the Notes menu. On the Actions
menu, select Evaluate.

–

The result replaces the expression.

Evaluating part of an expression
f To evaluate part of an expression, select the text or part of the math
expression. Then do the following:
–

On the Actions menu, select Evaluate and Replace.

–

Handheld: Press b to display the Notes menu. On the Actions
menu, select Evaluate Selection.

The result replaces the selected part only.

Breaking long calculations
Some calculations may take a long time. Notes indicates that the
handheld is performing a long calculation by displaying a busy icon. If a
calculation is taking more time than you want to spend, you can end the
calculation.
To stop the function or program in progress, do the following:
–

Windows®: Hold down the F12 key and press Enter repeatedly.

–

Macintosh®: Hold down the F5 key and press Enter repeatedly.

–

Handheld: Hold down the c key and press · repeatedly.

Showing warnings and errors
If a calculation in Notes results in a warning or error, you can view the
warning or error again even after you have dismissed the dialog box.
To display a warning or error in Notes after you have dismissed the dialog
box, do one of the following:
–

Windows®: Right-click and select Show warning info or Show
error.

–

Macintosh®: ì“ + click and select Show warning info or Show
error.

Note: You can change your settings so that warnings do not appear at
all. The showing of warning indicators is controlled by the Math Box
Attributes dialog box. See Changing the attributes of math expression

boxes.
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Converting selected items to math expression boxes
f To convert items to math expression boxes, first select the text, or
combination of text and existing math expression box, to evaluate.
Then do the following:
–

On the Actions menu, select Convert to Math Expression Box. Or
right-click and select Convert to Math Expression Box.

–

Handheld: Press b to display the Notes menu, and then press
Actions > Convert to Math Expression Box.

The result replaces the selected part only.

Deactivating math expression boxes
Calculations are by default activated, which means that results
automatically update when you evaluate or approximate an expression.
If you don’t want results to automatically update, you can deactivate a
math expression box, group of boxes, or the entire application.

Deactivating a box or a group of boxes
To deactivate a box or a group of boxes, do the following:
1. Select the box or boxes that you want to deactivate.
2. Deactivate the selected box or boxes:
–

Windows®: Select Actions > Deactivate or right-click and select
Actions > Deactivate.

–

Macintosh®: Select Actions > Deactivate or ì“ + click and select
Actions > Deactivate.

–

Handheld: Press b to display the Notes menu. On the Actions
menu, select Deactivate.

Note: You can manually update a deactivated box or boxes by

selecting the box or boxes and using the process described in
Evaluating and approximating math expressions.

Deactivating all boxes in the Notes application
To deactivate all boxes in the Notes application, do the following:
f With a document open, place your cursor in the Notes application
that you want to deactivate and select Deactivate All.
–

Windows®: Select Actions > Deactivate All or right-click and
select Actions > Deactivate All.

–

Macintosh®: Select Actions > Deactivate or ì“+ click and select
Actions > Deactivate.
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–

Handheld: Press b to display the Notes menu. On the Actions
menu, select Deactivate.

Note: When you use this option in Q&A and Proof templates,
Deactivate All deactivates only the math boxes in the current work
area.

Changing the attributes of math expression boxes
You can change attributes in one or more math expression boxes at the
same time. Controlling the attributes in math expression boxes allows
you to do the following:
•

Show or hide the input or output, or prevent calculation in the
box.

•

Select a symbol separator using Insert Symbol.

•

Choose the number of digits to display in the output of a math
expression.

•

Select angle settings so you can use both radian/degree and
gradian angle measures in the same Notes application.

•

Select whether to allow math expressions to wrap.

•

Select whether to show or hide warning indicators.

To change the attributes of one or more boxes, do the following:
1. Select the box or boxes that you want to change.
2. On the Math Box Options menu, select Math Box Attributes.
3. Use the drop-down menus or selection boxes to make your selections.
4. Click OK to save or Cancel to abandon the change.
Note: Math expression boxes recalculate automatically after you have
made attribute changes and saved the changes.

Undoing changes to math expression boxes
f To undo changes you have made to a math expression box, click
/ Z.

Using calculations in Notes
In the Notes application, the options on the Calculations menu enable
you to perform calculations. The calculations are described in the
following table.
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Important information to know
•

Notes does not support editing programs. Use Program Editor
instead.

•

Notes does not support executing Lock or Unlock commands. Use
Calculator instead.

•

Notes does not display intermediate results obtained via "Disp"
command. Use Calculator instead.

•

Notes does not support user-defined dialog boxes obtained via
"Request," "RequestStr," or "Text" commands. Use Calculator
instead.

•

Notes does not support the execution of multiple statistics commands
that produce stat. variables.

Menu
Name

Menu Option

Function

6: Calculations
1: Define Variables

2: Number

3: Algebra

Define a variable in a Note
using the Calculator
application.
Use tools from the Calculator
Number menu, including
Convert to Decimal,
Approximate to Fraction,
Factorise, Least Common
Multiple, Highest Common
Factor, Remainder, Fraction
Tools, Number Tools, and
Complex-Number Tools.
Use tools from the Calculator
Algebra menu, including
Numerical Solve, Solve System
of Linear Equations,
Polynomial Tools.
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4: Calculus

3 (CAS): Algebra

4 (CAS): Calculus

5: Probability

6: Statistics
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Use tools from the Calculus
menu including Numerical
Derivative at a Point,
Numerical Definite Integral,
Sum, Product, Numerical
Function Minimum, and
Numerical Function
Maximum.
Use tools from the Calculator
Algebra menu, including
Solve, Factorise, Expand,
Zeroes, Numerical Solve, Solve
System of Equations,
Polynomial Tools, Fraction
Tools, Convert Expressions,
Trigonometry, Complex, and
Extract.
Use tools from the Calculus
menu including Derivative,
Derivative at a Point, Integral,
Limit, Sum, Product, Function
Minimum, Function
Maximum, Tangent Line,
Normal Line, Arc Length,
Series, Differential Equation
Solver, Implicit
Differentiation, and
Numerical Calculations
Use tools from the Calculator
Probability menu, including
Factorial, Permutations,
Combinations, Random, and
Distributions.
Use tools from the Calculator
Statistics menu, including
Stats Calculations, Stat
Results, List Math, List
Operations, and others.

7: Matrix & Vector

8: Finance

Use tools from the Calculator
Matrix & Vector menu,
including Create, Transpose,
Determinant, Row-Echelon
Form, Reduced Row-Echelon
Form, Simultaneous, and
others.
Use tools from the Calculator
Finance menu, including
Finance Solver, TVM
Functions, Amortization, Cash
Flows, Interest Conversions,
and Days between Dates.

Note: For more information about performing Calculator

functions, please see the topics in the Calculator
documentation.

Using hints on the handheld
On the handheld, use the Hints option to access quick tips for performing
tasks.
1. From the Notes application, press b, then select Hints. The Hints
dialog box opens.

2. Use the scroll bar to move through the hints.
3. Click OK to close the dialog box.

Exploring Notes with examples
This section shows you how the Notes application works with other
applications to automatically update results.
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Example #1: Using Notes to explore roots of a quadratic
function
1. Open a new document and start the Notes application.
2. Define a function in a math box, evaluate, and hide the output using
the Math Box attributes.

3. Type some more text; for example: “Real Roots of f1(x) are:”
4. In a new math box, type: polyRoots(f1(x),x).
5. Press · and hide the input of this math box by using the Math Box
attributes dialog box.
6. Use the Page Layout toolbar icon to select the split layout.

7. Add the Graph application and plot f1(x).
See how the roots of f1 change when the function is modified in
Graph.
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Example #2: Using Notes to explore data sampling
In this example, we create a sampling distribution of sample means
drawn from a given population. We will be able to watch the sampling
distribution take shape for a given sample size and describe its
characteristics. You can change the population and the sample size.
1. Set up the population and the sample size.
a) Type "Create sample data:"
b) Insert a math expression box and define the population. For
example, type "population:=seq(n,n,1,50)".
c) Press · and hide the output using the Math Expression Box
Attributes dialog box.
d) Insert a math expression box and define the sample size. For
example, type "size:=5".
e) Press · and hide the output using the Math Expression Box
Attributes dialog box.
2. Set up the initialization.
a) Type "Start taking samples:"
b) Insert a math expression box and set the initial values for the
number of samples (num) and the list of sample means
(sampmeans). Type:
"num:=0:sampmeans:={}"
c) Press · and hide the output using the Math Expression Box
Attributes dialog box.
d) Deactivate the math expression box using Actions > Deactivate.
The deactivation will prevent the content of that math box from
Using Notes
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being overwritten when the values for num and sampmeans
change. The deactivated math box will be shown with the light
color background.
3. Set up Data & Statistics for the sampling.
a) Change the page layout and insert Data & Statistics.
b) Click on the horizontal axis and add sampmeans list.
c) Change the window setting: XMins=1 and XMax = 50.
d) You can also set up the plot of the mean of sample means using
Analyze > Plot Value.

4. Enter the instructions to add data.
a) Type "Create new samples:"
b) Insert a math expression to define the sample (sample) and
update the number of samples and the list of sample means. Type:
"num:=num+1:sample:=randsamp(population,size):
sampmeans:=augment(sampmeans,{mean(sample)})"
c) Press ·, hide the output, and turn off the expression wrapping
using the Math Expression Box Attributes dialog box.
d) Deactivate the math expression box using Actions > Deactivate to
prevent the content of the math box to be overwritten when num
and sampmeans values are reinitialized.
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e) Create math expression boxes that display the current number of
experiments (num), sample (sample), and the list of sample means
(sampmeans).

5. Now you are ready to explore. Add more samples by simply pressing
· when you are in the math expression box in the "Create new
samples" section.
Note: You can also automate the sampling process by using a
For ... EndFor loop.
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You can also change the sample size and restart the sampling.
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Using Question for Students
The teacher may send you a question in a variety of format types. You
may receive multiple choice, open response, and other types of
questions. This section will show you how to answer the different
question types.

Accessing the Question Toolbar
When you open a document with a question you may see a toolbar with
four tool options. If you don’t see this menu you can access it using one
of the following methods.
Software:
f In the Documents Toolbar, click the Tool Palette

icon.

Handheld:
f When in the question, click b.

Understanding the Question toolbar
When you open documents containing questions, the Question toolbar
displays four available tools:
Tool name

Tool function

Clear Answers

Lets you clear the answers in the
current question or in the document.

Check Answer

If your document is in Self-Check
mode, click here to view the correct
answer. You cannot check answers to
exam-type questions.

Insert

Lets you insert an expression box in
your answer.

Format

Click this tool to format the selected
text in your answer as subscript or
superscript.

Navigating in the Question application
f Use the mouse, or if using a handheld use the touchpad arrows, to
navigate to the correct response.
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f Use the Tab key to move between fields. Shift + Tab to move back.

Types of questions
There are several types of questions you may be asked. The following is a
list of the types. There may be variations in a type but how you answer
the question is basically the same for each type.
•

•

•

•

Multiple choice
–

Custom

–

ABCD

–

True/False

–

Yes/No

–

Always/Sometimes/Never

–

Agree/Disagree

–

Strongly Agree...Strongly Disagree

Open response
–

Explanation

–

Text match

Equation
–

y=

–

f(x)=

Coordinate points and list
–

(x,y) numerical input

–

Drop point(s)

–

List(s)

Answering questions
The general screen layout for all questions is the same. First is the
question area followed by a separating horizontal bar; then the area for
you to insert your answer. Some question types have slightly different
answer areas. See the rest of this section’s images for these differences.
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Checking your Answer
If your question is self-checking you will see the Check Answer option
available. If not it will be grayed out.
Software:
f Select the Tool Palette icon

.

Handheld:
f Click b.

Multiple Choice
Select one or more answers from the list depending on the question
type.
Multiple choice questions allow for the possibility of either multiple
correct responses or a single correct response. If multiple answers can be
given, the response will be in the form of a check box. If only one answer
is allowed, the form will be an option button (also known as a radio
button).
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Note: If you want to change your answer in a check box, select the
answer again and the selection will clear. It works as a toggle. For option
type questions, select a new option to mark. The previous one will clear.

Software:
f To answer the question, use your mouse to select the answer.

Handhelds:
f You can use the touch pad as you would a mouse. Alternately, you
can press e to navigate to your question and then press ·.
Example of multiple choice questions with boxes (1) and option (2)
buttons:
2

1

Note: Here are a few other examples illustrated in the preceding image.
In the first example, because there are more choices than what is seen
on the screen, the scroll bar is displayed. It is important that you verify
you are seeing all possible responses before choosing your answer
Handheld: The first picture is also an example of how the screen
appears on a handheld as compared to the software. The tabs at the
top are used to navigate to the different questions (pages and
problems) when using a handheld.
Software: The software uses the scrollbars or the page sorter
the Documents Tool bar.
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in

Software:
Inner scroll bar
is to see all the
answer
options.

Outer scroll bar
is to move to
another
question.

Open Response
In open response questions, use any combination of text and math
expressions. You can use any keys and any characters.
Note: If your instructor informs you this is an exact match question, this
means the instructor is using an automated checking system and you
must answer the question exactly in the correct form. For example, if the
question was "Give the value of X" and the correct response was "15"
only respond with the value. Do not respond "The value of X is 15
because the value of Y is 12." This would be counted wrong because it is
not an exact match with the answer key.
Note: The teacher may decide to ignore the the text capitialization.

Equation
y= and f(x)
When you receive a equation question, it will be a "y=" or "f(x)="
option. Both of these forms work the same. Enter your answer in the box
provided.
Note: When answering a question, spaces, upper and lowercase
differences, and extra parentheses are ignored. Also answers given in
math format are evaluated as correct when equivalent. For example,
y=2x+1 is a text match to Y = 2 X + 1 and 3--- is equivalent to 3/4.
4
Example question and question answered:
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445

Note: To enter math formats you can use the Utility function.
1. Click the Utilities icon (software:

or handheld t).

2. Select the correct format, in the example above, the fraction format is
used.
(Double-click in the software to select or press · on handheld).
3. Enter the values.
(Tab to go to the next value or to escape the math format box.)
Example using handheld:

1
2
3

Software: See the next example for more detail with the software.
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Coordinate Points, Drop Points, and and List
Coordinate Points
When answering a coordinate point question you will be shown the
question and then presented with two boxes to insert your answer.

Example answer completed:

You can use the Utility function to enter math formats.
Note: To enter math formats you can use the Utility function.
1. Click the Utilities icon (software:

or handheld t).

2. Select the correct format, in this example the fraction format.
(Double-click in software to select or press · on handheld).
3. Enter the values.
(Tab to go to the next value or to escape the math format box.)
Example user software:

1

3

2

Handheld: See the previous example for more detail on the handheld.
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Drop Points
A drop point question will automatically put you into the correct mode
to place points in a graph that the instructor provides. In the question,
you cannot alter the graph or its values, you can only insert a point.
Example question received:

When you place your cursor over the graph you will see the cursor looks
like a pencil. This indicates you can place the point.

Placing the point
Move the cursor to where you want to place a point and click to drop.
Note: When the question is presented to you with a grid background
you can place the point at any location but once you have placed it on
one of the grid points it will always snap to the grid when moving. After
it has been placed on a grid point it cannot be moved between grid
points.

Moving a point
To move a point that has been placed in the question:
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Software:
f Place your cursor over the point you want to move. The cursor’s icon
will change to the hand

. Click and hold the mouse while moving.

Handheld:
1. Place your cursor over the point. The cursor’s icon will change into a
hand ø.
2. Click / and select key a (on the touchpad). Use the touchpad
navigation arrow to move the point.
3. Press the select key a again to deselect.

Background grid. Once
a point is placed on a
grid point it will
always snap to the
grid.

Removing a point
To remove a point once placed in the graph pane.
Software:
f Ctrl + Z or Edit > Undo to clear the last action.
or
f Click Menu > Clear Answers > Current Question.
You can also click Menu > Clear Answers > Document if you want to
clear all answers in the entire document.
Handheld:
f Click b > Clear Answers > Current Question.
You can also click b > Clear Answers > Document if you want to
clear all answers in the entire document.
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List(s)
You can answer list questions simply by putting values into cells in the
correct columns.
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Libraries
What is a library?
A library is a TI-Nspire™ document that contains a collection of variables,
functions, and/or programs that have been defined as library objects.
Unlike ordinary variables, functions, and programs, which can be used
only within a single problem (the problem in which they are defined),
library objects are accessible from any document. You can even create
public library objects that appear in the TI-Nspire™ Catalog.
For example, suppose you have created library document matrix
containing public library function diagwithtrace() and a private library
function errmsg().
Function diagwithtrace() displays the diagonal of a square matrix and
calculates the trace of the matrix. If its input is not a square matrix, the
function calls errmsg(), which should then return an appropriate error
string.

You could then use the following syntax to display the diagonal and
calculate the trace of matrix m defined in the current problem:
matrix\diagwithtrace(m)

Creating libraries and library objects
A document is regarded as a library when it is saved or copied to the
designated library folder. The default location is:
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•

Windows®: My Documents\TI-Nspire\MyLib.

•

Macintosh®: Documents/TI-Nspire/MyLib.

•

Handheld: MyLib

If the folder has been inadvertently deleted, you must create it before
attempting to use libraries.
You can define library objects using either the Program Editor or the
Calculator application. Library objects must be defined with a Define
command and must reside in the first problem of a library document.
Note: If you use the Program Editor to define a library function or
program, you must store the object and also save the document. Saving
the document does not automatically store the object. For more
information, see the “Programming” section of the documentation.
Naming restrictions apply to library documents and library objects.
•

A library document name must be a valid variable name between 1
and 16 characters long, and it must not contain a period or begin
with an underscore.

•

A library object name must be a valid variable name between 1 and
15 characters long. It must not contain a period and must not begin
with an underscore.

Private and Public library objects
When you define a library object, you designate it as private (LibPriv) or
public (LibPub).
Define a=5

a is not a library object.
Define LibPriv b={1,2,3}

b is a private library object.
Define LibPub func1(x)=x^2 - 1

func1 is a public library object.
A Private library object does not appear in the Catalog, but you can
access it by typing its name. Private objects serve well as building blocks
that perform basic, low-level tasks. Typically, private library objects are
called upon by the public functions and programs.
A Public library object appears in the Catalog’s library tab after you
refresh the libraries. You can access a public library object through the
Catalog or by typing its name.
Macintosh® only: In version 1.4 of the software, a library document
name cannot contain extended characters, such as Ö, á, or ñ.
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Note: In library programs and functions defined as public, a comment
line (©) immediately following the Prgm or Func line is automatically
displayed as help in the Catalog. You could, for example, show a syntax
reminder there.

Using short and long names
Anytime you are in the same problem where an object is defined, you
can access it by entering its short name (the name given in the object’s
Define command). This is the case for all defined objects, including
private, public, and non-library objects.
You can access a library object from any document by typing the object’s
long name. A long name consists of the name of the object’s library
document followed by a backslash “\” followed by the name of the
object. For example, the long name of the object defined as func1 in the
library document lib1 is lib1\func1. To type the “\” character on the
handheld, press g p.
Note: If you cannot remember the exact name or the order of arguments
required for a private library object, you can open the library document
or use the Program Editor to view the object. You also can use
getVarInfo to view a list of objects in a library.

Using library objects
Before using a library variable, function, or program, make sure that
these steps have been followed:
•

The object has been defined with the Define command, and the
command specifies either the LibPriv or LibPub attribute.

•

The object resides in the first problem of a library document. The
document must reside in the designated library folder and must meet
the naming requirements.

•

If you defined the object using the Program Editor, it has been stored
using Check Syntax & Store from the Program Editor menu.

•

The libraries have been refreshed.

Refreshing the libraries
f Refresh libraries to make the library objects available to your
documents.
–

From the Tools menu, select Refresh Libraries.
Handheld: Press / b and select Refresh Libraries.
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Using a public library object
1. Refresh the libraries.
2. Open the TI-Nspire™ application in which you want to use the
variable, function or program.
Note: All applications can evaluate functions, but only the Calculator
and Notes applications can run programs.
3. Open the Catalog and use the library tab to find and insert the object.
4. If arguments are required, type them inside the parentheses.

Using a private library object
1. Refresh the libraries.
2. Open the TI-Nspire™ application in which you want to use the
variable, function or program.
Note: All applications can evaluate functions, but only the Calculator
and Notes applications can run programs.
3. Type the name of the object, such as lib1\func1().
In case of a function or program, always follow the name with
parentheses. To type the “\” character on the handheld, press
g p.
4. If arguments are required, type them inside the parentheses.

Creating shortcuts to library objects
You can make the objects in a library more easily accessible by using
libShortcut() to create shortcuts to them. This creates a variable group in
the current problem that contains references to all the objects in the
specified library document. You can choose to include or exclude the
private library objects.
For example, suppose the library document linalg contains functions
named clearmat, cofactor, gausstep, help, inversestep, kernelbasis, rank,
and simultstep. Executing libShortcut(“linalg”,“la”) would create a
variable group containing the following members:
la.clearmat
la.cofactor
la.gausstep
la.help
la.inversestep
la.kernelbasis
la.rank
la.simultstep
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You can refer to those library objects from within the current problem by
typing their variable names or by selecting them from the Variables
menu.
For details and an example of using libShortcut(), refer to the Reference
Guide.

Included libraries
To help you get started with libraries, the TI-Nspire™ Software
installation includes a library document with useful Linear Algebra
functions. The library is named linalg or linalgCAS and is installed in the
designated library folder.
Note: Updating the handheld’s operating system or reinstalling the
computer software places all included libraries in the default folder. If
you have edited an object in an included library or replaced an included
library with your own document of the same name, updating or
reinstalling will overwrite your changes. This could also happen after
batteries are replaced or the handheld system is reset.

Restoring an included library
If you inadvertently delete or overwrite an included library, you can
restore it from the installation DVD.
1. Open the DVD, and navigate to the libs folder.
2. Identify the library file to restore, such as linalg.tns or linalgCAS.tns
for the linear algebra library.
3. Copy the file.
–

Windows®: Copy the file to your designated library folder. The
default location is My Documents\TI-Nspire\MyLib.

–

Macintosh®: Copy the file to your designated library folder. The
default location is Documents/TI-Nspire/MyLib.

–

Handheld: Connect the handheld to your computer, open the
TI-Nspire™ Computer Link Software, and copy the library file to
the handheld’s MyLib folder.

4. Activate the new library objects.
–

From the TI-Nspire™ Software Tools menu, select Refresh
Libraries.

Handheld: Press / b, and select Refresh Libraries.
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Changing the library folder location (computer
only)
You can change the location of the designated library folder from the
default MyLib folder to any folder on your local drive or network.
1. On the File menu, select Settings > Keypad Options.
(For TI-Nspire™ Teacher Software, click File > Settings >
SmartView Options.)
2. In the Options dialog box, click Browse, and then navigate to the
folder that you want to designate.

3. Select the folder, and then click OK.
4. In the Options dialog box, click OK to change to the selected folder.
Notes:
•

Changing the designated folder does not automatically move the
library documents to the new folder. To make the objects in your
library documents accessible, you must move the documents into the
new folder and then refresh the libraries.

•

The location of the designated folder is determined during software
installation. By default, this folder is:
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–

Windows®: My Documents\TI-Nspire\MyLib.

–

Macintosh®: Documents/TI-Nspire/MyLib.
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Programming
You can create user-defined functions or programs by typing definition
statements on the Calculator entry line or by using the Program Editor.
The Program Editor offers some advantages, and it is covered in this
section. For information on defining programs and functions in
Calculator, see the “Calculator” chapter.

Overview of the Program Editor
The Program Editor helps you define, edit, and manage user-defined
functions and programs.
•

The editor has programming templates and dialog boxes to help you
define functions and programs using correct syntax.

•

The editor lets you enter multiple-line programming statements
without requiring a special key sequence to add each line.

•

You can easily create private and public library objects (variables,
functions, and programs). For details, see the “Libraries” chapter.

•

The editor is accessible from the main Insert menu as well as from the
Calculator’s Functions & Programs menu.

À

Â

Á
À

Program Editor menu – This menu is available anytime you are in the
Program Editor work area using the Normal view mode. On the
handheld, press b to display the menu.
Programming
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Á
Â

Program Editor work area
Status line shows line number information and the name of the
function or program being edited. An asterisk (*) indicates that this
function is “dirty,” which means that it has changed since the last
time its syntax has been checked and it has been stored.

Program Editor menu
Actions
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New

Displays a dialog box for defining a new
function or program.

Open

Lets you open an existing library function
or program for editing.

Import

Imports a program or function from a
library.

View

Lets you view (and optionally, edit) an
existing library function or program.

Create Copy

Lets you copy the current function or
program.

Rename

Lets you rename the current function or
program.

Change Library Access

Lets you change the access level of a
library object to private (LibPriv), public
(LibPub), or none.

Insert Comment

Inserts a comment (©) at the cursor
position.

Find

Displays a dialog box for text search.

Find and Replace

Lets you find and, optionally, replace
occurrences of specified text.

Go to Line

Moves the cursor to a specified line
number.

Go Back

Lets you easily return from the Program
Editor to the Calculator or Notes
application after a runtime error occurs.

Close

Closes the current function or program.
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Check Syntax & Store
Check Syntax & Store

Finds syntax errors and tries to put the
cursor near the first error. If no errors,
stores current function or program.

Check Syntax

Finds syntax errors and tries to put the
cursor near the first error.

Define Variables
Local

Inserts Local.

Define

Inserts Define.

Delete Variable

Inserts DelVar.

Func...EndFunc

Inserts Func...EndFunc template.

Prgm...EndPrgm

Inserts Prgm...EndPrgm template.

Lock

Inserts Lock, unLock, or getLockInfo().

Control
If

Inserts If statement.

If...Then...EndIf

Inserts If...Then...EndIf template.

If...Then...Else...EndIf

Inserts If...Then...Else...EndIf template.

ElseIf...Then

Inserts ElseIf...Then template.

For...EndFor

Inserts For...EndFor template.

While...EndWhile

Inserts While...EndWhile
template.

Loop...EndLoop

Inserts Loop...EndLoop
template.

Try...Else...EndTry

Inserts Try...Else...EndTry template.

ClrErr

Inserts ClrErr.

PassErr

Inserts PassErr.
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Control
errCode

Inserts variable name errCode.

warnCodes

Inserts warnCodes().

Transfer
Return

Inserts return().

Cycle

Inserts Cycle.

Exit

Inserts Exit.

Lbl

Inserts Lbl (label).

Go to Lbl

Inserts Goto.

Stop

Inserts Stop.

Input/Output
Disp

Inserts the Disp (display) command.

Request

Inserts the Request command.

RequestStr

Inserts the RequestStr command.

Text

Inserts the Text command.

Mode
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Display Digits

Lets you select from several Float and Fix
settings.

Angle

Lets you select Degrees, Radians, or
Gradians.

Exponential Format

Lets you select Normal, Scientific, or
Engineering.

Real or Complex

Lets you select Real, Rectangular, or Polar.

Programming

Mode
Auto or Approx

Lets you select Auto or Approximate
results.
CAS: Lets you select Auto, Approximate,
or Exact results.

Vector Format

Lets you select Rectangular, Cylindrical, or
Spherical.

Base

Lets you select Decimal, Hex, or Binary.

CAS: Unit System

Lets you select SI or Eng/US.

GetMode

Inserts getMode().

Get Language Info

Inserts getLangInfo().

Defining a program or function
Starting a new Program Editor
1. To start the editor from a Calculator page,
–

From the Insert menu, select Program Editor, and select New.
Handheld: Press b 9 1 1.

2. To start the editor when not on a Calculator page,
–

From the Insert menu, select Program Editor, and select New.
Handheld: Press / b 4 8 1.

3. Type a name for the function or program you are defining.
4. Select the Type (Program or Function).
5. Set the Library Access:
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–

To use the function or program only from the current document
and problem, select None.

–

To make the function or program accessible from any document
but not visible in the Catalog, select LibPriv.

–

To make the function or program accessible from any document
and also visible in the Catalog, select LibPub (Show in Catalog).
For details, see the “Libraries” chapter.

6. Click OK.
A new instance of the Program Editor opens, with a template
matching the selections you made.

Entering lines into a function or program
The Program Editor does not execute the commands or evaluate
expressions as you enter them. They are executed only when you
evaluate the function or run the program.
1. If your function or program will require the user to supply arguments,
type parameter names in the parentheses that follow the name.
Separate parameters with a comma.

2. Between the Func and EndFunc (or Prgm and EndPrgm) lines, enter
the lines of statements that make up your function or program.
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–

You can either type the names of functions and commands or
insert them from the Catalog.

–

A line can be longer than the width of the screen; if so, you might
have to scroll to view the entire statement.

–

After typing each line, press ·. This inserts a new blank line
and lets you continue entering another line.

–

Use the ¡, ¢, £, and ¤ arrow keys to scroll through the function
or program for entering or editing commands.

Inserting comments
A comment symbol (©) lets you enter a remark. Comments can be useful
to someone viewing or editing the program. Comments do not display
when the program runs, and they have no effect on program flow.

Define LibPub volcyl(ht,r) =
Prgm
©volcyl(ht,r) => volume of cylinder À
Disp “Volume =”, approx(p ¦ r2 ¦ ht)
©This is another comment.
EndPrgm

À

Comment showing required syntax. Because this library object is
public and this comment is the first line in a Func or Prgm block, the
comment displays in the Catalog as help. For details, see the
“Libraries” chapter.

To insert a comment:
1. Position the cursor at the end of the line where you want to insert a
comment.
2. From the Actions menu, select Insert Comment.
3. Type the text of the comment after the © symbol.

Checking syntax
The Program Editor lets you check the function or program for correct
syntax.
f From the Check Syntax & Store menu, select Check Syntax.
If the syntax checker finds any syntax errors, it displays an error
message and tries to position the cursor near the first error so you can
correct it.
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Storing the function or program
You must store your function or program to make it accessible. The
Program Editor automatically checks the syntax before storing.
An asterisk (*) is displayed in the upper left corner of the Program Editor
to indicate that the function or program has not been stored.
f From the Check Syntax & Store menu, select Check Syntax & Store.
If the syntax checker finds any syntax errors, it displays an error
message and tries to position the cursor near the first error.
If no syntax errors are found, the message “Stored successfully“ is
displayed in the status line at the top of the Program Editor.
Note: If the function or program is defined as a library object, you must
also save the document in the designated library folder and refresh
libraries to make the object accessible to other documents. For details,
see the “Libraries” chapter.

Viewing a program or function
1. From the Actions menu, select View.

2. If the function or program is a library object, select its library from the
Location list.
3. Select the function or program name from the Name list.

464

Programming

The function or program displays in a viewer.

4. Use the arrow keys to view the function or program.
5. If you want to edit the program, click Edit.
Note: The Edit selection is available only for functions and programs
defined in the current problem. To edit a library object, you must first
open its library document.

Opening a function or program for editing
You can open a function or program from the current problem only.
Note: You cannot modify a locked program or function. To unlock the
object, go to a Calculator page and use the unLock command.
1. Display the list of available functions and programs.
–

From the Actions menu, select Open.

2. Select the item to open.

Importing a program from a library
You can import a function or program defined as a library object into a
Program Editor within the current problem. The imported copy is not
locked, even if the original is locked.
1. From the Actions menu, select Import.
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2. Select the Library Name.
3. Select the Name of the object.
4. If you want the imported object to have a different name, type the
name under Import As.

Creating a copy of a function or program
When creating a new function or program, you might find it easier to
start with a copy of the current one. The copy that you create is not
locked, even if the original is locked.
1. From the Actions menu, select Create Copy.
2. Type a new name, or click OK to accept the proposed name.
3. If you want to change the access level, select Library Access, and
select a new level.

Renaming a program or function
You can rename and (optionally) change the access level of the current
function or program.
1. From the Actions menu, select Rename.

2. Type a new name, or click OK to accept the proposed name.
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3. If you want to change the access level, select Library Access, and
select a new level.

Changing the library access level
1. From the Actions menu, select Change Library Access.

2. Select the Library Access:
–

To use the function or program only from the current Calculator
problem, select None.

–

To make function or program accessible from any document but
not visible in the Catalog, select LibPriv.

–

To make the function or program accessible from any document
and also visible in the Catalog, select LibPub.

Finding text
1. From the Actions menu, select Find.

2. Type the text that you want to find, and click OK.
–

If the text is found, it is highlighted in the program.

–

If the text is not found, a notification message displays.

Finding and replacing text
1. From the Actions menu, select Find and Replace.
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2. Type the text that you want to find.
3. Type the replacement text.
4. Click Replace to replace the first occurrence after the cursor position,
or click Replace All to replace every occurrence.
Note: If the text is found in a math template, a message is displayed
to warn you that your replacement text will replace the whole
template—not just the found text.

Closing the current function or program
f From the Actions menu, select Close.
If the function or program has unstored changes, you are prompted
to check syntax and store before closing.

Running programs and evaluating functions
After defining and storing a function or program, you can use it from an
application. All the applications can evaluate functions, but only the
Calculator and Notes applications can run programs.
The program statements are executed in sequential order (although
some commands alter the program flow). The output, if any, is displayed
in the application’s work area.
•

Program execution continues until it reaches the last statement or a
Stop command.

•

Function execution continues until it reaches a Return command.

•

To stop a program or function manually,
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–

Windows®: Hold down the F12 key and press Enter repeatedly.

–

Macintosh®: Hold down the F5 key and press Enter repeatedly.

–

Handheld: Hold down the c key and press · repeatedly.
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Using short and long names
Anytime you are in the same problem where an object is defined, you
can access it by entering its short name (the name given in the object’s
Define command). This is the case for all defined objects, including
private, public, and non-library objects.
You can access a library object from any document by typing the object’s
long name. A long name consists of the name of the object’s library
document followed by a backslash “\” followed by the name of the
object. For example, the long name of the object defined as func1 in the
library document lib1 is lib1\func1. To type the “\” character on the
handheld, press g p.
Note: If you cannot remember the exact name or the order of arguments
required for a private library object, you can open the library document
or use the Program Editor to view the object. You also can use
getVarInfo to view a list of objects in a library.

Using a Public library function or program
1. Make sure you have defined the object in the document’s first
problem, stored the object, saved the library document in the MyLib
folder, and refreshed the libraries.
2. Open the TI-Nspire™ application in which you want to use the
function or program.
Note: All applications can evaluate functions, but only the Calculator
and Notes applications can run programs.
3. Open the Catalog and use the library tab to find and insert the object.
- or Type the name of the object. In the case of a function or program,
always follow the name with parentheses.

libs2\func1()
4. If the program requires you to supply one or more arguments, type
the values or variable names inside the parentheses.

libs2\func1(34,power)
5. Press ·.
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Using a Private library function or program
To use a Private library object, you must know its long name. For
example, the long name of the object defined as func1 in the library
document lib1 is lib1\func1.
Note: If you cannot remember the exact name or the order of arguments
required for a private library object, you can open the library document
or use the Program Editor to view the object.
1. Make sure you have defined the object in the document’s first
problem, stored the object, saved the library document in the MyLib
folder, and refreshed the libraries.
2. Open the TI-Nspire™ application in which you want to use the
function or program.
Note: All applications can evaluate functions, but only the Calculator
and Notes applications can run programs.
3. Type the name of the object. In the case of a function or program,
always follow the name with parentheses.

libs2\func1()
4. If the object requires you to supply one or more arguments, type the
values or variable names inside the parentheses.

libs2\func1(34,power)
5. Press ·.

Running a non-library program or function
1. Make sure you are in the same problem in which the function or
program is defined.
2. Type the name of the function or program on the entry line, or press
h to select the name from a list.
You must always include a set of parentheses after the name.

prog1()
If the function or program requires you to supply one or more
arguments, type the values or variable names inside the parentheses.

prog1(34,power)
3. Press ·.
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Interrupting a running program
While a function or program is running, the busy pointer } displays.
f To stop the function or program,
–

Windows®: Hold down the F12 key and press Enter repeatedly.

–

Macintosh®: Hold down the F5 key and press Enter repeatedly.

–

Handheld: Hold down the c key and press · repeatedly.

A message displays. To edit the function or program in the Program
Editor, select Go To. The cursor appears at the command where the
break occurred.

Getting values into a program
You can choose from several methods to supply the values that a
function or program uses in calculations.

Embedding the values within the program or function
This method is useful primarily for values that must be the same each
time the program or function is used.
1. Define the program.

Define calculatearea()=
Prgm
w:=3
h:=23.64
area:=w*h
EndPrgm
2. Run the program.

calculatearea() :area

70.92

Letting the user assign the values to variables
A program or function can refer to variables created beforehand. This
method requires users to remember the variable names and to assign
values to them before using the object.
1. Define the program.

Define calculatearea()=
Prgm
area:=w*h
EndPrgm
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2. Supply the variables, and then run the program.

w:=3 : h:=23.64
calculatearea() :area

70.92

Letting the user supply the values as arguments
This method lets users pass one or more values as arguments within the
expression that calls the program or function.
The following program, volcyl, calculates the volume of a cylinder. It
requires the user to supply two values: height and radius of the cylinder.
1. Define the volcyl program.

Define volcyl(height,radius) =
Prgm
Disp "Volume =", approx(p ¦ radius2 ¦ height)
EndPrgm
2. Run the program to display the volume of a cylinder with a height of
34 mm and a radius of 5 mm.

volcyl(34,5)

Volume = 534.071

Note: You do not have to use the parameter names when you run the
volcyl program, but you must supply two arguments (as values,
variables, or expressions). The first must represent the height, and the
second must represent the radius.

Requesting the values from the user (programs only)
You can use the Request and RequestStr commands in a program to
make the program pause and display a dialog box prompting the user for
information. This method does not require users to remember variable
names or the order in which they are needed.
You cannot use the Request or RequestStr command in a function.
1. Define the program.

Define calculatearea()=
Prgm
Request "Width: ",w
Request "Height: ",h
area:=w*h
EndPrgm
2. Run the program and respond to the requests.
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calculatearea() : area
Width: 3
(3 entered as a response)
Height: 23.64 (23.64 entered as a response)
70.92
Use RequestStr instead of Request when you want the program to
interpret the user’s response as a character string rather than a math
expression. This avoids requiring the user to enclose the response in
quotation marks (““).

Displaying information
A running function or program does not display intermediate calculated
results unless you include a command to display them. This is an
important difference between performing a calculation on the entry line
and performing it in a function or program.
The following calculations, for example, do not display a result in a
function or program (although they do from the entry line).
©

x:=12¦6
cos(p/4)&n
©

Displaying information in the history
You can use the Disp command in a program or function to display
information, including intermediate results, in the history.
©

Disp 12¦6
Disp "Result:",cos(p/4)
©

Displaying information in a dialog box
You can use the Text command to pause a running program and display
information in a dialog box. The user selects OK to continue or selects
Cancel to stop the program.
You cannot use the Text command in a function.
©

Text "Area=" & area
©
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Note: Displaying a result with Disp or Text does not store that result. If
you expect to refer later to a result, store it to a global variable.
©

cos(p/4)&maximum
Disp maximum
©

Using local variables
A local variable is a temporary variable that exists only while a userdefined function is being evaluated or a user-defined program is
running.

Example of a local variable
The following program segment shows a For...EndFor loop (which is
discussed later in this module). The variable i is the loop counter. In most
cases, the variable i is used only while the program is running.

Local i À
For i,0,5,1
Disp i
EndFor
Disp i

À

Declares variable i as local.

Note: When possible, declare as local any variable that is used only
within the program and does not need to be available after the program
stops.

What causes an undefined variable error message?
An Undefined variable error message displays when you evaluate a userdefined function or run a user-defined program that references a local
variable that is not initialized (assigned a value).
For example:

Define fact(n)=Func
Local m À
While n>1
n¦m&m: n–1&n
EndWhile
Return m
EndFunc

À
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Initialize local variables
All local variables must be assigned an initial value before they are
referenced.

Define fact(n)=Func
Local m: 1&m À
While n>1
n¦m&m: n–1&n
EndWhile
Return m
EndFunc

À

1 is stored as the initial value for m.

Note (CAS): Functions and programs cannot use a local variable to
perform symbolic calculations.

CAS: Performing symbolic calculations
If you want a function or program to perform symbolic calculations, you
must use a global variable instead of a local. However, you must be
certain that the global variable does not already exist outside of the
program. The following methods can help.
•

Refer to a global variable name, typically with two or more
characters, that is not likely to exist outside of the function or
program.

•

Include DelVar within a program to delete the global variable, if it
exists, before referring to it. (DelVar does not delete locked or linked
variables.)

Differences between functions and programs
A function defined in the Program Editor is similar to the functions built
into the TI-Nspire™ Software.
•

Functions must return a result, which can be graphed or entered in a
table. Programs cannot return a result.

•

You can use a function (but not a program) within an expression. For
example: 3 ¦ func1(3) is valid, but not 3 ¦ prog1(3).

•

You can run programs from Calculator and Notes applications only.
However, you can evaluate functions in Calculator, Notes, Lists &
Spreadsheet, Graphs & Geometry, and Data & Statistics.
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•

A function can refer to any variable; however, it can store a value to a
local variable only. Programs can store to local and global variables.
Note: Arguments used to pass values to a function are treated as
local variables automatically. If you want to store to any other
variables, you must declare them as Local from within the function.

•

A function cannot call a program as a subroutine, but it can call
another user-defined function.

•

You cannot define a program within a function.

•

A function cannot define a global function, but it can define a local
function.

Calling one program from another
One program can call another program as a subroutine. The subroutine
can be external (a separate program) or internal (included in the main
program). Subroutines are useful when a program needs to repeat the
same group of commands at several different places.

Calling a separate program
To call a separate program, use the same syntax that you use to run the
program from the entry line.

Define subtest1()=
Prgm
For i,1,4,1
subtest2(i,i¦1000)
EndFor
EndPrgm

Define subtest2(x,y)=
Prgm
Disp x,y
EndPrgm

Defining and calling an internal subroutine
To define an internal subroutine, use the Define command with
Prgm...EndPrgm. Because a subroutine must be defined before it can be
called, it is a good practice to define subroutines at the beginning of the
main program.
An internal subroutine is called and executed in the same way as a
separate program.
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Define subtest1()=
Prgm
local subtest2 À
Define subtest2(x,y)= Á
Prgm
Disp x,y
EndPrgm
©Beginning of main program
For i,1,4,1
subtest2(i,I*1000) Â
EndFor
EndPrgm

À
Á
Â

Declares the subroutine as a local variable.
Defines the subroutine.
Calls the subroutine.

Note: Use the Program Editor’s Var menu to enter the Define and
Prgm...EndPrgm commands.

Notes about using subroutines
At the end of a subroutine, execution returns to the calling program. To
exit a subroutine at any other time, use Return with no argument.
A subroutine cannot access local variables declared in the calling
program. Likewise, the calling program cannot access local variables
declared in a subroutine.
Lbl commands are local to the programs in which they are located.
Therefore, a Goto command in the calling program cannot branch to a

label in a subroutine or vice versa.

Avoiding circular-definition errors
When evaluating a user-defined function or running a program, you can
specify an argument that includes the same variable that was used to
define the function or create the program. However, to avoid circulardefinition errors, you must assign a value for variables that are used in
evaluating the function or running the program. For example:

x+1&x

À

– or –
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For i,i,10,1
Disp i À
EndFor

À

Causes a Circular definition error message if x or i does not have a
value. The error does not occur if x or i has already been assigned a
value.

Controlling the flow of a function or program
When you run a program or evaluate a function, the program lines are
executed in sequential order. However, some commands alter the
program flow. For example:
•

Control structures such as If...EndIf commands use a conditional test
to decide which part of a program to execute.

•

Loop commands such as For...EndFor repeat a group of commands.

Using If, Lbl, and Goto to control program flow
The If command and several If...EndIf structures let you execute a
statement or block of statements conditionally, that is, based on the
result of a test (such as x>5). Lbl (label) and Goto commands let you
branch, or jump, from one place to another in a function or program.
The If command and several If...EndIf structures reside on the Program
Editor’s Control menu.
When you insert a structure such as If...Then...EndIf, a template is
inserted at the cursor location. The cursor is positioned so that you can
enter a conditional test.

If command
To execute a single command when a conditional test is true, use the
general form:

If x>5
Disp "x is greater than 5"
Disp x Á

À
Á

À

Executed only if x>5; otherwise, skipped.
Always displays the value of x.

In this example, you must store a value to x before executing the
If command.
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If...Then...EndIf structures
To execute one group of commands if a conditional test is true, use the
structure:

If x>5 Then
Disp "x is greater than 5"
2¦x&x À
EndIf
Disp x Á

À
Á

À

Executed only if x>5.
Displays the value of:
2x if x>5
x if x{5

Note: EndIf marks the end of the Then block that is executed if the
condition is true.

If...Then...Else...EndIf structures
To execute one group of commands if a conditional test is true and a
different group if the condition is false, use this structure:

If x>5 Then
Disp "x is greater than 5" À
2¦x&x À
Else
Disp "x is less than or equal to 5"
5¦x&x Á
EndIf
Disp x Â

À
Á
Â

Á

Executed only if x>5.
Executed only if x{5.
Displays value of:
2x if x>5
5x if x{5

If...Then...ElseIf... EndIf structures
A more complex form of the If command lets you test for multiple
conditions. Suppose you want a program to test a user-supplied
argument that signifies one of four options.
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To test for each option (If Choice=1, If Choice=2, and so on), use the
If...Then...ElseIf...EndIf structure.

Lbl and Goto commands
You can also control the flow by using Lbl (label) and Goto commands.
These commands reside on the Program Editor’s Transfers menu.
Use the Lbl command to label (assign a name to) a particular location in
the function or program.
Lbl labelName
name to assign to this location (use the
same naming convention as a variable
name)

You can then use the Goto command at any point in the function or
program to branch to the location that corresponds to the specified
label.
Goto labelName
specifies which Lbl command to
branch to

Because a Goto command is unconditional (it always branches to the
specified label), it is often used with an If command so that you can
specify a conditional test. For example:

If x>5
Goto GT5 À
Disp x
--------------- Á
Lbl GT5
Disp "The number was > 5"

À
Á

If x>5, branches directly to label GT5.
For this example, the program must include commands (such as Stop)
that prevent Lbl GT5 from being executed if x{5.

Using loops to repeat a group of commands
To repeat the same group of commands successively, use one of the loop
structures. Several types of loops are available. Each type gives you a
different way to exit the loop, based on a conditional test.
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Loop and loop-related commands reside on the Program Editor’s Control
and Transfers menus.
When you insert one of the loop structures, its template is inserted at the
cursor location. You can then begin entering the commands that will be
executed within the loop.

For...EndFor loops
A For...EndFor loop uses a counter to control the number of times the
loop is repeated. The syntax of the For command is:
Note: The ending value can be less than the beginning value, provided
the increment is negative.
For variable, begin, end [, increment]

À
À
Á
Â
Ã

Á

Â

Ã

Variable used as a counter
Counter value used the first time For is executed
Exits the loop when variable exceeds this value
Added to the counter each subsequent time For is executed (If this
optional value is omitted, the increment is 1.)

When For is executed, the variable value is compared to the end value. If
variable does not exceed end, the loop is executed; otherwise, control
jumps to the command following EndFor.
i{5
i>5

For i,0,5,1
--------------EndFor
--------

Note: The For command automatically increments the counter variable
so that the function or program can exit the loop after a certain number
of repetitions.
At the end of the loop (EndFor), control jumps back to the For command,
where the variable is incremented and compared to end.
For example:
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For i,0,5,1
Disp i À
EndFor
Disp i Á

À
Á

Displays 0, 1, 2, 3, 4, and 5.
Displays 6. When variable increments to 6, the loop is not executed.

Note: You can declare the counter variable as local if it does not need to
be saved after the function or program stops.

While...EndWhile loops
A While...EndWhile loop repeats a block of commands as long as a
specified condition is true. The syntax of the While command is:
While condition

When While is executed, condition is evaluated. If condition is true, the
loop is executed; otherwise, control jumps to the command following
EndWhile.
x<5
x|5

While x<5
--------------EndWhile
--------

Note: The While command does not automatically change the condition.
You must include commands that allow the function or program to exit
the loop.
At the end of the loop (EndWhile), control jumps back to the While
command, where condition is re-evaluated.
To execute the loop the first time, the condition must initially be true.
•

Any variables referenced in the condition must be set before the
While command. (You can build the values into the function or
program, or you can prompt the user to enter the values.)

•

The loop must contain commands that change the values in the
condition, eventually causing it to be false. Otherwise, the condition
is always true and the function or program cannot exit the loop
(called an infinite loop).

For example:
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0&x À
While x<5
Disp x Á
x+1&x Â
EndWhile
Disp x Ã

À
Á
Â
Ã

Initially sets x.
Displays 0, 1, 2, 3, and 4.
Increments x.
Displays 5. When x increments to 5, the loop is not executed.

Loop...EndLoop loops
A Loop...EndLoop creates an infinite loop, which is repeated endlessly.
The Loop command does not have any arguments.

Loop
--------------EndLoop
-------Typically, you insert commands in the loop that let the program exit from
the loop. Commonly used commands are: If, Exit, Goto, and Lbl (label).
For example:

0&x
Loop
Disp x
x+1&x
If x>5 À
Exit
EndLoop
Disp x Á

À
Á

An If command checks the condition.
Exits the loop and jumps to here when x increments to 6.

Note: The Exit command exits from the current loop.
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In this example, the If command can be anywhere in the loop.
When the If command is:

The loop is:

At the beginning of the loop

Executed only if the condition is true.

At the end of the loop

Executed at least once and repeated
only if the condition is true.

The If command could also use a Goto command to transfer program
control to a specified Lbl (label) command.

Repeating a loop immediately
The Cycle command immediately transfers program control to the next
iteration of a loop (before the current iteration is complete). This
command works with For...EndFor, While...EndWhile, and
Loop...EndLoop.

Lbl and Goto loops
Although the Lbl (label) and Goto commands are not strictly loop
commands, they can be used to create an infinite loop. For example:

Lbl START
--------------Goto START
-------As with Loop...EndLoop, the loop should contain commands that let the
function or program exit from the loop.

Changing mode settings
Functions and programs can use the setMode() function to temporarily
set specific calculation or result modes. The Program Editor’s Mode menu
makes it easy to enter the correct syntax without requiring you to
memorize numeric codes.
Note: Mode changes made within a function or program definition do
not persist outside the function or program.

Setting a mode
1. Position the cursor where you want to insert the setMode function.
2. From the Mode menu, select the mode to change, and select the new
setting.
The correct syntax is inserted at the cursor location. For example:
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Debugging programs and handling errors
After you write a function or program, you can use several techniques to
find and correct errors. You can also build an error-handling command
into the function or program itself.
If your function or program allows the user to select from several
options, be sure to run it and test each option.

Techniques for debugging
Run-time error messages can locate syntax errors but not errors in
program logic. The following techniques may be useful.
•
•

Temporarily insert Disp commands to display the values of critical
variables.
To confirm that a loop is executed the correct number of times, use
Disp to display the counter variable or the values in the conditional

test.
•

To confirm that a subroutine is executed, use Disp to display
messages such as “Entering subroutine” and “Exiting subroutine” at
the beginning and end of the subroutine.

•

To stop a program or function manually,
–

Windows®: Hold down the F12 key and press Enter repeatedly.

–

Macintosh®: Hold down the F5 key and press Enter repeatedly.

–

Handheld: Hold down the c key and press · repeatedly.

Error-handling commands
Command

Description

Try...EndTry

Defines a block that lets a function or program execute
a command and, if necessary, recover from an error
generated by that command.

ClrErr

Clears the error status and sets system variable errCode
to zero. For an example of using errCode, see the Try
command in the Reference Guide.

PassErr

Passes an error to the next level of the Try...EndTry
block.
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Data Collection and Analysis
The Vernier DataQuest™ application enables you to collect, view, and
analyze real-world data.
To use the Vernier DataQuest™ application, your TI-Nspire™ software
must be 3.0 or higher. Visit education.ti.com if an update is needed.
This chapter introduces you to the Vernier DataQuest™ application
starting with opening the program, showing the navigation, examining
the menus, showing common screen structures, and providing
instructions for completing often used tasks. This chapter covers
instructions for using the Vernier DataQuest™ application in the
TI-Nspire™ software including:
•

TI-Nspire™ Teacher Software

•

TI-Nspire™ Student Software

•

TI-Nspire™ CAS Teacher Software

•

TI-Nspire™ CAS Student Software

•

TI-Nspire™ Navigator™ Teacher Software

•

TI-Nspire™ Navigator™ Teacher Software for Networked Computers

Chapter organization
This chapter is organized using the following sections:
•

Introduction and navigation
This is section you are in now. Use this section to orient yourself to the
Vernier DataQuest™ application.

•

Performing an experiment
This section is a “quick step” list on how to perform most types of
experiments.

•

Experiment details
Experiment details provides more detail on steps described in the
Performing an experiment section.

•

Working with data and Graph View
These are procedures primarily used in Graph View that were not
covered in the Performing an experiment or the Experiment details
sections.
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•

Working with data and Table View
There are procedures primarily used in Table View that were not
covered in the Performing an experiment or the Experiment details
sections.

•

Using advanced data collection options
This section provides information about using other data collection
methods such as remote data collection with the TI-Nspire™ Lab
Cradle.

•

Working with advanced analysis features
This section describes additional analysis features not covered in the
Performing an experiment or Experiment details sections.

•

Printing data views
How to use printing options with the Vernier DataQuest™
application.

•

Using sensors and data with other apps
This section has information about using the Sensor Console, a
specialized view of the Vernier DataQuest™ application designed for
using sensors with other TI-Nspire™ applications.

•

Reference of menus
The reference is a listing of the Vernier DataQuest™ menus with a
brief description.
Note: You can use the menu term under Data Collection in the index
to find where the option is explained.

Introduction and navigation
This section in to introduce you to the Vernier DataQuest™ application
and explain terms used, special instructions for the type of device your
are using (computer or handheld), and provide some early navigation of
the screens.
This section includes:
•

Using a computer or handheld

•

Navigating the screens

•

Selecting views

488

Data Collection and Analysis

Using a computer or handheld
The Vernier DataQuest™ application can be accessed and used from a
TI-Nspire™ handheld or from your computer desktop when using
TI-Nspire™ software. Unless otherwise specified, the screens and
instructions for the Vernier DataQuest™ application are the same
regardless of the TI-Nspire™ software or handheld you are using.
Besides the main application menus (and their submenus) the Vernier
DataQuest™ application also includes context menus. The context menu
provides access to the tools most commonly used with the selected
object. The context menu displays different options depending on the
active object and the task you are performing.
Note: To help illustrate how the Vernier DataQuest™ application looks
and works the same throughout the TI-Nspire™ product line, images
shown in this chapter are from a mixture of the software listed and are
also from the computer and handheld.

Special instructions for PC users
To access a Vernier DataQuest™ context menu, move the cursor to the
desired object, and right-click the object.

Special instructions for Macintosh® users
To access a Vernier DataQuest™ context menu, move the cursor to the
desired object, hold “ and click the object.

Special instructions for handheld users
•

To move the cursor, use the Touchpad.

•

To use the “hand” option to grab an item (like the edge of a box),
follow these steps:
–

Use the Touchpad to move over the item. Hover until the cursor
changes to

–

.

Press / and click or press x and hold. The cursor changes to
. Move the cursor to the desired location. Press d to release.
The cursor changes back to

.

•

To access the Vernier DataQuest™ Application menus press b.

•

To access a Vernier DataQuest™ context menu, move the cursor to
the desired object and press / b.

You can also use menu item numbered shortcuts when available.
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When there are special instructions or exceptions to these methods, they
will be indicated.

Navigating the screens
Complete one of the following steps to open the Vernier DataQuest™
application.
f From Document workspace menu bar, select Insert > Vernier
DataQuest or select

from the Welcome screen.

f From a handheld, select

from the Home screen.

or
Press ~ and select Insert > Vernier DataQuest from an open
document.
The Vernier DataQuest™ application opens.

Understanding the computer view
This is a general overview of the parts of the computer view.
An examination of the application screen sections will follow later.

À

Á
Â

À

Document Toolbox

Á

Application

Â

Status bar

The Document Toolbox:
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Close-up of the status bar

ÀÁ

À

Â

Click
to activate the handheld view. When activated, the
screen display emulates the display as shown on a handheld.
(Illustrated in Understanding the handheld view.)

Á
Click
to activate the computer view. When activated, the
screen displays the default view for the computer.

Â

The slider bolds the view when the computer view is active. The
slider scales the view when the handheld view is activated.

Understanding the handheld view
This is a general view of the Vernier DataQuest™ application opened on
a handheld. There are more possible icons on the handheld menu bar
than shown here. See the Getting Started with the TI-Nspire™ handheld
or the Getting Started with the TI-Nspire™ CX handheld for more
information.
An examination of the application screen sections will follow later.
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À

Á

À

Handheld menu bar

Á

Application

Close-up of the handheld menu bar

À

Á

ÂÃ

À

Page scrolling arrows and page tab - Use the
Touchpad and the arrows to scroll through
the pages in a document. The page tab(s)
indicates the problem number followed by
the page number.

Á

Document name - This shows the current
document name. You can click here to access
the Document menu. An asterisk by the
document name indicates changes were
made since the document was last saved.

Â

Status and Settings - The battery level is
shown here. You can hover for the
percentage value. You can click on the icon
for additional options.

Ã

Close document - Click here to close the
current document.
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Understanding the Application screen sections
The Vernier DataQuest™ application screen is identical for the computer
and handheld. The following is a general examination of the sections of
the application screen.

À
Á
Â
Ã

Ä

À

Vernier DataQuest™ application view tabs - There are
three selectable views: Meter, Graph, and Table. In this
example the Graph View is displayed.

Á

Data Set selection tool - This tool displays in the Graph
View only. This tool allows you to choose which data set is
graphed.

Â

View Details area - This area contains information about
the data appropriate for the current view.

Ã

Data display area -The primary display of the data. The type
of data displayed depends on the view. Examples of each
view will be covered later in this document.

Ä

Data collection controls - Use these buttons to start and
stop collections, store data sets, and capture data points.
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Selecting views
In the Vernier DataQuest™ application, you can choose from three views:
•

Meter

•

Graph

•

Table

The Vernier DataQuest™ application view tabs.

You can switch from one view to another at any time.

Selecting Meter View
When you first open the application, Vernier DataQuest™ is in Meter
View. If one or more sensors are attached, a meter is displayed for each.
f Select View > Meter or click

.

The Meter View displays.

Selecting Graph View
The Graph view is where you can visualize your data and use analysis
tools.
f Select View > Graph or click

.

The Graph View window is displayed.
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Selecting Table View
The Table view displays tabular data using columns, rows, and cells.
f Select View > Table or click

.

The Table View window is displayed.

Performing an experiment
This section provides an overview of the typical process for performing
an experiment. The steps are brief with more detail on parameters and
steps to follow later in the Experiment details section.
Note: If you are reading this in the abbreviated application installed
help, please see the full reference guide Data Collection and Analysis
chapter to access the additional sections referred to in these steps for
more information.
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1. Start with a new document.
When possible, start from a new document or new problem within an
existing document. This ensures the Vernier DataQuest™ application
is set to the default values. See Starting a new document or problem.
Note: It is also recommended to have only one document open
because the system may not know which document to assign the
sensor.
2. Connect your data collection device. The sensor is displayed in your
Vernier DataQuest™ document.
Auto launch will open the application on the current page if the page
is not split and there is no application already on the page.
Otherwise, a new full page is inserted immediately after the current
page with the Vernier DataQuest™ application.
See Data collection devices for more information about the different
data collection options.
3. Select Experiment > New Experiment to reset sensor defaults.
This ensures the default data collection mode and the settings are set
for the connected sensors and it removes any existing data.
Important: This step is extremely important when you are not
starting from a new document or problem.
4. (Optional) Modify the data collection mode and data collection
settings.
If desired, you can modify the default mode and settings to match the
experiment you are performing.
•

To change the mode and settings select Experiment > Collection
Mode.

•

Set the desired data collection mode for your experiment.

See Setting and using a collection mode.
5. (Optional) Modify the sensor settings
If desired, you can modify how the sensor values are displayed and
stored in the application. You can change units, modify the sensor
calibrations, and change the displayed precision of the data.
See Modifying sensor settings.
6. Start the Data Collection by selecting Experiment > Start Collection
or click
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If in Meter View, the Vernier DataQuest™ application changes to
Graph View and the recording of sensor data is enabled. The graph is
updated to show the collected data as it is occurring.
Important: When using data modes Events with Entry or Selected
Events, data points are not recorded until you select Experiment >
Keep or click

.

See Using the Keep option.
7. (Optional unless event-based) Stop data collection.
For most data collection modes, the collection will end automatically.
You can stop the collection early if desired. However, you must stop a
collection manually when using event-based data collections.
To stop a collection, select Experiment > Stop Collection or click

.

8. Analyze the collected data.
There are many tools you can use to analyze your data. See the
following sections in this document for more information.
•

Analyzing data to review common analysis features.

•

Working with advanced analysis features for additional analysis
options.

Important: Some information may be shown only in the All Details
for Graph dialog box. See Examining the View Details area data.
9. (Optional) Perform additional data collection runs.
For most experiments it is desirable to perform multiple trials (runs).
You can store the data set from the latest run before performing a
new run. Storing the data set retains the data from the previous run
by creating a new data set for your next run. If you do not need to
retain the data from the previous run, you can overwrite the data set
by starting another collection without storing.
To store the data set, select Experiment > Store Data Set or click
.
Important: You must save the document (File> Save) if you want to
keep the data after the application has been closed.
10. (Optional) Save the data by saving the document.
To save the document, choose the document to save and select File >
Save Document or press Ctrl + S.
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Handheld: Press ~ then select File > Save or press / + S.
Saving your document retains all of your data collection settings and
data for use at another time.
Save the document as a TI-Nspire™ document (.tns file) or as a
TI-Nspire™ PublishView™ document (.tnsp).
Important: PublishView™ is a special application of TI-Nspire™ that
is only available on the computer software.
11. (Optional) Print the document if desired.
See Printing data views.

Experiment Details
This section provides more detail to the procedure steps given in
Performing an experiment.
This section includes:
•

Starting a new document of problem

•

Connecting a sensor

•

Data collection devices

•

Setting and using a collection mode

•

Modifying sensor settings

•

Starting a data collection

•

Using the keep option

•

Stopping a collection

•

Examining data points

•

Data analysis options

•

Examining the View Details area

•

Showing and hiding details

•

Storing data

•

Saving an experiment

Starting a new document or problem
Starting a new document or problem ensures all Vernier DataQuest™
values and settings are set back to the defaults.

498

Data Collection and Analysis

Starting a new document
1. Best practices recommend closing all open documents. Save any open
documents, if desired, by selecting the document to be saved and
selecting File > Save Document or press Ctrl + S.
Handheld: Press ~ then select File > Save or press / + S.
Save the document as a TI-Nspire™ document (.tns file) or as a
TI-Nspire™ PublishView™ document (.tnsp).
Important: PublishView™ is a special application of TI-Nspire™ that
is only available on the computer software.
Important: The handheld can only have one document open. If you
do not save you will be asked if you want to save before creating a
new document.
2. Select File > New TI-Nspire Document or press Ctrl + N.
Handheld: Press c then select New Document.
3. Select the Vernier DataQuest™ application from the menu.

A new document is opened.

Adding a problem
You can add a new problem to an existing document. The new problem
page starts with the Vernier DataQuest™ default values and settings,
ensuring a “clean” start for this new problem.
1. Select Insert > Problem.
Handheld: Press ~ then select Insert > Problem.
2. Select the Vernier DataQuest™ application from the menu.
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A new problem document is created.

Connecting a sensor
Attach your sensor to the sensor interface, then attach your interface to
the computer or handheld.
Direct-connect USB sensors such as the Vernier Go!Temp® temperature
probe (for computers) or the Vernier EasyLink® temperature probe (for
handhelds) connect directly to the computer or handheld and do not
need a sensor interface.

Data collection devices
There are a variety of sensors and interfaces that can be used with your
TI-Nspire™ software running the Vernier DataQuest™ application.

Sensor Interfaces:
•

Texas Instruments TI-Nspire™ Lab Cradle - a multi-channel sensor
interface for use with handhelds or computers.

•

Vernier EasyLink® - a single-channel sensor interface for use with
handhelds.
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•

Vernier GO!Link® - a single-channel sensor interface for use with
computers.

Sensors
•

Analog Sensors - sensors such as temperature, light, pH, and voltage
probes are analog sensors. These sensors require a sensor interface.

•

Digital Sensors - sensors such as motion detectors, photogates,
radiation monitors, and drop counters are digital sensors. These
sensors can only be used with the TI-Nspire™ Lab Cradle.

Direct-Connect USB Sensors
These sensors connect directly to a handheld or computer and do not
require a sensor interface.
For Handhelds:
•

Texas Instruments CBR 2™

•

Vernier EasyTemp® temperature probe
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For Computers:
•

Vernier Go!Temp® temperature probe

•

Vernier Go!Motion® motion detector

Setting and using a collection mode
Use the Collection Mode option to assign the mode to use for collections.
The default collection mode is Time Based. If you have unsaved data, you
will be warned that changing modes will clear your data.
This section examines the procedures for the collection modes. Your
options are:
•

Time Based - The default for a new experiment.

•

Events with Entry

•

Selected Events

•

Photogate timing - Only used with the Vernier Photogate sensor.

•

Drop Counting - Only used with the Vernier Drop Count sensor.
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Setting a Time Based collection mode
The Time Based option captures data with respect to time. This is the
default mode for new experiments.
To set the collection mode as Time Based:
1. Select Experiment > Collection Mode > Time Based.
The Configure Time Based Data Collection dialog box opens with
either Interval or Rate selected. (It uses your previous settings as the
opening value.)

or

Rate (samples/second)

Interval (seconds/sample)

2. Select Rate or Interval mode from the drop-down menu.
Rate and Interval are used to determine how often data points are
collected. For convenience, you have two methods in which to enter
this information. Rate and Interval are simply reciprocals of each
other.
•

Rate (samples/second): Enter the number of samples per second.

The interval is calculated.
•

Interval (seconds per sample): Enter the number of seconds per

sample. The rate is calculated.
3. Enter the rest of values in the Configure Time Based Data Collection
dialog box.
•

Duration (seconds): Enter the duration that the data collection

should last.
•

Number of points: This is a calculated field. Review this value to

ensure your rate and duration are reasonable. This value is
determined by the formula, Rate * Duration + 1.
Important: Collecting too many data points impacts system
performance.
Data Collection and Analysis
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•

Strip Chart (Optional): Strip Chart will continuously collect
samples but only retain the last x data points collected. (“x”
represents the number of points defined in Number of Points.)

•

Data Marker (Optional): Selecting this option places

in the
Data collection controls area. Click the Add Data Marker icon
while collecting in time base mode to emphasize specific points.
Use this option to identify points of interest, such as an observed
change or when changing the conditions, while collecting data.
For example: Ice begins to form, began stirring, or added a
chemical.

4. Click OK to save your entries.
Your settings are saved for use on your next run.

Using Time Based collection mode
Use this procedure only after assigning Time Based as the collection
mode.
To use after setting Time Based as the collection mode:
1. Connect a sensor.
2. Select Experiment > Start Collection or click
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Setting Events with Entry
This collection mode allows you to capture samples manually. Events with
Entry and Selected Events are similar. The difference is that Selected
Events numbers the dependent column (1,2,3,...) where Events with Entry
ask you to define the independent value for each point you collect.
To set the collection mode as Events with Entry:
1. Select Experiment > Collection Mode > Events with Entry.
The Events with Entry Setup dialog box opens.

2. Enter a new name and (Optional) units for the independent variable
for your collection.
3. (Optional) Select Average over 10 s (seconds).
Use this option when sensor values fluctuate. Ten seconds of data are
collected and the average reading is retained.
4. Click OK to save your entries.
Your settings are saved for use on your next run. The Keep current
reading icon

now appears (inactive) in Data collection controls.

Using Events with Entry
Use this procedure only after assigning Events with Entry as the collection
mode.
To use the Events with Entry collection mode:
1. Connect a sensor.
2. Select Experiment > Start Collection or click

.

The Keep current reading icon
becomes active. The sensor shows
the data point in the center of the screen.
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3. When ready, click

. One of the following dialog boxes opens.

•

If you selected “Average over 10 s,” the Averaging dialog box
opens with a count down displayed. When the seconds reaches
zero, it will record the data point in the appropriate location on
the graph.

•

If you did not select “Average over 10 s”, the Events with Entry
dialog box is opened.
–

Manually enter the value of your data point.

–

Click OK.

The data point is saved in the appropriate location on the graph.
The next point appears in the center of the graph.
4. Repeat step three until all your desired data points are captured.
5. Stop the collection.

Setting Selected Events
This collection mode allows you to capture samples manually. Events with
Entry and Selected Events are similar. The difference is that Selected
Events numbers the dependent column (1,2,3,...) where Events with Entry
ask you to define the independent value for each point you collect.
To set the collection mode as Selected Events:
1. Select Experiment > Collection Mode > Selected Events.
The Events with Entry Setup dialog box opens.
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2. Enter a new name and (optional) units.
These are labels. Use any meaningful values.
3. (Optional) Select Average over 10 s.
4. Click OK to save your entries.
Your settings are saved for use on your next run. Keep current
reading

now appears (inactive) in Data collection controls.

Using Selected Events
Use this procedure only after setting Selected Event as the collection
mode.
To use the Selected Events collection mode:
1. Connect a sensor.
2. Select Experiment > Start Collection or click

.

Keep current reading becomes active. The sensor shows the data
point in the center of the screen when in Graph View.
3. When ready, click

.

The data point is saved in the appropriate location on the graph. The
next point appears in the center of the graph.
4. Repeat step three until all your desired data points are captured.
5. Stop the collection.
Your data set run is complete.

Using Photogate Timing
Select this mode only if using the Vernier Photogate. See sensor
specifications for information to help you choose your collection mode
options.
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Using Drop Counting
Select this mode only if using the Vernier Drop Counter. See sensor
specifications for information to help you choose your collection mode
options.

Modifying sensor settings
Use this option to modify the values returned by a sensor. For example,
when using a temperature probe, you can change the units from
Centigrade to Fahrenheit.

Changing sensor units
Default units and available options to change the units vary depending
on the selected sensor. For example, options for the Vernier Go!Temp®
Temperature probe are Fahrenheit, Celsius, and Kelvin. Options for the
Vernier Hand Dynamometer (a specialized force sensor) are Newton,
Pound, and Kilogram.
To change a sensor’s unit of measure:
1. Select Experiment > Set Up Sensors > Change Units.
2. Select the sensor you want to change the units.
Available sensor(s) are dependent on attached and offline sensor(s)
selected.
3. Select the unit type from the menu associated with the sensor.

The measurement unit is changed.
Note: You can change the units before or after the data has been
collected. The collected data will reflect the new units.
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Calibrating a sensor
When a sensor is detected, it automatically loads a calibration for that
sensor. You have the option of calibrating sensors. Some sensors cannot
be calibrated, while other sensors, such as the Colorimeter and the
Dissolved Oxygen Probe must be calibrated to be useful.
There are three options when calibrating a sensor:
•

Manual Entry

•

Two Point

•

Single Point

See your sensor’s specifications for information on the calibration values
and procedures to change.

Zeroing a sensor
Not all sensors can be zeroed. Sensors where relative measurements are
common, such as Force, Motion, and Pressure, can be zeroed. Sensors
designed to measure specific environmental conditions, such as
Temperature, PH, and CO2 cannot be zeroed.
To set the standing value to zero:
f Select Experiment > Set Up Sensor > Zero.
The sensor value is now at zero.
If more than one attached sensor can be zeroed, you will see a list of
sensors to chose from along with an option to zero all sensors.

Reversing a sensor
Use this feature to change the display of the reading.
By default, pulling with a force sensor produces a positive force and
pushing produces a negative force. Reversing the sensor allows you to
display pushing as a positive force.
If more than one sensor can be reversed, choose the one to reverse from
the provided list.
To reverse the sign of the sensor reading:
f Select Experiment > Set Up Sensor > Reverse.
The sensor sign is now reversed. If you are in Meter View, you can see
the reverse indicator “

” after the sensor name.
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Starting a data collection
Use this method to start a collection. If you already have a collection you
must decide if you want to overwrite the existing data or store it.
If you do not need to save the data from the previous run, you can
overwrite the data set by performing the following step.
If you want to store your existing data set and not overwrite the data,
see Storing data before performing this step.
f Start the Data Collection by selecting Experiment > Start Collection
or click

.

If in Meter View, the Vernier DataQuest™ application changes to
Graph View and the recording of sensor data is enabled. The graph is
updated to show the collected data as it is occurring.
Important: When using data modes Events with Entry or Selected
Events, data points are not recorded until you select Experiment >
Keep or click

.

See Using the Keep option.

Using the Keep option
Use the Keep option to store the connected sensor’s values.
Note: See Setting and using a collection mode to assign the entry name
and unit labels.
Using Keep stores a specific data point. This option is available when the
Collection Mode specified is "Events with Entry" or "Selected Events."
If the Collection Mode is "Events with Entry," you must assign the
independent value that corresponds to the dependent variable.
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Defining Collection Mode as Selected Events
To set collection mode to Selected Events:
1. Select Experiment > Start Collection or click
2. Select Experiment > Keep or click
to keep.

.

for each data point you want

3. Repeat step two until all data points you want to collect are selected.
4. Select Experiment > Stop or click

after all points are selected.

The data point is captured for each selection. Data is visible in the
Graph and Table views.

Defining Collection Mode as Events with Entry
To set collection mode to Events with Entry:
1. Select Experiment > Start Collection or click
2. Select Experiment > Keep or click
to keep.

.

for each data point you want

The Events with Entry dialog box opens.

3. Enter the independent value in the “Enter Value” field.
Note: Value is typically numeric, but you can also use text.
4. Click OK to continue.
5. Repeat steps two through four until all data points you want to
collect are selected.
6. Select Experiment > Stop or click

after all points are selected.

The data point is captured for each selection. Data is visible in the
Graph and Table views.
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Stopping a collection
You can stop a data collection before the data set’s run is expired.
To stop a collection:
f Select Experiment > Stop Collection or click

.

The current run is stopped.

Analyzing data
Analyzing data in the Vernier DataQuest™ application is done from the
Graph View. Start by setting up graphs and then use analysis tools such as
integral, statistics, and curve fit to investigate the mathematical nature
of your data.
This section includes:
•

•

Examining data points
–

Interpolate

–

Tangent

–

Examine Settings

Data analysis calculations
–

Integral

–

Statistics

–

Curve Fit

–

Model

See Working with data and Graph View.
Also see, Working with advanced analysis features.
Important: The Graph menu and Analyze menu items are only available
when working in Graph View.

Examining data points
The following provides information about the methods available for
examining data points in the Vernier DataQuest™ application.

Interpolate
Use Interpolate to estimate the value between two data points and to
determine the value of a Curve Fit between and beyond data points.
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The examine line moves from data point to data point. When Interpolate
is on, the examine line moves between and beyond data points.
To turn Interpolate on and off:
f Select Analyze > Interpolate.
When Interpolate is on, a check mark appears in the menu next to the
option.
To use Interpolate:
1. When Interpolate is on, move the cursor over the graph and click
once. The examine indicator is drawn to the nearest data point.
The values of the plotted data are shown in the View details area and
the All Details for Graph dialog box.
2. You can move the examine line by moving the cursor with your arrow
keys or clicking on another data point.

Tangent
Tangent is used to display a measure of the rate at which the data is
changing at the point you are examining. The rate value is displayed in
the View Details area and in the All Details for Graph dialog box. The
value is labeled “Slope.”
To turn Tangent on and off:
1. Select Analyze > Tangent.
When Tangent is on, a check mark appears in the menu next to the
option.
2. When Tangent is on, move the cursor over the graph and click once.
The examine indicator is drawn to the nearest data point.
The values of the plotted data are shown in the View details area and
the All Details for Graph dialog box.
3. You can move the examine line by moving the cursor with your arrow
keys or clicking on another data point.
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Examine Settings
This option allows you to select which of the plotted columns and curve
fit you would like to trace when examining the data. Values are
displayed in the View details area and in the All Details for Graph dialog
box.
You can also show cursor position and delta values as you examine the
data by selecting the Position and Delta option. The values are displayed
below the graph.
To examine settings:
1. Select Analyze > Examine Settings.
The Examine dialog box opens. The default is to have all “Show
Examine” items selected. In this example, there is one sensor column
and a curve fit with both selected.
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2. Choose your options.
•

Position and Delta - Show the cursor position and delta values
The Position and Delta tool is used in the following ways:
Position - The cursor’s pixel coordinates will show under the
graph so you can determine the coordinates of a point on the
screen between and beyond data points without using interpolate
mode or doing a curve fit.
Delta - This is used to determine changes in x and y between two
points (the coordinate of the start and graph points of a selected
region). This can be used to answer a question like “How much did
the temperature drop, and how long did it take?”

•

Plotted column name (in this example Pressure) - Show the

value and units of the displayed column.
3. If examining the position and delta, you may also select a region.
To select a region, place your cursor at the start of the area. Click and
drag across the graph to the end of your selected region. The selected
area is indicated by gray shading. (See a following example that
shows Position and Delta for an illustration.)
The following are examples of the Examine dialog box and the Graph
View (with data) when both the Show Examine and Position and Delta
options are unselected.

The following are examples of the Examine dialog box and the Graph
View (with data) when only the Show Examine option is selected. Notice
the value and units of Pressure is shown.
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The following are example screens of the Examine dialog box and the
Graph View (with data) when both the Examine options and Position and
Delta are selected. This example also shows a selected range. (See
Selecting a range for instructions on how to select a range.)
Notice that the value and units are shown, and now position and delta
values are also shown under the graph.

x-axis range
y-axis
range

Data analysis calculations
Integral
Use Integral to determine the area under a data plot. You can find the
area under all of the data or a selected region of the data. The value is
displayed in the View Details area and in the All Details for Graph dialog
box.
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To view integral:
1. Leave the graph unselected to examine all the data, or select a range
to examine a specific area.
See Selecting a range for instructions on how to select a range.
2. Select Analyze > Integral.
3. Select plotted column name if you have more than a single column.
The following is an example with an area selected.

Statistics
Use this option to determine the statistics associated with the plotted
data. Minimum, maximum, mean, standard deviation, and number of
samples are calculated. You can find the statistics for all the data or a
selected region of data. The values are displayed in the View details area
and in the All Details for Graph dialog box.
To generate statistics:
1. Leave the graph unselected to examine all the data, or select a range
to examine a specific area.
See Selecting a range for instructions on how to select a range.
2. Select Analyze > Statistics.
3. If you have more than a single column, select the plotted column
name (example: run1.Pressure) which you want to examine.
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The statistics dialog box open.

4. Review the data and click OK when done.

Curve Fit
Find a best curve fit to match your data. Select all of the data or a
selected region of data. The curve is drawn on the graph and the
equation information is displayed in the View details area and in the All
Details for Graph dialog box.
To generate curve fit:
1. Leave the graph unselected to examine all the data, or select a range
to examine a specific area.
See Selecting a range for instructions on how to select a range.
2. Select Analyze > Curve Fit.
3. Select the curve fit option from the menu.
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Curve fit option

Calculated in the form:

Linear

y = m*x + b

Quadratic

y = a*x^2 + b*x + c

Cubic

y = a*x^3 + b*x^2 + c*x + d

Quartic

y = a*x^4 + b*x^3 + c*x^2 + d*x + e

Power (ax^b)

y = a*x^b

Exponential
(ab^x)

y = a*b^x

Logarithmic

y = a + b*ln(x)

Sinusoidal

y = a*sin(b*x + c) + d

Logistic (d

0)

y = c/(1 + a*e^(-bx)) + d

Natural
Exponential

y = a*e^(-c*x)

Proportional

y = a*x

The curve fit details dialog box opens.
4. Review the data and click OK when done.
The following image is an example of curve fit (Quadratic).
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Model
This option provides a manual method of plotting a function to fit data.
Use one of the predefined models or enter your own.
To generate the model:
1. Select Analyze > Model.
2. Enter your own function or select from drop-down menu.

Example manually entered function:

3. Click OK.
4. Set the coefficient and increment values.
These are the initial values. You can also adjust these values later with
the “sliders,” also called “spinners,” in the View Details area.
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5. Click OK.
The model is shown on the graph with adjustment options in the
View Details area and in the All Details for Graph dialog box.
Notice that the screen’s minimum and maximum axis are too large for
this particular example.

6. (Optional) Adjust the window setting for minimum and maximum
axis by clicking on the y and x minimum and maximum values directly
on the screen to change, or select Graph > Window Settings. Click
OK when done. See Setting Min and Max axis ranges.
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7. Make any desired adjustments to the coefficients by clicking on
clicking directly on the value in the View Details area.
Example of a value entered directly:

Example model with values adjusted:
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Removing analysis options
Use to clear previous analyzed data from the graph and the View Details
area. You can choose to clear all or a specific data display. This option can
also remove any generated models.
Use this menu to remove the following items:
•

Integral

•

Statistics

•

Curve Fit

•

Model

f Select Analyze > Remove.
When there is only one item to remove, the Remove option will
include the name of the item available to be removed or the curve fit.
For example, “Remove Cubic.”
When there is more than one item, select the item to remove from
the list provided.

Examining the View Details area data
When you are performing analysis options such as statistics, the All
Details for Graph dialog box opens. You can examine the details and click
OK to close the box. You can reopen this dialog box manually. See
Opening a View Details area dialog box.
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The detail information is shown in the View Details area even when the
dialog box is closed.
You can open a dialog box to show the data detail. Alternatively, you can
expand the View Details area to have more space to display information.
Important: Some information is only shown in the view details dialog
box.

Opening a View Details area dialog box
You can open a dialog box to see the data included in the View Details
area.
1. Open the context menu in the View Detail area.
2. Select Details > All Details.
The All Details for Graph dialog box opens.

Use the scroll bar to see the rest of the data.
Other menu options under Detail context menu may be available. These
are subsets you can select if you only want part of the details.

Expanding the View Details area
Use this procedure to expand the View Detail area. By increasing its
screen “real estate” you reduce the space for the graph. You can use this
same procedure to constrict the View Details area.
In this example, tangent line and statistics are displayed.
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1. Place your cursor at the edge of the View Details area and hover until
the cursor changes to

.

2. Click and hold until cursor changes to

.

3. Drag until it is the size you desire.
In this sample the View Details area is resized.
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Showing and hiding details
You can hide parts of the screen to provide more screen “real estate.”
The following are example screens with the details shown.

To hide details:
f Select Options > Hide Details.
The menu changes from Hide Details to Show Details.
The following parts of the screen are hidden:
•

Vernier DataQuest™ application view tabs

•

View Details area

•

Data collection controls

The following are example screens with the details hidden.
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To show details:
f Options > Show Details.

Storing data
When data is present, use the Store Data Set option to create a new
data set for subsequent data collections so data already collected is not
overwritten. The data set is not saved outside the currently running
application until you save the data set as a TI-Nspire™ or PublishView™
document.
To store a data set:
f Select Experiment > Store Data Set or click

.

The first data set is stored as "Run 1" by default and "Run 2" opens
for collecting additional data. The data set names can be changed.

Saving an experiment
Save the document as a TI-Nspire™ document (.tns file) or as a
TI-Nspire™ PublishView™ document (.tnsp).
Important: PublishView™ is a special application of TI-Nspire™ that
is only available on the computer software.
1. Select the document to be saved.
2. Select File > Save Document or press Ctrl + S.
Handheld: Press ~ then select File > Save or press / +S.

Working with data and Graph View
Use the Graph View to visualize your data and for analysis. This section
shows how to view multiple graphs, select the plotted data to be
displayed, change the x and y axis ranges, and zoom in and out of your
graph.
Important: The Graph menu and Analyze menu items are only active
when working in Graph View.
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This section’s topics include:
•

Showing graphs

•

Adding a title to a graph

•

Selecting a data set to plot

•

Setting min and max axis ranges

•

Selecting a Data Set to plot

•

Using autoscale

•

Using zoom in and zoom out

•

Selecting a range

•

Setting the point display

•

Selecting an independent variable column

•

Selecting a dependent variable column

Showing graphs
The Show Graph menu option is used to show separate graphs when you:
•

Have a sensor that plots more than one column of data.

•

When multiple sensors having different defined units are used at the
same time.

You can select to show the top graph, bottom graph, or both. In these
conditions, the default is to show both graphs.
In this example, two sensors (the Gas Pressure sensor and the Hand
Dynamometer) were used in the same run. The following image shows
the columns Time, Force, and Pressure in the Table View to illustrate why
two graphs are shown.
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1. Select View > Graph or click

.

In this example, both graphs are shown by default.

Showing Graph 1
Continuing with the same example as Showing Graphs, this process
shows how to display only Graph 1.
f Select Graph > Show Graph > Graph 1.
Only Graph 1 is displayed. Graph 1 is the top graph when both graphs
are displayed.

Data Collection and Analysis

529

Showing Graph 2
Continuing with the same example as Showing Graphs, this process
shows how to display only Graph 2.
f Select Graph > Show Graph > Graph 2.
Only Graph 2 is displayed. Graph 2 is the bottom graph when both
graphs are displayed.

Showing both graphs
Continuing with the same example as Showing Graphs, this process
shows how to display both graphs if you have previously selected to
show only Graph 1 or Graph 2.
f Select Graph > Show Graph > Both.
Both graphs are displayed.
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Adding a title to a graph
You can add a title to your graph. The title displays in the View Details
area and is printed with your graph.
1. Select Graph > Graph Title.
The Graph Title dialog box is opened.

When you have two graphs, the dialog box has two title options.

2. Enter the name of your title.
3. Select Enable to show the title.
Note: With the Enable option you can enter a graph name and turn it
on or off as your needs change.
4. Click Ok.
If enabled, the title is shown.
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Setting min and max axis ranges
You can modify the minimum and maximum range for the x and y axis
using these procedures.

Setting the axis range using the menu
1. Select Graph > Window Setting.
The Windows Setting dialog box opens.

When you have two graphs there are two y axis minimum and
maximum values to enter but only one set of minimum and maximum
values for the x axis.
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2. Edit the values you want to change.
The application will use these new values for the graphs visual range
until you modify or change data sets.

Setting the axis range from the window
You can modify the minimum and maximum range for the x and y axis
from the window.
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f Select one or more values to change by highlighting the text and
typing a new value.
Handheld:
•

Place your cursor over the value until the cursor changes to an Ibeam

.

•

Click the text to highlight and type your new value.

•

Press ·.

Handheld example screens:
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Selecting a Data Set to plot
Select which data set to plot when there is more than one data set
available.
1. Select Graph > Select Data Set or click on the Data Set selection tool.
The list of available data sets opens.

2. Select one of the following:
•

Data Set name - plot one data set

•

All - plot all data sets

•

More - Choose a combination of data sets to plot. Click OK when

Done.
When using the More option, if you select more than one data set
and less than all, the Data Set selection tool will read “Custom.”
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Using autoscale
You can use the autoscale option anytime to change the screen view to
accommodate all available points. You can also define the system’s
automatic autoscale behavior to be used during and after a collection.

Using autoscale now
Use autoscale at anytime to restore the graph to show all the points
plotted. Autoscale Now is very useful after changing the x and y axis
range and after a zoom in or out.

Autoscale Now using the menu
f Select Graph > Autoscale Now.
The graph now displays all the points plotted.

Autoscale Now using the window (context menu)
1. Open the context menu in the graph area.
2. Select Window/Zoom > Autoscale Now.
The graph now displays all the points plotted.

Defining autoscale during a collection
You have two options for the system’s automatic autoscaling that occurs
during a collection. Use this procedure to set your choice.
1. Select Options > Autoscale Settings.
2. Click the During Collection drop-down list and select one:
•

Autoscale Larger - This option expands the graph as needed to
show all points as they are collected.

•

Do Not Autoscale - With this option selected, the graph window

is not changed during a collection.

Defining autoscale after a collection
You have three options for the system’s automatic autoscaling that
occurs after a collection. Use this procedure to set your choice.
1. Select Options > Autoscale Settings.
2. Click the After Collection drop-down list and select one:
•

Autoscale to Data - With this option selected, the system expands

the graph as needed to show all data points. This is the default
mode.
•

Autoscale From Zero - This option modifies the graph so all data

points are displayed as well as the origin point.
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•

Do Not Autoscale - The graph window settings are not changed.

Using zoom in and zoom out
You can zoom in to a subset of the collected points. You can also zoom
out from a previous zoom or to expand the graph window beyond the
data points collected.

Zoom In
1. Select the area range you want to zoom in or use your current view.
See Selecting a range for instructions on how to select a range.
2. Select Graph > Zoom In or open the context menu on the graph and
select Windows/Zoom > Zoom In.
The graph window is now adjusted to only display your selected area.
The selected x range will be used as the new x range. The y range will
autoscale to show all graphed data points in the selected range.
The following images show an original (autoscale) view and zoom in
performed multiple times (or as a selected region).

Zoom Out
1. Select Graph > Zoom Out or open the context menu on the graph
and select Windows/Zoom > Zoom Out.
The graph window is now expanded.
If a zoom in preceded a zoom out, it will return the settings prior to
the zoom in.
For example, if you zoomed in twice the first zoom out would return
the window to the state of the first zoom in. To get back to the full
graph (showing all data points) quickly from multiple zoom ins, use
Autoscale Now.
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Selecting a range
Selecting a range on the graph is useful in several situations, such as
when zooming, striking and unstriking data, and examining settings.
To select a range:
1. Place your cursor at the start of the area. Click and drag across the
graph to the end of your selected region. The selected area is
indicated by gray shading.
Handheld:
•

Place you cursor at the starting point and click x (center of the
Touchpad).
The cursor changes to

(double-headed arrow).

•

Move the cursor to the end of your selection.

•

Press d.
The cursor returns to å (single-headed arrow).

2. Perform your action (such as zooming).
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Setting the point display
You can adjust the way points are displayed on your graphs.

Point Options
Use this procedure to determine how often marks appear on the graph
and whether to use a connecting line.
1. Select Options > Point Options.
The Point Options dialog box opens.

2. Select your Mark option from the drop-down box.
•

None - No point protectors.

•

Regional - Periodic point protectors.

•

All - Display every data point as a point protector.

3. Select or deselect Connect Data Points.
Selecting Connect Data Points displays a line between points.
The following shows examples of some of the point Mark options.
Regional
Connect Data Points - Selected

All
Connect Data Points - not selected

None
Connect Data Points - Selected
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Point Colors
Use this procedure to set the color of the marks different than the
system’s settings.
Note: On a non-color handheld, the “color” is represented by different
shades of gray.
1. Open the context menu in the Graph and select Color from the menu.
Note: The Color option is often preceded by the data set name and

column name.

2. Select the column variable to change.
3. Select the color to set.
In this example, Force was selected and green was the color chosen.
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Point Markers
Use this procedure to change the symbols used for your point markers.
1. Open the context menu in the Graph and select Point Marker from
the menu.
Note: If there is only one dependent variable column, the Point
Maker option is preceded by the data set name and column name.
Otherwise, the Point Marker option has a menu.

2. Select the column variable to change.
3. Select the point marker to set.
In this example, Pressure was selected and the inverted fill triangle
was the point chosen.
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Selecting an independent variable column
The option Select X-axis Column allows you to select the column used as
the independent variable when graphing the data. This column is used
for all graphs.
f Select Graph > Select X-axis Column and choose from available
variables.
The x-axis label on the graph changes and your graph is reordered
using the new independent variable for graphing the data.

Selecting a dependent variable column
The option Select Y-axis Column allows you to select which dependent
variable columns to plot on the displayed graph(s).
1. Select Graph > Select Y-axis Column.
2. Select one of the following:
•

A variable from the list.
The list is a combination of your dependent variables and the
number of data sets.

•

More

Selecting More opens the Select dialog box. Use this when you
want to select a combination of data set variables to display.
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Working with data and Table View
This section primarily involves working with your data sets in Table View.
This section’s topics include:
•

Defining column options

•

Changing a data set name

•

Adding a new manual column

•

Adding a calculated column

•

Creating a new data set

Defining column options
Set the column name, units, and precision here. All existing columns are
listed.
To define the column:
1. Select View > Table or click

.

You can be in the Meter, Graph, or Table views and still perform these
steps. The results will still be visible.
The Table View is displayed. In this example, no data sets have been
run and the Vernier Gas Pressure Sensor is attached.
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2. Select Data > Column Options and the column you want to define,
for example, the Pressure column.

The Column Options menu opens.
3. Enter the values you want to edit. The fields are populated but allow
editing.
•

Name: Enter the long name for the column.

•

Short Name: The preferred abbreviation for a column where the
column has not been expanded large enough to show the full
name.

•

Units: Enter the unit label. The label is used when values from this
column are displayed in graphs and detail boxes.

•

Displayed Precision: Specifies the number of decimal places or
significant values. This default precision is related to the precision
of the sensor.

•

Link to List: Allows the system to link columns to the symbol
table and make the variable (such as run1.x) available to other
TI-Nspire™ applications outside of the Vernier DataQuest™
application. Linking is the default for most sensors.
Note: Heart rate and blood pressure sensors require a
tremendous amount of data to be useful, and the default for
these sensors is to be unlinked to improve system performance.

•
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Apply changes to all Data Sets: Allows you to apply the settings
to all data sets or just to the latest data set.
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In this example, the name was changed to “Pressure Ex01a” and the
displayed precision was set to “4.”

4. Click OK.
The column settings are now defined with your new values.
The following example shows some views after a data collection.
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Changing a data set name
Defining Column Options explained how to change the column
headings. This section shows you how to change the Data Set name
above the column headings (also in the Data Set selection tool and the
Details View area).
1. Select View > Table or click

.

2. Open the context menu for the table’s data set name, for example,
Run1.

3. Select Options (preceded by the data set name).
The Data Set Options dialog box opens.

4. Change the name.
Note: The maximum character limit is 30 and the name cannot
contain commas.
The data set name is now changed.
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Table View

Graph View

Adding a new manual column
You can add a column for manual entry of data. Sensor columns cannot
be modified, but manual column data and entry data may be edited.
1. Select Data > New Manual Column.
The Column Options dialog box opens.

2. Enter the values you want to edit. Most fields are populated but still
allow editing.
•

Name: Enter the long name for the column.

•

Short Name: The preferred abbreviation for a column where the
column has not been expanded large enough to show the full
name.

•

Units: Enter the unit label. The label is used when values from this
column are displayed in graphs and detail boxes.
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•

Displayed Precision / Significant Figures: Specifies the number
of decimal places or significant values. The default precision is
related to the precision of the sensor.

•

Apply changes to all Data Sets: Allows you to apply the settings
to all data sets or just to the latest data set.

•

Generate Values: This option box allows you to automatically

populate the manual column’s rows. You can enter a starting
value, an ending value, and an increment value. The number of
points is calculated for you.
•

Link from List: Allows you to link (which acts like a copy and
paste - not automatically updated) to data held by another
TI-Nspire™ application on an additional page, such as List &
Spreadsheets. The list is only populated when data exists in the
other application and includes a column label.

•

Link to List: Allows the system to link columns to the symbol
table and make the variable (such as run1.x) available to other
TI-Nspire™ applications outside of the Vernier DataQuest™
application. Linking is the default for most sensors.
Note: Heart rate and blood pressure sensors require a
tremendous amount of data to be useful, and the default for
these sensors is to be unlinked to improve system performance.

3. Click OK.
A new column is added to the table. This column can be edited.

Adding a calculated column
You can add an additional column to the data set where the values are
calculated from an expression using at least one of the existing columns.
1. Select Data > New Calculated Column.

548

Data Collection and Analysis

The Column Options dialog box opens.

2. Enter the values you want to edit. Most fields are populated but still
allow editing.
•

Name: Enter the long name for the column.

•

Short Name: The preferred abbreviation for a column where the
column has not been expanded large enough to show the full
name.

•

Units: Enter the unit label. The label is used when values from this
column are displayed in graphs and detail boxes.

•

Displayed Precision / Significant Figures: Specifies the number

of decimal places or significant values.
•

Expression: Enter an expression that includes one of the column
names provided. The system provided column names are
dependent on the sensor(s) selected and any changes made to the
name field in Column Options.

Important: The Expression field is case-sensitive. (Example:
“Pressure” is not the same is “pressure.”)
•

Link to List: Allows the system to link columns to the symbol
table and make the variable (such as run1.x) available to other
TI-Nspire™ applications outside of the Vernier DataQuest™
application. Linking is the default for most sensors.
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Note: Heart rate and blood pressure sensors require a
tremendous amount of data to be useful, and the default for
these sensors is to be unlinked to improve system performance.
Example with fields.

3. Click OK.
The new calculated column is created.
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Creating a new data set
You can create a new data set that has the same columns as the existing
data set(s). Column definitions from the latest data set are applied to the
new data set.
f Select Data > New Data Set.
An empty data set is created with the same column definitions as the
existing data set.

Using advanced data collection options
This section covers setting up more advanced data collection options.
This section’s topics include:
•

Setting up an offline sensor

•

Selecting a remote collection unit

•

Collecting remote data

•

Retrieving remote data

•

Setting up triggering

Setting up an offline sensor
The Add Offline Sensor option provides you with a method of setting
collection parameters and changing units for a sensor that is not
currently attached.
You cannot use an offline sensor but you can prepare it for use before it
is attached. This is useful to help speed up a lesson or lab when there are
not enough sensors for everyone, and the students are waiting for their
turn to use the sensor.
1. Select Experiment > Advanced Set Up > Configure Sensor > Add
Offline Sensor.
2. Select a sensor from the drop-down menu.
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The sensor is displayed in the Meter View and is available for set up
options.
The following is an example of an offline motion detector sensor in
Meter View.

Selecting a remote collection unit
Only the TI-Nspire™ Lab Cradle, TI CBR 2™, and Vernier Go!Motion®
support remote data collection.
Parameters for collection setup will use current values. Desired edits must
be performed before this procedure. See Setting and using a collection
mode.
To select the collection unit:
1. Set up your experiment for data collection.
2. Select Experiment > Advanced Set Up > Remote Collection.
3. Select the data collection device you want to use from the drop-down
list.
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The Remote Setup Details dialog box appears.
The following is an example dialog when the TI-Nspire™ Lab Cradle
was selected.

Other remote collection devices include The Texas Instruments
CRB 2™ and the Vernier Go!Motion®.
4. (Optional) Enter your delay value.
Setting the delay at zero allows you to use the manual trigger button
on the lab cradle to start your collection. See Using the manual
trigger to start the collection.
5. Click OK.
6. When ready, the Remote Setup dialog box is opened. A message
informs you how to start the collection and that it is safe to
disconnect the data collection device.
The following is an example message with the delay set to zero.

The following are example messages with the delay set to 11 seconds.
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Collecting remote data
This section describes the procedures for collecting remote data using the
TI-Nspire™ Lab Cradle. While you can use the lab cradle simply as a
sensor interface that allows you to use many sensors at one time, the
TI-Nspire™ Lab Cradle is also a data collection device.
The lab cradle can be used in conjunction with:
•

TI-Nspire™ handhelds

•

TI-Nspire™ software for computers

•

As a stand-alone tool.
To use as a stand-alone collection tool for remote collection, the data
collection parameters must first be set in the Vernier DataQuest™
application as described in Setting up the lab cradle for remote
collection.

Note: See the "TI-Nspire™ Lab Cradle Guide" included with the lab
cradle for more information. (If you do not have the TI-Nspire™ Lab
Cradle, go to education.ti.com to learn more and how to purchase.)

Setting up the lab cradle for remote collection
Use one of the two following methods for the remote collection:
•

Using the manual trigger on the TI-Nspire™ Lab Cradle or a sensor
with a trigger to start the collection

•

Using a delay to start the collection
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Using the manual trigger to start the collection
1. Save and close any open documents.
When performing experiments it is recommended that you have only
one document open. The system cannot determine which of the
documents to use with the sensor if multiple documents are open.
2. Attach a sensor to the TI-Nspire™ Lab Cradle.
3. Attach the TI-Nspire™ Lab Cradle to the computer or handheld.
4. Set up your experiment as desired.
5. Navigate to Experiment > Advanced Set Up > Remote Collection
> TI-Nspire Lab Cradle.

6. Review the settings. Verify the delay is at zero (no delay).
Setting the delay at zero allows you to use the manual trigger button
on the lab cradle to start your collection.

7. Select OK.
A message displays stating the device is ready for remote collection.
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8. Disconnect the cradle before pressing the OK in the message box.
9. When the TI-Nspire™ Lab Cradle is disconnected from the handheld
or computer, verify the status. When the LED transfer is blinking
amber it is ready and waiting.
10. When you are at the site to collect the data, click the trigger button
on the lab cradle. The data collection will start immediately.
After you have collected your data see Retrieving data from remote
data collection.

Using a delay to start the collection
1. Save and close any open documents.
When performing experiments it is recommended that you have only
one document open. The system cannot determine which of the
documents to use with the sensor if multiple documents are open.
2. Attach sensor to the TI-Nspire™ Lab Cradle.
3. Attach the TI-Nspire™ Lab Cradle to the computer or handheld.
4. Set up your experiment as desired.
5. Navigate to Experiment > Advanced Set Up > Remote Collection
> TI-Nspire Lab Cradle.

6. Review the settings. Specify the time (in seconds) to delay the start of
the collection.
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When you use a delay, the manual trigger button on the TI-Nspire™
Lab Cradle has no impact on the start of the collection.

7. Select OK.
A messages displays informing you it will use your delay value to start
the collection.

8. Select OK when you are ready to begin the countdown.
A message displays stating the countdown has begun.

9. Disconnect the cradle.
10. Proceed to collect your data.
11. At some point after the collection, click OK on the Remote Setup
dialog box.
After you have collected your data see Retrieving remote data.

Retrieving remote data
Use this procedure for retrieving the remote data collection.
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Follow these steps after you collected your data with the TI-Nspire™ Lab
Cradle.
1. Open the Vernier DataQuest™ application.
2. Attach the TI-Nspire™ Lab Cradle to the handheld or computer.
3. Shortly, the Remote Data Detected message box displays: "The
connected device has remote data. Do you wish to import or discard
the data?"

4. Select Import.
The data is now in the Vernier DataQuest™ application.

Setting up Triggering
Data collection can be set to start based on a specific sensor reading. This
functionality is only available when using the TI-Nspire™ Lab Cradle.

Setting up the sensor for triggering
Set the sensor and the threshold type for the system to use when
analyzing when the trigger is reached so it can start the data collection.
You must have the TI-Nspire™ Lab Cradle and sensor connected to
perform this procedure.
1. Select Experiment > Advanced Set up > Triggering > Set Up.
The Configure Trigger dialog box is opened.
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2. Enter desired values.
•

Select the sensor to use as trigger. - The drop-down menu

displays the sensors connected to the TI-Nspire™ Lab Cradle.
Select the sensor you want to use.
•

Select the type of trigger to use. - Select one of the following

from the drop-down menu:
–

Increasing through threshold - Use this option when you
want the trigger on increasing values.

–

Decreasing through threshold - Use this option when you

want the trigger on decreasing values.
•

Enter the trigger threshold in units of the selected sensor. When entering the value to start the trigger, enter a value within
the range of your sensor. The value should be in regards to the
current sensor units you are using.

If you change the unit type after setting the threshold the value
will automatically be updated.
For example, if using the Vernier Gas Pressure sensors units with
the units as atm and you later change the units to kPa, the
settings are updated.
•

Enter the percentage of the points to keep prior to the trigger
event. - You can specify a percentage amount of data points to

keep before the trigger value occurs.
3. Click OK.
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The trigger is now set and enabled if valued values were entered. You
can select Experiment > Advanced Set up > Triggering to verify the
active indicator is set to Enabled.

Important: When the Trigger is enabled, it stays active until it is disabled
or a new experiment is started.

Enabling the trigger
If you have previously set the trigger values in the current experiment
and have it disabled, you can enable the trigger.
f Select Experiment > Advanced Set Up > Triggering > Enable.
The trigger is now active.

Disabling the trigger
You can disable the active trigger.
f Select Experiment > Advanced Set Up > Triggering > Disable.
The trigger is no longer active.

Working with advanced analysis features
This section examines features not as commonly used when performing
experiments but are valuable to know about and use when applicable.
This section’s topics include:
•

Replaying the data collection

•

Striking and restoring data

•

Adjusting derivative settings

•

Drawing a predictive plot

•

Using Motion Match

•

Examining graphs using Page Layout
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Replaying the data collection
Use the Replay option to playback the experiment’s data collection. This
option enables you to:
•

Pause the playback.

•

Advance one point.

•

Adjust the playback rate.

•

Repeat the playback.

Starting the playback
To start a data set’s playback:
f Select Experiment > Replay > Start Playback.
Playback of the data set run starts, and the Data Collection Control
buttons change to Stop Playback, Pause, and Advance by One Point.
The Advanced by One Point button (and menu item) is inactive until
you pause the replay.

Pausing and resuming the playback
To pause the playback:
f Select Experiment > Replay > Pause or click

.

The following events occur:
•

The playback is paused.

•

The menu option changes to "Resume."

•

The button changes to

•

The menu option Advance by One Point and the button
become active.

.

To restart the playback after pausing:
f Select Experiment > Replay > Resume or click
playback.

to restart the
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The playback resumes.

Advancing the playback by one point
This option enables you to advance the playback point by point. The
playback must be active and paused for this option to be available.
To advance the paused playback:
f Select Experiment > Replay > Advance One or click

.

The playback advances by one point until the last point is reached.

Adjusting the playback rate and repeating the playback
1. Select Experiment > Replay > Playback Rate.
The Playback Rate dialog box opens.

2. In the Playback Rate field, click ¤ to open the drop-down menu.
3. Select the rate at which the playback will play.
Normal speed is 1.00. Less is slower, higher is faster.
4. Decide whether you want to repeat the playback.
5. Select one of the following:
•

Click Start to start the playback and save your settings.

•

Click OK to save you settings for use on your next playback.

Selecting a data set to replay
You can only replay one data set at a time. By default, the latest data set
plays using the first column as the base column (example: time
reference).
If you have multiple data sets, and want a different data set or base
column than the default, use this procedure to select which data set to
run and to select your base column.
To select the data set to replay:

562

Data Collection and Analysis

1. Select Experiment > Replay > Advanced Settings.
The Advanced Replay Settings dialog box is opened.

2. Select which data set to replay from the Data Set drop-down menu.
3. (Optional) Select a new value from the Base Column list.
The selected column will act as the “Time” column for the replay.
Note: The base column should be a strictly increasing list of numbers.
4. Select one of the following:
•

Click Start to start the playback and save your settings.

•

Click OK to save your settings for use on your next playback.

Note: Data Set and Base Column options are dynamic depending on
number of stored runs and sensor type used.
Note: Changing the run in the Data Set selection tool will not affect
the playback choice. You must specify which data set in
Experiment > Replay > Advanced Settings.
Data Set selection tool:

If you set the replay for run2 and switch to run1, you will not see the
data replayed.

Striking and restoring data
Data that is struck is not deleted and can be restored. Struck data is
temporarily ignored when graphing data or performing computations.
Struck data is shown in the table with a single line through the value. On
the graph, the struck data points are not visible. At least one point must
be selected from a table or graph to strike data.

Data Collection and Analysis

563

Data can be struck in Graph View or Table View. You can strike data in
one view and review it in another (between Graph and Table views). You
cannot see struck data in Meter View.

Striking data in Graph View
1. To start this procedure, open a data set that contains data to be
struck.
The following is an example graph with all data unstruck (before any
strike was performed):

2. Select View > Graph or click

.

3. With your graph displayed, select the region you want to strike or to
protect from the strike. (See Selecting a range for instructions on how
to select a range.)
Note: You have the option to strike all data in the selected region or
strike all data outside the selected region.
4. Select Data > Strike Data or open the context menu in the graph and
select Strike Data.
Handheld: Click b and select Data > Strike Data or click

/ + b and select Strike Data.
5. Select one of the following:
•
•

In Selected Region: Strike the data from the area you selected.
Outside Selected Region: Strike all data except the area you

selected.
6. Click on the graph, off the selected area to remove the gray shading.

564

Data Collection and Analysis

Strike results In Selected Region
selected.

Strike results Outside Selected
Region selected.

Striking data in Table View
1. To start this procedure, open the data run that contains the data to
be struck.

2. Select View > Table or click

.

3. Select your starting row and scroll to your ending point. To select the
region:
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Hold the right-button on the mouse down and drag your cursor to
the bottom or top of the screen (depending on the direction of your
selection). This “pushes” the cursor to select the area out of your
immediate view. It will scroll the screen so you can see the selection.
Handheld:
•

Select the first cell by clicking with the Touchpad and holding until
the cell is filled.

•

Release and move your cursor across cells until the row is selected.

•

Move your cursor to the bottom or top of the screen to select the
rest of your region.

In this example, row 21 is selected as the beginning area and row 147
as the end.

Beginning of
selections

End of selection.

4. Select Data > Strike Data or open the context menu in the table and
select Edit > Strike Data.
Handheld: Select b then Data > Strike Data or / + b then
Edit > Strike Data.
5. Select one of the following:
•
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In Selected Region: Strike the data from the area you selected.
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•

Outside Selected Region: Strike all data except the area you

selected.

Strike results In Selected Region
selected.

Strike results Outside Selected
Region selected.

You can switch views and still see the results.
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Strike results In Selected Region
selected.

Strike results Outside Selected
Region selected.

Restoring struck data
You can restore previously struck data in any view.
1. Select the range of data to restore or if restoring all struck data, start
at step two.
See Selecting a range for instructions on how to select a range.
2. Select Data > Restore Data or from the context menu select Edit >
Restore Data.
3. Select one of the following:
•
•

In Selected Region - Restore data in your selected area.
Outside Selected Region - Restore data outside your selected

area.
All Data - Restore all data. No selection necessary.

Adjusting derivative settings
Use this option to select the number of points used in derivative
calculations. This value affects the tangent tool, velocity, and
acceleration values.
1. Select Options > Derivative Settings.
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2. Select the number of points from the drop-down menu.

3. Click OK.

Drawing a predictive plot
Use this option to draw the predicted outcome of an experiment by
adding points to your graph.

Drawing the prediction
To draw the prediction:
1. Select Analyze > Draw Prediction > Draw.
2. Move your cursor over the graph, clicking at each area you want to
place the point.
3. Click the Esc key to release.
Handheld: Press d to release.
The following image is an example of a drawn prediction.

Clearing the prediction
To clear the drawn prediction:
f Select Analyze > Draw Prediction > Clear.
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Using Motion Match
Use this option to create a randomly generated plot on position vs. time
or velocity vs. time graphs.
This feature is only available when using a motion detector like the
CBR 2™ sensor or the Go!Motion® sensor.

Generating a Motion Match plot
To generate a plot:
1. Attach the motion detector.
2. Select View > Graph or click

.

3. Select Analyze > Motion Match.
4. Select one of the following:
•

New Position Match - Generates a random position plot.

•

New Velocity Match - Generates a random velocity plot.

The following image is an example of the Motion Match (New
Velocity Match) generated plot:

Note: You can keep selecting a new position or a new velocity match to

generate a new random plot without removing the existing plot.

Removing a Motion Match plot
To remove the generated plot:
f Select Analyze > Motion Match > Remove Match.
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Examining graphs using Page Layout
You can use the Page layout functionality when Show Graph is not the
appropriate solution for showing more than one graph.
The Show Graph option is not applicable when:
•

You have multiple runs using a singe sensor.

•

When using two or more of the same sensors.

•

When you have multiple sensors that use the same column(s) of data.

In these situations the Page Layout functionality is useful.
Note: See the chapter, Using multiple applications on a page, for more
information about Page Layout.
To use Page Layout:
1. Open the original data set you want to see in two graph windows.
In this example, the data set is using two of the same sensors.

2. Select Edit > Page Layout > Selected Layout or click

.

Handheld: Press ~ and select Page Layout > Select Layout.
3. Select the type of page layout you would like.
In this example, the top and bottom

page symbol was selected.
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4. Click inside the window that reads, “Click here to add an
application.”
Handheld: The text reads “Press Menu”. Click in the window and
press b.
5. Select Add Vernier DataQuest from the drop-down menu.
This example screen shows two running Vernier DataQuest™
applications.

6. To see separate views, click the view you want to change and select
View > Table (or the view you want) or click

The window displays your change.
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.

Note:
Selection
in one
view is
reflected
in the
other

7. To show the same view, click the view to change, then select View >
Graph (or the view you want) or click

.

The window displays your change.

To show the plots separately:
8. Click the top graph to select it.
9. Select Graph > Select Y-axis Columns.
10. Select the first Pressure value (or unit you are working with).
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The graph now displays only one of the columns.

11. Select the bottom application and repeat steps nine and ten but
select the second data value.
The application shows the changes.
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Note: You could also use the same procedure for graphs with
multiple runs.

To use procedure for multiple runs:
•

Repeat steps one through seven.

•

Set the Data Set selection tool for the runs on each graph.
Your window will look similar to the window is the following
example.
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Run1

Run2

Printing data views
This section includes printing information when using the Vernier
DataQuest™ application.
This section includes:
•

Selecting Print All options

•

Printing

You can print any active view when selecting to print the viewable
screen, however, with the Print All option you can print one data view, all
of the data views, or a combination of the data views when printing.
Select Options > Print All Settings to determine which view(s) will be
printed when you select Print All as your print selection. By default, if not
set, only the displayed view will be printed.
The Print All option has no affect in applications outside of the Vernier
DataQuest™ application.
Handheld: You can use this option to set the printing options for when
Print All is selected, but printing can only be performed from the
computer.

Setting Print All options
1. Select Options > Print All Settings.
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2. Select one of the following:
•

Print Current View

When printing, the current view is sent to the printer.
No other steps needed for setup.
•

Print All Views

When printing, all three views (Meter, Graph, & Table) are sent to
the printer.
No other steps needed for setup.
•

More

When printing, only the views selected are sent to the printer.
If More is selected:
–

Activate the option boxes of the views to print.

–

Click OK.

The Print All settings are now complete and can be used when
printing.
The following image is an example of the More setting. In this
example, the Graph and Table view are set to print when Print All is
selected and the print command is executed.

Printing
Printing can only be performed on the computer.
1. Select File > Print.
2. Select Print All from the Print What drop-down menu.
3. Complete any additional printing options you desire.
See the chapter Working with TI-Nspire™ Documents for information
about the other options.
4. Click Print.
The following example shows the print dialog box with Print All selected.
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Using sensors and data with other Apps
Predominantly, you want to perform all your data collection and analysis
in the Vernier DataQuest™ application because it is the most feature rich
for data collection. However, for times when you need to examine data
or use sensors with other TI-Nspire™ applications, use the Sensor Console
function.
The Sensor Console is a specialized view of the Vernier DataQuest™
application designed for using sensors with other TI-Nspire™
applications such as Graphs & Geometry and Data & Statistics.
Sensor Console works with the following applications:
•

Graphs

•

Geometry

•

Data & Statistics

•

Lists & Spreadsheet
When performing experiments it is recommended that you have only
one document open. The system cannot determine which of the
documents to use with the sensor if multiple documents are open.

This section’s topics include:
•

Collecting data in other applications

•

Opening the Sensor Console application menu
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•

Opening the Sensor Console context menu

•

Viewing existing data

•

Special steps for Data and Statistics

Collecting data in other applications
Use the Sensor Console to collect data using a sensor in another
TI-Nspire™ application.
To use Sensor Console with a sensor:
1. Open the application you want to use to capture the data.
Example: Graphs
2. Click Insert > Sensor Console or click anywhere in the application
and press Ctrl + D.
Handheld: Press b + Insert > Sensor Console or / + D.
3. Attach the sensor to use if not already attached. Wait a moment for
the Sensor Console area to appear active.

Example Sensor Console area with the Gas Pressure sensor
attached.
4. Click Collect Data > Start Collections or click

.

5. Wait for the data set to end or stop the collection.
Computer: To stop collection: Collect Data > Stop Collection or click
.
Handheld: To stop collection: Press b and select Collect Data >
Stop Collection or click

.

6. Click Collect Data > Close Console or click

.

The data collection is available for use in the current application.

Opening the Sensor Console application menu
The Sensor Console menus are a subset of the Vernier DataQuest™
application menus previously covered in this document.
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Accessing the menu on the computer
To Access the Sensor Console menu from an application running Sensor
Console:
1. Click anywhere on the Sensor Console bar to see the Sensor Console
Menu (

Collect Data).

2. Select Collect Data.
The Sensor Console application menu opens.

Accessing the menu on the handheld
1. Click anywhere on the Sensor Console area and click b to see the
Sensor Console menu (

Collect Data).

2. Select Collect Data.
The Sensor Console application menu opens.

580

Data Collection and Analysis

Opening the Sensor Console context menu
The Sensor Console menus are a subset of the Vernier DataQuest™
application menus previously covered in this document.
Accessing the context menu on the computer
To Access the Sensor Console context menu from an application running
Sensor Console:
f Right click the Sensor Console bar.
The Sensor Console context menu opens.

Accessing the context menu on the handheld
To Access the Sensor Console context menu from an application running
Sensor Console:
1. Click on the Sensor Console bar.
2. Press / b.
The Sensor Console context menu is opened.
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Viewing existing data
You can view data collected from a different TI-Nspire™ application in
your current application.
1. Open the document with your captured data set.
For example, open the Graphs application.

2. Select Insert > [your other application].
For example, insert Lists and Spreadsheet.

Your selected application opens.
3. Select Insert > Sensor Console.
The Sensor Console area is opened at the bottom of the application.
In this example a sensor is attached, but it doesn’t have any affect on
this procedure.
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4. Select Collect Data > View Data in Apps on Current Page or Open
the context menu in the Sensor Console area.
Handheld: Click in the Sensor Console area.
Press b then Collect Data > View Data in Apps on Current Page
or click in the Sensor Console area and click / + b and then
select View Data in Apps on Current Page.
Wait until the data is populated. After a few moments, the data is
displayed.

5. Select Collect Data > Close Console.
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You can now work with the data in the current application.

Special steps for Data and Statistics
When opening existing data in the TI-Nspire™ Data and Statistics
application, the data first displays as a Dot Point graph. There are
additional steps required to organize the points.
The following image is an example of existing data opened as a Dot
Point graph in the Data and Statistics application:

This procedure assumes you have already collected data in another
application.
1. Open the Data and Statistics application with the existing data.
2. Click on the y-axis side of the text on the screen “Click to add
variable.”
3. Select the variable.
4. Click on the x-axis side of the text on the screen “Click to variable.”
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5. Select the variable.
The data is replotted.

Reference of Menus
Vernier DataQuest™ application menus
The following is a list of the Vernier DataQuest™ application menus and
a brief explanation of their functions for your reference.
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Experiment menus

Menu - Experiment

Description

New Experiment

Starts a new experiment, resetting
defaults (such as units, sampling rate,
and mode). New Experiment also
removes any previous data sets.

Start / Stop Collection

Starts or stops the collecting of data.

Store Data Set

Creates a new data set for
subsequent data collections so
collected data is not overwritten. This
is only available when data is present.
The data set is not saved permanently
until you save the document file.

Keep

Stores the current connected sensor’s
values. Keep stores a specific data
point. This option is available when
Events with Entry or Selected Events
is specified for the Collection Mode
option.

Extend Collection (value s)

Extend Collection (value s) “value”
represents the new data collection
duration after the extend has been
selected. “s” represents the time unit,
“seconds.” This option extends the
duration of an active experiment. It is
only enabled for time-graph modes.

Replay

Replays the experiment’s data
collection.
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Start Playback

Start the collection playback.

Pause / Resume

Pause and/or resume playback of the
data collection.

Advance One

Advance one point. Playback must be
active and paused for this option to
be available.

Playback Rate

Specify speed and whether to repeat
the playback.
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Menu - Experiment
Advanced Settings
Collection Mode

Description
Select which data set to replay and
the Base Column.
Select the mode of collection. The
default is Time based.

Time Based

Capture data with respect to time.

Events with Entry

Capture samples manually every time
"Keep current reading"
is
selected from the Graph View data
collections controls area. In Events
with Entry, you define the value.

Selected Events

Capture samples manually every time
"Keep current reading"
is
selected from the Graph View data
collections controls area. In Selected
Events, the "x" value will
automatically be the sample number.

Photogate Timing

Used only with a Photogate sensor.

Drop Counting

Used only with Drop Counter sensor.

Collection Setup

Configure the data collection.

Setup Sensors

Use to modify the values returned by
the sensor.

Change Units

Units are variable depending on the
sensors.
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Menu - Experiment

Description

Calibrate

When a sensor is detected, it
automatically loads a calibration for
that sensor. If you wish to edit a
sensor’s calibration, you can do so by
manually entering new calibration
values or by using either a singlepoint or two-point calibration
procedure. Note: Some sensors
cannot be calibrated while other
sensors, such as the Colorimeter and
the Dissolved Oxygen Probe, must be
calibrated to be useful.

Zero

Change the standing value in meter
view to zero.

Reverse

Changes the sign of sensor reading.
This only available for sensors where
direction is relevant (for example,
motion detectors and force sensors).

Advanced Setup

Set up more advanced data collection
options including remote collection
and triggering.

Remote Collection

Set up supported data collection
devices for data collection without a
handheld or computer.
Supported devices: TI-Nspire™ Lab
Cradle, TI CBR 2™, and Vernier
Go!Motion®.
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Triggering

Data collection can be set to start
based on a specific sensor reading.
This functionality is only available
when using the TI-Nspire™ Lab
Cradle.

Configure Sensor

Set up sensors that are not
automatically identified or not
available when creating a data
collection document.
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Menu - Experiment
Add Offline Sensor

Description
The offline option provides the
teacher or student with a method of
setting up the sensor without actually
having to attach the sensor.
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Data menus

Menu - Data

Description

Column Options

Set the column name, units, and
precision. All existing data columns
are listed.

New Manual Column

Add a column for manual entry of
data. Manual columns include a
Generate Values option for quickly
adding sequential data. Manual
columns can also be linked to list data
that was created outside of the
Vernier DataQuest™ application.

New Calculated Column

Add an additional column to the data
set where the values are calculated
from an expression using at least one
of the existing columns.

New Data Set

Create a new data set having the
same columns as the existing data
set(s). Column definitions from the
latest data set are applied to the new
data set.

Strike Data

Mark data that should be ignored
when graphing data or performing
computations.

In Selected Region

The data that is in the selected region
will be struck.

Outside Select Region

The data that is not currently selected
will be struck.

Restore Data
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Restores previously struck data.

In Selected Region

Restores any selected struck data.

Outside Selected Region

Restores any struck data that is not
currently selected.

All Data

Restore all struck data. No selection
needed.
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Graph menus
Menu - Graph

Description
Note: The Graph menu is only
available when in the Graph View.

Show Graph

The application has the option to
display one or two graphs in the
Graph View. Use this option to
determine which graph(s) to display.

Graph 1

Show one graph, Graph 1 (top
graph). Graph 1 is always shown by
default.

Graph 2

Show one graph, Graph 2 (bottom
graph).

Both

Show both Graph 1 and Graph 2.
Both graphs are shown by default for
sensors that plot more than one
column of data, or when multiple
sensors have defined units that are
different are used at the same time.

Graph Title

Add a title to the displayed graph(s).

Select X-axis Column

Select the column used as the
independent variable when graphing
the data.
Note: This column is used for all
graphs.

Select Y-axis Column

Select which dependent variable
columns to plot on the displayed
graph(s).

Select Data Set

Select which data set is plotted when
there is more than one date sets
available.

Run1 (or other data set
name)

Selecting a specific data set will
display data from only that data set
on the graph(s).

All

Select data from all runs to be
displayed on the graph(s).
Data Collection and Analysis
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Menu - Graph
More

Description
Use this option to select two or more
data sets from which to plot the data
on the graph(s). Not all data sets are
required to be selected.

Window Settings

Modify minimum and maximum
range for x and y axes. Displays values
for all active graphs.

Autoscale Now

Rescales the graph so that all points
from the plotted y-scale columns will
be displayed on the graph. Available
anytime there is data on the graph.

Zoom in

Zoom in view. If a region of the graph
is selected, the selected x range will
be used as the new x-range. The ywill autoscale to show all graphed
data points in the selected range.

Zoom Out

Zoom Out view. If Zoom In precedes a
Zoom Out, Zoom out will return the
window settings prior to the Zoom In.
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Analyze menus
Menu - Analyze
Note: The Analyze menu is only
available when in the Graph View.
Interpolate

Use to estimate the value between
two data points. Use to determine
the value of a Curve Fit between and
beyond data points.

Tangent

Use to determine the rate at which
the data is changing at a given point.
The value is displayed in the View
detail area and in the All Details for
Graph dialog box.

Examine Settings

Allows you to select which of the
plotted columns and curve fit you
would like to trace when examining
the data. Values are displayed in the
View details area.
You can also show cursor position and
delta values as you examine the data
by selecting the Position and Delta
option. The values are displayed
below the graph.

Integral

Use to determine the area under a
data plot. You can find the area
under all of the data or a selected
region of data. The value is displayed
in the View details area and in the All
Details for Graph dialog box.

Statistics

Use to determine the statistics
associated with the plotted data.
Minimum, maximum, mean, standard
deviation, and number of samples are
calculated. You can find the statistics
for all the data or a selected region of
data. The values are displayed in the
View details area and in the All
Details for Graph dialog box.
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Menu - Analyze
Curve Fit

Find a best fit curve to match your
data. Fit all of the data or a selected
region of data. The curve is drawn on
the graph and the equation
information is displayed in the View
detail area and in the All Details for
Graph dialog box.

Linear

This fit is calculated in the form of
y = m*x + b.

Quadratic

This fit is calculated in the form of
y = a*x^2 + b*x + c.

Cubic

This fit is calculated in the form of
y = a*x^3 + b*x^2 + c*x + d.

Quartic

This fit is calculated in the form of
y = a*x^4 + b*x^3 + c*x^2 + d*x + e.

Power (ax^b)

This fit is calculated in the form of
y = a*x^b.

Exponential (ab^x)

This fit is calculated in the form of
y = a*b^x.

Logarithmic

This fit is calculated in the form of
y = a + b*ln(x).

Sinusoidal

This fit is calculated in the form of
y = a*sin(b*x + c) + d.

Logistic (d

0)

Natural Exponential

This fit is calculated in the form of
y = a*e^(-c*x).

Proportional

This fit is calculated in the form of
y = a*x.

Model
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This fix is calculated in the form of
y = c/(1 + a*e^(-bx)) + d.
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This option provides a manual
method of plotting a function to fit
data. Use one of the predefined
models or enter your own.

Menu - Analyze
Remove

Clears previous analyzed data from
the graph, the View Details area and
the All Details for Graph dialog box.
You can choose to clear all or select
specific data to clear.

Draw Prediction

Predict the outcome of an
experiment by adding points to your
graph.

Draw

Manually set data points. Line
appears between data points.

Clear

Clears data points and lines created.

Motion Match

Creates a randomly generated plot
on position vs. time or velocity vs.
time graphs.
Only available when using a motion
detector like the CBR 2™ sensor or
the Go!Motion® sensor.

Remove Match

Remove motion match plots.

New Position Match

Add a motion match plot to the
position vs. time graph.

New Velocity Match

Add a motion match plot to the
velocity vs. time graph.
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View menus

Menu - View

Description

Meter

Displays the Meter view of the
Vernier DataQuest™ application.

Graph

Displays the Graph view of the
Vernier DataQuest™ application.

Table

Displays the Table view of the Vernier
DataQuest™ application.

Options menus
Menu - Options

Description

Point Options

Change the way your points are
plotted on your graphs.

Autoscale Settings

Set autoscale behavior during and
after data collection.

Derivative Settings

Select the number of points used in
derivative calculations. This value
affects the tangent tool, velocity, and
acceleration values.

Print All Settings

Use to determine which Vernier
DataQuest™ view(s) will be printed
when Print All is selected within the
TI-Nspire™ software.
Note: Specifying the print settings
can be done from the computer or
handheld, however, printing is only
available from a computer.
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Print Current View

Print the current view (Meter, Graph,
or Table).

Print All Views

Print all views as previously set in the
More settings.

More

Specify the views that apply when
"Print All" is selected.
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Menu - Options

Description

Show/Hide Meters

Modify which columns display a
meter in the Meter View.

Show/Hide Details

Show or Hide the Detail View.

Sensor Console application menu options
This is the menu you see when selecting Collect Data.
Menu -

Collect Data

Description

New Experiment

Starts a new experiment, resetting
defaults (such as units, sampling rate,
and mode). New Experiment also
removes any previous data sets.

Start/Stop Collection

Starts or stops the collecting of data.

Store Data Set

Creates a new data set for
subsequent data collections so
collected data is not overwritten. This
is only available when data is present.
The data set is not saved permanently
until you save the document file.

Keep

Stores the current connected sensor’s
values. Keep stores a specific data
point. This option is available when
Events with Entry or Selected Events
is specified for the Collection Mode
option.

Replay

Replays the experiment’s data
collection.

Start Playback

Start the collection playback.

Pause/Resume

Pause and/or resume playback of the
data collection.

Advance One

Advance one point. Playback must be
active and paused for this option to
be available.
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Menu -

Collect Data

Description

Playback Rate

Specify speed and whether to repeat
the playback.

Advanced Settings

Select which data set to replay and
the Base Column.

Collection Mode

Select the mode of collection. The
default is Time based.

Time Based

Capture data with respect to time.

Events with Entry

Capture samples manually every time
"Keep current reading"
selected.

Selected Events

is

Capture samples manually every time
"Keep current reading"
selected.

is

Photogate Timing

Used only with a Photogate sensor.

Drop Counting

Used only with Drop Counter sensor.

Collection Setup

Configure the data collection.

Set Up Sensors

Use to modify the values returned by
the sensor.

View Data in Apps on Current
Page

View existing data in the current
application.

Close Console

Close the Sensor Console application.

Sensor Console context menu options
This is the menu you see when accessing the Sensor Console context
menu.

Menu - Sensor Console Context menu

Description

Change Units

Units are variable depending on the
sensors.
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Menu - Sensor Console Context menu

Description

Calibrate

Enter manual calibration to override
the sensors automatic calibration
when the sensor is attached.

Manual Entry

Manually enter known calibration
equation values.

Two Point

Create a linear calibration curve using
two known points. This method
adjusts both slope and intercept of
the calibration equation.

Single Point

Modify the calibration equation
using a single reference point. Only
the intercept of the calibration
equation is modified using this
method.

Zero

Change the standing value in meter
view to zero.

Meter Display

Displays the values to appear in the
Sensor Console view of the meter
such as Name, Unit, and the displayed
precision.

Collection Settings

Displays the data collection
parameters for the current mode.
This option also provides buttons for
you to configure the data collection
parameters such as Mode, Rate,
Interval, and Duration.

View Data In Apps on Current
Page

Displays the data previously collected
in a different application in the
current application. Works with
Graphs, Geometry, Data & Statistics,
and Lists & Spreadsheet applications.

Close Console

Closes the Sensor Console.

All Details

Displays the data collection
parameters for the current mode.
Same menu as Collection Settings.
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Using the TI-SmartView™ emulator
The TI-SmartView™ panel enables you to emulate the TI-Nspire™ CX,
TI-Nspire™ with Touchpad, and the TI-Nspire™ with Clickpad handhelds
in the following TI-Nspire™ software:
•

TI-Nspire™ Teacher Software

•

TI-Nspire™ CAS Teacher Software

•

TI-Nspire™ Student Software

•

TI-Nspire™ CAS Student Software

•

TI-Nspire™ Navigator™ Teacher Software

With three layout options to choose from, teachers will find that the
emulator facilitates classroom presentations. In the teacher software,
layout options are:
•

Handheld only

•

Keypad plus side screen

•

Handheld plus side screen

In the student software, the TI-SmartView™ emulates the keypad, which
along with the handheld view, gives students the ability to drive the
software as if using a handheld.

Opening the TI-SmartView™ emulator
The TI-SmartView™ emulator is located in the Documents Workspace. To
open the emulator view:
1. Open the Documents Workspace.
2. Click

, which is located in the Documents Toolbox.

In the teacher software, the handheld is displayed with Handheld and
SideScreen panels open in computer mode as shown in the following
illustration. You can use the keypad on the emulated handheld, but
the document won’t appear on the emulated handheld screen until
you switch to Handheld mode.

Using the TI-SmartView™ emulator
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In the student software, the TI-Nspire™ CX keypad is displayed with the
side screen open in computer mode. You can use the keypad on the
emulated handheld, but the document won’t appear on the emulated
handheld screen until you switch to Handheld mode.

3. Select View > Handheld or click
handheld mode.
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in the status bar to switch to

Choosing a keypad
An open document is not affected by changing the keypad. You can
switch between keypads anytime you want. To select a keypad:
1. In the emulator panel, click
to open the drop-down menu and
select one of the following options:
•

TI-Nspire™ CX

•

TI-Nspire™ with Touchpad

•

TI-Nspire™ with Clickpad

2. Click ¢ to select a faceplate option:
•

Normal

•

High Contrast

•

Outline

Choosing a display option
In the teacher software, use this option to choose how to display the
emulator in the software window.
1. In the emulator panel, click

or select File >
Settings > TI-SmartView™ from the menu bar to open the dropdown menu.

2. Select one of the following options:
•

Handheld Only - displays the emulated handheld and hides the
work space and other panels.
Note: To keep the Handheld Only display in front of other
application windows, click Always in Front at the top right of the
TI-SmartView™ panel.

•

Keypad + SideScreen - opens a larger view of the keypad along
with the side screen.

•

Handheld + SideScreen - opens the entire emulated handheld
along with the side screen.

Changing the size of the TI-SmartView™ panel
and side screen
Changing the width of the TI-SmartView™ panel
To change the width of the TI-SmartView™ emulator panel:
Using the TI-SmartView™ emulator

603

f Click the right edge of the panel and drag it until it is the width you
want.

Changing the size of the screen in the workspace
When in handheld mode, use the Scale to change the size of the screen.
f Drag the slider to the appropriate scale percentage. The scale slider is
located on the far right side of the status bar, at the bottom of the
TI-Nspire™ window. Scale percentages range from 100% to 200%.
The default scale is 150%.

Note: If computer mode is selected, you cannot change the size of the
workspace.

Working with the emulated handheld
To input data and work with files on the emulator, you can use the
computer keyboard, TI-SmartView™ keypad, TI-Nspire™ menus and
icons, or any combination of these.
Note: Within one command, you cannot use a combination of both the
keypad and the keyboard. For example, you cannot press Ctrl on the
keyboard and click b on the emulator to open a context menu.
For the most part, you can perform any function in the TI-SmartView™
emulator that you can perform on the handheld. Keys and applications
operate the same way.
Note: If you switch to Computer mode, you can still use most of the keys
on the emulated handheld or keypad and all keystrokes are reflected in
the work space. However, some key combinations may only work in
Handheld mode.
As you click keys on the emulator or press keys on the keyboard that
activate keys on the emulator, those keys change color, making it easy for
your audience to follow along. The last key selected stays highlighted.
In the teacher software, the emulator screen and the side screen are both
interactive. You can click on icons and menu items on both screens. You
can also right-click to display menus on both screens.
All handheld shortcuts and arrow functionality work from the computer
keyboard. For example, to save a document, you can click / S on the
emulator keypad or you can press Ctrl + S on the computer keyboard.
When using a Macintosh®, press “ + S.
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Using the Touchpad
You can operate the touchpad on the TI-Nspire™ Touchpad keypad using
either the touchpad on a laptop or by using the mouse to click the
Touchpad. Areas of the Touchpad are highlighted as you click the arrow
zones.

An arrow is highlighted when
you click or tap it.

•

Clicking the ¡, ¢, £, or ¤ keys on the Touchpad moves through
menus one item at a time.

•

Clicking and holding down an arrow on the Touchpad causes
continual movement in the selected direction.

•

Clicking and sliding the mouse across the Touchpad area enables you
to move the mouse pointer.

•

Clicking the middle of the Touchpad selects the highlighted menu
option.

Using the Clickpad
You can use the Clickpad on the TI-Nspire™ Clickpad keypad using either
the touchpad on a laptop or by using the mouse to click the Clickpad.
Areas of the Clickpad are highlighted as you click the arrow zones.

•

Clicking the ¡, ¢, £, or ¤ keys on the Clickpad moves through menus
one item at a time.

•

Clicking and holding down an arrow on the Clickpad causes continual
movement in the selected direction.

•

Clicking the middle of the Clickpad selects the highlighted menu
option.
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Using settings and status
When working with the TI-SmartView™ emulator, you can change
General Settings and Document Settings. See Using the Documents
Workspace for information about changing these settings.
You can view all other settings, but you cannot change them in the
TI-SmartView™ emulator. However, the ability to view these options
provides teachers with an instructional tool when they need to show
students how to set up a handheld.
To view settings and status:
1. Click c to access the Home screen.
2. Click Settings.
Setting or
Settings

Description

Language

You can open the languages drop-down menu and
select a language, but you cannot save changes. To
change the language, use the TI-Nspire™ menu
File > Settings > Change Language.

Handheld Setup You can open the drop-down menus and select
items to demonstrate which items to choose, but
you cannot save any changes.
Handheld Status You can access the screen. The # symbol replaces
any numerical values that would be displayed on the
handheld.
About

You can open the About screen and view the
software version. Other information that pertains
only to the handheld hardware is marked as "Not
Applicable."

Login

You can display the Login to Class screen and type
in the User Name and Password fields. Login is not
available.

Changing TI-SmartView™ options
You can change the emulator options, even when the emulator panel is
closed.
1. In the teacher software, select File > Settings > TI-SmartView™
Options.
The TI-SmartView™ Options dialog box opens.
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In the student software, select File > Settings > Keypad Options.
The Keypad Options dialog box opens.

2. Click Browse to change the folder where documents are saved and
accessed in the My Documents folder when using the emulator.
3. Click ¤ to open the drop-down menu and select a keypad.
4. Click ¤ to open the drop-down menu and select a faceplate.
5. In the teacher software, click ¤ to open the drop-down menu and
select a view. If selecting Handheld only, check Always in Front to
keep this window on top of all other open applications.

Working with documents
You can open multiple documents in the workspace by selecting
File > Open Document from the menu or using keyboard shortcuts.
When you switch between these documents, the emulated handheld
shows only the current document. You can insert pages and problems
using either the TI-Nspire™ menus or icons, keyboard shortcuts, or
TI-SmartView™ menus or shortcuts.

Opening a document
You can open a document by navigating to it on the emulator, the same
way you open a document on the handheld, or you click
File > Open Document.
Using the TI-SmartView™ emulator
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When you open a document using the emulator, you can only open
documents that are in the folder displayed on the emulator (usually the
My Documents folder, unless you specified a different folder in your
TI-SmartView™ settings). When you open a document using the menu
path, you can browse to find any TI-Nspire™ document on your
computer or network. If you open a document using the emulated
handheld, it replaces the document that was previously open.
Note: If the number of characters in the document’s file path name
exceeds 256 characters, the document cannot be opened and an error
message is displayed. To avoid this error, keep file and folder names short
or move files up in the file path.

Saving a document
When you save a document using the File > Save Document menu or
icon, keyboard shortcuts, keypad shortcuts, or emulator menus, the
document is saved in the same location where the file was opened. To
save the file in another location or with a different name, click
File > Save As.

Using Screen Capture
To capture the current page, press Ctrl + J (Macintosh®: ì“ + J) on your
keyboard or on the emulated handheld. The image is automatically
placed in the clipboard and in the TI-Nspire™ Screen Capture window.
You can paste the image into another application without having to take
additional steps. This feature is only available when the TI-SmartView™
panel is active and the work space is in Handheld mode.
All other screen capture features work the same way they do in other
areas of TI-Nspire™ software. For more information, please see the Using
the Documents Workspace.
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Appendix: Service and Support
Texas Instruments Support and Service
For general information
For more information about TI products and services, contact TI by e-mail
or visit the TI Internet address.
E-mail inquiries:

ti-cares@ti.com

Home Page:

education.ti.com

Service and warranty information
For information about the length and terms of the warranty or about
product service, refer to the warranty statement enclosed with this
product or contact your local Texas Instruments retailer/distributor.

Service
Refer Servicing to Qualified Service Personnel under the Conditions
Listed Below:
•

If liquid has been spilled or objects have fallen into the product.

•

If the product has been exposed to rain or water.

•

If the product does not operate normally as per the operating
instructions.

•

If the product has been dropped or the case has been damaged.

Battery Precautions
Take these precautions when replacing batteries.
•

Do not leave batteries within the reach of children.

•

Do not mix new and used batteries. Do not mix brands (or types
within brands) of batteries.

•

Do not under any circumstances use rechargeable AAA batteries in
your handheld.

•

Install batteries according to polarity (+ and - ) diagrams.

•

Properly dispose of used batteries immediately.

•

Do not incinerate or dismantle batteries.
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Disposing of Batteries
•
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Do not mutilate, puncture, or dispose of batteries in fire. The
batteries can burst or explode, releasing hazardous chemicals. Discard
used batteries according to local regulations.
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Symbols
.tilb file 48
©, comment 463

Numerics
3D functions
graphing 309
3D graph
animating 314
defining 309
displaying context menu for 309
editing 310
setting colors of 310
3D graphs
showing and hiding 312
tracing 313
3D view
customizing 312
rotating 313

A
About documents 55
About PublishView™ documents 93
about the software 16
Activating your software license 10
add files to lesson bundle 44
adding
a Calculator to a page 180
Notes to a page 421
adding a copyright 81
Adding a problem
PublishView(TM) 112
adding an application to a problem
108
Adding color from a list 76
Adding color from a palette 76
Adding files to a lessono bundle 44
adding hyperlink 124
adding images 126

Adding multiple applications to a
page 67
adding problem to a document 70
Adding text
PublishView(TM) 119
adding text and numbers to a
Graphs & Geometry page 297
adjacent cells
filling 329
adjusting a variable with a slider 241
adjusting histogram scale 384
adjusting variable values with a
slider 412
algebra
menu in the Calculator 175
alphanumerics
adding to a Graphs & Geometry
page 297
analytic and geometric work areas
(Graphs & Geometry) 272
analytic/geometric work area
differences 236
angle
finding the measure of 292
Angle Bisector tool 303
Angle tool 292
angles
bisecting 303
animating
a 3D graph 314
animating a point on an object 306
animating objects 306
animation 306
changing speed of 308
pausing and resuming 308
resetting 308
starting 306
stopping 308
animation control panel (Graphs &
Geometry) 307
animation values
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capturing from Graphs &
Geometry 342
capturing with Lists &
Spreadsheet 342
answer
using last answer 212
answering
questions 442
appearance of work area,
customizing 238
application
Calculator 173
Program Editor 457
tools menu 3, 6, 20
applications 64
deleting 70
grouping 70
swapping 68
using multiple 67
applications that accept images 83
Data & Statistics 83
Geometry 83
Graphs 83
Notes 83
Question 83
Applying a background color 425
Applying a text format 424
approximate results 181
approximating expressions 429
area
of a circle 292
of a polygon 292
of a rectangle 292
of a triangle 292
Area tool 292
attach (Graphs & Geometry) 227
Attribute tool 234, 235, 306
attributes
changing appearance 234
frameborder 138
height 138
iframes 137
scrolling 138
width 138

attributes (Graphs & Geometry) 235
Automatically creating variables in
Lists & Spreadsheet 205
axes
changing appearance 239
showing and hiding 238

B
background image 240, 411
bar charts
creating comparative 392
bisecting a segment 302
bisecting an angle 303
BMP 85
borders
show and hide 116
box plot
split by cagtegory 382
breaking long calculations 430
BUSY indicator 471

C
Calculate output option 346
Calculate tool 297
calculations
breaking 430
Calculator
adding to a page 180
getting started with 173
Calculator history 198
viewing 165, 198
Calculator toolbar 174
Calculator toolbar, using 180
calculus
menu in the Calculator 176
caption, clicking to see variable
names for case plot (Data &
Statistics) 374
capture pages
saving 79
capturing
Graphs & Geometry data 342
Capturing a page 77
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capturing pages 77
Capturing pages in a document 50
Catalog 161
converting measurement units
189
inserting items from 75, 161, 163,
182, 185, 328, 345
catalog 73
categorical variable (Data &
Statistics) 370
categories
sorting 397
splitting numeric plot 393
cell references
absolute and relative 327
using in a formula 328
cells
copying in a table 328
filling adjacent 329
linking to a variable 207, 330
selecting a block of 328
sharing table cells 329
changing
language 9
Changing General Settings 39
Changing Graphs & Geometry
settings 41
Changing language 9
Changing text colors 425
character strings
storing as variables 202
charts
comparative bar chart 392
checking for software updates 14
chi-square goodness of fit test 361
choosing a folder for
PublishView(TM) objects 130
choosing a working TI-Nspire(TM)
document
PublishView(TM) 110
circle
finding perimeter of 291
finding the area of 292
Circular definition error 477

clear
error, ClrErr 485
clearing
data from columns 332
the Calculator history 166, 200
Clipboard with images 87
closing the Welcome screen 2
ClrErr, clear error 485
code snippet 147
creating 152
edit 152
color 424
adding 76
setting, 3D graph 310
color in Data & Statistics 411
color in Lists & Spreadsheet 231, 327
colors
changing text 425
using in documents 76
column
clearing data from 332
inserting into a matrix 185
columns
based on other columns 334
copying in a table 331
deleting from a table 331
generating data in tables 333
inserting in a table 331
linking to a list variable 323
moving in a table 332
resizing 330
selecting in a table 330
sharing table column as a list 322
comment, © 463
comments 426
inserting in Notes application
426
comparative bar chart, creating 392
connected handheld 60
Construction Menu tools (Graphs &
Geometry) 224
contact information 609
Content Explorer 34
Content workspace 3
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context menu
displaying for 3D graph 309
opening 66
context menus
PublishView(TM) 101
PublishView(TM) objects 101
TI-Nspire(TM) applications 101
control panel, animation 307
Convert to analytic on context menu
(Graphs & Geometry) 227
Convert to geometric on context
menu (Graphs & Geometry) 227
converting
measurement units 189
converting PublishView(TM)
documents 130
converting text to a hyperlink 125
copying
items from Calculator history
165, 198, 199
table cells 328
table data 340
table rows or columns 331
copying and pasting problems 71
Copying supported files and folders
62
copyright 80
adding information to
documents 81
copyright information 80
copyright statement ii
creating
a system of equations 188
code snippet 152
folders 62
functions and programs 191
lists from a table column 322
matrices 184
piecewise functions 187
user-defined units 190
variables 201
Creating a new lesson bundle 44
Creating a new PublishView(TM)
document 92

Creating a new TI-Nspire(TM)
document 56
creating a point 276
creating a point on an object 276
creating a shape 287
Creating a variable from a Graphs &
Geometry value 204
Creating a variable from a Lists &
Spreadsheet cell value 206
creating a web page 147
creating linear objects
line 280
parallel line 282
perpendicular line 283
ray 280
segment 281
segment with midpoint 281
tangent line 285
vector 284
creating midpoints 281
creating objects 285
creating parallel lines 282
creating perpendicular lines 283
creating points and lines (Graphs &
Geometry) 275
creating segments 281
creating shapes 285
creating tangents 285
creating vectors 284
customer support and service 609
customizing 238
3D view 312
customizing an embedded TINspire(TM) Document Player 143

D
data
capturing from Graphs &
Geometry 342
clearing from columns 332
generating columns of 333
graphing table data 337
raw and summary overview 377
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sorting in a table 333
sorting plotted categories 397
Data & Statistics 83
getting started with 367
plotting data from Lists &
Spreadsheet 393
Data & Statistics menu 368
Data Collection 487
add offline sensor 551, 589
advance one 562, 586
advanced settings, playback 562,
587
advanced setup 560, 588
all
all (select data set) 535, 591
all data (restore) 568, 590
autoscale now 536, 592
autoscale settings (before/after)
536, 596
both, graph 530, 591
calibrate 509, 588
change data set name 546
change units 508, 587
collect data (Sensor Console) 597
collection
mode 502, 587
setup 587
column options 543, 590
configure sensor 551, 588
curve fit 518, 594
derivative settings 568, 596
draw prediction 569, 595
drop counting 508, 587
events with entry 505, 587
examine settings 514, 593
graph
graph 1 529, 591
graph 2 530, 591
graph title 531, 591
view 494, 596
in selected region 563, 590
restore 568, 590
integral 516, 593
interpolate 512, 593

keep 510, 586
menu
Analyze 593
Data 590
Experiment 586
Graph 591
View 596
meter 494, 596
model 520, 594
more (select data set) 535
more, select data set 592
motion match 570, 595
new
calculated column 548, 590
data set 551, 590
experiment 586
manual column 547, 590
outside selected region 563, 590
restore 568, 590
pause/resume 561, 586
performing an experiment 495
photogate timing 507, 587
playback rate 562, 586
point options 539, 596
color 540
mark 539
marker 541
print all settings 576, 596
remote collection 588
collecting data 554
retrieving data 557
selecting unit 552
using delay 556
using manual trigger 555
remove (analysis options) 523,
595
replay 561, 586
restore data 568, 590
reverse 509, 588
run1 (or other data set name)
535, 591
select
data set 535, 591
x-axis column 542, 591
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y-axis column 542, 591
selected events 506, 587
Sensor Console 578
menu ref 597

context menu 598
setup sensors 508, 587
show
graph 528, 591
show graph using Page
Layout 571
show/hide
details 526, 597
meters 597
start playback 561, 586
start/stop collection 510, 512, 586
statistics 517, 593
store data set 527, 586
strike data 563, 590
table 494, 596
tangent 513, 593
time based 503, 587
triggering 558, 588
using a computer or handheld
489
window settings 533, 592
with other apps 578
zero 509, 588
zoom
in 537, 592
out 537, 592
data types
variables 202
deactivating math expression boxes
431
dedicating TI-Nspire(TM) Document
Player window 156
deferring evaluation in Calculator
188
define work area window (Data &
Statistics) 373
defined function
recalling 195
defining

3D graph 309
functions and programs 191
internal subroutine 476
multiple-line functions 191, 193
piecewise functions 187
settings 9
units 190
defining an intersection point 277
delete a hyperlink 125
delete image 89
deleting
an element from a list in Lists &
Spreadsheet 324
an entry from the Calculator
history 199
applications 70
contents of table cells 328
pages 70
part of an expression 196
problems 71
table rows and columns 331
variable, DelVar 475
variables 214
Deleting a problem
PublishView(TM) 113
deleting a text box 106
deleting functions 264
deleting images 89, 128
DelVar, delete variable 475
derivative
finding the 268
diagnostics 13
differential equations, graphing 256
dilating an object 301
Dilation tool 302
Disp, for debugging 485
display
Disp command 473
document
create 56
settings 6, 39
document properties 80
document settings 39
Document View chooser 6, 39
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documents
closing 64
colors 76
comverting 130
deleting 62
making read-only 81
printing 79, 133
protecting 81
saving 56, 57, 97
sharing 153
sharing offline 156
sharing online 153
storing 153
TI-SmartView(tm) emulator 607
documents in tiled view 63
Documents Toolbox 7, 29
page sorter 32
PublishView(TM) 98
documents workspace 4
Downloading guidebooks 12
draw option, example 416
Draw output option 346

E
Edit menu
Documents workspace 23
edit mode
PublishView(TM) 121
Edit Relation on context menu
(Graphs & Geometry) 227
editing
a 3D graph 310
math expressions 166, 195
values in a list 323
editing a hyperlink 124
editing code snippets 152
editing functions 262
editing text
PublishView(TM) 121
else if, ElseIf 479
else, Else 479
ElseIf, else if 479
E-mailing a lesson bundle 48

embedded document
view source code 147
embedded TI-Nspire(TM) Document
Player 143
embedded web pages 135
embedding documents in web pages
135
emulator, see
TI-SmartView(tm) emulator 601
end
for, EndFor 478, 481
if, EndIf 478
loop, EndLoop 483
try, EndTry 485
while, EndWhile 482
end values
showing and hiding 238
EndFor, end for 478, 481
EndIf, end if 478
EndLoop, end loop 483
EndTry, end try 485
EndWhile, end while 482
entering math expressions 160, 180,
428
entry line
showing and hiding 238
equations
identifying 289
labeling 289
errors
showing 430
errors and troubleshooting
Circular definition 477
clear error, ClrErr 485
pass error, PassErr 485
programs 485
evaluating
math expressions 160, 180
evaluating a math expression 162,
184
evaluating math expressions 180
exchanging table data 340
execute program, Prgm 476
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Exploring the Content Explorer pane
34
Exploring the Content workspace 3
Exploring the Documents Toolbox 98
Exploring the Documents workspace
4, 19
Exploring the Page Sorter Pane 32
Exploring the TI-SmartView™ pane
or keypad pane 32
Exploring the Tool Palette 31
Exploring the Utilities pane 36
Exploring the web page 142
Exploring TI resources 12
export
generate HTML code 147
Export HTML to Clipboard 147
Export options 147
Export Web Page 147
exporting HTML to the clipboard 152
Exporting to a web page 147
expression templates
using 75, 182, 328
expressions 428
approximating 429
copying from Calculator history
165, 198, 199
deleting part of 196
editing 166, 195
entering and evaluating 160, 180
entering from a template 162,
184
entering in a table 325
entering with a wizard 163, 185,
345
evaluating 429
selecting in Calculator 166, 196
variables 202

F
file menu
Documents workspace 21
files
types you can transfer 60

using My Files to move 61
video 128
filling adjacent cells 329
finance 196
finance functions 197
finance solver 196
finding
text in Program Editor 467
finding and replacing
text in Program Editor 467
finding points of interest 268, 298
finding the derivative (slope) of a
function 268
folder
Publishview(TM) objects 130
folders
creating 62
footers
inserting text 115
for, For 478, 481
format text 424
formatting text
PublishView(TM) 121
frequency plot 338
function definition
recalling 195
function, y= 260
functions
creating 191
creating piecewise 187
defining multiple-line 191, 193
deleting 264
editing 262
entering (Graphs & Geometry)
246, 251
graphing 3D 309
renaming 261
storing as variables 202
user-defined 475
working with (Graphs &
Geometry) 246
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G
General settings 39
generating
data in tables 333
generating HTML source code 147
Geometry 83
getting help 9
global variables 475
go to, Goto 477, 480, 484
Graph Trace tool (Data & Statistics)
373
Graph Type Menu tools (Graphs &
Geometry) 219
graphing
3D functions 309
differential equations 256
table data 337
graphing inequalities 261
Graphs 83
Graphs & Geometry
variables, creating 204
work area 228
Graphs & Geometry settings 39
grid
showing and hiding 238
spacing 239
group
objects (Graphs & Geometry) 274
grouping applications 70
grouping objects (Graphs &
Geometry) 227
guidebooks
download 12

H
handheld
opening handheld documents
on the computer 61
saving a document to 60
sending files 43
handheld OS 14
installing 15
headers

inserting text 115
help 9
Help menu 9
Documents workspace 28
Hide/Show Axes tool 239
hiding
3D graphs 312
Hiding problem breaks
PublishView(TM) 113
histogram
properties of 384
histogram scale, adjusting 384
history
deleting Calculator history 166,
200
in Calculator 198
viewing Calculator 165, 198
history, Calculator
copying from 165, 198, 199
HTML
exporting to clipboard 152
generate code 147
HTML code for iframes 137
HTML document 147
HTML inline frames 136
HTML to Clipboard feature 152
HTML-compatible container 152
hyperlink
adding 124
editing 124
remove 125
hyperlinks in PublishView(TM) 121

I
identifying an equation 289
if, If 478, 479
iframe
frameborder 138
height 138
scrolling 138
width 138
iframe attributes 138
source 137
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iframe source code 136
iframe tags 137
Iframe tags and attributes 137
iframes 136
image
inserting in Data & Statistics 411
inserting in Graphs & Geometry
240
Image types 85
bmp 85
jpg 85
png 85
images
deleting 128
inserting 425
moving 127
PublishView(TM) 126
resizing 128
images, working with
applications 83
Clipboard 87
context menu 87
delete 89
image types 85
maximum color depth 90
maximum memory 90
maximum number 90
maximum pixel size 90
moving 89
pasting 87
resize 89
selecting 88
inequalities
graphing 261
inferential statistics
calculating test results
(Calculate) 346
drawing plots 416
graphing test results (Draw) 346
input descriptions table 346
pooled option 364
inline frames 136
Insert menu
Documents workspace 25

insert page
PublishView(TM) 108
inserting
a Calculator on a page 180
a row or column in a table 331
a row or column into a matrix
185
an element in a list in Lists &
Spreadsheet 324
an image in Data & Statistics 411
an image in Graphs & Geometry
240
comments in Notes application
426
Notes on a page 421
inserting a link to video files 128
inserting a text box
PublishView(TM) 103
inserting an image 85
Clipboard 87
context menu 87
Insert command 86
original image is replaced 85
pasting 87
Inserting Images 425
inserting images 126
inserting items from the Catalog 161
Inserting math expressions, shapes,
or comments 426
inserting text (Data & Statistics) 371
inserting text in headers and footers
115
inserting text into a text box 119
installing handheld OS 15
installing updated software 14
intercept
changing for a line 401
Intersection Point tool 277
intersection points
defining 277
invT (inverse Student T distribution)
355
items
insert from catalog 161
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J
Java applets 152
JPG 85

L
label, Lbl 477, 480, 484
labeling an equation 289
language 9
changing 9
lanuching a dedicated TI-Nspire(TM)
Document Player window 156
last answer
using 212
launching edit mode
PublishView(TM) 121
launching TI-Nspire(TM) Document
Player 140
length
labeling 289
measuring 289
Length tool 290, 291
lesson bundle
add files 44
adding files 44
creating 44
lesson bundle managing files 47
lesson bundles 4
Documents workspace 43
libraries 74, 451
library objects
using 453
license 10
line
finding the slope of 293
Line tool 280
lines
creating 275
lines of regression 403
lines, creating 280
linking
table cell to a variable 207, 330
table column to a list 323
values 201

linking to a web site 124
linking to video files 128
linking variables 207
links
removing linked variables 214
lists
capturing Graphs & Geometry
data 342
deleting elements in a table 324
inserting elements in a table 324
sharing table columns as 322
storing as variables 202
viewing and editing 323
Lists & Spreadsheet
adding to a page 322
getting started with 317
variables 206, 207, 209
Lists & Spreadsheet toolbar 318
local variable, Local 474
locking
measurements 235
points 235
locking the intercept of movable line
at zero 402
locus
creating 304
Locus tool 304, 305
loop, Loop 483

M
Managing files in a lesson bundle 47
Managing lesson bundles 49
managing problem breaks
PublishView(TM) 113
Managing TI-Nspire™ documents 56
math expression boxes
attributes 432
converting to 431
deactivating 431
math expressions 426
editing 166, 195
entering and evaluating 160, 180
entering in a table 325
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selecting in Calculator 166, 196
with multiple statements 208
math operators 73
math templates 72
using 75, 182, 328
matrices
creating 184
storing as variables 202
matrix
inserting a row or column 185
maxima
finding 268, 298
Measurement Menu tools (Graphs &
Geometry) 223
measurement units, converting 189
measurements
finding angle 292
storing as variables 202
transferring onto objects 294
measuring length 289
Menu
Data & Statistics 368
menu
context 66, 309
menu bar
Documents workspace 20
menus
PublishView(TM) 100
Midpoint tool 281
minima
finding 268, 298
modes
setting in programs 484
modify
nspirefile parameter 154
modifying the nspirefile parameter
154
movable line
adding to a plot 400
locking intercept at zero 402
tracing 402
movable line, adding (Data &
Statistics) 371
movalble line

rotating 401
move image 89
moving
rows and columns in a table 332
vector 285
moving a text box
PublishView(TM) 105
moving images 89, 127
moving multiple points in Data &
Statistics 396
moving pages with the Page Sorter
68
multiple applications 67
multiple cells
selecting 328
multiple documents
working with 63
multiple documents in tiled view 63
multiple-line functions
defining 191, 193
multiple-statement expressions 208
My Files
moving files and folders 61

N
naming
table columns 322
naming objects during construction
279
naming variables
preventing name conflicts 330
navigating in a table 322
normal probability
creating plot 385
Normal Probability plot (Data &
Statistics) 368
Notes 83
adding to a page 421
inserting comments in 426
PublishView(TM) 119
selecting text 424
toolbar 421
nspirefile parameter 137
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numeric plot, splitting by categories
393

O
object
finding perimeter of 291
objects
creating 285
dilating 301
naming while constructing 279
PublishView(TM) 130
reflecting 299
rotating 301
symmetry of 299
translating 300
ODEs (ordinary differential
equations) 256
offline
sharing files 156
storing files 156
online storage sites 143
opening
files 57
Opening a lesson bundle 46
Opening Content Explorer 58
Opening Context menus 66
Opening files within a lesson bundle
46
Opening Notes 420
opening the about window 16
Opening the application menu 65

P
page
multiple applications 67
Page Sorter 68
moving pages 69
rearranging pages 69
page sorter 32
pages 70
adding 71
adding a Lists & Spreadsheet
application 322

adding to a problem 71
capturing 77
deleting 70
multiple applications 67
saving captured 79
ungroup 70
using the page sorter 69
panning views 238
Parallel (Line) tool 282
parameters
nspirefile 137, 154
pass error, PassErr 485
pasting
table data 340
pasting images 87
pasting problems 71
pause, Pause 485
performing an experiment 495
perimeter
finding 291
Perpendicular (Line) tool 283
Perpendicular Bisector tool 302
picture as background 240, 411
piecewise functions
creating 187
pinning objects (Graphs &
Geometry) 227, 274
plot
a value on existing plot 397
summary 338
plot mean (Data & Statistics) 372
plot standard deviation (Data &
Statistics) 372
plot type
changing 399
Plot types menu (Data & Statitics)
368
plot value tool (Data & Statistics) 372
plotting
table data 337
PNG 85
Point On tool 276
Point tool 276
points
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creating 275, 276
moving in Data & Statistics 396
redefining 279
selecting multiple in Data &
Statistics 396
Points and Lines Menu tools (Graphs
& Geometry) 222
points of interest, finding 268, 298
points on
creating 276
polygon
finding perimeter of 291
finding the area of 292
pooled option 364
precision of results 181
pre-defined measurement units 189
printing
previewing 80
Printing documents 79
printing PublishView(TM)
documents 133
probability
creating plot 385
problem
adding to PublishView(TM) 108
problems 70
adding pages 71
adding to documents 70
copying 71
deleting 71
pasting 71
PublishView(TM) 112
renaming 71
product
register 12
Program Editor
overview 457
programs
creating 191
programs and programming
arguments 472
branching 478, 480
calling another program 476
clear error, ClrErr 485

comment, © 463
debugging 485
Disp 473
else if, ElseIf 479
else, Else 479
end for, EndFor 478, 481
end if, EndIf 478, 479
end loop, EndLoop 483
end try, EndTry 485
end while, EndWhile 482
for, For 478, 481
functions 475
go to, Goto 477, 480, 484
if, If 478, 479
label, Lbl 477, 480, 484
local, Local 474
loop, Loop 483
looping 478, 481, 482
pass error, PassErr 485
passing values 472
return, Return 477
running 468
stopping 471
subroutines 476
Then, Then 479
try, Try 485
while, While 482
Proof template 422
protecting a document 81
PubishView(TM)
hiding problem breaks 113
publishing documents as web pages
135
PublishView
inserting text 119
show and hide borders 116
PublishView(TM)
add text 119
adding a problem 112
adding an application 108
contect menus 101
convert text to hyperlink 125
converting documents 130
delete images 128
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deleting a problem 113
deleting a text box 106
Documents Toolbox 98
edit a hyperlink 124
hyperlinks 121
images 126
inserting a text box 103
inserting headers and footers
115
inserting images 126
launching edit mode 121
linking to a web site 124
managing problem breaks 113
menus 100
moving text box 105
new document 92
printing documents 133
problems 112
remove hyperlinks 125
renaming a problem 113
resize text box 104
showing problem breaks 113
software requirements 91
status bar 96
toolbar 100
using Notes 119
video console 129
video file links 128
video files 128
working document 110
PublishView(TM) documents 93
PublishView™ documents 55
PublishView™ feature 91

Q
Q & A template 422
Question 83
answering questions 442
navigating the application 441
toolbar 441
Questions - students
accessing toolbar 441
checking you answer 443

coordinate points 447
drop points 448
equation 445
how to answer 442
list 448
multiple choice 443
navigating 441
open response 445
toolbar options 441
types of 442
Quick Graph, using 337

R
raw data 377
adjusting histogram scale 384
ray
finding the slopeof 293
Ray tool 280
rays
creating 280
read-only documents 81
rearranging pages 69
recalling
a function definition 195
rectangle
finding perimeter of 291
finding the area of 292
Redefine tool 279
redefining a point 279
reflecting an object 299
Reflection tool 299
Registering your product 12
regression
showing lines of 403
regression line
requirements for 402
regression tools (Data & Statistics)
372
removing
variables 214
removing a hyperlink 125
renaming
problems 71
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Renaming a problem
PublishView(TM) 113
renaming functions 261
replacing
text in Program Editor 467
repositioning a measured value 293
requirements
viewing embedded web pages
135
rescaling a graph
dilation 400
translation 399
rescaling the work area 239
residuals tools (Data & Statistics) 372
resize image 89
resizing
table rows and columns 330
vector 285
resizing a text box
PublishView(TM) 104
resizing image 89
resizing images 128
resources 12
results
approximating 181
copying from Calculator history
165, 198, 199
deferring in Calculator 188
using last answer 212
return, Return 477
reusing
items from Calculator history
165, 198, 199
last answer in Calculator 212
rotating an object 301
rotating the 3D view 313
row
inserting into a matrix 185
rows
copying in a table 331
deleting from a table 331
inserting in a table 331
moving in a table 332
resizing 330

selecting in a table 330
running diagnostics 13

S
saving
documents 57, 97
saving a document to a connected
handheld 60
Saving captured pages 79
Saving handheld documents in the
software 62
saving Scratchpad contents 171
Saving TI-Nspire(TM) documents 56
scale indicator
showing and hiding 238
scaling 7, 39
science
data collection 487
performing an experiment 495
Scratchpad
saving 171
Screen Capture 77
scrolling
a table 322
segment
bisecting 302
finding the slope of 293
Segment tool 281
selecting
a block of table cells 328
expressions in Calculator 166,
196
multiple points in Data &
Statistics 396
table rows or columns 330
text in Notes application 424
Selecting a template 422
selecting images 88
Selecting pages in the Page Sorter 69
selecting pages with the Page Sorter
68
Sending files to a handheld 43
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Sending Lesson Bundles to
connected handhelds 50
Sensor Console. See Data Collection
sequence
plotting (Graphs & Geometry)
252
sequences
generating in a table column 335
service and support 609
set axes min and max (Data &
Statistics) 373
settings
defining 9
language 9
TI-SmartView(tm) emulator 606
Shape tool 287
shapes 426
adding in Notes 427
creating 285, 287
Shapes Menu tools (Graphs &
Geometry) 223
sharing
a table column as a list 322
table column as a list 322
table-cell values 329
sharing documents 153
sharing documents online 153
sharing files offline 156
Show Normal PDF (Data & Statistics)
373
showing
3D graphs 312
showing and hiding borders
PublishView(TM) 116
showing problem breaks
PublishView(TM) 113
showing warnings and errors 430
slider
animating a 3D graph 314
using to adjust a variable 241
sliders 412
sliders (Data & Statisitcs) 371
slope

finding the derivative of a
function 268
of a line 293
of a ray 293
of a segment 293
of a vector 293
slope fields 256
Slope tool 293
software
About window 16
installing 14
overview 3, 19
updating 13
Software fequirements
PublishView(TM) 91
software license 10
software updates
checking 14
sorting
table data 333
sorting plotted categories 397
source attribute 137
source code
iframes 136
viewing 147
source code template 148
splitting
numeric plot by categories 393
splitting a categorical plot 392
spreadsheet applications,
exchanging data with 340
statistics
drawing plots 416
status bar 6, 20, 38
storage site
online 143
stored variables
linking to 207
storing document 153
storing file offline 156
strings
storing as variables 202
substituting a value for a variable
213
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summary data 377
Summary Plot 337
summary plot 338
support and service 609
symbols 72
symmetry 299
Symmetry tool 299
syntax
using to prevent naming
conflicts 330
system of equations 188

T
table data
exchanging with other
applications 340
graphing 337
sorting 333
table data use in statistical analysis
(Lists & Spreadsheet) 345
tables
capturing Graphs & Geometry
data 342
copying a row or column 331
deleting contents of cells 328
deleting list elements in 324
deleting rows and columns 331
generating column data 333
getting started with 317
inserting a row or column 331
inserting list elements 324
linking a column to a list 323
moving a row or column 332
navigating in 322
selecting a row or column 330
sharing a column as a list 322
working with cells 327
tags
iframes 137
Tangent tool 285
template
selecting 422
source code 148

templates
Proof 422
Q & A 422
using 162, 184
text
add to PublishView(TM)
document 119
adding to a Graphs & Geometry
page 297
convert to hyperlink 125
editing and formatting 121
finding and replacing in Program
Editor 467
finding in Program Editor 467
formatting in Notes 423
headers and footers 115
selecting in Notes application
424
text box
delete 106
inserting text 119
moving 105
resize 104
text colors 425
text editor 152
text formats 424
Text tool 228, 260
text, converting (Graphs &
Geometry) 229
Then, Then 479
TI Connect, exchanging data with
340
TI resources 12
tic marks
spacing 239
tiled view 63
time plot
sequence (Graphs & Geometry)
252
TI-Nspire(TM) Document Player 140
customizing 143
TI-Nspire(TM) Document Player tool
bar 143
TI-Nspire™ Document Player
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description 83
TI-Nspire™ documents 55
TI-SmartView(tm) 32
TI-SmartView(tm) emulator 601, 604
capturing screens 608
opening 601
options 606
settings 606
sizing 603
working with documents 607
title, clicking to see variable names
(Data & Statistics) 374
title, clicking to see variable names
for case plot (Data & Statistics)
374
tool bar
Documents workspace 21
tool bars
TI-Nspire(TM) Document Player
143
Tool Palette
Documetns workspace 31
tool palette 6, 20
toolbar
Notes 421
PublishView(TM) 100
using in Calculator 180
toolbars
Calculator 174
Lists & Spreadsheet 318
Tools
Angle 292
Angle Bisector 303
Area 292
Attributes 234, 235, 306
Calculate 297
Dilation 302
Hide/Show Axes 239
Intersection Point 277
Length 290, 291
Line 280
Locus 304, 305
Midpoint 281
Parallel 282

Perpendicular 283
Perpendicular Bisector 302
Point 276
Point On 276
Ray 280
Redefine 279
Reflection 299
Segment 281
Shape 287
Slope 293
Symmetry 299
Tangent 285
Text 228, 260
Trace 245, 246
Translate 300
Vector 284
tools
variable
variable

tool 207
Tools menu
Document workspace 26
trace distribution curve (Data &
Statistics) 373
trace plotted function (Data &
Statistics) 373
trace regression (Data & Statistics)
373
Trace tool 245, 246
Tracing
3D view 313
transferring a measurement onto a
circle 296
transferring measurements 294
Transformation Menu tools (Graphs
& Geometry) 225
Translate tool 300
translating an object 300
triangle
finding perimeter of 291
finding the area of 292
try, Try 485
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U
unattach (Graphs & Geometry) 227
underscore symbol in conversions
189
Ungroup objects (Graphs &
Geometry) 274
ungroup pages 70
ungrouping objects (Graphs &
Geometry) 227
unit conversions 74
units
converting measurement uints
189
creating user-defined 190
unpinning objects (Graphs &
Geometry) 227, 274
updated handheld OS 15
updated software
installing 14
updating software 13
upgrading a handheld OS 14
user-defined functions 475
using
TI-Nspire(TM) Document Player
140
Using color in notes 424
Using Content Explorer to locate
files 58
using export to generate HTML
source code 147
using hyperlinks 121
Using Screen Capture 77
Using templates 421
Using the Clickpad 605
using the Documents Toolbox 29
Using the Documents workspace
Edit menu 23
Using the Documents workspace File
menu 21
Using the Documents workspace
menu bar 20
Using the Documents workspace
tool bar 21

Using the menus and toolbar 100
Using the status bar in
PublishView(TM) 96
Using the Welcome screen 1
Using the workspace 38
utilities 72
catalog 73
inserting items 75
libraries 74
math operators 73
math templates 72
symbols 72
unit conversions 74
wizards 75
Utilities pane 36

V
values
assigning to variables 201
variable, adjusting value with a
slider 241
variables 188
adjusting value with a slider 412
checking in Calculator 203
creating 201
creating from table cells 329
delete, DelVar 475
Graphs & Geometry values 204
linking 201, 207
linking table column to a list 323
linking to 207, 330
Lists & Spreadsheet cells 206, 209
local, Local 474
preventing naming conflicts 330
removing 214
sharing table column as a list 322
sharing with other applications
201
substituting a value for 213
types 202
updating in Calculator 212
using 201
using in a calculation 208
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vector
finding the slope of 293
moving 285
resizing 285
Vector tool 284
Vernier DataQuest™. See Data
Collection
video console 129
View menu
Documents workspace 24
viewing
embedded PublishView(TM)
documents 135
embedded TI-Nspire(TM)
documents 135
values in a list 323
Viewing and changing document
settings 39
viewing copyright information 80
Viewing document properties 80
viewing embedded PublishView(TM)
documents 135
viewing embedded TI-Nspire(TM)
documents 135
viewing embedded web pages
requirements 135
viewing the source code 147
views 238
in Graphs & Geometry 236

W
warnings
showing 430
web page
create 147
explore 142
view source code 147
web plot
sequence (Graphs & Geometry)
252
Welcome Screen
closing 2
welcome screen 1

while, While 482
window
TI-Nspire(TM) Document Player
156
Window Menu tools (Graphs &
Geometry) 219
Window Settings tool 239
Windows menu
Documents workspace 26
wizard
entering expressions with 163,
185, 345
wizards, using in utilities 75
work area
customizing 238
Graphs & Geometry 228
zooming or rescaling 239
work areas
multiple 67
working document
PublishView(TM) 110
working folder 107
working with context menus 101
working with functions (Graphs &
Geometry) 246
working with images 126
Working with Lesson Bundles 43
Working with lesson bundles 4
Working with problems 112
Working with problems and pages
70
Working with PublishView(TM)
documents 91
working with PublishView(TM)
documents 93
working with video files 128
workspace
Content 3
Documents 4
Documents workspace 38
Workspace toolbar 5, 20
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Y
y= functions, graphing 260

Z
zeroes
finding 268, 298
zoom, adjusting (Data & Statistics)
373
zooming the work area 239
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