Quick Start-up Guide

Cabri 3D – version 1.0.1 – September 2004
Copyright © 2004 Cabrilog
Author: Eric Bainville
Updates: www.cabri.com

Introduction

Welcome to the world of interactive 3D geometry!
This document will enable you to install Cabri 3D and to start using it. The ⇨ arrows show you how to perform a given operation.
File>Open designates the Open entry of the File menu. [object]>Hide/Show designates the Hide/Show entry of the right-click menu obtained by clicking the right button on object.
Ctrl+S describes a keyboard short-cut: press the S key while holding the Ctrl key depressed.
Rollover is the movement of the mouse on an object without action on the buttons. Carrying out a “drag” on an object is equivalent to moving the mouse above the object, depressing a button, moving the mouse while holding the button depressed and, finally, releasing the button.
On MacOS, to be consistent with standard system operation, the Ctrl key becomes Command for short-cuts, and Alt for tools, while the Alt key becomes Ctrl and corresponds to pressing the mouse right button.

Installation

Cabri 3D runs on Windows 95, 98, Me, 2000, XP and on MacOS X 10.3.
For acceptable performance, a 800 MHz (or greater) processor and a graphic card using an nVidia GeForce 2 or ATI Radeon 7000 (or greater) processor are recommended, although Cabri 3D can be used on less powerful configurations.
Installation on Windows: insert the CD and follow the instructions.
Installation on MacOS: move the Cabri 3D icon in the Application directory (in the Administrator mode) or else on the desktop.
When the application is launched for the first time, you need to save the version. Enter your name, the name of your company or organisation (optional) and the product key that you will find inside the software box.

**Documents, pages and views**

A Cabri 3D document is made up of one or more pages, whose dimensions may differ. Each page contains one or more views. A view is a rectangular zone of the page in which document objects are displayed. Cabri 3D proposes two types of view: 3D graphic views and text views. The 3D graphic view displays a projection of document graphic objects, while a text view lets you add captions, comments, etc. to the document.

A number of documents can be opened at the same time. The document displayed in the foreground is known as the current document. One of the views of a document may be active. The active view is displayed with a thicker border. Likewise, one of the document pages may be active and is also displayed with a thicker border.

**Document management**

- **Create a new document**: select File>New (Ctrl+N) to open the default template, or File>New according to template… to choose the document template in a list.
- **Open a document**: select File>Open (Ctrl+O) to access the file open dialogue box, or File>Open recent to open a recently opened document. You can also drag the icon of one or more Cabri 3D documents in the application window to open them, or double click on the icon of a Cabri 3D document, or select Open with>Cabri 3D in the right-click menu of a Cabri 3D document. In Windows, all Cabri 3D documents open in the same application instance.
- **Save the current document**: select File>Save (Ctrl+S). If the document is new, the first save works like File>Save as… and asks for a file name.
- **Change the current document**: use one of the entries of the Window menu or one of the short-cuts Ctrl+Tab and Ctrl+Maj+Tab to move from one document to the next or to the previous one.
- **Close the current document**: select File>Close (Ctrl+W).

**Page management**

- **Add a page**: select Display>New page… or [page]>New page… then choose the page template. The page templates correspond to the templates of new documents. The new page is inserted after the active page.
- **Activate a page**: click on the page or on a view on the page; in the latter case, the view is also activated.
- **Delete the active page**: select Display>Delete page or [page]>Delete page. The last page of a document cannot be deleted.
- **Duplicate a page**: select Display>Copy page or [page]>Copy page, then select Edit>Paste (if necessary in another document). The page dimensions, layout and view type are copied. The other document objects are not modified.
**View management**

- **Add a view:** select **Display > New view** or **[page] > New view**, then choose the type of view and, if necessary, the type of projection for graphic views.
- **Activate a view:** click in the view.
- **Select a view:** click on the view border. The selected view is displayed with handles and becomes the active view.
- **Move and resize a view:** select the view and move the handles (drag).

Views can be copied, pasted or deleted in standard manner via the Edit menu or the right-click menu of the selected view.

**Projections**

A graphic view is always associated with a projection, used to project the objects in the 3D space in the 2D plane of the view. Cabri 3D proposes central projections (conical) and parallel projections. In both cases, to project a point M, you need to build a straight line passing through M, either passing through a given point (central projection) or parallel to a given direction (parallel projection), and the projected line is the intersection of this straight line with the rectangle of the view. This rectangle corresponds to what is displayed in the view and is centred on the origin of the reference. Thus, in all graphic views, the reference origin is projected in the centre of the view. The view rectangle is oriented in azimuth (rotation of the z axis in the horizontal plane) and elevation (with respect to the horizontal plane). The vertical continues to be vertical after projection.

There are two possibilities for parallel projections: the projection direction is either orthogonal to the view rectangle (orthogonal parallel projection) or is not (oblique parallel projection).

Cabri 3D supplies all conventional and standardised parallel projections. When significant, a scale factor is introduced to provide actual size projections on one or more coordinate axes.

Some projections can be oriented freely in azimuth and elevation (free rotation): central, parallel orthogonal. Others can be oriented only in steps of 90° in azimuth and fixed in elevation (rotation by quadrant): isometric, dimetric, trimetric, cavalier, military. The remaining projections are fixed: left, right, front, etc.

**Objects and constructions**

Cabri 3D is used to construct and handle the following types of object:

- point,
- straight line,
- segment, semi-straight lines (parts of a straight line)
- vector,
- circle, conic section,
- plane,
- triangle, semi-plane, sector, polygon, (parts of a plane)
- cylinder, cone, sphere,
- polyhedron.

Constructions are built using construction tools, selected by means of the tool bar displayed by default under the menu bar. Each icon in the tool bar is used to access a tool box containing various construction tools.

Construction tools accept as inputs existing objects as well as objects implicitly created at the time of construction. To reduce the number of tools and increase software user-friendliness, most tools let you build a number of constructions, according to the objects selected in the input.

The last object created can be named as you work by typing its name just after its construction. Cabri 3D automatically inserts an index for names of the letter+digit type.

A construction tool works like a programmable logic controller. Transitions correspond to selection of objects as input. The Backspace key lets you move back an object, while the Esc key returns you to the initial status of the current object or selects the Handle tool if you are already in the initial status.

The following tables describe in detail the various tool boxes. In the icons, the input objects are blue, the constructed objects red and the transformation items green.

**Points**

- **Point.** Constructs a new point. Accepts all implicit point constructions (free point on a curve or surface, in space, intersection point, vector extremity, polyhedron vertex).

A free point cannot be created on a polygon (position definition problem), but this is possible for the other plane parts.

The Ctrl key lets you disable all implicit constructions and construct a free point in space.

- **Intersection point(s).** Builds all the intersection points of the selected objects (3 planes, 2 co-planar straight lines, straight & conical, straight & plane, straight & quadric, conical & plane). Intersections also accept parts of straight lines and planes.

**Curves**

- **Straight line.** Straight line through two points, straight line intersection of two planes (implicit).

- **Segment.** Segment through two points.

- **Ray.** Ray through two points. The first point is the origin of the semi-straight line.

- **Vector.** Vector through two points. The first point is the origin of the vector.

- **Circle.** Circle in a plan centred in the first point and passing through the second point (both points must be in the plane). Circle passing through three points. Circle through its axis (straight line, part of straight line) and passing through a point.
**Conic section.** Conic section passing through 5 co-planar points, tangent conic section with 5 co-planar straight lines, intersection of plane & quadric (implicit).

**Intersection curve.** Intersection curve of the two surfaces selected (plane & plane, plane & quadric).

### Surfaces

- **Plane.** Plane passing through 3 points. Plane passing through one point and containing a straight line. Plane containing two co-planar straight lines.
- **Triangle.** Triangle through 3 points.
- **Polygon.** Polygon through N co-planar points. To finish the selection, press Enter or the Space bar, or select a point already selected. You must select at least 3 points. [non-convex polygons are not managed in the current version]
- **Half-plane.** Semi-plane limited by a straight line and passing through a point.
- **Sector.** Sector with as its origin the first point A and delimited by the two semi-straight lines AB and AC, where B and C are the two other points.
- **Cone.** Cone through one point (the vertex) and an ellipse.
- **Cylinder.** Cylinder through its axis (straight line, segment, semi-straight line) and passing through a point. For a segment, the cylinder is truncated at the segment extremities.
- **Sphere.** Sphere through its centre and passing through a point.
- **Sphere through 4 points.** Sphere passing through 4 points.

### Constructions

- **Middle.** Middle of two points. Middle of a segment.
- **Parallel.** Straight line parallel to a straight line (or part of one) and passing through a point. Plane parallel to a plane (or part of one) and passing through a point.
- **Perpendicular.** Plane perpendicular to a straight line (or part of one) and passing through a point. Straight line perpendicular to a plane (or part of one) and passing through a point.
- **Sum of 2 vectors.** Vector that is a sum of two vectors, with a given point as its origin.
Transformations

For transformations, the first object selected is always the object to be transformed. This is followed by the objects defining the transformation. Only these objects are described in the table.

- **Central symmetry.** Symmetry defined by its centre.
- **Axial symmetry.** Half-turn defined by its axis.
- **Symmetry with respect to a plane.** Orthogonal symmetry with respect to a plane.
- **Translation.** Translation defined by a vector.
- **Rotation by axis and points.** Rotation defined by an axis D and two points A and B. This is the rotation sending the semi-plane D, A onto the semi-plane D,B.

Polyhedrons

- **Platonic solids.** Constructs one of the 5 Platonic solids defined by three points A,B,C. One of the solid’s edges is AB. The semi-plane AB, C is matched with one side of the solid. During construction, the CAPS key lets you choose between one of the two for matching. This construction ensures easy inter-stacking of these solids.

- **XYZ box.** Box with edges parallel to the reference axes and defined by two points A and B. AB is a box diagonal.

- **Polyhedron / semi-space intersection.** Constructs a new polyhedron, an intersection of the polyhedron given as an input one of the semi-spaces defined by a plane and containing a point. [construction of the section side is missing in the current version]

Handling, selection

At any time, whatever tool is active, the free objects (points, labels) can be moved by a left button drag. For projections so allowing, you can also change orientation of the view point at any time by a right button drag.

When the Handle tool is active, the objects can be selected. A click selects the object under the mouse. **Ctrl+ clic** selects/deselects the object under the mouse. **Edit>Select all (Ctrl+A)** selects all the objects. To cancel the selection, click in an empty field in the view or select **Edit>Deselect all.**

Movement of free points in space is a special operation. The **CAPS** key lets you switch between horizontal moves and vertical moves. Moreover, the **Ctrl** key allows you to restrict
point coordinates to multiples of 5 mm. During movements, a grid is displayed perpendicular to the point in the plane \( z=0 \), and a graduated segment connecting the point and its projection on this plane. In fixed orthogonal projection views (front, right, left, top, below, rear), free points in space are always moved in a frontal view plane.

**Undo, redo**

Cabri 3D offers an Undo function letting you go back (undo) and forward (redo) in construction steps as from file opening, separately from save operations. To go back, select Edit>Undo (Ctrl+Z) and to go forward, select Edit>Redo (Ctrl+Y). A new construction deletes the future history (“Redo” can no longer be selected).

**Hide, show**

Each object belongs to one of two groups: visible or hidden objects. Edit>Hide/Show (Ctrl+G) or [object]>Hide/Show changes the group of objects selected. Each view can display one of the two groups or both. The selection is made via the palette of groups accessible via Display>Groups (F8).

**Graphic attributes**

Each object has graphic attributes, grouped in the following categories:
- point attributes: colour, size, style,
- curve or border attributes: colour, radius, style,
- surface attributes: colour, thickness, style,
- label attributes: colour, font,
- common attributes: display hidden parts, visible/hidden.

According to its type, an object display uses attributes in one or more of these categories.

You can modify the attributes of the selected objects using the right-click menu or the palette of attributes accessible via Display>Attributes (F9).

To modify the attributes of future objects, you must modify styles in the preference dialogue box, accessible via Edit>Preferences… These modifications are applied to all future objects, for all documents, and continue to be valid after the application is closed.

The graphic attributes of objects hidden by surfaces are accessible only via the preference dialogue box. These attributes are not saved in the document file.

**Preferences**

The application preference dialogue box is accessible via Edit>Preferences… It has three parts.

The first part concerns general preferences:
- interface language (not included in the MacOS version, in which language is always the system language),
- the document template used by File> New, to be chosen from the list of page templates, 
- print quality.

The two other parts are used to define the graphic attributes of new objects and the hidden attributes of all objects (see the Attributes section)

Export, publication

Cabri 3D proposes various methods for exporting and publishing figures.

Copy to a Cabri 3D document

You can copy/paste a page, a view or selected objects of a document to another Cabri 3D document (possibly the same).

For a page, you copy the dimensions of the page, and the position, dimension and projection of the page views.

For a view, you copy the dimension and projection of the view.

For selected objects, you copy the objects and their antecedents.

Printing

The document is printed via File> Print… and operates as standard. Graphic views are printed in the bitmap mode, with a resolution defined in the preference dialogue.

Copy images to the clipboard

The selected view can be copied in image form in the clipboard, and pasted in a document accepting images (word processing, etc.). Select [view]> Copy to bitmap format, and choose the required resolution. Generation of a complex image in high resolution may take a few tens of a second.

Inclusion of a dynamic figure (Windows)

In Windows, Cabri 3D offers Active X control allowing inclusion of Cabri 3D documents in other software (Word, Internet Explorer, etc.) in dynamic figure form.

In all cases, Cabri 3D shall be installed on the machine used to view the document. A free visualisation plug-in will be available shortly.

From a Microsoft Office document, select Insert> Object…> Cabri 3D Document, which inserts a rectangular zone displaying the Cabrilog logo. In the context menu of this zone, choose Import…, and select the file to display.

In a Web page, insert the following HTML code:

```
<embed src="test1.cg3" width="500" height="600"></embed>
```

The src parameter is the name of the file to display (path relative to the HTML page), width and height are the dimensions (pixels).